21:03:16 <ttx> #startmeeting
21:03:17 <openstack> Meeting started Tue Jun 21 21:03:16 2011 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:03:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:03:25 <ttx> Welcome to our weekly meeting...
21:03:32 <ttx> Agenda for today:
21:03:38 <ttx> #link http://wiki.openstack.org/Meetings/TeamMeeting
21:04:18 <ttx> #topic Actions from previous meeting
21:04:23 <ttx> * vishy to get integrate-nova-authn status from anotherjesse
21:04:28 <ttx> That was DONE, as we'll see
21:04:37 <ttx> * glance-core to review in priority https://code.launchpad.net/~jaypipes/glance/bug713154/+merge/59110
21:04:38 <westmaas_> woo!
21:04:44 <ttx> jaypipes: this still needs some love, right ?
21:04:53 <jaypipes> ttx: I'll talk about that in glance status part.
21:04:57 <ttx> ok
21:05:02 <ttx> #topic Swift status
21:05:07 <ttx> 1.4.1 was released yesterday.
21:05:12 <vishy> bak
21:05:13 <ttx> notmyname: plans for 1.4.2 ?
21:05:50 <notmyname> ttx: continuing what was originally scheduled for 1.4.1. Also it depends on the outcome of next week's ppb meeting discussion
21:06:01 <jaypipes> notmyname: why?
21:06:18 <notmyname> nothing to report now other than what's on LP
21:06:41 <notmyname> I have reached out to some deployers to get feedback for swift and make sure needs are met
21:06:53 <ttx> notmyname: Other announcements or comments ?
21:06:53 <notmyname> jaypipes: code hosting
21:07:03 <notmyname> ttx: no, I don't think so
21:07:06 <jaypipes> notmyname: that affects what is in 1.4.2?
21:07:51 <notmyname> jaypipes: it affects from where 1.4.2 will be released
21:08:04 * jaypipes lost on that one...
21:08:06 <mtaylor> why?
21:08:12 <jaypipes> makes no sense to me.
21:08:26 <mtaylor> tarballs will still go on launchpad no matter where VCS is stored - so I'm lost as well
21:09:20 <jaypipes> alright, move on then... we can discuss offline on ppb list.
21:09:33 <ttx> other questions ?
21:10:01 <ttx> #topic Glance status
21:10:08 <ttx> jaypipes: Hi!
21:10:22 <ttx> diablo-2 is targeted for June 30 release, with a release branch cut at the end of Monday, June 27
21:10:31 <ttx> So my understanding is that a few things will be deferred ?
21:11:03 <ttx> Looking at https://launchpad.net/glance/+milestone/diablo-2, anything that should already be deferred to d3 ?
21:11:07 <jaypipes> ok, so we're moving along nicely with bcwaldon's API improvements (thanks much brian!). keystone integration came to a halt as I didn't have a standard way of starting up Keystone servers during functional testing, so I switched focus to the common daemon project for the time being.
21:11:35 <jaypipes> I will be deferring keystone integration to D3 due to some stuff that has come up on our team (thx johnpur! :P)
21:11:56 <ttx> jaypipes: and SSL, I suppose ?
21:11:58 * mtaylor clones jaypipes
21:12:03 <jaypipes> and hopefully getting the common daemon stuff done this week before heading out to SFO to meet with NTT about the FreeCloud project
21:12:05 * ttx forks jaypipes
21:12:16 <jaypipes> ttx: yes. I will clean the BPs up today.
21:12:22 <ttx> ok.
21:12:41 <ttx> jaypipes: I'll talk to you about a new way to handle "Low" stuff.
21:12:45 <jaypipes> ttx: had a great webinar today on Glance with james weir from UShareSoft. good feedback from users.
21:12:51 <jaypipes> ttx: coolio.
21:13:06 <ttx> jaypipes: basically keep it untargeted and just target it retrospectively if it happens to be done.
21:13:13 <jaypipes> ttx: other than that, want to discuss that bug 713154.
21:13:14 <uvirtbot> Launchpad bug 713154 in glance "S3 Backend doesn't support POST either." [Medium,In progress] https://launchpad.net/bugs/713154
21:13:28 <ttx> Who could help with that ?
21:13:56 <jaypipes> so, a bug in webob <=1.0.7 broke chunked transfer encoding. this bug was highlighted by the changes to the S3 driver in that bug's merge proposal.
21:14:27 <jaypipes> since the bug came up, the guys over at webob have now released a fixed 1.0.8 and that has hit all the ubuntu targets.
21:14:30 <jaypipes> so...
21:14:50 <jaypipes> with 1.0.8 required, that S3 bug fix and patch should be able to go through now.
21:15:07 <jaypipes> I'll be testing with smokestack tomorrow and hopefully we'll get it into fix committed into D2.
21:15:13 <jaypipes> that's all from glance.
21:15:26 <ttx> Any question ?
21:16:18 <ttx> jaypipes: you also have lots of D2-targeted bugs, might be god to make a pass on them to check which really are milestone-critical.
21:16:24 <ttx> good*
21:16:26 <jaypipes> ttx: will do.
21:16:33 <ttx> #topic Nova status
21:16:42 <ttx> diablo-2 is also targeted for June 30 release, with a release branch cut at the end of Monday, June 27
21:16:58 <ttx> That leaves less than a week to merge things, and we still have quite a few incomplete targeted features
21:17:09 <ttx> so we should have a look at what's not likely to make it and defer :)
21:17:10 <vishy> Thanks to everyone who has been coding/merging/reviewing while i was on vacation
21:17:22 <vishy> a lot got merged recently
21:17:24 <ttx> vishy: don't do that again. It hurts.
21:17:38 <ttx> #link https://launchpad.net/nova/+milestone/diablo-2
21:17:42 <soren> #ACTION vishy to not go on holiday
21:17:45 <soren> Darn it.
21:17:50 <ttx> * https://blueprints.launchpad.net/nova/+spec/integrate-nova-authn (anotherjesse)
21:17:58 <ttx> vishy: So that was marked implemented, but there is no code link, could you explain what was done and what's left to do ?
21:17:59 <jesse_> vishy: do you want to remove no db?
21:18:07 <ttx> jesse_: I'll come to it
21:18:26 <jesse_> ttx: for authn-authz we have admin-ness & project/user delegated to keystone
21:18:39 <vishy> the middleware is in the keystone project
21:18:54 <jesse_> and a paste config to show it in use
21:19:17 <ttx> vishy: oh, ok.
21:19:17 <zns> https://github.com/rackspace/keystone/blob/master/keystone/auth_protocols/nova_auth_token.py
21:19:35 <ttx> jesse_: would be good to drop some email/blogpost/wikipage on how to test that ?
21:19:59 <jesse_> ttx: will do - we've been working through some issues with how many-to-many work
21:20:01 <ttx> vishy: the remaining work is covered by the "finalize Auth" blueprint ?
21:20:04 <jesse_> within the backend
21:20:16 <jesse_> we've not really focused on authz yet - since the openstack api never had rbac
21:20:18 <ttx> vishy: or do we need more ?
21:20:37 <vishy> ttx: we could probably use a couple of middling blueprints
21:21:02 <ttx> vishy: yes, that's what i was thinking. I guess work on this is continuous.
21:21:10 <jesse_> also with respect to the integration - right now openstack tokens don't send a ID and Name separately
21:21:21 <jesse_> we're still talking through that
21:21:33 <ttx> * https://blueprints.launchpad.net/nova/+spec/no-db-messaging (vishy)
21:21:33 <vishy> ec2_compatibility, rename project -> tenant, migrations, authz, remove auth manager are the steps
21:22:24 <ttx> vishy: you can track the steps in the blueprint whiteboard.. or using separate blueprints. Whatever makes you more comfortable.
21:22:34 <vishy> so that won't make it d2, I'm debating between pushing it and just cancelling it.  I've had lots of discussions with people, and still not convinced that it is the right change
21:23:02 * ttx marsks it "blocked"
21:23:07 <vishy> i guess lets move it to d3 for now, and I'll make an email to the list with different options and feedback
21:23:52 <ttx> ok, done
21:23:58 <ttx> * https://blueprints.launchpad.net/nova/+spec/nova-multi-nic (tr3buchet)
21:25:08 <ttx> Last time I heard this was deep in testing, but now the merge proposal needs to hit if it is to make it into d2
21:25:27 <westmaas_> mp is in
21:25:38 <ttx> indeed.
21:25:39 <vishy> we need to get this in
21:25:52 <_cerberus_> He just pushed it back to needs review this morning, but he's out for the day
21:25:53 * ttx checks if all is in it.
21:25:55 <vishy> lots of people are testing and giving feedback
21:26:30 <_cerberus_> vishy: he's looking for feedback from you, specifically, if you have time to spare
21:26:33 <ttx> looks complete. Good.
21:26:43 <ttx> * https://blueprints.launchpad.net/nova/+spec/boot-from-volume (isaku)
21:26:44 <primeministerp1> vishy: Question re: network blueprints.. the db fields… Shouldn't we include a guest interface type.. i.e. paravirt vs. emulated, it matters as some hypervisors provide different functionality for each, and the current blueprints (as of last week) didn't reflect this as an option
21:26:50 <ttx> Looking at the latest merge prop this looks a bit incomplete...
21:26:54 <vishy> yes i will be looking at it and hopefully helping out with test fixing
21:26:55 <primeministerp1> sorry guys.. before we move on
21:27:23 <primeministerp1> question for vishy above..
21:27:27 <vishy> primeminsterp1: lets talk about that after the meeting
21:27:30 <primeministerp1> kk
21:27:39 <primeministerp1> thx
21:27:50 <vishy> boot from volume is coming in stages
21:27:58 <vishy> i think first stage is in and second is proposed
21:28:19 <vishy> probably we will need a third stage before it is "complete"
21:28:21 <ttx> the second is proposed but it says that it's for comments only, as it is incomplete
21:28:33 <ttx> so it looks like D3 is a better target
21:28:37 <vishy> agreed
21:28:47 <ttx> good targeting helps to focus review resources on D2 targets.
21:28:55 <vishy> although the current version works for a limited use case afaik
21:29:10 <ttx> #action ttx to talk to isaku about D3 retargeting of boot-from-volumes
21:29:15 <ttx> * https://blueprints.launchpad.net/nova/+spec/unittest-examples (westmaas)
21:29:34 <westmaas_> vishy: you want us to just publish that on the list?
21:29:51 <vishy> yes please
21:30:00 <westmaas_> alrighty, will do it this week
21:30:11 <vishy> i think we should either link to it in the docs or put the whole thing there
21:30:43 <ttx> * https://blueprints.launchpad.net/nova/+spec/openstack-api-floating-ips (reldan)
21:30:44 <westmaas_> which docs?
21:30:47 <annegentle> vishy: I think testing info can go on the wiki - it's project info
21:31:04 <vishy> nova dev docs
21:31:05 <annegentle> or it could go on nova.openstack.org
21:31:23 <annegentle> westmaas_: I can work with you to get it in the nova dev docs = nova.openstack.org
21:31:47 <vishy> it is build from then nova source tree, so we can just propose it in
21:31:51 <westmaas_> I'd love to get feedback too.  this isn't nova specific either
21:32:10 <ttx> nobody from griddynamics around -- vishy do you have an updated status for the floating-ips stuff ?
21:32:20 <westmaas_> annegentle: I'll work with you later
21:32:36 <vishy> there was a merge proposal, no?
21:32:40 <annegentle> westmaas_: sounds good
21:32:44 <ttx> no, just a branch link.
21:33:00 <ttx> https://code.launchpad.net/~openstack-gd/nova/floating-os-api
21:33:20 <vishy> ah you're right
21:33:26 <vishy> no i don't have status on that one
21:33:33 <msinhore> guys, only to introduce me to the team: My name is Marco, I'm working as a leader of a private cloud project in Globo.com / Brazil. We've a system running on top of XCP with some layers (backend, queue, monitoring services, network services, load balancers services and a nice frontend integration all of these stuffs in a web 2.0 web interface) and we will planning to migrate all to use openstack and we will open the source of workflow f
21:33:46 <ttx> ok, will try to get updated status on that
21:33:57 <ttx> #action ttx to query status on floating-ips
21:34:10 <ttx> * https://blueprints.launchpad.net/nova/+spec/testing-jenkins-integration (mtaylor)
21:34:44 <msinhore> I'm talking for a some days with Stephen Spector and I need map the guys working with priv cloud components to interact with them to align our next step with them.
21:34:46 <vishy> mtaylor: promised to divide that up into a couple other blueprints
21:35:07 <ttx> mtaylor: do it dude :)
21:35:12 <mtaylor> vishy, ttx: yeah. I got sucked in to a few other things. I will still divide that up in ot other blueprints
21:35:15 <ttx> * https://blueprints.launchpad.net/nova/+spec/provider-firewall (xtoddx)
21:35:19 * mtaylor flagellates self
21:35:41 <msinhore> please, if someone want to know more about the project contact me: marco.sinhoreli@corp.globo.com and I will be glad to explain about our plan and components into the system.
21:35:46 <vishy> todd is working on that
21:35:52 <ttx> looks like the scope of that one grew from d1 to d2, is it reasonable to get that all in d2 ?
21:36:01 <vishy> ttx: i think so
21:36:08 <vishy> it just was missing a couple of tests i think
21:36:25 <ttx> * https://blueprints.launchpad.net/nova/+spec/schedule-instances-on-heterogeneous-architectures (lorin)
21:36:41 <ttx> (or anyone at USC-ISI)
21:37:52 <vishy> seems highly doubtful that will make this milestone
21:38:00 <ttx> unsure if the merge prop they have in work in progress actually covers everything they had in mind.
21:38:19 <ttx> vishy: ok, will hunt them down for more status.
21:38:37 <ttx> #action ttx to get updated status on heterogeneous-arch bp
21:38:42 <ttx> * https://blueprints.launchpad.net/nova/+spec/system-usage-records (mdragon)
21:38:45 <ttx> (last one)
21:39:11 <ttx> started, no code link, so I don't really know.
21:39:32 <ttx> pvo: do you ?
21:39:42 <dragondm> yah ther is code for that
21:39:53 <dragondm> It just needs to be re-mergeds
21:39:58 <pvo> sorry, paging back in.
21:40:14 <dragondm> and merge-prop'ed
21:40:29 <pvo> should be ok for d2, right dragon?
21:40:33 <dragondm> yup
21:40:38 <ttx> dragondm: cool! Thanks.
21:40:49 <ttx> On another subject, are there any blocking bugs that we should make milestone-critical ?
21:41:20 <ttx> If you see any, just ping me or vishy
21:41:30 <ttx> vishy: anything else you wanted to mention ?
21:41:45 <vishy> i think i noticed a few over the past week.  I'll see if any haven't been addressed yet
21:42:10 <ttx> vishy: we just need to make sure that whatever we target to the milestone, has an assignee on it
21:42:15 <vishy> ttx: no
21:42:23 <ttx> no point in adding bugs there if nobody commits to trying to fix them.
21:42:38 <ttx> Questions for the Nova PTL ?
21:43:28 <ttx> #topic Announce Name of E
21:43:35 <ttx> So the winner is...
21:43:42 <ttx> "Essex".
21:43:47 <ttx> https://launchpad.net/~openstack/+poll/e-release-naming
21:43:57 <ttx> Essex: 32 votes, beats Exeter (26 votes). (I lost)
21:44:09 <vishy> are the guys working on esx here?
21:45:08 <jamesurquhart> OK to announce on Twitter?
21:45:16 <ttx> jamesurquhart: I just did :P
21:45:43 <jamesurquhart> Me too. RT race is on! ;)
21:45:49 <vishy> damn
21:45:55 <ttx> jamesurquhart: pretty sure you'll win.
21:45:55 <vishy> my epsom lost
21:46:40 <ttx> jamesurquhart: as you've like 20 times more followers than I do.
21:46:50 <Vek> heh.
21:47:11 <ttx> vishy: I voted "Exeter". wtf voted Essex ?
21:47:28 <vishy> it was bound to win as it has 'sex' in it
21:47:31 <salv-orlando> me :-)
21:47:33 <soren> I would have voted "Effing" if given the chance.
21:47:42 <vishy> the voters are a bunch of geeks after all :)
21:47:46 <soren> That was my favourite
21:47:53 <vishy> soren: +1
21:47:59 <ttx> soren: if you could only prove that Effing was somewhere near Boston, with any definition of near.
21:48:07 <ttx> like a fake wikipedia page.
21:48:11 <termie> pretty effing close to boston
21:48:36 <ttx> termie: maybe "F" should be called "effing".
21:48:48 <primeministerp1> I like essex
21:48:55 <primeministerp1> and voted that way… ;)
21:49:11 <ttx> #topic Open discussion
21:49:31 <primeministerp1> so i'd like to give an update about the status of openstack on suse
21:49:33 <termie> how many chips are there in a large bag of doritos?
21:49:52 <soren> primeministerp1: Go for it.
21:49:53 <ttx> primeministerp1: go!
21:49:54 <primeministerp1> we've begun to organize our packaging efforts
21:49:57 <Vek> that's pretty open, termie :P
21:50:17 <primeministerp1> we now have people contributing time to getting our packages in the OBS up to speed
21:50:24 <dragondm> termie: 142. next question.
21:50:39 <vishy> termie n * pi where n is the number of licks it takes to get to the center of a tootsie roll pop
21:50:44 <primeministerp1> also shortly there should be an appliance in the suse studio market place
21:51:10 <primeministerp1> to rapidly setup a controller and compute nodes
21:51:46 <jamesurquhart> Heh. I screwed up, ttx, and didn't use a hash tag. #rookiemistake
21:52:25 <spectorclan_> I need some help with why we chose Python as the development language for a Python community promotion we are doing.
21:52:31 <soren> primeministerp1: Is it going to end up in SuSE itself?
21:52:41 <primeministerp1> for anyone wishing to try the suse bits, they can be located here: http://download.opensuse.org/repositories/Virtualization:/Cloud:/OpenStack/
21:52:44 <primeministerp1> no not yet
21:52:48 <soren> primeministerp1: Or are you providing packages outside of SuSE, but for SuSE?
21:52:50 <primeministerp1> we have just started packaging
21:52:51 <primeministerp1> it
21:52:53 <spectorclan_> Please send me thoughts on Python so I can put together info for the promotin, thanks,
21:52:54 <primeministerp1> in the obs
21:53:03 <vishy> primeministerp1: afk for about half an hour.  talk network stuff then?
21:53:06 <primeministerp1> soren:  exactly
21:53:09 <soren> primeministerp1: Ok.
21:53:16 <ttx> primeministerp1: could you contribute install instructions somewhere on the wiki, that we could integrate whenever I end up refactoring the nova install pages ?
21:53:17 <termie> spectorclan_: because it was the best
21:53:31 <primeministerp1> soren: also there's an opensuse mailing list for discussion around our efforts if anyone is interested
21:53:45 <primeministerp1> also there's an opensuse mailing list for discussion around our efforts if anyone is interested
21:53:48 <spectorclan_> termie: Need something a bit more detailed. Like "It's not FORTRAN or COBOL"
21:53:49 <primeministerp1> that was for everyone
21:54:16 <termie> spectorclan_: i made this whole presentation about that...
21:54:28 <Vek> "It's not ruby"?
21:54:30 * Vek ducks
21:54:33 <primeministerp1> opensuse-cloud@opensuse.org is the mailing list address
21:54:35 <spectorclan_> termie: great, can you send it my way or give me a link! Very helpful
21:54:37 <creiht> http://www.youtube.com/watch?v=3jYcW1nEsGk
21:55:08 <primeministerp1> ttx: we are in the works for doing that
21:55:12 <termie> spectorclan_: http://blip.tv/pycon-us-videos-2009-2010-2011/pycon-2011-an-open-success-for-the-cloud-openstack-4899478
21:55:20 <primeministerp1> ttx:  Installation documentation
21:55:23 <ttx> primeministerp1: ok
21:55:28 <soren> primeministerp1: Sounds good!
21:55:34 <creiht> termie: - all the ums :)
21:55:38 <termie> UM
21:55:47 <ttx> um um.
21:55:52 <termie> it mellows out about halfway through :p
21:55:56 <creiht> hehe
21:56:32 <Vek> classes on public speaking should have an entire semester dedicated to "de-umming" speech...
21:56:51 <ttx> ok, anything else  before we close ?
21:57:16 <spectorclan_> exit
21:57:58 <ttx> plenary by Hettinger at EuroPython was on "why makes Python awesome". Pretty much all of his points applied to OpenStack in some way.
21:58:01 * pvo &
21:58:03 <ttx> what*
21:58:10 <termie> Vek: indeed, though in my defense that was largely due to not having slept at all
21:58:14 <ttx> #endmeeting