19:10:55 <mtaylor> #startmeeting
19:10:56 <openstack> Meeting started Tue Jul  5 19:10:55 2011 UTC.  The chair is mtaylor. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:10:57 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:11:31 <mtaylor> #topic CI Meeting
19:11:51 <mtaylor> hey everybody - I'm assuming we've got some folks in here and stuff?
19:11:52 <mtaylor> hi nati
19:12:00 <dprince> yo
19:12:13 <mtaylor> hey dprince
19:12:15 <nati> hi mtaylor
19:12:19 <spectorclan_> just watching from the background
19:12:26 <mtaylor> excellent
19:12:39 <mtaylor> so - first things first - let's check in on stuff from last time
19:12:54 <mtaylor> #topic Actions from last meeting
19:13:22 <mtaylor> dprince: you got the openstack_vpc job added and running. so, w00t!
19:13:41 <dprince> mtaylor: Yep. I think we can mark that completed.
19:13:49 <mtaylor> agree!
19:14:22 <mtaylor> can we add a new action for getting the tests run through nosexunit and returning the xml?
19:14:30 <dprince> mtaylor: So like we talked late last week I had to add a sleep to the job to get around this issue: https://bugs.launchpad.net/nova/+bug/804317
19:14:31 <uvirtbot> Launchpad bug 804317 in nova "FixedIpNotFoundForInstance: Instance 1 has zero fixed ips." [Undecided,Incomplete]
19:14:55 <mtaylor> yes. do we have anybody on the nova side of things working on a real fix for that?
19:15:03 <dprince> Essentially after the multi_nic merge nova-network has to run a periodic task at least once before the network is set.
19:15:10 <dprince> I'll take it.
19:15:16 <mtaylor> sweet
19:15:18 <dprince> Or at least I'll argue for it.
19:15:28 <mtaylor> ttx marked it as incomplete... ttx, do you hate us?
19:15:30 <dprince> And yes. Lets have another task for the nosexunit stuff.
19:15:50 <ttx> I do. Let me check that.
19:15:59 <mtaylor> #action dprince Have smoketests return xunit file via nosexunit
19:16:08 <dprince> Yeah. I saw he marked it incomplete. I can refile in a more cleanly worded ticket perhaps?
19:16:16 <mtaylor> #action dprince fight with ttx over fixing bug 804317
19:16:17 <uvirtbot> Launchpad bug 804317 in nova "FixedIpNotFoundForInstance: Instance 1 has zero fixed ips." [Undecided,Incomplete] https://launchpad.net/bugs/804317
19:16:55 <ttx> dprince: marked it incomplete because tr3buchet seemed to consider it was normal behavior
19:17:07 <ttx> so it didn't seem everyone agreed it was something to be fixed :)
19:17:17 <dprince> Sure. I'll vet the idea a bit more.
19:17:34 <dprince> My options are sleep. Or edit the DB manually.
19:17:34 <mtaylor> ttx: well - in _some_ manner we need to be able to smoketest things without adding in a "sleep 1" call :)
19:17:49 <dprince> I'd prefer to do this via a nova-manage command.
19:17:52 <ttx> Though your comment #2 makes sense.
19:18:01 <ttx> rigth. I can confirm/wishlist it
19:18:06 <dprince> Additionally I think some end users will want a preset option as well.
19:18:14 <ttx> doing so right now. /me hates incomplete bugs anyway.
19:18:18 <mtaylor> yay!
19:18:30 <mtaylor> dprince: look at that - one of your actions for next week is done already!
19:18:32 <mtaylor> :)
19:18:42 <dprince> Yep. progress already.
19:18:46 <ttx> also note that the bug triaging game is a game that everybody is allowed to play. It's not just me.
19:18:59 <ttx> I'm doing it because almost nobody else does, boohoohoo
19:19:14 <mtaylor> so - next on the list is mtaylor jenkins job for the PXE boot goodness
19:19:24 <dprince> ttx: we just value your oppinion.
19:19:27 <nati> Thank you for your work! :ttx
19:19:33 * ttx pads himself in the back
19:19:53 * dprince and by oppinion I really mean opinion
19:20:08 <mtaylor> I had a meeting at rackspace last week with the folks from rcb in san fran (including termie, since he's in the meeting here)
19:20:49 <mtaylor> and it came out that it makes _way_ more sense to have them set up the bare metal deploy infrastructure that we'll just trigger from our jenkins (otherwise we were duplicating efforts)
19:21:08 <nati> cool
19:21:15 <mtaylor> so this is still outstanding, but we have a whole new approach to it ... termie, are you a point person for that?
19:21:33 <termie> mtaylor: oui
19:22:11 <mtaylor> termie: sweet - mind if I mark you down with an action of getting that spun up for this week?
19:22:29 <termie> sure
19:22:33 <mtaylor> #action termie finish work on bare-metal testing deployment
19:22:47 <mtaylor> sweet. if we don't watch out - we're going to have progress around this joint
19:23:02 <soren> It'll pass.
19:23:09 * soren <- optimist
19:23:16 <mtaylor> I'll burn through the next ones real quick
19:23:23 <mtaylor> mtaylor fork griddynamics/openstack-rhel into openstack/openstack-rhel - done
19:23:53 <mtaylor> talk with Novel/MSFT Interop guys about an OBS build profile run from our jenkins - not done - kept playing phone tag with peter (mostly my fault or the fault of our offsite meeting)
19:24:16 <mtaylor> #action mtaylor connect with Peter from Novel/MSFT lap about OBS builds
19:24:26 <mtaylor> #action mtaylor connect with Peter from Novel/MSFT lap about hyperV testing
19:24:43 <mtaylor> mtaylor coordinate with Mihai from rPath to get him what he needs for getting the rPath builder up and going
19:25:17 <mtaylor> I spoke with mihai and we had a plan for this - but then last week everything changed with the machines we're using and the approach we're looking at across the board for testing different deployment options
19:25:22 <mtaylor> so I need to re-discuss with hium
19:25:32 <mtaylor> #action talk to Mihai about new options for rPath testing
19:26:08 <mtaylor> and I did none of the rest of the pinging - so I'll need to do that this week ... but will probably loop in termie as well so that we can make a good plan for what that might look like
19:26:22 <mtaylor> #action mtaylor ping ewanmellor about testing esx and vsphere
19:26:35 <mtaylor> #action mtaylor ping community at large about lxc testing
19:26:45 <mtaylor> #action mtaylor ping reddwarf team about openvx/lxc testing
19:26:53 <mtaylor> alright - so that was fun
19:27:07 <mtaylor> #topic Update on status of bare metal testing changes from last week
19:27:44 <mtaylor> so - the only other thing I've got on this weeks agenda before open discussion was just to do an update on last week's conversations so that interested folks can be looped in
19:28:14 <mtaylor> before last week, the idea was that I had a chunk of machines and was working on the deployment of openstack on them for automated testing
19:28:43 <mtaylor> turns out - my lovely colleagues in san francisco are not only working on the same thing, it's what they do and they already have it working
19:29:35 <mtaylor> therefore, in the interest of sanity, we decided it made the most sense to hand the machines over to them and have them do their deployment thing and hand me a jenkins slave ...
19:29:59 <dprince> mtaylor: how many machines is it?
19:30:13 <mtaylor> which, incidentally, is the exact same approach that we would take with novell/msft and the hyperv lab - so I think we have a consistent approach to how we handle hardware setups people want tested
19:30:35 <mtaylor> dprince: 10 machines at the moment - we're working on requisitioning a different set of machines though (also, hopefully 10 machines)
19:30:51 <nati> consistent approach+
19:31:08 <westmaas> mtaylor: sorry I came in a little late, but whats the config on this set of 10 machines?
19:31:27 <westmaas> which hypervisor, in particular, I mean/
19:31:53 <mtaylor> westmaas: right now it's just 10 boxes ... termie - any thoughts on hypervisor you guys are going to attack first?
19:32:35 <mtaylor> westmaas: (actually, I eventually would love to get both a xenserver and a kvm hypervisor test up and going with our machines ... but I'll defer to termie there on what's sensible, if we know yet)
19:32:55 <termie> we always start with kvm
19:33:12 <termie> xenserver requires the knowledge and love of somebody else
19:33:20 <dprince> Termie: I've got a good start on some XenServer Cookbooks if you want to see them.
19:33:49 <dprince> termie: Wnat are you using for config mgmt?
19:33:57 <mtaylor> might it make sense to loop in with someone from rax cloud servers and get them to provide a set of machines + jenkins slave for xenserver deployments?
19:34:05 <mtaylor> or dprince perhaps :)
19:34:21 <termie> mtaylor: probably, that just isn't my focus at the moment
19:34:32 <mtaylor> termie: agree
19:34:41 <termie> dprince: we're using both chef and puppet at current
19:34:57 <dprince> mtaylor: I'm up for the task. Not sure I'm in a position to volunteer my time. Feel free to assign it to me and I'll get back to you.
19:35:13 * mtaylor is sort of thinking that the stakeholders who want a particular thing tested should make sure that we get an environment on which we can run tests
19:35:13 <termie> dprince: we generally prefer chef, but we had some customer reqs that ended up putting puppet back onto our plates
19:35:14 <dprince> mtaylor: very interested in seeing it done.
19:35:46 <mtaylor> dprince: cool - I'll put you down for it and then see if we can find internal rax motivation for ensuring you have the resources you need
19:35:59 <dprince> termie: I was wondering why you guys started getting cranking on the Puppet. Thanks. Good to see both.
19:36:25 <mtaylor> #action dprince investigate getting a xenserver-based bare-metal deploy up and going for CI purposes
19:36:36 <mtaylor> #action mtaylor bug people in management to get dprince resources
19:36:56 <mtaylor> actually, speaking of that action
19:37:09 <dprince> termie: In case you are interested... https://github.com/dprince/openstack_cookbooks/tree/master/cookbooks/xenserver
19:37:40 <dprince> termie: There is more work to be done there but it is a good start.
19:37:48 <termie> coolio
19:38:16 <mtaylor> anything else on that topic? or I'll open things up for general discussion
19:38:36 <nati> so which puppet recipes we use?
19:38:49 <nati> for baremetal setup
19:39:27 <dprince> nati: you might check out the cloud builders puppet scripts: https://github.com/cloudbuilders/openstack-puppet
19:39:42 <dprince> nati: I haven't tried them myself but they seem to be the furthest along.
19:39:58 <nati> Thank: dprince
19:40:07 <nati> I got another one. https://github.com/puppetlabs/puppetlabs-openstack
19:40:10 <mtaylor> nati: yes, I believe that is what is being used right now - there was discussion about getting that work integrated in with the stuff from the guys at puppetlabs eventually
19:40:41 <mtaylor> nati: sorry - I mean, I believe https://github.com/cloudbuilders/openstack-puppet  is the one being used, and there is an eventual todo for someone to get that integrated with https://github.com/puppetlabs/puppetlabs-openstack
19:40:55 <nati> I got it
19:41:01 <mtaylor> sweet
19:41:25 <nati> so this branch may be a official puppet recipes?
19:41:26 <mtaylor> #topic Open Discussion
19:43:08 <mtaylor> nati: perhaps not 100% related to CI itself, but since it's testing related... there is a guy at Dell wanting to do work on increasing test coverage and coordinating work on writing new tests ... I told him he should definitely talk with you about that
19:44:05 <mtaylor> nati: I believe dprince is also talking with him
19:44:21 <dprince> mtaylor: Is that Dean? We are talking to him on Thursday right?
19:44:31 <mtaylor> dprince: yes. that's him
19:45:38 <nati> Yes, I agree with you
19:45:38 <nati> Personally speaking, there are several dep tools, and I think we need a offial dep tool ..
19:45:52 <nati> cool
19:45:56 <mtaylor> nati: can you define dep tool for me in this context?
19:46:09 <mtaylor> #action mtaylor and dprince will discuss testing with Dean from Dell
19:46:13 <nati> automated openstack deploy tool
19:46:39 <mtaylor> ah - well, that's some of the stuff termie and folks are working on
19:46:55 <nati> cool
19:47:16 <termie> aye, working on that right this moment, actually
19:47:54 <nati> is there some docs of your work? :termie
19:48:28 <termie> nati: nope
19:48:40 <termie> nati: i am making the tool
19:48:40 <nati> cobbler + puppet?
19:48:57 <nati> or cobbler + chef?
19:49:20 <termie> dunno yet, still digging through the existing stuff
19:49:29 <termie> we've previously done pxe + preseed + chef
19:49:33 <mtaylor> vishy had also mentioned something about looking at orchestra+puppet, but don't know if that will make sense or be helpful
19:49:42 <termie> it isn't going to be helpful today
19:49:56 <termie> maybe next week once we have the basics moving
19:50:20 <nati> I got it, thank you for your information
19:50:39 <mtaylor> termie: speaking of - did you get my email with the wrap up of what I had moving on that box? I can't remember if I copied you on it or not
19:50:50 <termie> mtaylor: i don't think so
19:51:03 <mtaylor> termie: k. I'll go find and send it your way in case any of it is useful at all
19:51:39 <termie> general fyi, a bunch of work went into parts of these over the last week but it is all jumbled at the moment
19:51:45 <termie> which is why i don't have a lot of specific info
19:51:51 <termie> digging it out of the people who were working on it
19:52:15 <mtaylor> sweet
19:53:02 <mtaylor> k. sent
19:53:19 <mtaylor> alright ... anybody got anything else CI related they want to talk about?
19:55:15 <mtaylor> ok. in that case - I'm going to say that we're done - and early even!
19:55:19 <mtaylor> #endmeeting