21:02:26 <ttx> #startmeeting
21:02:27 <openstack> Meeting started Tue Jul  5 21:02:26 2011 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:02:34 <vishy> it is 5 EDT right now....
21:02:56 <ttx> Meeting is at 21 UTC
21:03:08 <ttx> I don't even want to know about this EDT thing
21:03:18 <ttx> Today's agenda is at:
21:03:21 <ttx> #link http://wiki.openstack.org/Meetings/TeamMeeting
21:03:25 <ttx> #topic diablo-2 postmortem
21:03:28 <jaypipes> vishy: doh! still had my time set to San Antonio! :(
21:03:43 <ttx> travel fail
21:03:46 <ttx> Last week we released diablo-2, and for the first time there were fixes committed to the milestone-proposed branch
21:04:08 <ttx> The branches proposed for merging into milestone-proposed were reviewed by core teams, which caused confusion (since the branch was already reviewed for its trunk inclusion)
21:04:22 <ttx> So we decided that the milestone-proposed merge should be reviewed by another team
21:04:35 <ttx> and only accepted if (1) it made it to trunk first and (2) it was considered milestone-critical
21:04:50 <ttx> (so the core teams still control the quality of what gets in)
21:05:06 <ttx> The team in charge of that is openstack-release (me, soren + PTLs), so the core teams should not be bothered by double reviews again
21:05:21 <ttx> Any question or comment on how we handled diablo-2, or how we can improve the process ?
21:05:47 <jaypipes> nope, the solution works for me...
21:06:10 <ttx> the process is mostly automated now, we need to cover the remaining gaps
21:06:32 <ttx> soren: btw, I worked on a script to do the LP "release" thing.
21:06:48 <ttx> so nothing should be manual anymore
21:07:05 <ttx> #topic Swift status
21:07:11 <ttx> notmyname: howdy
21:07:14 <notmyname> howdy
21:07:18 <ttx> notmyname: So at this point we are still planning on 1.4.2 release on July 20th ?
21:07:53 <notmyname> perhaps. we're in the middle of discussions with you about making it more closely align with the other projects in version number and release date. there is no resolution yet, though
21:08:12 <notmyname> but either way, the date will be july 20-29
21:08:13 <ttx> ok
21:08:20 <ttx> Plan at https://launchpad.net/swift/+milestone/1.4.2 looks in very good shape.
21:08:30 <ttx> notmyname: Other announcements or comments ?
21:08:58 <notmyname> I don't think so.
21:09:02 <ttx> Questions on Swift ?
21:09:37 <ttx> #topic Glance status
21:09:42 <ttx> jaypipes: Hi!
21:09:53 <ttx> Looking at: https://launchpad.net/glance/+milestone/diablo-3
21:10:07 <ttx> That plan looks a bit optimistic, and D4 is pretty empty... Anything that should already be pushed back ?
21:11:13 <ttx> jaypipes: ?
21:11:37 * Vek guesses the jet lag is getting to jaypipes...
21:11:38 <comstud> he fell back into san antonio time.
21:11:44 <jaypipes> ttx: sorry... here now
21:11:49 <ttx> comstud: lol
21:12:21 <jaypipes> ttx: keystone integration work is lagging a bit... I'll know by EOD tomorrow who/what team can pick up the slack on that. I will email you an update.
21:13:01 <ttx> nobody is assigned to https://blueprints.launchpad.net/glance/+spec/glance-notifications, so it looks like a good D4 defer ?
21:13:24 <ttx> unless someone picks it up ?
21:13:29 <jaypipes> ttx: yes, please do.
21:13:33 <ttx> ack
21:13:49 <jaypipes> ttx: now that the Nova notification stuff is done, should be fairly simple to emulate
21:14:01 <comstud> jay: my team was trying to figure out if we were ready to do keystone/glance integration.. it's possible we could pick something up next sprint
21:14:20 <comstud> (july 18th)
21:14:35 <ttx> jaypipes: I'll wait for your update
21:14:37 <jaypipes> comstud: yeah, I'll email you and gabe to chat about it.
21:14:43 <ttx> jaypipes: Other announcements, comments ?
21:14:52 <jaypipes> ttx: no.
21:15:02 <ttx> Questions for the Glance PTL ?
21:15:43 <ttx> #topic Nova status
21:15:48 <ttx> vishy: yo!
21:15:59 <ttx> Looking at: https://launchpad.net/nova/+milestone/diablo-3
21:16:15 <ttx> vishy: So the plan is ambitious, and I'm in the process of confirming with all assignees that they still think they can deliver
21:16:34 <ttx> Everyone, let us know of anything in there that should be abandoned, or pushed back to D4
21:16:50 <ttx> We already did a pass to adapt
21:17:06 <ttx> We should expect a lot of branch merges for this milestone, so the sooner we review, the better !
21:17:18 <ttx> With that in mind, would be good to give review time to:
21:17:24 <ttx> https://code.launchpad.net/~nttdata/nova/block-migration/+merge/64662
21:17:29 <comstud> Rackspace Shared IP groups might be changing per something I heard earlier today
21:17:32 <comstud> so that might be something that slips
21:17:39 <ttx> anyone feeling like they know that area enough to review that ? It only got one (syntactic) review in 20 days.
21:17:50 <ttx> comstud: yes, I still need to sync with Ozone
21:18:00 <ttx> comstud: thanks for the headsup
21:18:41 <comstud> ttx: you'll probably want to sync with ed conzel from rackspace product
21:18:47 <comstud> (i saw him join in here)
21:19:02 <comstud> (fyi)
21:19:14 <edconzel> yep
21:19:27 <edconzel> shared IP group might be replaced with AffinityID
21:20:08 <ttx> edconzel: what's the timeframe for the decision ? Would it still make the diablo-3 milestone ?
21:20:11 <comstud> i have a guess that won't make diablo-3 due to it being up in the air
21:20:55 <edconzel> final decision by 7/13
21:21:54 <ttx> hmm, sounds a bit late to be written and merged for d3. We should probably retarget to D4... vishy ?
21:22:05 <vishy> agreed
21:22:18 <edconzel> ok
21:22:22 <ttx> that doesn't mean work should not start on it asap
21:22:30 <edconzel> agrred
21:22:37 <ttx> just that it would be merged early in D4 rather than late in D3 :)
21:23:13 <ttx> so nobody feeling up to reviewing the block-migration stuff ? Looks like daily reviewers have been avoiding it like the plague
21:23:47 <ttx> I'd rather not have it miss another milestone due to lack of reviews :)
21:24:11 <ttx> In related news, we also need an assignee for https://bugs.launchpad.net/nova/+bug/803654 -- since it's targeted to diablo-3
21:24:12 <uvirtbot> Launchpad bug 803654 in nova "availability zone ignored when creating volume" [High,Confirmed]
21:24:18 <ttx> Anyone interested ?
21:25:01 <comstud> current volume api can't really work with zones at all
21:25:11 <ttx> vishy: ^
21:25:13 <comstud> if that's what that is
21:25:23 <comstud> since you have to create a volume.. and then later attach it
21:25:37 <vishy> this is actually just ec2 zones
21:25:40 <comstud> (to an instance)
21:25:51 <vishy> old school zones
21:25:52 <comstud> oops, just saw zones
21:25:56 <comstud> ok
21:26:11 <ttx> hah terminology overload
21:26:56 <ttx> ok, I guess I'll ask for reviewers/takers on the ML, it usually works better
21:27:11 <ttx> #action ttx to resurrect "stuff needing attantion" emails
21:27:19 <ttx> vishy: anything else on your mind ?
21:28:08 <ttx> Questions on Nova ?
21:29:11 <ttx> #topic Open discussion
21:29:13 <vishy> nope
21:29:29 <ttx> annegentle asked me to tell everyone that "the Doc/web team meeting is moving to Mondays at 2000 UTC once a month, second Monday of the month".
21:29:41 <ttx> The calendar was updated
21:29:46 <spectorclan_> Any developers wishing to participate in the 1 year OSCON video please contact me so I can work to get your 2 to 5 minute video. Thanks,
21:29:51 <carlp> Any word if the location of the October summit was finalized?
21:30:03 <ttx> spectorclan: ^
21:30:13 <spectorclan_> carlp: It is b/w the Intercontinental Hotel or the Microsoft Research Lab but I think the hotel will win
21:30:19 <spectorclan_> 95% positive it is at the hotel
21:30:35 <spectorclan_> October 3-5
21:30:46 <carlp> spectorclan, awesome, thanks!
21:31:34 <ttx> anything else, anyone ?
21:31:41 <mrmartin> Re, October 3-5 is the final date?
21:31:46 <ohnoimdead> what is the status of keystone support in swift? doesn't look like it's in for 1.4.2?
21:31:51 <spectorclan_> mrmartin: yes
21:32:03 <spectorclan_> conference is 5-7 with 5th just being evening event
21:32:44 <ttx> ohnoimdead: it's not showing up in the plan yet... maybe notmyname knows when this is planned
21:33:07 <creiht> I thought support was already available through keystone?
21:33:19 <ohnoimdead> would be awesome to get that stitched up in the dashboard since right now it's a tempauthtrocity
21:33:43 <mrmartin> creiht: do you have any news about lunr?
21:34:00 <creiht> I should be making an email to the list either this evening or tomorrow
21:34:16 <ttx> creiht: oh, it can be used directly ?
21:34:27 <creiht> ttx: I thought... I'm trying to find that doc
21:35:35 <creiht> https://github.com/rackspace/keystone
21:35:38 <creiht> in the README
21:35:49 <creiht> "Swift Integration - Quick Start"
21:36:05 <ttx> yes, google just found it for me, reading
21:36:22 * creiht notes that note at the bottom
21:36:27 <creiht> Note: Keystone currently allows any valid token to do anything with any account.
21:36:46 <jaypipes> creiht: is there a bug on that somewhere?
21:36:47 <ttx> hmm, I sure like that
21:37:01 <creiht> jaypipes: I have no idea, just repeating what I am reading :)
21:37:22 <ohnoimdead> yeah, wasn't sure if that was official or not. i tried to get it to work but was getting some errors (sent to the list). i'll try again see if i can get further.
21:37:55 <creiht> I've been a bit out of the loop on the swift/keystone things, just relaying what I have seen come accross the screen
21:38:19 <ttx> yes, I need to catch up too. Sign, so many things to look at, and only 24 hours in a day
21:38:23 <ttx> Sigh, even
21:38:57 <creiht> ohnoimdead: I would ask the keystone devs
21:39:02 <ttx> which makes me think it's getting close to the end of that 24th hour here, so...
21:39:15 <ttx> if nobody has anything more, I'll close this
21:39:46 <ttx> #endmeeting