20:02:03 <annegentle> #startmeeting
20:02:04 <openstack> Meeting started Mon Jul 11 20:02:03 2011 UTC.  The chair is annegentle. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:02:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:02:21 <annegentle> #topic action items from last meeting
20:02:45 <annegentle> 1. toddmorey and annegentle to work with ttx on making openstack-website project
20:03:09 <annegentle> toddmorey completed this, making the openstack-org project on Github which he'll cover momentarily
20:03:56 * heckj lurks, but has another meeting conflicting
20:04:03 <annegentle> 2.    annegentle to ask ttx about RSS and subscribing to doc bug feeds - I talked to ttx and found that all doc bugs are tagged and aggregated with openstack bugs at https://bugs.launchpad.net/openstack
20:04:10 <annegentle> heckj: s'okay :)
20:04:43 <annegentle> So that's it on action items. We can move to toddmorey now, on openstack-org
20:04:57 <annegentle> #topic General documentation status - openstack.org project - now in GitHub
20:05:18 <annegentle> toddmorey, floor's yours
20:05:35 <toddmorey> Great. So as Anne said, the repository (in an early first stage) is now online: https://github.com/toddmorey/openstack-org
20:06:14 <toddmorey> So there are two types of involvement with openstack.org: 1. content authoring and 2. design / development
20:06:29 <toddmorey> this, of course, is concerning #2
20:07:29 <toddmorey> Several folks (anne and stephen, for example) are already working with me on content authorship
20:07:41 <annegentle> #info Openstack.org design and dev now a GitHub repo
20:07:44 <annegentle> #link https://github.com/toddmorey/openstack-org
20:07:47 <toddmorey> this is a step to include other people who would like to get involved in development of site features, etc.
20:08:07 <toddmorey> thanks, moderator anne :0
20:08:21 <annegentle> toddmorey: sorry for the unintended interruption, I'm new at this moderator thing :)
20:08:48 <annegentle> toddmorey: does the repo include bug tracking? I'm also new to Github.
20:08:58 <toddmorey> the next step for me is a package of sorts so its super easy to stage the site on a local computer. At any rate, if you'd like to get involved, please don't hesitate to reach out to me: todd@openstack.org
20:09:09 <annegentle> not that there are any bugs!
20:09:44 <toddmorey> Yup! There is issue tracking in github (which we can use) or we could do launchpad if that helps unite with other pieces of the project
20:09:52 <toddmorey> though I guess it's all going github over time :)
20:10:03 <annegentle> you're a trendsetter I'm sure :)
20:10:16 <annegentle> any questions?
20:10:30 <toddmorey> Creating a new issue for the site is easy: https://github.com/toddmorey/openstack-org/issues
20:11:01 <deshantm> is there a staging.openstack.org?
20:11:23 <deshantm> xen.org has one and that makes it easy for us to stage changes before making them live
20:11:47 <toddmorey> good question! There is indeed. That URL is live, though it requires an account to see the content
20:11:47 <deshantm> we also run out of a git tree and there is just a staging and live branch
20:11:56 <toddmorey> (mostly to keep robots from crawling it)
20:12:08 <annegentle> toddmorey: ah, that might be easier than packaging up for local testing?
20:12:24 <annegentle> pesky robots.
20:12:24 <deshantm> (ok so i won't tell you what our staging link is ;)
20:12:27 <toddmorey> #action get folks who would like accounts and create them
20:12:48 <mtaylor> toddmorey: hey! no plans to move issue tracking to github
20:12:50 <toddmorey> uh, maybe I should have made that action make more sense. Is rewording my action another action?
20:13:01 <annegentle> toddmorey: uh, I dunno?
20:13:04 <spectorclan_> toddmorey:  is there a review process for postings or does everyone have free for all?
20:13:43 <annegentle> mtaylor: ok, I wonder if we could log bugs against the openstack-manuals Launchpad project for the openstack.org site?
20:13:44 <toddmorey> There is a review process for sure, but the logistics of it are currently in works.
20:14:05 <mtaylor> annegentle: potentially? hrm ... should probably think about that
20:14:24 <toddmorey> Sure, guys. Would rather use the standard than create a new one.
20:14:26 <annegentle> mtaylor: I really like that doc bugs are rolled up under /openstack esp. when tagged correctly. Seems like we can make it work.
20:14:31 <mtaylor> toddmorey: we're working on review automation (similar to tarmac is now) for the git projects ... would it be helpful to have website hooked in to that?
20:15:00 <mtaylor> as in - we could have things go through review, then get merged, then have jenkins deploy new version of website?
20:15:05 <deshantm> toddmore: I think the action item that intended is to publicize the ability to get an account to the community
20:15:10 <toddmorey> yes, I think that would be helpful. Let's figure out how to hook it in
20:15:29 <toddmorey> deshantm: right you are
20:15:33 <mtaylor> sweet. I'll add it to the todo list of things we should look at once the actual automation stuff is in place
20:15:36 <spectorclan_> toddmorey: I can handle the community account process
20:15:38 <annegentle> mtaylor: yes I also think that'll work well
20:15:51 <mtaylor> annegentle: and yes - I agree re: bug rollups into the /openstack project
20:16:12 <annegentle> Ok, what actions are there?
20:16:21 <jeblair> I'm working with monty on the review automation
20:16:33 <jeblair> now might be a good time to introduce myself :)
20:16:50 <annegentle> #action spectorclan_ to handle community account process, email stephen.spector at openstack dot org to request an account
20:17:19 <annegentle> #action toddmorey and mtaylor to look at hooking up Jenkins for a staging area for openstack.org
20:17:34 <annegentle> jeblair: sure, introduce yourself, sounds apropos
20:18:21 <jeblair> My name is James Blair; I recently joined Rackspace working on the team with Monty, Jay, etc.
20:18:45 <annegentle> we love doc automation and staging, welcome aboard!
20:18:49 <jeblair> I'm starting by helping out monty with the review automation
20:18:50 <jeblair> thanks!
20:19:26 <annegentle> ok, sounds like we're moving along the "opening openstack.org" path
20:19:29 <mtaylor> spectorclan_: 'community account process' ... can I butt in and ask what those are accounts to?
20:19:57 <spectorclan_> mtaylor: people who can edit the OpenStack.org website, not sure we want this but I can have a process built just in case.
20:20:03 <annegentle> mtaylor: I think the idea would be to provide access to the staging area but keep robots out
20:20:11 <mtaylor> great
20:20:32 <toddmorey> those would be CMS author / preview accounts for the staging site
20:20:34 <annegentle> ah, sorry, I'm confusing the two projects - we are talking about 2) design/dev
20:20:35 <mtaylor> so - definitley loop jeblair and I in on that - again the stuff we're doing for the other projects I think can probably apply to the mechanics of that
20:20:44 <mtaylor> AH
20:20:47 <mtaylor> cms author
20:20:57 <mtaylor> gotcha - I totally follow the words you are saying now
20:21:23 <annegentle> mtaylor: hee, saying/typing, you know, it's words.
20:21:29 <mtaylor> bah. words.
20:21:44 <annegentle> ok, thanks for clarifying all. Let's move on...
20:21:46 <annegentle> #topic RST developer docs updates
20:22:02 <annegentle> In no particular order, starting with swift.
20:22:04 <annegentle> For swift, we now have archived sites for the 1.4.0 and 1.4.1 release at http://swift.openstack.org/1.4.0 and http://swift.openstack.org/1.4.1.
20:22:22 <annegentle> To make those archived sites, you can run a build on the Jenkins server at http://jenkins.openstack.org/view/Swift/job/swift-docs-archive/ and enter the version number and the Launchpad branch that you want to use to build the archived site.
20:22:35 <annegentle> thank you mtaylor for making the automagic happen
20:22:47 <mtaylor> yay!
20:22:56 <mtaylor> (although I believe I still have a bug to fix in there somewhere...)
20:23:13 <annegentle> #link http://jenkins.openstack.org/view/Swift/job/swift-docs-archive/ <- Job that creates archived RST doc site from version number and lp branch
20:23:26 <annegentle> That's all the news I know for Swift dev docs.
20:23:40 <annegentle> The most recent addition to Nova docs is the Developer reference for the Distributed Scheduler, contributed by Sandy Walsh.
20:23:49 <annegentle> #link http://nova.openstack.org/devref/distributed_scheduler.html
20:24:03 <annegentle> excellent use of "dating service" as a metaphor, thank you sandywalsh!
20:24:33 <annegentle> #action annegentle to add the distributed scheduler page to the devref index page itself
20:24:51 <annegentle> That's all I know for nova dev docs.
20:26:33 <annegentle> And for Glance dev docs, I did get changes to the docs for Glance flags, where glance_api_servers replaces glance_host/glance_port in the compute admin guide
20:26:58 <annegentle> Thanks to Brian Waldon for that update.
20:27:27 <annegentle> Also, I wanted to let everyone know that the Rackspace doc tools team provided an RST to Docbook conversion tool in their last sprint.
20:27:52 <annegentle> So I can bring over dev docs and write them for ops/devops in DocBook rather handily.
20:28:19 <annegentle> #topic DocBook docs updates
20:28:36 <annegentle> Docs on http://docs.openstack.org can have either Apache licensing (if they came from RST docs, for example) or CC licensing (if it came from a blog, for example).
20:29:01 <annegentle> Hopefully this opens up possibilities to more contributors.
20:29:17 <toddmorey> awesome!
20:29:49 <spectorclan_> very cool
20:30:24 <annegentle> I also spoke with Jacek Artymiak a few weeks back about licensing and collaboration - he recently wrote an ebook about managing Rackspace cloud servers with the openstack-compute tool, and is very interested in working with us.
20:30:30 <annegentle> #link http://www.readwriteweb.com/cloud/2011/06/how-to-manage-rackspace-cloud.php <- review of his book
20:30:43 <annegentle> Always open to more contributors, y'all. :)
20:30:53 <annegentle> #topic Doc incubation
20:31:20 <annegentle> I brought the Keystone dev guide into openstack-manuals last week, and it builds automatically to http://docs.openstack.org/incubation/identitydevguide/content/index.html.
20:31:30 <heckj> annegentle: re contribution - you're welcome to the FlatNetworking pieces I put on the wiki - tried to make it available for the most folks there.
20:31:32 <annegentle> thanks again to mtaylor and dwcramer for the help on that one.
20:31:41 <annegentle> heckj: excellent, thanks.
20:32:10 <deshantm> what is doc incubation?
20:32:24 <annegentle> heckj: I took a look at bringing wiki markup into docbook and the HTML that MoinMoin outputs is miserable, but I'll look again soon.
20:32:52 <annegentle> deshantm: Doc incubation is the process for brining relevant documentation under the docs.openstack.org umbrella once the Project Policy Board votes to incubate a project.
20:33:05 <deshantm> ah ok thanks
20:33:10 <heckj> annegentle: I'm happy to help translate if needed, but I don't know docbook, and my initial forays into trying to edit it were tinged with horror
20:33:14 <annegentle> in this case, Keystone had a DocBook Dev Guide ready to release, so under the umbrella it went.
20:33:21 <annegentle> heckj: horror! :)
20:33:30 <dwcramer> heckj: MoinMoin can output to DocBook. That might be worth exploring.
20:33:38 <annegentle> heckj: we can work on a path
20:33:42 <annegentle> dwcramer: nice
20:33:51 <annegentle> #action explore MoinMoin to DocBook paths
20:34:41 <annegentle> One other note on incubation, there's also the Extensions Guide that is under pre-incubation now
20:35:04 <annegentle> The docs don't necessarily distinguish between "already incubated" and "applying for incubation"
20:35:48 <annegentle> Ok, guess I'll open it up for open discussion
20:35:52 <annegentle> #topic Open discussion
20:36:28 <annegentle> I do have one item that seems low-hanging fruit to me. If anyone is interested in uploading man pages for Debian, there are stub files available. I think it's a copy/paste job.
20:36:45 <deshantm> toddmorey: did you get my email about the idea of having a redirect from blog.openstack.org to openstack.org/blog
20:36:50 <annegentle> For example, see http://cdn.debian.net/debian/pool/main/s/swift/ . You'd replace the stub files in the debian/mans folder of
20:36:50 <annegentle> the .debian.tar.gz file.
20:36:54 <heckj> A number of doc updates will be needed around installing OpenStack and the nova-manage commands (some of which have changed recently)
20:37:18 <toddmorey> I did! I asked for that to be set up. Very sensible request.
20:37:44 <annegentle> heckj: yes, also the nova-manage network create command now requires public or private.
20:37:47 <toddmorey> I do the same thing. :)
20:37:52 <annegentle> I've started updating in trunk - such as http://docs.openstack.org/trunk/openstack-compute/admin/content/configuring-networking-on-the-compute-node.html
20:38:13 <heckj> annegentle: Great! Wanted to make sure that wasn't missed.
20:38:36 <annegentle> heckj: would love help with the editing passes, maybe we'll get you ramped up on DocBook :)
20:38:43 <deshantm> I was talking to a user the other day that had some confusion about which version of the nova/euca tools work with which version of openstack
20:39:00 <heckj> I think we also need to be even handed with handing out links to install mechanisms - both Puppet, Chef, and the various scripts and distributions. The wiki implies some over others right now.
20:39:02 <deshantm> is there a place that documents the various interactions?
20:39:34 <annegentle> deshantm: that's a good question. I know soren started http://wiki.openstack.org/Nova/EucalyptusFeatureComparison
20:39:39 <heckj> annegentle: Would be happy to help read through & edit! Just need to get over the hump with DocBook
20:40:29 <heckj> deshantm: It's a bit of an ongoing discussion when it comes down to APIs too - the euca-upload-images, for example, doesn't work with the Glance pieces to my knowledge, and many examples are starting to switch from using Euca commands to OpenStack API commands.
20:41:17 <deshantm> ok so is there a good place to track this discussion and outcomes of it in order have a nice place to point users?
20:41:38 <annegentle> deshantm: I think some of the difficulty also lies in using the API spec as a Dev Guide.
20:41:52 <heckj> deshantm: I don't think there's one place - it's all over
20:41:55 <annegentle> deshantm: it's a reuse that means it's hard to know where that info should live
20:42:10 <annegentle> right, the scattering is what I'm getting at too. Where should such info live?
20:42:28 <annegentle> on the wiki for starters?
20:42:46 <deshantm> ok I'm fine following the situation and synthesizing for users if I know what to follow
20:43:13 <spectorclan_> Great meeting anne, have to run. Thanks,
20:43:14 <spectorclan_> exit
20:43:18 <annegentle> deshantm: for example, the API 1.1 spec just updated
20:43:29 <heckj> Reasonable - easy to edit and accessible to anyone. We might want to mark some specific wiki pages to indicate they're sourcing information - there's enough happening in that wiki it's getting a little hard to distinguish signal from noise.
20:43:29 <deshantm> I'm planning on doing some OpenStack testing for work
20:43:36 <annegentle> but that Dev Guide doesn't provide "use this and this and it'll work"
20:44:08 <annegentle> heckj: agree on the signal/noise difficulty on the wiki. Do we just need a new section written in the Compute Admin Guide?
20:44:48 <annegentle> or, is it a brutally honest wiki page that best serves this purpose (clarifying which version of the nova/euca tools work with which version of member:openstack)
20:45:22 * annegentle leans towards brutally honest wiki page for now
20:45:29 <deshantm> it seems like this is more of a wiki thing until things stablize
20:45:34 <annegentle> sounds good.
20:45:35 * heckj agrees with brutal honest wiki page
20:46:04 <annegentle> #action annegentle to start wiki page to clarify which version of the nova/euca tools work with which version of openstack distro
20:46:12 <heckj> We need to keep it super easy to edit, and maybe just closely monitored/edited
20:46:32 <annegentle> deshantm: like what you're doing towards Xen packaging, thanks for doing that, it'll help immensely with docs
20:46:43 <deshantm> annegentle: can you email that wiki page out once it is created so I can folow it and try to help
20:46:43 <heckj> I'm reacting a bit to StackOps page on the wiki which encourages folks to use their Distro, but has a number of holes they don't appear to be responding to.
20:47:13 <deshantm> annegentle: Yeah, I also found a docs bug about the xenapi plugins
20:47:16 <annegentle> heckj: we can all do our part to spackle :)
20:47:25 <deshantm> once this gets resolved I'll update that bug
20:47:42 <annegentle> ok, thanks. Any thing else from any one else?
20:47:54 <deshantm> I'll also need to go back and add the relevant information the compute admin guide
20:48:04 <annegentle> deshantm: great, that would be excellent
20:48:08 <deshantm> that's all I can think of for now
20:48:10 <deshantm> thanks
20:48:14 <annegentle> ok, thanks all
20:48:23 <annegentle> #endmeeting