19:05:23 <mtaylor> #startmeeting
19:05:24 <openstack> Meeting started Tue Jul 12 19:05:23 2011 UTC.  The chair is mtaylor. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:05:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:05:40 <mtaylor> #topic Review of last week's actions
19:06:12 <mtaylor> dprince Have smoketests return xunit file via nosexunit
19:06:21 <mtaylor> dprince has gotten this done
19:06:48 <mtaylor> as evidenced by the lovely test report on the nova-vpc job:
19:06:51 <mtaylor> #link http://jenkins.openstack.org/job/nova-vpc/59/testReport/
19:07:03 <mtaylor> so, well done dprince
19:07:09 <mtaylor> dprince fight with ttx over fixing bug 804317
19:07:09 <uvirtbot> Launchpad bug 804317 in nova "FixedIpNotFoundForInstance: Instance 1 has zero fixed ips." [Wishlist,Confirmed] https://launchpad.net/bugs/804317
19:07:18 <mtaylor> that one was done last week during the meeting, IIRC
19:07:32 <mtaylor> termie finish work on bare-metal testing deployment
19:08:02 <mtaylor> we're still in work on that one - but we have some dedicated hardware coming our way. once I have that, I can hand termie some resources to use for the openstack jenkins
19:08:10 <mtaylor> #action mtaylor provide termie with machines
19:08:18 <mtaylor> #action termie finish work on bare-metal testing deployment
19:08:45 <mtaylor> the next two are about connecting with Peter from Novell/MSFT - he's out of town atm, so we'll connect when he gets back in
19:08:54 <mtaylor> #action mtaylor connect with Peter from Novel/MSFT lap about OBS builds
19:08:59 <mtaylor> #action mtaylor connect with Peter from Novel/MSFT lap about hyperV testing
19:09:12 <mtaylor> I also haven't spoken with mihai yet
19:09:21 <mtaylor> #action mtaylor talk to Mihai about new options for rPath testing
19:09:39 <mtaylor> mtaylor ping ewanmellor about testing esx and vsphere
19:10:03 <mtaylor> we've had some good discussions with ewan and some other folks from citrix about testing
19:10:29 <mtaylor> to that end, we've set up a stub job and a stub slave:
19:10:33 <mtaylor> #link http://jenkins.openstack.org/job/citrix-nova/
19:10:41 <mtaylor> that can be the entrypoint for their testing efforts
19:11:33 <mtaylor> haven't really talked to anyone about lxc testing - but honestly at this point we have about 6 different baremetal testing efforts underway - so I think if we just get them working before we solicit _additional_ people, that'll be stellar
19:11:48 <heckj> agreed
19:11:57 <heckj> more than enough moving parts right now
19:12:02 <mtaylor> and dprince and I had a lovely talk with Dean from Dell which led to the creation of an openstack-testing team
19:12:16 <mtaylor> #link https://launchpad.net/~openstack-testing
19:12:37 <mtaylor> which will aim to coordinate QA and testing efforts across all of the companies that are wanting to write new tests
19:13:33 <mtaylor> I'm hoping that the work with the folks from citrix will serve as a nice template we can point to for how contributed testing resources can work and what that looks like
19:13:46 <mtaylor> that's all I've got on that...
19:14:07 <mtaylor> anything else on last week before we move to open discussion?
19:14:26 <heckj> are you blocked on anything? (Anything that could use external help?)
19:15:06 <mtaylor> not really - we've actually been making some pretty decent progress over the last week or two
19:15:09 <mtaylor> #topic Open Discussion
19:15:55 <heckj> I've just joined in the openstack-testing group - would like to offer assitance, but not sure where I can do much useful right now. Any suggestions?
19:16:27 <mtaylor> heckj: it's pretty early stage - but drop a note to the list there and let folks know you're interested in helping
19:16:33 <heckj> K
19:16:51 <mtaylor> I think part of the status of that is everybody figuring out who all is around and who wants to do what
19:17:36 <mtaylor> possibly unrelated - but I started making jenkins slaves for each project, which will help isolate the machine setup needs of each project
19:17:42 <mtaylor> should have that done soon
19:19:45 <dprince> mtaylor: hey man. Sorry I'm late. Like you said the xunit output is done.
19:20:02 <heckj> dprince: nice work
19:20:32 <shwetaap> hey mtaylor, - does that include the Quantum project as well. I know that so far it has not been added in jenkins. Is there any plan for it any time soon?
19:21:23 <mtaylor> shwetaap: yes - I'm working on getting keystone added this week, and will start hitting quantum after that
19:22:13 <dprince> mtaylor: Do we have keystone packages yet?
19:22:32 <nati> Can we talk about testing in this meeting time?
19:22:48 <mtaylor> dprince: nope. we also need those soon
19:22:58 <mtaylor> soren: have you done any keystone packaging work?
19:23:02 <dprince> mtaylor: is anyone working on them?
19:23:05 <soren> I was just about to say :)
19:23:10 <soren> I have them mostly ready.
19:23:12 <mtaylor> #action mtaylor quantum in to jenkins
19:23:15 <mtaylor> w00t
19:23:19 <dprince> soren: great. Thanks man.
19:23:26 <soren> The problem was figuring out a good place to put them (Seeing as Keystone isn't an official openstack project).
19:23:33 <soren> ...but I think we got a solution for that.
19:23:43 <soren> Now I just need to get to it.
19:23:52 <mtaylor> yeah - that's sort of been a weird thing so far - and is actually a general question (which I've been answering in my own way)
19:23:53 <soren> There's 3 other things I need to do first.
19:24:05 <mtaylor> which is what to do with non-official openstack projects from a ci perspective
19:24:09 <soren> So unless something sneaks in front, it'll be within a couple of days.
19:24:58 <dprince> soren: Where will it be then? Launchpad? GitHub?
19:25:41 <soren> dprince: The packages? Launchpad. That's the only place for packages.
19:26:03 <dprince> soren: Sure. So under 'keystone' or 'ubuntu'?
19:26:33 <soren> dprince: That was (and is) the other problem. We don't yet have the infrastructure to do automated builds of stuff from github, but people started shoving things on there..
19:26:57 <soren> dprince: It'll follow the same pattern as everything else.
19:27:04 <mtaylor> we're getting closer on that one
19:27:19 <soren> dprince: So the packaging code wil llive (and maybe already does?) at lp:~openstack-ubuntu-packagers/keystone/ubuntu
19:27:35 <soren> Closer is not "there" :)
19:27:49 <mtaylor> nope. it's not
19:27:52 <dprince> soren: Thank you sir. I'll stay tuned.
19:27:54 <soren> They didn't exactly do themselves any favours by jumping the gun on that.
19:28:29 <jaypipes> soren: I told them to do that. It would give us experience integrating with GitHub. So blame me.
19:28:30 <dprince> mtaylor: I have one action item for you (If I'm allowed to add one).
19:28:34 <mtaylor> soren: well, we _do_ have some keystone jobs triggered from git/github changes in launchpad (the pep8 and pylint stuff) ... in case that's helpful
19:28:38 <mtaylor> dprince: please!
19:28:43 <soren> "Sure, let me construct a massive amount of intfrastructure to set up automated builds of this project that isn't even yet an official openstack project" :)
19:28:47 * jaypipes takes blame for anything...
19:29:02 <dprince> mtaylor: I'd like DNS entry for smoke.openstack.org please!
19:29:13 <dprince> mtaylor: or smokestack.openstack.org.
19:29:16 <mtaylor> #link http://jenkins.openstack.org/job/keystone
19:29:26 <jaypipes> soren: part of the incubation status is integrating the project into our CI and build/packaging platforms.
19:29:45 <mtaylor> #action mtaylor actually set up the dns entry for smokestack that dprince has been asking him for for weeks
19:29:58 <mtaylor> dprince: can you drop me the IP address again real quick?
19:30:20 <dprince> mtaylor: great. Here is the IP: 184.106.189.251
19:30:32 <mtaylor> #info smokestack.openstack.org == 184.106.189.251
19:31:59 <dprince> nata: you wanted to talk about tests. Anything specific?
19:32:24 <dprince> SOrry. nati: ^^^^
19:32:54 <nati> Hi dprince, I would like to share testing list in communities
19:33:18 <dprince> nati: Can we start a wiki page with the existing test suites and go from there?
19:33:28 <nati> Cool
19:33:38 <nati> Can we use google spreadsheet?
19:34:02 <mtaylor> nati: well - is it possible to use etherpad or the wiki instead?
19:34:14 <mtaylor> I'd hate to add another group technology to the mix if we didn't have to
19:34:16 <heckj> I would much prefer a wiki page or etherpad - hard to share globally w/ google docs
19:34:17 <dprince> nati: I think it would make more sense if it were on wiki.openstack.org. At least people will look for it there.
19:34:30 <nati> OK I got it
19:35:03 <dprince> lets make this an action item then? Create a wiki page to list the test suites we have?
19:35:20 <nati> I'll create initial list of existing tests :D
19:35:33 <dprince> nati: great
19:35:46 <mtaylor> #action nati create an initla list of existing test suites
19:36:00 <nati> NTT will create Testing team for Openstack
19:36:15 <nati> We would like to write tons of testing code :)
19:36:33 <nati> We would like to share progress of testing work in communities
19:37:21 <mtaylor> lovely
19:37:46 <mtaylor> nati: you joined the openstack-testing team on launchpad, yes? because I think you and Dean from Dell will probably have very good conversations on this point
19:37:48 <nati> Thanks
19:38:06 <nati> Yes I joined the testing team
19:38:31 <nati> I'll post this topic to the testing team mailing list
19:39:09 <mtaylor> perfect!
19:40:09 <mtaylor> nati: on the call with Dell, dprince and I discussed an idea of creating a project outside of the nova/swift/glance trees that would contain tests - so that we would develop an external test suite and then be able to apply that to an openstack installation
19:40:16 <mtaylor> nati: does that sound like a good idea to you?
19:40:31 <nati> Cool!
19:41:05 <nati> NTT's testing efforts are mainly for diablo-release version
19:41:14 <dprince> It would be nice to have a robust common set of tests. But I can see companies expanding that to target their specific setups as well.
19:41:35 <nati> We would like to add tests for diablo branch after releases
19:42:11 <mtaylor> so - just for the sake of completeness - perhaps someone should look at http://www.phoronix-test-suite.com/ ?
19:42:20 <mtaylor> it's an external set of test suites that can be run against things...
19:42:51 <mtaylor> I don't know that it's the right choice - but since it's a collection of test suites to test things, perhaps working with them would be nicer than making our own complete setup from scratch?
19:45:10 <nati> What's difference between Jenkins and Phoronix Test Suite?
19:46:02 <mtaylor> jenkins is a continuous integration tool ... it's what we use to run jobs against things
19:46:32 <mtaylor> phoronix on the other hand is a collection of tests and tools for running them ... so it would be a framework in which we could choose to write tests if we wanted
19:46:47 <nati> I got it!
19:47:56 <mtaylor> anyway - like I said - it may be a terrible idea - but I think canonical were talking about doing something with that setup for testing of ubuntu server installations
19:48:27 <heckj> Glancing through the docs, it looks very focused on repeated testing with slight variations (i.e. benchmarking)
19:48:43 <heckj> related link: http://openbenchmarking.org/
19:48:50 <jaypipes> heckj: glancing, huh? :)
19:49:16 <heckj> I won't claim to have read it - more skimmed and looked at headers and links quickly
19:49:19 <heckj> :-)
19:50:03 <mtaylor> #link http://www.phoronix-test-suite.com/
19:50:08 <mtaylor> #link http://openbenchmarking.org/
19:51:15 <dprince> gotta go. talk to you all next week.
19:51:53 <mtaylor> I think that's about it?
19:51:56 <mtaylor> anybody got anything else?
19:52:41 <mtaylor> #endmeeting