22:03:06 <danwent> #startmeeting
22:03:06 <ryu_ishimoto> hello
22:03:06 <openstack> Meeting started Tue Jul 12 22:03:06 2011 UTC.  The chair is danwent. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:03:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
22:03:20 <danwent> #topic project-status
22:03:37 <danwent> dendrobates has updates on email list (yay!) and incubation (nay!)
22:03:50 <dendrobates> ok
22:04:04 <dendrobates> I hope everyone saw my email about the email list
22:04:24 <dendrobates> please use the link on the bottom of the netstack team page to join
22:04:28 <danwent> https://launchpad.net/~netstack
22:04:32 <SumitNaiksatam> yes
22:04:33 <dendrobates> thanks dan
22:05:07 <dendrobates> also we are holding off on requesting incubation status, while the openstack PPB decides a few things
22:05:25 <dendrobates> basically, the PPB is trying to decide what it means to be a part of openstack
22:05:33 <danwent> makes sense.
22:05:38 <dendrobates> I think we should let them figure that out first.
22:05:44 <somik> about netstack ML: my only concern is that if we dont send stuff to openstack list, then we might be out of the loop or duplicate efforts
22:06:07 <dendrobates> and the two incubation applications that have been pushed have not gone well
22:06:22 <somik> we need some guidance then on when to use ML and why..
22:06:23 <dendrobates> somik: true, we should still try to keep communication open
22:06:26 <danwent> somik: netstack list is for detailed design discussions.  outcomes of those discussions (design proposals) should still be sent out more broadly.
22:06:47 <dendrobates> or things that interface with other components, i,e nova
22:07:20 <danwent> we've just noticed that some conversations don't see to happen on the list, so at least we want a way that people can say "I want all of the emails, even if its really noisy"
22:07:36 <dendrobates> I hope this encourages people to use the list instead of just cc'ing a private group
22:07:41 <danwent> anything else on project status?
22:07:49 <dendrobates> nope
22:07:56 <somik> dendrobates: whats the requirement more incubation, I and others may not be familiar, it would be good to have a brief summary requirements for us who dont know the process as well
22:08:20 <dendrobates> somik: I'm not sure that is completely decided yet, that is the problem
22:08:36 <dendrobates> we are still deciding what it means to be a part of openstack
22:08:47 <danwent> #topic quantum
22:08:51 <heckj> What they have (minimal) is at http://wiki.openstack.org/ProjectTypes
22:08:59 <markvoelker> somik: http://wiki.openstack.org/Governance/Approved/Incubation  is what's currently out there but it doesn't address everything.
22:09:22 <salv> before moving into Quantum, what are we going to do with jenkins integrations?
22:09:23 <dendrobates> and the outcome of the current discussions is likely to change things
22:09:44 <danwent> thanks for tracking all this dendrobates
22:09:45 <dendrobates> we are going to work to integrate immediately
22:09:58 <danwent> Ok, for Quantum status, salvatore wanted to bring up his plans for unit/functional tests.  Salvatore?
22:10:00 <dendrobates> I will contact mordred
22:10:23 <danwent> sorry, salvatore, please hold a sec
22:10:34 <danwent> dendrobates, are you talking about for the build infrastructure?
22:10:47 <dendrobates> yes
22:10:51 <danwent> k, cool.
22:10:58 <danwent> sorry salvatore, go ahead.
22:11:04 <heckj> note: The CI team is setting up an external project for smoke tests. Should be easy to plug into that.
22:11:06 <dendrobates> I think we should try to move forward and I have discussed it with a few people
22:11:28 <dendrobates> ttx had initially asked me to hold off
22:11:50 <dendrobates> but we need to move forward asap
22:12:02 <dendrobates> ok go
22:12:07 <danwent> :)
22:12:25 <heckj> #link https://launchpad.net/~openstack-testing
22:12:42 <salv> About unit/functional tests: not a lot progress during this week. I think we can speed up things by separating unit test (almost ready) from functional tests
22:13:01 <salv> So we can merge the branch with unit tests in a very short term
22:13:43 <danwent> Ok, sounds good.  Anyone have concerns with this?
22:13:43 <salv> Any comment?
22:13:54 <dendrobates> It sounds like a good idea to me
22:14:04 <danwent> salvatore, if someone wants to help out, where do they look to pick off unit tests?
22:14:10 <danwent> or functional tests that are needed?
22:14:29 <danwent> this is the blueprint: https://blueprints.launchpad.net/quantum/+spec/api-spec-unit-tests, I believe.
22:14:33 <salv> I have a wiki page for unit tests
22:14:41 <salv> looking for it...
22:15:05 <salv> sorry
22:15:09 <salv> Implications for XenServer
22:15:11 <salv> http://wiki.openstack.org/QuantumUnitTestStatus
22:15:20 <salv> I should be more careful with cut & paste
22:15:44 <danwent> haha, good thing it wasn't top secret
22:15:52 <danwent> I think we know that you work on XenServer :)
22:16:18 <danwent> salv: great list....
22:16:32 <salv> maybe somebody else can pick the work on functional tests, so the activities can proceed in parallel
22:16:37 <salv> any takers?
22:16:37 <danwent> is brad here?
22:16:52 <danwent> brad: did you write document on how to write/run unit tests?
22:17:11 <bhall> I'm here
22:17:13 <dendrobates> markvoelker: do you have any free resources
22:17:19 <bhall> I haven't written it yet, I'll do it today
22:17:21 <markvoelker> Let me check--we may
22:17:38 <danwent> bhall: great, we can send it out on our shiny new email list :)
22:17:44 <bhall> :)
22:17:51 <salv> dendrobates, markvoelker: couple of guys at Cisco tried out the test branch.
22:18:14 <salv> I don't know if they are in your teams: Shubhangi and Shweta.
22:18:33 <markvoelker> salv: Yep, that'll be Zhiang Deng and company.  I know he was working on some other proejcts this week, but I think they are planning to shift back over shortly.  Building up some infrastructure in the lab for that now.
22:18:53 <markvoelker> salv: Shabhangi & Shweta work with Zhiang
22:19:10 <dendrobates> on the quantum from, cisco has a branch:  https://code.launchpad.net/~cisco-openstack/quantum/plugin-framework
22:19:12 <markvoelker> I'll ping Zhiang in the morning and see if they can pitch in on this
22:19:32 <danwent> markvoelker: great, thanks.
22:19:48 <danwent> dendrobates: that's great.
22:19:49 <dendrobates> sumit will be sending an email to the list explaining it.   Feel free to check it out
22:19:57 <somik> dendrobates: i was litle intimidated by the "simple" merge prop of that cisco branch ;)
22:20:26 <danwent> :)
22:20:32 <dendrobates> sorry, I made a typo using the bzr lp integration
22:20:37 <dendrobates> I deleted it right away
22:21:10 <danwent> troy, you still here?
22:21:20 <somik> dendrobates: no problem ;)
22:21:22 <dendrobates> plus that had an unnecessary test file in it that made in uselessly long
22:21:31 <danwent> Troy said he had to leave early, but I wanted to see if he had anything to say about the extensions branch his team sent out.
22:22:12 <danwent> is that all on testing?
22:22:21 <danwent> Troy, any comments on the extension work?
22:22:31 <danwent> (or melange, if you need to run)
22:22:41 <salv> yes, that is all. I'll split the branches. Dan, put an action for it, please :-)
22:23:00 <troytoman> no. i think we're waiting for some feedback and are working on unit tests to make the existing capabilities more clear
22:23:01 <danwent> #action salv, splite unit testing and functional testing branches
22:23:16 <troytoman> we've moved the melange focus to integration with Nova.
22:23:27 <troytoman> first step is to look at how to get it into the nova project
22:23:52 <troytoman> then, how we intersect some of the nova refactoring work to integrate into the nova flows
22:24:01 <troytoman> should be more on that in the next week or two
22:24:31 <troytoman> there is an updated wiki page with the current IPAM API documentation
22:24:48 <troytoman> http://wiki.openstack.org/MelangeAPIBase
22:25:11 <danwent> troy: I have some interesting customer uses cases for melange to talk to you about... remind me :)
22:25:18 <danwent> when you have more time.
22:25:44 <troytoman> danwent: perhaps we can dig in during our regular phone catch up
22:25:52 <danwent> troy: sounds good.
22:25:54 <salv> troytoman: just skimming over the wiki page. Does Melange handle NAT as well?
22:26:32 <troytoman> salv: melange can track NAT relationships but does not currently actually 'do' the NATing
22:26:48 <salv> troytoman: ok, understood.
22:26:55 <danwent> ok, is that all troy?
22:27:05 <troytoman> yes. unless there are other questions
22:27:30 <danwent> thanks.  Ok, back to our regularly scheduled programming....  nova refactoring, ryu?
22:27:51 <ryu_ishimoto> yup
22:28:25 <ryu_ishimoto> I have a new branch https://code.launchpad.net/~midokura/nova/network-refactoring-l2  that I created very recently, which concentrates solely on intergration with L2 service(like Quantum)
22:28:40 <danwent> specifically the "vif plugging", right?
22:28:49 <danwent> in the virt layer
22:29:11 <ryu_ishimoto> the other branch I had dealt with more broad refactoring of Nova, and I thought we should first concentrate on the integration with Qauntum and start from there
22:29:18 <ryu_ishimoto> danwent: yes, this is the VIF plugin implementation
22:29:51 <danwent> This is great as it will let us make progress with Quantum + nova ASAP, while taking a bit more time on the grand refactoring of nova.
22:30:04 <ryu_ishimoto> this branch contains the concept of VIF drivers that handle the networking setup on the compute host, as well libvirt interface configuration generation
22:30:17 <danwent> ryu: has sumit validated that this works for him?
22:30:44 <SumitNaiksatam> I checked the blueprint and looks fine to me
22:30:49 <SumitNaiksatam> not looked at the code
22:30:50 <danwent> great.
22:31:03 <danwent> ah, ok. definitely take a look at the code and give it a try
22:31:04 <ryu_ishimoto> danwent:  I was going to send this over to the netstack list as well, as soon as we get the very basics down
22:31:14 <danwent> ok, sounds good.
22:31:21 <SumitNaiksatam> dan, ryu: sure
22:31:34 <SumitNaiksatam> good job guys!
22:31:58 <danwent> If there is anyone trying to get vif-plugging code in for D3, please speak up, as we want to get this proposed for merging before the end-of-milestone craziness
22:32:15 <danwent> (anyone beyond those who've already been talking, that is)
22:32:19 <SumitNaiksatam> sorry, when is D3?
22:32:28 <danwent> end of the month, is that correct?
22:32:35 <danwent> someone have the exact date?
22:32:57 <salv> Jul 28
22:33:09 <danwent> https://launchpad.net/nova/+milestones
22:33:10 <SumitNaiksatam> ok, and what are we planning to get accomplished on the nova-refactoring-l2 branch before that?
22:33:12 <danwent> thanks salv
22:33:15 <SumitNaiksatam> thanks
22:33:28 <salv> that's release date however, merge proposal should be done a week earlier at latest
22:34:22 <danwent> sumit: mainly that the nova virt layers can "plug" in to different types of switches (bridge, OVS, your cisco NICs, etc.)
22:34:28 <ryu_ishimoto> great, let's at least get the VIF plugin in.  I still have some questions I want to ask Nova guys regarding some extension APIs, so I don't think we can get everything in for this milestone
22:34:58 <danwent> yeah, ideally we'd like to get an extension that exposes the VIF-IDs via the API, but that may not happen in time.
22:35:18 <SumitNaiksatam> ok, do we need to get all the VIF drivers in before that, or just the ones which Ryu might be putting in?
22:35:31 <ryu_ishimoto> also we need to figure out some way to have the VIFs plugged into ports when launching VM
22:35:55 <danwent> people will be able to add vif drivers later as well (which is why we're adding the abstraction).  I'm just making the point that if you want it in by D3 as part of the existing blueprint, we'll have to have it done soon.
22:36:19 <danwent> ryu: yes, though in my mind that may be part of the larger nova refactoring bucket.
22:36:24 <heckj> worth noting that Vish has a proposed merge (https://code.launchpad.net/~vishvananda/nova/ha-net) that will impact the existing nova network setup. Might be worth providing feedback there.
22:36:34 <danwent> I will be sending some thoughts out the the list about this hopefully this week.
22:36:44 <ryu_ishimoto> heckj: thanks I will take a look
22:37:12 <danwent> ok, anything else on nova refactoring?
22:37:47 <danwent> Ok, markvoelker, any update on the client-lib / GUI?
22:37:53 <ryu_ishimoto> that's it for me
22:37:55 <markvoelker> Yep.
22:37:57 <danwent> I think I saw a new branch on the client-lib at least, very cool :)
22:38:04 <markvoelker> There's now a branch linked to the blueprint here:
22:38:04 <markvoelker> https://blueprints.launchpad.net/quantum/+spec/quantum-client-library
22:38:43 <markvoelker> Tyler has a few more changes he wants to make (look for an email on our new netstack list tomorrow for details), but a lot of copy/pastey stuff has hopefully been eliminated.
22:39:45 <markvoelker> Next step will be to get some feedback from everyone, make tweaks, and start using it for a dashboard module
22:39:48 <danwent> great.  A good client lib will pay a lot of dividends, its come up in conversation several times just in the last week when talking to people about working against the quantum APIs.
22:40:14 <markvoelker> Is anyone planning to work on integrating the new lib with the CLI client, or should we add that to our to-do list as well?
22:40:23 <markvoelker> We don't mind a bit, just didn't want to dupe efforts. =)
22:40:43 <danwent> If you're volunteering, that's great, otherwise we can help :)
22:40:55 <salv> markvoelker: the client library might be integrated with the functional tests as well
22:41:15 <danwent> I think they already tweaked at least some of the tests...
22:41:17 <markvoelker> salv: Agreed.  I've mentioned that to Zhiang/Shweta/Shughangi too.
22:41:19 <heckj> markvoelker: I'm working closely with the dashboard team - they're restructuring to make plugins easier right now. Should be a great integration.
22:41:45 <markvoelker> heckj: Great!  I've been noticing the activity in dashboard-land. =)
22:42:24 <danwent> great, thanks mark
22:42:54 <markvoelker> Any questions on dashboard/client lib?
22:43:22 <danwent> One final comment for quantum: Salv and I are going to have a chat Thurs morning (u.s. time) to talk about authentication/authorization in quantum.  Last time I mentioned this no one else said they wanted to participate, but I just wanted to throw it out there...
22:43:44 <dendrobates> danwent: I'd like to join
22:43:54 <markvoelker> danwent: I wouldn't mind being a fly on that wall either
22:44:09 <danwent> #action danwent: send auth invites to dendrobates, markvoelker
22:44:10 <salv> dendrobates: Is tomorrow 10 AM Midwest time fine for you
22:44:13 <heckj> danwent: integration into Keystone for that?
22:44:20 <dendrobates> yep
22:44:23 <danwent> heckj: yes
22:44:39 <danwent> ok, anything else on quantum?
22:44:58 <salv> All people wanting to join the meeting on AuthN/AuthZ please drop me an email and I will extend the invitation
22:45:13 <danwent> #topic melange
22:45:21 <danwent> see troytoman comments above
22:45:30 <danwent> anyone have anything else on melange?
22:45:33 <danwent> or donabe?
22:45:36 <dendrobates> yep
22:45:45 <danwent> dendrobates, donabe?
22:45:46 <SumitNaiksatam> salv: can you send invite to netstack mailer?
22:45:53 <dendrobates> We are starting to push donabe api code
22:45:59 <danwent> #topic donabe
22:46:02 <dendrobates> https://code.launchpad.net/~netstack-core/donabe/diablo
22:46:12 * markvoelker cheers for donabe api code
22:46:13 <salv> SumitNaiksatam: sure
22:46:14 <danwent> very cool.
22:46:28 <dendrobates> We expect to have all the crud operations and a stubbed out backend by next week
22:46:34 <danwent> dendrobates: is there an API doc?
22:46:43 <somik> dendrobates: very cool, any blue prints for that code anywhere yet?
22:46:45 <dendrobates> I will be sending the doc to the mailing list
22:47:03 <danwent> definitely looking forward to it.
22:47:08 <dendrobates> somik: not yet.  I will be workin gon the docs this week
22:47:41 <somik> dendrobates: sounds great! looking forward to getting the next leg of netstack started.
22:47:53 <dendrobates> me too!
22:47:55 <danwent> :)
22:48:07 <danwent> #topic open discussion
22:48:24 <dendrobates> is anyone going to oscon in a couple weeks?
22:48:36 * markvoelker wishes he was
22:48:38 <dendrobates> if so, we should try to have a meetup
22:49:04 <danwent> don't think anyone from my team will be there.
22:49:29 <danwent> sounds like fun though
22:49:32 <dendrobates> also I am speaking at the ogf meeting this week in Salt lake city, if anyone is around
22:49:33 <danwent> any more open discussion?
22:49:50 <dendrobates> dan it is fun, I encourage everyone to attend oscon
22:50:10 * heckj will be there
22:50:16 <salv> dendrobates: I think Ewan will be there
22:50:26 <salv> (oscon)
22:50:32 <dendrobates> I have a question for salv:  Why did you guys buy cloud.com  :)
22:50:48 <danwent> well, i guess the topic is "open discussion" ... :P
22:50:59 <dendrobates> sorry, just a joke
22:51:08 <danwent> ok, sounds like we're good?
22:51:23 <danwent> #endmeeting