19:02:51 <mtaylor> #startmeeting
19:02:52 <openstack> Meeting started Tue Jul 19 19:02:51 2011 UTC.  The chair is mtaylor. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:02:53 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:03:04 <mtaylor> dprince: you are quite welcome!
19:03:32 * jaypipes thinks mtaylor and jeblair doing a good job of creating blueprints in openstack-ci now. nice work.
19:03:42 <mtaylor> yay!
19:03:55 <jeblair> thanks! i updated some this morning
19:03:55 <mtaylor> jaypipes: but I'll have to point out that we are not to that topic yet. :)
19:03:58 <jaypipes> very, very useful for folks to see what's up.
19:04:06 <jaypipes> mtaylor: ah, sorry mate. pls continue!
19:04:11 <mtaylor> #topic Actions from last meeting
19:04:30 <mtaylor> alright -the first two are about machines for bare metal testing.
19:04:38 <mtaylor> we don't have them yet, so that hasn't been accomplished
19:04:56 <mtaylor> but - I did talk to folks about getting them, and we should have them in a couple of weeks. yay
19:05:39 <mtaylor> the next ones are all really items that should be blueprint workitems (and there is no new update on them)
19:05:57 <mtaylor> in a win for progress - we did get dprince set up with a dns entry! yay!
19:06:23 <mtaylor> and nati doesn't seem to be here, so we can't ask him about list of existing tests
19:06:33 <dprince> Yay!
19:06:46 <mtaylor> any questions on those before we move on?
19:07:31 <dprince> On the GitHub blueprint.
19:07:40 <mtaylor> #topic Blueprints are up
19:07:56 <dprince> What is the expected date for Nova/Glance conversion to GitHub?
19:08:05 <mtaylor> #link https://blueprints.launchpad.net/openstack-ci
19:08:31 <mtaylor> dprince: I'm guessing we're still probably a couple of weeks out
19:08:50 <mtaylor> jaypipes: how solid do you want keystone testing to be before we work on migrating glance?
19:09:23 <mtaylor> dprince: we're wanting to shake out process/code/implementation issues with smaller projects before throwing the mass of nova devs at the thing
19:09:36 <jaypipes> mtaylor: heh, not sure. tbh, there isn't a huge chorus of glance contribs itching to move to GH ;)
19:09:45 <mtaylor> hehe
19:09:55 <jaypipes> mtaylor: other than dprince, that is ;)
19:09:58 <mtaylor> jaypipes: are you planning on moving then? or staying?
19:10:26 <jaypipes> mtaylor: we will use whatever system/platform is recommended by your team.
19:10:26 <mtaylor> as I do believe the current policy is "project can decide to use approved environments", yeah?
19:10:32 <mtaylor> jaypipes: hehe. ok
19:10:45 <jaypipes> mtaylor: we're not sticklers about tooling.
19:10:54 <dprince> jaypipes: To be clear I'm not pushing it. Just want to be ahead of the game. Thats all.
19:10:56 <mtaylor> jaypipes: honestly, at the moment, the git/gerrit setup is going to be more robust and better integrated with jenkins
19:11:07 <jaypipes> dprince: I'm just pulling your chain, mate. no worries :)
19:11:27 <jaypipes> mtaylor: yes, that's what I've seen, and I've been impressed with the gerrit setup so far.
19:11:28 <mtaylor> the gerrit plugin does essentially everything I wanted the tarmac replacement plugin for launchpad to do - and I didn't have to write it. :)
19:11:34 <jaypipes> right.
19:11:53 <mtaylor> jaypipes: I think my favorite thing is that it listens actively to a stream of events - so the INSTANT something happens in gerrit jenkins is testing stuff
19:12:06 <mtaylor> no waiting for poll cycles
19:12:13 <jaypipes> mtaylor: so... on a practical side of things, Glance could probably move to GH soon. Though it would be good to get through the existing code reviews. About 5 of them outstanding.
19:12:14 <dprince> mtaylor: One question about your Git pulls. Do you plan on cloning or using the GitHub tarball URLs.
19:12:42 <dprince> jaypipes: I plan on taking a look at the caching stuff today/tomorrow.
19:12:52 <dprince> jaypipes: Rick's branch.
19:12:59 <mtaylor> dprince: I'm not sure what you mean by "your git pulls" ... but I do not believe that github tarball urls provide any value
19:13:36 <dprince> mtaylor: I just meant each time Gerrit runs does it use a local repo (clone) or a tarball.
19:13:46 <dprince> mtaylor: I think you answered my question.
19:13:50 <mtaylor> dprince: :)
19:13:59 <mtaylor> dprince: so, they way it works is actually this:
19:14:10 <jaypipes> dprince: yeah, I've already read through it. Looks pretty good, though I wish folks would stick to doing just the feature in a single merge proposal, and not random refactoring and style cleanups, too ;)
19:14:42 <mtaylor> gerrit holds a repo internally for each project
19:14:52 <mtaylor> code reviews are triggered by pushing to gerrit
19:15:01 <mtaylor> once it's reviewed and merged, gerrit replicates to github
19:15:09 <mtaylor> so it's all VERY git-y
19:15:45 <dprince> great
19:16:25 <mtaylor> jeblair: where's that wiki page?
19:16:44 <jeblair> #link http://wiki.openstack.org/GerritWorkflow
19:17:03 <mtaylor> yay. thanks
19:17:11 <jaypipes> docs ++
19:17:41 <mtaylor> we're working on more of them - I should have a http://ci.openstack.org up and going soon for us with docs on the whole CI infrastructure
19:17:51 <mtaylor> well - I mean, that's what WILL go there
19:18:03 <mtaylor> the site will be up soon, then we can ADD docs on the whole infrastructure to it :)
19:18:27 <jaypipes> mtaylor: excellent.
19:18:30 <jeblair> i'm working on adding docs on the installation / integration process for gerrit, github, and jenkins
19:18:58 <mtaylor> also - in case anyone's been following along at home, I think we've got a solution for the problem of needing keys on the jenkins slaves. once that's sorted, we can move the rest of the jobs to all build on slaves
19:19:05 <jeblair> so how we set up this process will be fully documented and repeatable, and the recipe is out there if others want to do the same thing
19:19:44 <mtaylor> then we can move jenkins to a new server ... and then I can stop dorking around with that and help jeblair with getting the +2 events and or the openid issue sorted (which I believe are our two main pain points with gerrit right now, yeah?)
19:19:56 <jaypipes> jeblair: woot.
19:20:05 <jeblair> that and the launchpadlib sync script
19:20:12 <mtaylor> I _definitely_ want to figure out the tests-run-after-+2 thing before nova gets brought over.
19:20:14 <mtaylor> oh yes.
19:20:24 <mtaylor> so, in a perfect world, we will solve those three issues before nova migrates
19:20:51 <mtaylor> everything past that is bunnies, rainbows and gravy
19:20:54 <jeblair> i'm wondering whether all the keystone devs will register with gerrit before i get around to writing the script that would obviate their need to register ;)
19:21:04 <jaypipes> mtaylor: for us morons in the audience, the run-after-+2 thing is because Gerrit runs tests when a pull request is received, not after approvals, right?
19:21:05 * mtaylor is guessing no
19:21:15 <mtaylor> jaypipes: that is correct
19:21:18 <jaypipes> k
19:21:44 <jaypipes> mtaylor, jeblair: rough timeframe on solving those three issues?
19:21:44 <mtaylor> and, although that is nice for parallelism ... it's problematic from a "any damn person can now submit code and have that run on our farm of servers" perspective
19:21:58 <jaypipes> mtaylor, jeblair: is there anything I can do to assist you?
19:22:41 <mtaylor> well - two of them involve java. the launchpadlib sync script is python and shouldn't be too hard to do - but I'm guessing it would take jim more time to knowledge dump what's needed there
19:23:11 <jaypipes> mtaylor: a week of work? two days? what's your feeling about time needed for that?
19:23:26 <jaypipes> mtaylor: and is there anything we can do to help?
19:24:06 <mtaylor> I'm going to defer to jeblair there ... what do you think jeblair?
19:24:25 <jeblair> launchpadlib is probably just a couple of days.  i may get to start on it this afternoon
19:25:13 <jeblair> +2 is really waiting on some changes to the gerrit jenkins plugin -- we may start on it before then, but we shouldn't plan on having something final with that for, what did they say, a few weeks?
19:25:43 <mtaylor> yeah - although if it's not hard to do, it might be worth having a divergent version of the plugin for a few weeks
19:25:58 <jaypipes> jeblair: can we deploy gerrit before the +2 thing is fixed? or is that a full blocker?
19:26:09 <mtaylor> I think if we put the nova guys off for a _few_ weeks (i.e. closer to a month) that they'll get antsy
19:26:21 <jaypipes> mtaylor: right. agreed.
19:26:45 <jeblair> the openid change is a relatively simple change to gerrit; probably a few days.
19:27:11 <jeblair> then yeah, we should hack something together.  i got the impression that the event refactoring they were doing wasn't the highest priority, so it could slip on their side.
19:27:15 <mtaylor> the +2 thing will mean a workflow change, and I'd prefer to not introduce the confusion of "here's the new workflow" and then a week later "oh! we changed it"
19:27:25 <mtaylor> jeblair: agree
19:27:42 <heckj> mtaylor: agree
19:27:43 <jeblair> just to be clear, we can continue with keystone in our current state, as soon as they finish signing up
19:27:53 <mtaylor> yes. and glance, for that matter
19:28:14 <jeblair> it's easier to use a temporary workflow with more caveats with a couple of small teams
19:28:14 <mtaylor> I just don't want to do workflow changes like that for 100 devs
19:28:20 <mtaylor> ++
19:28:37 <mtaylor> (even if the 2nd workflow is easier)
19:29:43 <mtaylor> so, I'd say actually though - we should do the other two first - openid and launchpad sync script - because those affect the signup/initial process - and that way we give ericsson a brief chance to make their changes before we briefly fork
19:30:12 <mtaylor> unless folks think I'm nuts
19:31:03 <jeblair> that was my thinking.
19:31:09 <jaypipes> fine by me.
19:32:01 <mtaylor> sweet. should we target launchpadlib script and openid as actions for next week? (jeblair I could probably get the launchpadlib sync script going since I wrote the ssh user one - unless you really want to do it)
19:33:11 <jeblair> that works for me
19:33:15 <mtaylor> cool
19:33:39 <mtaylor> #action jeblair Fix OpenID support in Gerrit
19:34:01 <mtaylor> #action mtaylor Write script to sync launchpad users/teams to gerrit users/groups
19:34:19 <mtaylor> and just for completeness
19:34:33 <mtaylor> #action mtaylor finish migrating jenkins jobs from running on master to running on slaves
19:36:18 <mtaylor> that's about all I've got... any other discussion on the openstack-ci blueprints?
19:37:13 <mtaylor> #topic Open Discussion
19:37:23 <mtaylor> how about anything that isn't about openstack-ci blueprints?
19:37:58 <heckj> nothing here
19:38:20 <mtaylor> sweet.
19:38:46 <mtaylor> than I'ma gwanna call this bad boy done. early even!
19:38:48 <mtaylor> #endmeeting