19:04:17 <jeblair> #startmeeting
19:04:18 <openstack> Meeting started Tue Jul 26 19:04:17 2011 UTC. The chair is jeblair. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:04:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:04:37 <jeblair> #topic Actions from last meeting
19:04:56 <jeblair> so the first item was: jeblair Fix OpenID support in Gerrit
19:05:31 <jeblair> i've patched gerrit so that it operates in a single-sign-on mode, like our jenkins install, with launchpad as the openid provider
19:06:15 <jeblair> so we have SSO with launchpad, gerrit, and jenkins. this should make it a bit easier to use all of those tools
19:06:34 <jeblair> in a related note, the second item was: mtaylor Write script to sync launchpad users/teams to gerrit users/groups
19:07:11 <jeblair> that is mostly done; monty has written an initial version of a script that does that, so that developers should only have to register with launchpad
19:07:27 <jeblair> then all their (public) information is synced to gerrit
19:08:16 <jeblair> there's a bit of optimization to do so that group membership changes are propogated quickly, but what is there now should be a big time saver for any projects that start using gerrit.
19:08:30 <jeblair> finally: mtaylor finish migrating jenkins jobs from running on master to running on slaves
19:09:20 <jeblair> this is _nearly_ complete at this point. I believe there were some hiccups with the slaves being a little different from the previous config used on the master.
19:10:47 <jeblair> i'll go ahead and put the last two items back on the stack for next week just to make sure they're closed out
19:10:49 <jeblair> #action mtaylor Optimize script to sync launchpad users/teams to gerrit users/groups
19:10:53 <jeblair> #action mtaylor finish migrating jenkins jobs from running on master to running on slaves
19:11:32 <jeblair> #topic Blueprints are up
19:12:12 <jeblair> our roadmap and tasks are visible here:
19:12:14 <jeblair> #link https://blueprints.launchpad.net/openstack-ci
19:12:43 <jeblair> you can see that right now, we're putting a lot of effort into getting a git based workflow operational
19:13:15 <jeblair> we've started testing that with the keystone project, which is in the incubation stage
19:14:04 <jeblair> this morning Jenkins ran its first test out of that workflow (triggered by a change in gerrit)
19:15:26 <jeblair> so we're making progress, and writing documentation to help other projects if/when they transition
19:16:19 <jeblair> anything regarding the blueprints before we move to open discussion?
19:17:39 <jeblair> #topic Open Discussion
19:18:09 <jeblair> anything else anyone wants to talk about?
19:19:15 <jeblair> bengrue: are you going to be doing CI work at piston cloud?
19:19:22 <bengrue> I will be.
19:19:54 <bengrue> I might be able to assist with the git porting here too, after I get more familiar with the projects as a whole.
19:20:12 <bengrue> If help is needed/desired/welcome/etc.
19:20:12 <jaypipes> hey guys, sorry, just got back from dentist... :(
19:20:21 <jeblair> hi jay
19:20:26 <adrian17od> Will the openstack-ci code be migrated to github at some point? it's a bit of a pain accessing bazaar+launchpad from behind a proxy.
19:21:05 <jeblair> bengrue: right now we're in a sort of pilot/evaluation phase with keystone and glance
19:21:38 <jeblair> if things work out, i imagine many of the openstack projects will move to git
19:21:47 <adrian17od> cool
19:21:48 <bengrue> cool; how's that been going thusfar?
19:21:54 <alekibango> + 1 for git
19:22:19 <bengrue> I think I've got +6 in this (physical) room for git.
19:22:25 <alekibango> i never got used to bzr
19:23:08 <jeblair> our gerrit/jenkins/github workflow seems to be functioning; since the keystone devs just started using it yesterday, it's probably a bit early for subjective reports
19:23:43 <bengrue> Is everyone involved in that effort comfortable with the git workflow?
19:24:35 <jeblair> the workflow is based around a gated trunk -- so after each change is approved in code review, jenkins will run tests and the change is automatically merged only if it succeeds.
19:24:56 <jeblair> the keystone devs are existing git users, but they've been using only github without gerrit.
19:25:20 <bengrue> I see. I've not used gerrit myself, but this sounds relatively sane/simple.
19:25:58 <bengrue> Cool. I look forward to seeing more and helping out in the future. But for now, I look forward to lunch. ; )
19:26:16 <jeblair> :) great, let us know how we can facilitate your work
19:26:30 <creiht> so wait... you will have to log into gerrit through launchpad openid?
19:26:59 <jeblair> it hasn't shown up in this meeting, but we've also been helping folks integrate their local testing efforts into the openstack jenkins system
19:27:31 <jeblair> creiht: yes -- that way we can use launchpad's group system universally
19:27:41 <jeblair> to manage ACLs in gerrit, jenkins, and launchpad
19:27:58 <creiht> heh... alright.. just seems a bit wonky
19:28:53 <jeblair> we're aiming for "seamless". :) hopefully gerrit should have your group membership, username, real name, email address, and ssh key on your first visit
19:29:24 <jeblair> so you don't have to do any registration, or otherwise duplicate effort
19:29:49 <creiht> but I will still have to log in to 2 systems
19:29:54 <creiht> github and gerrit
19:30:18 <creiht> but I digress...
19:31:11 <jeblair> adrian17od: we have moved openstack-ci to git
19:31:24 <jeblair> #link https://github.com/openstack/openstack-ci
19:32:32 <jeblair> i'm guessing we need to update the launchpad project to reflect that
19:32:55 <jeblair> #action update launchpad project page for openstack-ci to point to github
19:33:13 <jeblair> we did that to eat our own dogfood with github and gerrit
19:33:55 <adrian17od> that's great. thanks jetblair
19:34:02 <jeblair> #link https://github.com/openstack/openstack-ci-puppet
19:34:16 <jeblair> we put our puppet modules there as well
19:34:32 <jeblair> so we've been reviewing changes to those with gerrit for about a week.
19:35:17 <jeblair> it's not the same kind of use the other projects will see, but it does mean that we get to run into technical problems first
19:36:18 <jeblair> did i miss anything from anyone else?
19:38:13 <jeblair> all right, i'll wrap it up then. see you next week!
19:38:23 <jeblair> #endmeeting