19:05:07 <mtaylor> #startmeeting
19:05:08 <openstack> Meeting started Tue Aug  2 19:05:07 2011 UTC.  The chair is mtaylor. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:05:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:06:16 <mtaylor> #topic actions from last meeting
19:06:50 <mtaylor> lookie there- we only had a few things from last time
19:06:58 <mtaylor> update launchpad project page for openstack-ci to point to github: DONE
19:07:08 <mtaylor> mtaylor Optimize script to sync launchpad users/teams to gerrit users/groups
19:07:21 <mtaylor> this is effectively done - this should be rolled out today
19:07:33 <mtaylor> (once it gets reviewed and merged, of course)
19:07:43 <mtaylor> mtaylor finish migrating jenkins jobs from running on master to running on slaves
19:08:21 <mtaylor> this is also essentially done. there was a set of jobs that ttx put back on master during milestone release that should get fixed (there was a path issue)
19:08:36 <mtaylor> #action mtaylor fix the milestone-proposed jenkins jobs to be able to run on the slaves
19:08:58 <ttx> ands I would do it again, anytime :P
19:09:27 <mtaylor> hehe
19:09:49 <soren> Is there an agenda anywhere, btw?
19:09:57 <mtaylor> http://wiki.openstack.org/Meetings/CITeamMeeting
19:10:05 <soren> ta
19:10:31 <mtaylor> Blueprints are up is probably a holdover from a previous version of the page ...
19:10:37 <mtaylor> s/probably//
19:10:54 <mtaylor> #topic Open discussion
19:11:41 <mtaylor> well - for whoever is interested - the git/gerrit transition is fully underway with keystone (after a few initial bumps in the road)
19:11:57 <mtaylor> and we are going to get glance moved over on thursday
19:12:15 <mtaylor> which should be slightly more telling from a process assessment perspective, as they are used to using the current process
19:13:06 <mtaylor> soren: do the tarball_script.sh and/or ppa_script.sh need changed for glance if it's in git and not bzr?
19:13:19 <soren> Yes.
19:13:33 <soren> I think so, at least.
19:14:03 <soren> I forget if I actually implemented support for git in there, but if I did, it's not tested.
19:14:19 <soren> (since at the time there weren't any projects in git)
19:14:25 <mtaylor> good point :)
19:15:09 <mtaylor> well, those are in openstack/openstack-ci on github and managed by gerrit now - and should get auto-updated on the slaves if you merge changes in to the repo
19:15:34 <soren> Ok-
19:15:40 <soren> s/-/./
19:16:02 <mtaylor> (I added some fun with bzr checkouts to handle the versions files with stuff running on slaves ... feel free to punch me in the face for any of that)
19:16:43 <mtaylor> #action soren update tarball_script.sh and ppa_script.sh to work with git for glance transition
19:17:08 * alekibango loves git
19:17:15 <mtaylor> heh
19:17:30 <mtaylor> well, hopefully alekibango will love gerrit as well
19:17:57 <alekibango> will try :)
19:20:13 <mtaylor> we should have some new baremetal boxes in the next week or two - and as soon as we do we'll work with termie to get some install and test stuff up and going
19:22:47 <mtaylor> anything else from anybody?
19:23:26 <soren> Nope.
19:26:54 <jaypipes> I do!
19:27:19 <jaypipes> https://blueprints.launchpad.net/openstack-ci/+spec/glance-upgrade
19:27:33 <jaypipes> I was hoping to discuss how we continually test upgrade paths?
19:28:00 <mtaylor> yes. this will be MUCH easier once we have jclouds plugin finished
19:28:16 <mtaylor> and/or once we have bare metal machines and magic install on them from termie
19:28:46 <mtaylor> (actually, upgrade paths will probably be testable on cloud servers without using bare metal)
19:28:48 <jaypipes> mtaylor: were you answering my question above?
19:28:54 <mtaylor> jaypipes: yes
19:29:07 <jaypipes> mtaylor: ah, sorry. yes, I think cloud servers would be easier...
19:29:21 <jaypipes> mtaylor: but I'd like some help desigining the jenkins job for it, if that's ok?
19:29:36 <mtaylor> jaypipes: totally
19:29:46 <mtaylor> jaypipes: I think the main key is that that job wants a clean env to start with
19:29:52 <jaypipes> mtaylor: ok, maybe next week we can flesh it out on an ehterpad or something.
19:29:56 <mtaylor> yes
19:29:56 <jaypipes> mtaylor: right
19:30:10 <mtaylor> #action jaypipes design upgrade path jenkins job with mtaylor
19:30:23 <jaypipes> mtaylor: and then a registry database migrated to trunk, then upgrade, check registry db ok, run tests, etc
19:30:32 <mtaylor> yay! I finally have someone else who has a vested interest in getting jclouds jenkins plugin finished :)
19:30:54 <jaypipes> mtaylor: can you gimme some more details on why jclouds is a critical thing there? just curious.
19:31:31 <mtaylor> jaypipes: that lets us tell jenkins that to run a job we want a particular kind of resource, and it jenkins will create it at the top of the job and then destroy it after the job
19:31:38 <mtaylor> jaypipes: we can obviously do this by hand and stuff
19:31:55 <jaypipes> mtaylor: oh, nice. ok, that sounds perfect.
19:32:16 <mtaylor> jaypipes: but given the plugin is at about 90% anyway and will allow us to describe the thing we _actually_ want the job to do, rather than the setup/teardown mechanics. :)
19:32:17 <jaypipes> mtaylor: btw, you meet up with termie? he was looking for you earlier.
19:32:25 <mtaylor> jaypipes: yup. we did some chatting
19:32:29 <jaypipes> coolio.
19:45:15 <mtaylor> ok. that seems to be about all we have for today
19:45:17 <mtaylor> #endmeeting