20:00:08 <jbryce> #startmeeting
20:00:09 <openstack> Meeting started Tue Aug  9 20:00:08 2011 UTC.  The chair is jbryce. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:00:19 <termie> jbryce: !
20:00:32 <jbryce> termie: !
20:00:55 <soren> o/
20:00:55 <jbryce> which ppb members do we have?
20:01:02 <anotherjesse> here
20:01:08 <vishy> chuck norris: !
20:01:10 <notmyname> here
20:01:13 <soren> present
20:01:28 <jmckenty_> heyo
20:01:36 <dendrobates> o/
20:01:44 * jmckenty_ waves
20:01:58 <eday> here
20:02:06 <ttx> o/
20:02:07 <jmckenty_> no ewan expected, right?
20:02:13 <vishy> wow good turnout
20:02:13 <jmckenty_> he's in some weird time zone
20:02:14 <jaypipes> o/
20:02:18 <vishy> missing ewan and purrier
20:02:57 <jbryce> well let's get started. agenda: http://wiki.openstack.org/Governance/PPB
20:03:03 <jbryce> #topic previous action items
20:03:26 <jbryce> jmckenty_: any update on FITS or academic cooperation?
20:03:27 <jmckenty_> I have two of those
20:03:39 <jmckenty_> FITS has a mailing list set up, and a reasonably representative set of members
20:03:53 <jmckenty_> We haven't done a kickoff yet, was waiting to hear how things went with Dell first
20:04:02 <jmckenty_> as it probably changes our mandate somewhat
20:04:48 <jmckenty_> Academics, I've spoken with Stephen Spector and a few others directly (Qatar Foundation, etc), should have a proposal in shape in a few weeks, but I was thinking we should set aside a couple of blocks at the summit
20:05:06 * jaypipes wonders if I missed some ML post on FITS...
20:05:21 <jmckenty_> jaypipes: what, specifically?
20:05:31 <zns> Hi - is there a PPB mtg today?
20:05:39 <jbryce> zns: yes. going on right now
20:05:39 <ttx> zns: it's on
20:05:39 <jaypipes> zns: you're in it :)
20:06:06 <jaypipes> jmckenty_: about FITS. Were you going to introduce the concept on the ML and invite people to comment?
20:06:06 <zns> Cool. Multi-tasking.. :-)
20:06:39 <jmckenty_> jaypipes: wasn't planning on it.
20:06:47 <jaypipes> jmckenty_: any reason?
20:06:48 <jmckenty_> not until we had a proposal
20:07:00 <jmckenty_> I think it makes a very messy public discussion topic
20:07:14 <jmckenty_> Would rather come to the community with two or three distinct proposals
20:07:23 <jaypipes> jmckenty_: ah, ok. but after you have a proposal, you will, correct?
20:07:27 <jmckenty_> and some background research that's well articulated
20:07:29 <jmckenty_> current
20:07:34 <jmckenty_> current / correct
20:07:40 <jaypipes> :) gotcha. ok, cool.
20:07:50 <jbryce> ok
20:08:01 <jbryce> other outstanding action item is the next item on the agenda
20:08:13 <jmckenty_> project autonomy?
20:08:16 <jbryce> #topic common project tooling/processes aka autonomy
20:08:29 <jbryce> http://wiki.openstack.org/Governance/Proposed/ProjectToolingAndPractices
20:08:56 <jbryce> i plan on adding that to the existing project description page that already covered some of the project philosophy ideas
20:09:00 <jbryce> http://wiki.openstack.org/ProjectTypes
20:09:10 <ttx> jbryce: I sent my comments to the thread
20:09:30 <ttx> otherwise lgtm
20:09:41 <jbryce> ttx: i haven't been getting lp email today, but i just saw them on the web archive
20:09:51 <johnpur> i am in basic agreement with ttx
20:10:09 <jbryce> i'll add in a note about default 4-week milestone
20:10:26 <jmckenty_> I'd rather hold off on approving that doc until we get a status update from the vetting process for github+gerritt
20:10:26 <jaypipes> already responded, lgtm..
20:10:39 <jmckenty_> If we're going to have vetted options, we should have more than one, imo
20:10:43 <jaypipes> why?
20:11:00 <jaypipes> meaning, why does one affect the other?
20:11:03 <jmckenty_> because a very large community contingent has asked for it
20:11:08 <ttx> jmckenty_: some people are waiting for doc approval to vote, so it looks like a catch-22
20:11:21 <jaypipes> so, you're fine with vetted options as long as they're the vetted options you approve of...
20:11:21 <jbryce> jmckenty_: once approved, i will update this list
20:11:36 <jaypipes> but that's not what the vote is on. The vote is whether to have a set or a single vetted option.
20:11:38 <jbryce> the bottom section would change anytime we add new options or categories
20:11:40 <eday> notmyname: were there any specific things you were waiting on from project autonomy docs? I know you had been asking for it
20:11:42 <soren> I expected we'd discuss whether we'd have "one true set of tools" vs. "a set of vetted optoins" before we discussed a document that specifically speaks of "the vetted options".
20:11:54 <jmckenty_> soren: we did that already
20:11:57 <jmckenty_> and voted on it
20:12:04 <jmckenty_> and then reviewed it
20:12:05 <ttx> jmckenty_: not everyone is convinced of that.
20:12:12 <jmckenty_> I can pull up the ppb meeting logs
20:12:16 <eday> jmckenty_: it ended in a tie
20:12:18 <jaypipes> no, we didn't.
20:12:20 <soren> So why was the question raised again on the mailing list?
20:12:27 <jmckenty_> really? I don't remember a tie
20:12:46 <eday> jmckenty_: someone changed their vote, and we didn't have enough folks attending to break the tie
20:12:51 <soren> If it's the meeting I remember, it ended up a tie as dendrobates changed his vote.
20:13:01 <jmckenty_> ah, gotcha
20:13:08 <jmckenty_> sorry
20:13:14 <jbryce> we did discuss it in subsequent meetings
20:13:17 <dendrobates> :)
20:13:21 <notmyname> eday: that's what I was waiting on :-)
20:13:25 <jmckenty_> yes, but I was never clear about why we were discussing it again
20:13:31 <jmckenty_> it's clear now
20:13:48 <jaypipes> so, we ready to vote on it?
20:14:08 <jmckenty_> wait
20:14:13 <jmckenty_> we still don't have a set of options
20:14:15 <jbryce> the last discussion it seemed that most people were on the side of a vetted set of options (which could be a set of one)
20:14:16 <jmckenty_> we have a single option
20:14:21 <jmckenty_> in every case
20:14:40 <jmckenty_> hence my feeling that voting is premature
20:14:45 <jbryce> the next step was to attempt to draft the summary of the discussion that went on over multiple weeks
20:14:49 <notmyname> jmckenty_: are you ok with the idea of having a set of options?
20:14:52 <jbryce> hence the document with the link
20:14:57 <jmckenty_> notmyname: yes
20:15:14 <jbryce> jmckenty_: the document includes existing approved options which is only one currently
20:15:20 <jmckenty_> but I'm not okay with approving that as our official mechanism when there's only one option
20:15:25 <jbryce> if we approved additional options they get added to the document
20:15:28 <notmyname> so we can settle the single option/vetted list issue?
20:15:31 <jaypipes> jmckenty_: the point is to vote on whether to have a single option or more than one, not whether LP or Gerrit/GitHub IS the single option or one of the options.
20:15:35 <ttx> "a set of options" actually includes "only one option"
20:15:43 <soren> Whether we want a set of vetted options vs "one true set of options" is orthogonal to whatever the vetted options would be, hopefully.
20:15:48 <jmckenty_> it's not semantics per se...
20:15:48 <jbryce> jmckenty_: i'm totally fine with a set only have one element
20:15:58 <jmckenty_> I'm not
20:16:17 <soren> Then what's the problem?
20:16:23 <jaypipes> jmckenty_: you are if it's the option you prefer.
20:16:25 <jbryce> so you want to always force multiple options to be available?
20:16:27 <soren> You've clearly decided on what your vote is going to be.
20:16:39 <jmckenty_> jaypipes: not true
20:16:40 <eday> how about "should we ever support more than one project hosting option?"
20:16:50 <jaypipes> eday: right, that is the question.
20:17:08 <eday> at least, until we vote on this again :/
20:17:12 <jaypipes> ugh
20:17:19 <jbryce> ok
20:17:52 <jbryce> jmckenty_: i don't understand your issue. are you saying you want to require more than one option in every category?
20:17:59 <jmckenty_> no
20:18:14 <jmckenty_> I'm just saying that voting to approve multiple options, when we don't have a SINGLE alternative,
20:18:19 <jbryce> right
20:18:22 <jmckenty_> is a bunch of sycophantic posturing
20:18:27 <jbryce> no
20:18:30 <jaypipes> jmckenty_: no, it's not.
20:18:33 <soren> It's not at all.
20:18:36 <jbryce> step one is to approve a philosophy that allows for multiple options
20:18:37 <johnpur> sycophantic?
20:18:42 <jbryce> step two is to add the addition options
20:18:57 <jaypipes> jmckenty_: replace Launchpad with "BLAHBLAH". It doesn't matter what is on there to vote on whether ot have >1 option.
20:19:06 * johnpur gets out his dictionary
20:19:10 <jmckenty_> "http://www.thefreedictionary.com/sycophantic"
20:19:16 <jbryce> this document attempted to capture the idea that there can be multiple options
20:19:17 <ttx> johnpur: give it to me when you're done
20:19:21 <mtaylor> it's voting to allow approval of a second option without having to categorically remove the first option at the same time
20:19:25 <johnpur> jmckenty_: thanks
20:19:35 <jbryce> next item on the agenda was to vote on if there's a second option in 2 of these categories
20:20:04 <johnpur> mtaylor: +1
20:20:22 <jmckenty_> fine, I won't hold it up.
20:20:46 <jbryce> so can we vote on this: http://wiki.openstack.org/Governance/Proposed/ProjectToolingAndPractices
20:20:53 <soren> No?
20:21:05 <soren> That's the entire point. It speaks of "vetted options".
20:21:08 <soren> What if we don't want such a concept?
20:21:08 <jaypipes> don't we need to vote on >1 vs. 1 option?
20:21:10 <mtaylor> (although me would like to put out there, as a person who supports a good amount of this - that he'd prefer long term to only be supporting a single infrastructure- but is fine with "set of vetted options"
20:21:20 <jmckenty_> I had a minor observation on the autonomy point
20:21:24 <jbryce> jaypipes: yes. that is what the document discusses
20:21:41 <jmckenty_> just that, although swift works perfectly well standalone, nova depends on glance, and glance (at scale) depends on swift
20:21:45 <jbryce> the key point of the document being that for certain categories there are predefined default options that projects should choose from
20:21:45 <jaypipes> jbryce: ah, so you're saying since the document says vetted options, we are voting up or down on that?
20:22:24 <jbryce> jaypipes: correct
20:22:31 <soren> Ah.
20:22:31 <jaypipes> ready when you are.
20:22:33 <jmckenty_> +1 for vetted options
20:22:34 <soren> But...
20:22:35 <johnpur> is there a "preferred" designation on the betted options?
20:22:44 <jmckenty_> johnpur: separate vote?
20:22:47 <jbryce> the bottom is just a catalog that we would update as things change
20:22:56 <soren> What if we reject this document?
20:22:58 <soren> What happens then?
20:23:08 <jbryce> then someone else gets to draft the next one. = )
20:23:21 <jbryce> and go through 6 weeks of meeting logs to try to understand the discussion
20:23:25 <mtaylor> hahaha
20:23:26 <jaypipes> inded
20:23:30 <ttx> +1 as vetted options is still very open-ended :)
20:23:38 <soren> -1
20:23:49 <notmyname> -1 for vetted options
20:23:50 <jaypipes> ttx: no, it's not... it's merely a vote on 1 or >1 option.
20:24:03 <jaypipes> -1 on vetted options. +1 on singular option.
20:24:03 <johnpur> +1 for vetted options
20:24:05 <ttx> jaypipes: no, it's a vote on 1 or >=1.
20:24:14 <jaypipes> ttx: sure, yes.
20:24:15 <mtaylor> ttx++
20:24:18 <soren> Then I don't undertand what we're voting?
20:24:20 <soren> At all.
20:24:26 <eday> -1 for vetted (since we voted one project, we shouldn't split it)
20:24:32 <dendrobates> -1
20:24:39 <ttx> soren: we are voting on enforcing 1 optoin... or deciding to keep the option to have >=1
20:24:45 <soren> I'd like to retract my vote on the grounds of not having the faintest idea what we're voting on.
20:25:04 <jmckenty_> aha!
20:25:06 <ttx> should it be ==1 or >=1 option.
20:25:13 <soren> But.
20:25:13 <soren> Ok.
20:25:14 <soren> fine.
20:25:15 <jbryce> eday: to be precise we voted on one product made up of independent projects
20:25:17 <soren> Then ==1
20:25:20 <jmckenty_> fetch me... an HALIBUT!
20:25:25 <soren> That's unambiguous.
20:25:37 <jaypipes> soren: if you want no flexibility on whether an openstack project gets to choose from a list of vetted options, vote -1.
20:25:49 <soren> -1
20:25:51 <soren> Wicked.
20:26:01 <soren> jaypipes: Thanks.
20:26:04 <jaypipes> np.
20:26:20 <soren> (then why did people start saying "no" when someone tried to sum it up that way?)
20:26:20 <jaypipes> who's missing a vote?
20:26:25 <vishy> +1
20:26:36 <jaypipes> jbryce: your vote?
20:26:43 <jbryce> +1
20:26:48 <anotherjesse> what is the score?
20:26:53 <jbryce> i have no idea
20:26:59 <jbryce> trying to scrollback and see where everyone ended up
20:27:05 <jmckenty_> Vetted = jmckenty, jbryce, vishy, johnpur
20:27:06 <vishy> 6 -2 i think
20:27:10 * ttx retracts to +0 if it's tied.
20:27:16 <jmckenty_> oh, and ttx
20:27:35 <jmckenty_> and mtaylor, or no?
20:27:36 <vishy> k missed a few
20:27:39 <soren> notmyname: I'm kind of baffled here. You've spent the last 7 meetings talking about autonomy and letting people choose their own tools, but now you're voting against having options?
20:27:42 * mtaylor doesn't get a vote
20:27:43 <ttx> I don't really mind -- I expect that the PPB will only vet one option at a time anyway.
20:27:46 * mtaylor just lurks and talks
20:27:48 <jmckenty_> right, sorry
20:27:52 <jmckenty_> the pluses confused me
20:27:57 <anotherjesse> notmyname: yeah - reasoning?
20:28:23 <vishy> so 1 option is -> ewan, soren, jaypipes, dendrobates, eday
20:28:35 <jmckenty_> single option = eday, dendrobates, soren, jaypipes
20:28:40 <vishy> so 5 -5 ?
20:28:43 <jmckenty_> was that ewans?
20:28:46 <jmckenty_> k
20:28:51 <jmckenty_> so we're deadlocked on ttx
20:28:52 <jmckenty_> fun
20:28:56 <vishy> i thought he said one option in his email
20:29:01 <jmckenty_> yeah, he did
20:29:04 <jbryce> where is ewan?
20:29:06 <vishy> anotherjesse can tie break
20:29:07 <notmyname> my understanding of the original autonomy descision is that openstack is a single unit with cooperating components. I think my current vote goes along with that. I was never for a vetted set. I originally wanted no set approved or otherwise
20:29:09 <jmckenty_> he doesn't want to teach his devs git and bzr
20:29:17 <soren> jbryce: Sleeping, probably. He's in India (where it's 2 AM).
20:29:20 <ttx> nah, notmyname votes -1
20:29:26 <ttx> so -1 wins
20:29:27 <jbryce> so where did his vote come in?
20:29:35 <anotherjesse> notmyname: k - I agree
20:29:50 <anotherjesse> and vote with notmyname
20:29:50 <ttx> jbryce: PPB ML post
20:29:53 <jmckenty_> k, I'm happy
20:29:57 <vishy> so single option wins 6 - 5?
20:30:16 <ttx> yes
20:30:29 <jmckenty_> so we chuck that page, then
20:30:34 <jbryce> anotherjesse: did you vote?
20:30:47 <jmckenty_> he voted with notmyname
20:30:52 <anotherjesse> yes same as notmyname - not sure if that is + or -
20:30:53 <anotherjesse> ;)
20:30:58 <jbryce> ok
20:30:59 <notmyname> I voted -1
20:31:06 <notmyname> for single option
20:31:14 <jmckenty_> who's missing?
20:31:17 <jmckenty_> we have 12, right?
20:31:23 <jmckenty_> oh, ttx
20:31:26 <jmckenty_> abstained
20:31:32 <jbryce> #agreed VOTE: Not vetted set of options allowed. All projects must use same tooling. result 7 - 5
20:31:45 <jmckenty_> jbryce: it's 6-5
20:31:53 <jmckenty_> with one abstention
20:31:55 <jmckenty_> right?
20:32:01 <jbryce> i thought ttx was abstaining if it was tied?
20:32:09 <jmckenty_> oh, I see
20:32:10 <jmckenty_> gotcha
20:32:25 <jbryce> #topic GItHub + gerrit
20:32:25 <soren> jbryce: Hang on, hang on.
20:32:35 <jbryce> soren: ok
20:32:49 <soren> jbryce: You said explicitly that voting against this only meant that we rejected that document. Not that any specific other options was then chosen.
20:33:08 <jaypipes> soren: that's correct.
20:33:15 <jmckenty_> um... no?
20:33:15 <jbryce> jaypipes:soren: if you want no flexibility on whether an openstack project gets to choose from a list of vetted options, vote -1.
20:33:16 <jbryce> [3:25pm]soren:-1
20:33:16 <jbryce> [3:25pm]soren:Wicked.
20:33:16 <jbryce> [3:26pm]soren:jaypipes: Thanks.
20:33:19 <ttx> jbryce let's quickvote on "single optoin everywhere" then
20:33:24 <jmckenty_> +1
20:33:28 <soren> +1
20:33:35 * jmckenty_ is avoiding further ambiguity
20:33:43 <vishy> +1
20:33:44 <ttx> +1
20:33:45 <johnpur> +1
20:33:48 <jaypipes> +1
20:33:53 <dendrobates> +1
20:33:54 <ttx> I want a rule, whatever that ends up being.
20:33:55 <soren> jmckenty_: I asked what happened if we voted against it. The answer was htat someone would get th epleasure of coming up with a new document.
20:34:21 <jmckenty_> that was in reference to a previously proposed vote, not the vote we ended up having, though
20:34:21 <jmckenty_> right?
20:34:27 <jmckenty_> we didn't vote on the doc
20:34:33 <jaypipes> soren: right, and the change would be everywhere it says "vetted options" would be replaced with "a single option".
20:34:34 <jmckenty_> we revoted on the ==1 or >1
20:34:38 <jbryce> i'm assuming the new document would represent the outcome of the vote
20:34:46 <jaypipes> right
20:34:48 <soren> ...but I'm perfectly happy to *not* have someone do that. I just want us to actually be consistent in what we're saying we're voting on and then what we state for the record was decided.
20:34:50 <jbryce> which is that we don't want to allow a vetted set of options
20:35:50 <jmckenty_> so tooling is now by PPB decree, right?
20:36:30 <jbryce> that is what i understand it to mean
20:36:35 <jmckenty_> cool
20:36:36 <jmckenty_> done
20:36:37 <jmckenty_> ?
20:36:39 <ttx> I think this was beaten to death, let's move on
20:36:42 <johnpur> jmckenty_: no the *policy* for tooling is directed by the ppb
20:36:42 <eday> jmckenty_: well, it has been since the vote a few weeks ago, now it's just only one option choosen by PPB, not many choosen by PPB
20:36:50 <jmckenty_> right
20:37:03 <johnpur> the actual tooling needs wider community input (ala the github thing)
20:37:13 <jbryce> so on github, this is now an interesting situation
20:37:22 <jmckenty_> can we get a status update?
20:37:28 <mtaylor> sure
20:37:40 <mtaylor> we've moved glance over to git/gerrit
20:37:49 <mtaylor> which went much better than the keystone move :)
20:38:43 <mtaylor> and then in the openstack-ci meeting earlier today, we got agreement from me, jay, notmyname AND termie that continuing to mirror to github and installing a hook that automatically closes pull requests submitted with instructions on submitting to gerrit was acceptable
20:38:57 * jaypipes was amazed..
20:39:04 * mtaylor believes that some pigs flew
20:39:17 <jmckenty_> So I set up my own mirrors to Github last weekend
20:39:24 <jmckenty_> because the openstack ones had bitrotted
20:39:31 <mtaylor> in any case- that means that the overall system as put forward is the one we have now
20:39:33 <jmckenty_> will that be part of the CI infrastructure going forward?
20:39:34 <notmyname> jmckenty_: the swit one is kept up-to-date ;-)
20:39:42 <termie> jmckenty_: they aren't bitrotted
20:39:44 <jmckenty_> *how* up to date?
20:39:46 <mtaylor> jmckenty_: well, once nova/swift are in gerrit, that will be done automatically on merge
20:39:47 <_0x44> Piston is also volunteering to write the app that integrates gerrit+github pull-requests so the auto-closing can go away.
20:39:49 <notmyname> jmckenty_: latest commit
20:39:53 <termie> jmckenty_: nova is current as of yesterday most recently
20:40:20 <mtaylor> jmckenty_: but to answer your question - yes, if we move forward with this setup, that will be part of CI infrastructure
20:40:22 <jmckenty_> termie: I'm on a 20-minute task
20:40:23 <jmckenty_> k
20:40:25 <jmckenty_> cool
20:40:32 <termie> jmckenty_: nova is now 1 second old
20:40:39 <zns> Would be great to get pull requests in. But does the vote on "one option" mean we only support LP or github now?
20:40:40 <notmyname> of course, based on the last descision, either the other projects need to move to github+gerrit or glance/keystone need to move back
20:40:50 <soren> zns: That remains to be decided.
20:41:24 <zns> soren: when/how will it be decided?
20:41:32 <soren> zns: Momentarily, I imagine.
20:41:34 <mtaylor> I would put forward, that since we are in a transition period- as long as the decision has been made and plans are afoot, that immediate moving in either direction isn't required, no?
20:41:38 <jbryce> zns: that's the current discussion
20:41:49 <soren> mtaylor: I would support that.
20:41:54 <jmckenty_> I wouldn't
20:42:04 <jmckenty_> I believe we made a previous decision to resolve this in time for Diablo summit
20:42:10 <mtaylor> as in - if the ppb votes yay in the next 5 minutes we don't have to IMMEDIATELY throw a switch - we just need to plan to throw the switch
20:42:11 <jmckenty_> sorry, essex summit
20:42:21 <ttx> jmckenty_: in time for essex summit sounds reasonable
20:42:25 <notmyname> jmckenty_: +1
20:42:55 <soren> jmckenty_: We have different ideas of what "immediate" means, apparently.
20:43:01 <ttx> jmckenty_: nova is a bit late already, I'd hate to lose time in a transition before d4... and I'd hate to transition in the last weeks before release
20:43:12 <soren> There's plenty of room for plenty of immediates before the Essex summit in my calendar.
20:43:14 <johnpur> ttx: are you nervous about the timing of all of this?
20:43:15 <jaypipes> mtaylor: ++
20:43:17 <jbryce> any other questions? ready to vote on approving github + gerrit as the source control system for all core openstack projects with a timeline of moving to it by essex design summit?
20:43:23 <ttx> johnpur: yes
20:43:23 <vishy> _0x44: +1000
20:43:37 <eday> so, the proposal to vote on is: the official option is code=>GitHub, review=>Gerrit, bugs/blueprints/release stay on LP for now?
20:43:44 <mtaylor> vishy: jeblair and I will work with Piston on that for sure
20:43:48 <johnpur> the most important votes are the ptls
20:43:58 <jmckenty_> johnpur: what?
20:43:59 <jaypipes> eday: yes.
20:44:02 <jbryce> eday: correct
20:44:02 <zns> mtaylor: ++
20:44:07 <jmckenty_> the point of having a vote is that all votes are equakl
20:44:20 <johnpur> the ptls are on the hook to make sure their stuff and processes work after a move
20:44:29 <jmckenty_> everyone is on that hook
20:44:35 <jmckenty_> the ptl is holding the hook that's all
20:44:43 <johnpur> not discounting your opinion of course :)
20:44:51 <mtaylor> something tells me /me will be on the hook if it fails ... :)
20:44:56 <soren> I'd say mtaylor and his posse is more on the hook in that respect than anyone else.
20:45:02 <jaypipes> ttx: moving Nova in the final "integrated milestone release" cycle might actually be better, since fewer features going in...
20:45:22 <ttx> jaypipes: ...or just after release.
20:45:28 <jmckenty_> negative
20:45:33 <jmckenty_> we hashed this already
20:45:34 <vishy> jaypipes, ttx: I've been thinking immediately after D4 myself
20:45:38 <jaypipes> ttx: when features are lined up to go in?
20:45:56 <soren> ttx: As opposed to when we're trying to polish a release?
20:46:00 <soren> err..
20:46:01 <ttx> vishy: miletsone-proposed branch handling is not baked yet
20:46:03 <soren> jaypipes: As opposed to when we're trying to polish a release?
20:46:07 <jaypipes> ttx: having just gone through this with glance, I don't think it will be too bad to do Nova after d4, but that's vishy's decision...
20:46:11 <mtaylor> ttx: it can be
20:46:22 <mtaylor> ttx: we can set up some tests over to the side
20:46:29 <ttx> anyway, that's out of scope
20:46:31 <jaypipes> soren: meh, no good time, really. :(
20:46:39 <ttx> I agree on "before essex summit"
20:47:08 <ttx> depending on how ready milestone-proposed is (glance will need it) maybe post-D4 is ok for Nova
20:47:12 <jbryce> #info VOTE: GitHub for Source Control; Gerrit for merge; everything else stays the same. Goal of having all core projects moved before Essex design summit.
20:47:23 <jmckenty_> +1
20:47:24 <jaypipes> +1
20:47:28 <vishy> +1
20:47:36 <johnpur> +1
20:47:36 <eday> At one point (at diablo summit I think) we decided to have a community-wide survey once we had a git-based option. Should we still do this before having a PPB vote?
20:47:42 <ttx> +1
20:47:46 <soren> +1
20:47:53 <eday> I guess that is a no :)
20:47:54 <dendrobates> +1
20:48:06 <jmckenty_> eday: if they riot, we'll revisit it?
20:48:08 <termie> eday: PPB CRUSH PUNY COMMUNITY
20:48:27 <jmckenty_> "I'm on the brute squad."... "You ARE the brute squad"
20:48:48 <jbryce> +1
20:48:56 <notmyname> +1
20:48:58 <jmckenty_> anotherjesse: ?
20:49:13 <jmckenty_> I think we can count ewan at +1 as well
20:49:14 <anotherjesse> +1
20:49:15 <ttx> jbryce: we might have time for the next topic, hurry up :)
20:49:30 <jmckenty_> eday - vote?
20:49:37 <jaypipes> does it matter? :)
20:49:47 <eday> 0, I'd rather have seen community survey feedback first
20:49:47 <jmckenty_> I like to have the counts right :)
20:49:52 <jmckenty_> fair enough
20:50:00 <jbryce> #agreed GitHub for Source Control; Gerrit for merge; everything else stays the same. Goal of having all core projects moved before Essex design summit. 10 +, 2 abstain
20:50:00 <jmckenty_> +0 or -0 ?
20:50:07 <jbryce> #topic Deadline for Essex core projects applications
20:50:18 <jbryce> ttx: this one yours?
20:50:21 <jaypipes> I think ttx offered Setp 3rd?
20:50:24 <ttx> sure
20:50:32 <johnpur> +1
20:50:33 <jmckenty_> Sept 3rd seems reasonable
20:50:33 <jaypipes> Sept 3rd. Good with folks?
20:50:37 <jaypipes> +1
20:50:43 <jmckenty_> Any feedback on the PTL voting mechanism?
20:50:44 <vishy> =1
20:50:50 <vishy> er +1
20:50:52 <anotherjesse> +1
20:50:53 <ttx> +1
20:50:54 <eday> +1
20:50:57 <jmckenty_> +1
20:51:07 <jbryce> +1
20:51:08 <ttx> I'm fine with first PTL being not elected.
20:51:09 <notmyname> +0
20:51:10 <johnpur> vishy: now you are just confusing us
20:51:31 <dendrobates> +1
20:52:01 <jbryce> #agreed September 3rd is the deadline for core project applications. 9 +, 3 abstain
20:52:13 <ttx> the idea is that they can participate in design summit org, as well as the newly-elected PTLs
20:52:18 <jaypipes> this has been the most productive PPB meeting in months. or ever.
20:52:24 <jbryce> #topic open discussion
20:52:37 <jmckenty_> jaypipes: the first few were good
20:52:38 <jbryce> anyone have any random thoughts or observations?
20:52:43 <mtaylor> quick question - should I submit openstack-ci to be a project? or are we fine with managing it how it is now?
20:52:50 <jbryce> it helps to have a full contingent present
20:52:57 <jmckenty_> mtaylor: I'd like to see it as a project
20:52:57 <soren> mtaylor: I woulnd't bother.
20:52:58 <ttx> jaypipes: that's just because you won every vote.
20:53:04 <jaypipes> jbryce: I have lots of random thoughts, but probably shouldn't say them.
20:53:05 <jmckenty_> but I'm not fussy
20:53:08 <ttx> mtaylor: it's not a code project.
20:53:23 <soren> mtaylor: It's not going to do releases, for instance. It seems pointless.
20:53:26 <ttx> it's an infrastrtcture thing
20:53:27 <mtaylor> it's not  - and I'm fine with it not being- I just wanted to make sure folks were happy
20:53:59 <jaypipes> mtaylor: yeah, leaving it as-is is fine I think...
20:54:11 <ttx> do we expect core promotions for Essex ?
20:54:12 <mtaylor> ok
20:54:25 <johnpur> keystone?
20:54:25 <ttx> is one of the incubated projects considering filing for core ?
20:54:30 <jaypipes> ttx: thought you wanted to vote on Sept 3rd? :)
20:54:32 <jbryce> ttx: i'll check with keystone and dashboard and see if they want to try
20:55:02 <jmckenty_> I think keystone should try for core
20:55:08 <jmckenty_> anotherjesse: thoughts?
20:55:09 <ttx> I'd rather have them present *before* Sep 3rd
20:55:10 <johnpur> jbryce: those are the two i would think
20:55:16 <jaypipes> ttx: ah, yes.
20:55:16 <jbryce> ttx: I agree
20:55:26 <ttx> otherwise it's a straight yes/no, no second chance.
20:55:37 <jmckenty_> I'd rather see keystone go first, fwiw
20:55:51 <jmckenty_> Since I'd love to see dashboard support keystone well before it goes in
20:56:29 <jbryce> all right...last call
20:56:31 <anotherjesse> jmckenty_: I think keystone needs to go to core … but we need to get the extensions stuff done
20:56:46 <jmckenty_> thanks jbryce
20:56:50 <jbryce> thanks everyone
20:56:50 <johnpur> i think the dashboard is somewhat inevitable, and they can work to improve keystone support over time
20:56:51 <jmckenty_> hey, any dell update?
20:56:54 <jbryce> #endmeeting