20:07:03 <annegentle> #startmeeting
20:07:04 <openstack> Meeting started Mon Aug 15 20:07:03 2011 UTC.  The chair is annegentle. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:07:05 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:07:17 <annegentle> Welcome one and all to the OpenStack Doc Team monthly meeting
20:07:30 <annegentle> We'll start by reviewing last month's action items.
20:07:44 <annegentle> #topic Action items
20:07:55 <annegentle> community accounts for http://openstack.org - request accounts through stephen.spector@openstack.org
20:08:09 <annegentle> I'm pretty sure that people are using these mostly to blog, which is great.
20:08:22 <annegentle> I'm going to mark it as Done.
20:08:29 <annegentle> next one: staging area for http://openstack.org
20:09:05 <annegentle> so, we got a little distracted/confused by a need for a staging area for http://wiki.openstack.org so we've not got a next step for this yet. I emailed Todd Morey and mtaylor to find a good next step.
20:09:17 <annegentle> we likely need staging for both the wiki and the main site.
20:09:26 <annegentle> I'm going to call this one In Progress.
20:09:40 <annegentle> Next:
20:09:43 <annegentle> Anne to add distributed scheduler to devref
20:09:57 <annegentle> Done: http://nova.openstack.org/devref/index.html
20:10:10 <annegentle> Next one: explore MoinMoin to DocBook paths
20:10:46 <annegentle> Turns out in the case of the flat networking docs, copy/paste was just fine, but David Cramer and I did email some ideas for exporting MoinMoin to DocBook, he noted this MoinMoin feature: http://moinmo.in/RenderAsDocBook.
20:11:04 <annegentle> I was concerned about security on the OpenStack wiki. You'd have to turn the feature on and then off real quick it seems, so for now, copy/paste is fine.
20:11:27 <annegentle> Lastly, a request for a wiki page to clarify which version of the nova/euca tools work with which version of openstack distro - Not yet started.
20:12:29 <annegentle> #info ongoing action items including staging areas for wiki and openstack.org main site; wiki page to clarify version matrix that works with moving parts of OpenStack
20:12:39 <deshantm> is that last action item feasible at this time?
20:13:17 <annegentle> deshantm: with just a few Q&A sessions where I started investigating, I'd say it's complicated, but not impossible
20:13:31 <deshantm> fair enough
20:13:37 <annegentle> deshantm: what might be easier/more feasible is "known working arrangements?"
20:14:02 <annegentle> it seems to involve a lot of poking devs to get answers.
20:14:18 <deshantm> yeah we could get uses to report success of running euca/nova test scripts
20:14:33 <deshantm> s/uses/users/
20:14:35 <annegentle> yeah that would be a quicker method
20:14:54 <annegentle> ok, next topics all revolve around general documentation status
20:15:05 <annegentle> #topic openstack.org project status
20:15:23 <annegentle> A round of updates on openstack.org from Todd rolled out first week of August.
20:15:35 <annegentle> #info openstack.org projects page now has Image service as a core project
20:15:48 <annegentle> #info project pages have current features and roadmap on each individual page
20:16:07 <annegentle> #info openstack.org company count dynamically updated on the community page
20:16:18 <annegentle> #info Partner company logos scale to proper size
20:16:24 <annegentle> I think those four items capture the changes.
20:16:32 <annegentle> Like I said previously, still working on a staging area.
20:16:51 <deshantm> 100 companies now, nice!
20:16:53 <annegentle> Any questions about openstack.org?
20:17:03 <annegentle> yeah, it's so cool to see it update so fast too
20:17:06 <annegentle> updated
20:17:33 <annegentle> #topic RST docs in each project (glance, nova, swift)
20:17:49 <annegentle> the RST docs are developer oriented - by dev for dev.
20:18:20 <notmyname> as god intended
20:18:38 <annegentle> One work in progress item is to get doc/man/ for man pages for all services and CLI tools. I'm tackling it little by little but certainly would invite others to do so too. I think the Swift team has intentions to store their man pages with the code like nova does.
20:19:10 <annegentle> notmyname: preach it brother notmyname :)
20:19:48 <notmyname> annegentle: (for the record here) one of our ops guys has proposed adding the man pages for swift to the swift codebase
20:19:51 <annegentle> nova's man page is woefully out of date, but I've got some updates
20:19:59 <annegentle> notmyname: excellent, thanks
20:20:31 <annegentle> I would like to hold a week-long doc sprint sometime after code freeze, if anyone has suggestions for a week, please do propose some.
20:21:14 <annegentle> It looks like sometime after Aug 24th would work well since the code will be "slushy" and only bug fixes accepted.
20:22:04 <annegentle> I'm thinking a virtual doc sprint would work well, but I'm happy to host one somewhere as well, with a preference for Austin, San Antonio, or San Francisco.
20:22:24 <annegentle> #info looking for a good week to hold a doc sprint after the Aug 24 date.
20:22:57 <annegentle> anything else on RST docs?
20:23:23 <annegentle> #topic DocBook docs in openstack-manuals project
20:23:48 <annegentle> #info I'm adding CSS OSS http://wiki.openstack.org/DocBook updates from http://code.launchpad.net/openstackbook to build automatically using our Jenkins server.
20:24:20 <annegentle> Found out this week that the book also ships with Ubuntu Cloud. We're going to call it the OpenStack Starter Guide. Love Creative Commons licensing and a dedicated team, thank you CSS OSS!
20:24:35 * deshantm likes Jenkins for CI
20:24:56 <annegentle> yep, still working on the actual building but it's getting there.
20:25:12 <annegentle> sure makes the possibilities for building out a library exciting.
20:25:42 <annegentle> deshantm: you want to talk about the Hypervisor support matrix and testing?
20:25:58 <annegentle> #link http://wiki.openstack.org/HypervisorSupportMatrix
20:26:16 <annegentle> #topic Hypervisor support matrix
20:26:27 <deshantm> Has the matrix so far been filled in manually?
20:26:36 <deshantm> And now we are working on making automated tests?
20:26:48 <deshantm> I didn't hear back from soren or jaypipes
20:26:51 <annegentle> deshantm: yes, that's right. Mostly with notes from Rajesh interviewing vishy and others.
20:27:19 * vishy looks around
20:27:35 * vishy disappears in a puff of smoke
20:27:37 <annegentle> testing has been fragmented, last I heard soren is working on all quality efforts
20:28:06 <jaypipes> deshantm: not quite sure what you are asking for.... mtaylor is responsible for the CI infrastructure, but what kind of automated tests specifically are you asking about (because there are many...)
20:28:30 <deshantm> I'd like to establish if libvirt is used for KVM, the normal Xen hypervisor etc. or is KVM/Xen called directly at times?
20:28:47 <jaypipes> deshantm: libvirt is used for KVM
20:29:03 <deshantm> Also, there is a distinction between libvirt-based hypervisors and XenAPI-based hypervisors
20:29:07 <jaypipes> deshantm: for Xen, Xen is called directly
20:29:36 <deshantm> jaypipes: for Xen there you must mean XenServer right?
20:29:38 <soren> I'm working on generating this stuff mostly automatically.
20:29:42 <jaypipes> deshantm: yes, KVM, LXC use libvirt. XenServer/XCP uses straight XenServer calls
20:30:17 <jaypipes> deshantm: you can check out the code in /nova/virt/
20:30:17 <deshantm> Xen (not XCP nor XenServer) can also be supported via libvirt
20:30:26 <soren> So, i'll be cleaning things up to make sure that everything returns NotImplementedErrors when there's something they don't implement. During the test suite run, I track this, and dump it in a file that I'll then parse and generate the support matrix from.
20:30:29 <jaypipes> deshantm: yes, but it's not AFAIK
20:31:05 <jaypipes> deshantm: meaning if you choose Xen, we use the XenServer/XCP driver in /nova/virt/xenapi IIRC
20:31:18 <deshantm> soren: wasn't there some libvirt/Xen testing done early on (not XenServer/XenAPI-based), but normal Xen
20:31:43 <soren> deshantm: Yes.
20:32:03 <annegentle> it would be great to use test results as "documentation" for what works on which release/revno
20:32:19 <deshantm> with Xen support coming back to Ubuntu, shouldn't we consider Xen a fist class citizen again
20:32:30 <deshantm> 11.10 will have dom0 tech preview
20:32:38 <deshantm> 12.04 should have Xen in main
20:33:04 <deshantm> The Xen.org team is able to help work through any issues
20:34:11 <deshantm> also from the XenAPI side of things, do you guys need any help from the Citrix devs to make sure those tests are automated?
20:35:19 <annegentle> sore: this generated support matrix from test suite results - what will it look like, where will you publish it?
20:35:32 <soren> annegentle: No clue yet.
20:36:18 <soren> annegentle: It's not going to be done any time soon. There's a massive amount of work to be done before everything is covered by tests.
20:36:28 <soren> ...and until then I can't extract this information.
20:36:41 <deshantm> there has been a fair amount of use/testing going on with XCP/XenServer + OpenStack lately
20:36:50 <annegentle> soren: sounds like calling in some supporting teams to send in tests is a good idea then
20:37:22 <annegentle> #action: deshantm, soren, jaypipes, mtaylor pow-wow about test automation
20:37:38 <annegentle> mind if I move to next topic?
20:37:49 <soren> hang on.
20:38:09 <annegentle> sure, go ahead
20:38:10 <soren> deshantm: This isn't about people trying stuff out in various configurations.. This is about actual unit test coverage.
20:38:26 <deshantm> soren: yeah, i understand that
20:38:28 <soren> It's also not about automating a set of existing tests.
20:38:54 <soren> It's about writing a mind numbing amount of unit tests for all the stuff that has no coverage whatsoever at the moment.
20:39:12 <deshantm> right, I get that.. that is why I think there is an issue with the matrix
20:39:13 <soren> I just want to manage expectations here :)
20:39:29 <annegentle> so, is the matrix only going to be manual for a while?
20:39:31 <soren> It's not going to be done in a week or two or three. It'll be a *while*.
20:39:38 <annegentle> #undo
20:39:39 <soren> annegentle: Yes.
20:39:39 <openstack> Removing item from minutes: <MeetBot.items.Action object at 0x1a51450>
20:39:55 <deshantm> i think it may give users a wrong impression of what is possible for each of the hypervisors
20:40:12 <jaypipes> http://wiki.openstack.org/GlanceFeatureMatrix
20:40:18 <jaypipes> I keep ^^ up to date manually...
20:40:36 <annegentle> #info automated tests aren't just about various configurations, there is a gap in actual unit test coverage
20:41:32 <deshantm> so it's non-trivial, but Xen.org/Citrix is willing to help on the Xen sides of things
20:41:42 <annegentle> #info manually compiled support matrices may give users less info and not specify what is possible with each hypervisor
20:42:12 <deshantm> we just need to know what help we should provide
20:42:21 <annegentle> #info tradeoff and balancing act is in the amount of work for automated testing and configurations available.
20:42:48 <annegentle> I still think there's an action in there for you guys to discuss further.
20:43:01 <annegentle> could we take this to the next CI meeting? It's tomorrow, right?
20:43:48 <deshantm> http://wiki.openstack.org/Meetings/CITeamMeeting
20:44:27 <annegentle> yup. I'll update that agenda.
20:44:53 <annegentle> ok, last topic under status updates is for deshantm to fill us in on the XenServer plugin
20:44:58 <annegentle> #topic Discuss XenServer Plugin status and docs
20:45:38 <deshantm> ok so we are building the openstack xenapi plugins to an RPM with an internal jenkins instance
20:45:46 <deshantm> The yum repo is here:
20:46:06 <deshantm> #link http://downloads.xen.org/XCP/openstack/openstack-xen-plugins/
20:46:57 <deshantm> #action deshantm to test and document usage of XenAP-based hypervisors
20:47:26 <deshantm> any questions?
20:47:44 <annegentle> nice, that was one of the dependencies for starting to document deployment practices? We keep sending people to the wiki page, http://wiki.openstack.org/XenServerDevelopment, but would love deployment-oriented doc.s
20:47:59 <deshantm> yeah, that's the plan
20:48:26 <annegentle> excellent. I should be able to test your instructions and review as you see fit.
20:48:36 <deshantm> great, thanks
20:48:46 <annegentle> #topic Doc bugs
20:49:40 <annegentle> Triaging and fixing as I go, you can always send people there if they want small doc tasks.
20:49:57 <annegentle> link: https://bugs.launchpad.net/openstack-manuals
20:50:02 <annegentle> #link https://bugs.launchpad.net/openstack-manuals
20:50:29 <annegentle> and also the ones tagged "documentation" gathered from all the openstack projects
20:50:32 <annegentle> #link https://bugs.launchpad.net/openstack/+bugs?field.tag=documentation
20:50:55 <annegentle> ok, just 10 minutes to go, how about open discussion?
20:50:59 <annegentle> #topic Open discussion
20:51:12 <annegentle> #info Project policy board voted to standardize tools for OpenStack projects and I'd like the docs to follow suit.
20:51:17 <deshantm> can this (https://bugs.launchpad.net/~openstack-doc) link to that one
20:51:49 <annegentle> deshantm: sure, I think so.
20:52:03 <annegentle> though I like the "There are currently no open bugs" ha ha.
20:52:26 <deshantm> so things are moving to git right?
20:52:30 <annegentle> I want to move from Launchpad to Github and store source using git by October (in time for the Oct 3-5 Design Summit). Any Gotchas or potholes to discuss? Considerations for docs or reasons not to are certainly welcome as well.
20:53:19 <annegentle> deshantm: only code hosting is moving to git. Bugs, blueprints, stay in Launchpad
20:53:45 <deshantm> code in git for docs works fine for me, I can't think of any issues
20:54:14 <annegentle> deshantm: ok, great. So far I haven't heard any compelling reasons not to.
20:54:20 <annegentle> or any reasons not to :)
20:54:35 <deshantm> can we start by mirroring to github and using it by default or something?
20:54:39 <annegentle> #info OpenStack docs want to move from Launchpad to Github and store source using git by October (in time for the Oct 3-5 Design Summit).
20:55:02 <annegentle> deshantm: I haven't even looked at the first steps yet, if mirroring is the right first step then we can do that.
20:55:16 <annegentle> mtaylor has offered to help out
20:55:18 <deshantm> others probably know the process better
20:55:30 <annegentle> #action annegentle to work on process for getting to git
20:55:46 <deshantm> I'm happy to start using git for docs when it is ready to test
20:55:51 <deshantm> just let me know
20:56:08 <annegentle> my only first step has been reading "Pro Git" thanks to David Cramer pointing it out
20:56:09 <jaypipes> annegentle: http://wiki.openstack.org/GerritWorkflow
20:56:11 <annegentle> #link http://progit.org/2010/05/17/progit-for-the-ipad.html
20:56:19 <annegentle> thanks jaypipes
20:56:22 <jaypipes> np
20:56:32 <annegentle> #link http://wiki.openstack.org/GerritWorkflow
20:56:39 <annegentle> Ok, any other open discussion items/
20:57:28 <deshantm> nothing else here
20:57:30 <annegentle> If not, I'll close out the meeting.
20:57:45 <annegentle> Ok, thanks for all the good discussion. I'll report it up to the team meeting tomorrow.
20:57:48 <annegentle> #endmeeting