21:01:34 <ttx> #startmeeting
21:01:35 <openstack> Meeting started Tue Aug 16 21:01:34 2011 UTC. The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:36 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:01:45 <ttx> Welcome to our weekly team meeting...
21:01:52 <ttx> Today's agenda is at:
21:01:56 <ttx> #link http://wiki.openstack.org/Meetings/TeamMeeting
21:02:12 <ttx> #topic Actions from previous meeting
21:02:21 <ttx> * ttx to look at best dates for final Swift 1.4.3
21:02:29 <ttx> done , we'll talk about it in next topic
21:02:39 <ttx> #topic Swift status
21:02:46 <ttx> notmyname: o/
21:02:57 <ttx> notmyname: Could you confirm the Swift plans for 1.4.3 ?
21:02:58 <notmyname> swift 1.4.3 set for sept 7 and 9
21:03:11 <notmyname> branch on 9-7, final on 9-9
21:03:53 <ttx> notmyname: Does https://launchpad.net/swift/+milestone/1.4.3 miss already-implemented significant features ?
21:04:04 <notmyname> checking...
21:04:13 <ttx> ISTR you mentioned *several* cool features :)
21:04:28 <notmyname> ISTR?
21:04:32 <notmyname> is that french?
21:04:32 <ttx> I seem to remember
21:04:33 <notmyname> :-)
21:05:32 <notmyname> I'll double check that everything is included there
21:05:36 <ttx> 1.4.3 milestone page only shows "Catch more with quarantine code" so far
21:05:54 <notmyname> most of our recent work has been in things like language bindings and slogging
21:05:59 <ttx> #action notmyname to double check that everything is included in https://launchpad.net/swift/+milestone/1.4.3
21:06:00 <notmyname> (ecosystem projects)
21:06:09 <ttx> notmyname: Anything else ?
21:06:26 <notmyname> nothing springs to mind
21:06:32 <ttx> Raise your hand if you have questions on Swift...
21:07:00 <ttx> #topic Glance status
21:07:10 <jaypipes> https://launchpad.net/glance/+milestone/diablo-4
21:07:11 <ttx> Last feature branches for Diablo need to be merged by August 22 !!
21:07:26 <jaypipes> http://wiki.openstack.org/GlanceFeatureMatrix
21:07:45 <jaypipes> I've been putting together the above feature matrix to help folks understand what's in the different releases...
21:07:57 <glenc> nice
21:08:02 <ttx> jaypipes: I renamed the integrated-freeze milestone to diablo-rbp (release branch point) and adjusted the date, btw
21:08:22 <ttx> so that it matches our recent release process decisions
21:08:26 <jaypipes> Glance contribs are kicking ass in D4. Vek proposed for merging a control script into keystone which unblocks the remaining tasks for keystone-integration blueprint (functional tests)
21:08:41 <jaypipes> ttx: no prob on freeze release
21:08:51 <ttx> Are all the blueprints at https://launchpad.net/glance/+milestone/diablo-4 still on track ?
21:08:57 <ttx> Or should we already defer some to Essex ?
21:08:58 <jaypipes> ttx: yep.
21:09:12 <jaypipes> ttx: no, i'm confident for all of them.
21:09:14 <jaypipes> in d4
21:09:29 <ttx> jaypipes: I heard that one before :)
21:09:37 <jaypipes> ttx: yeah, yeah...
21:09:38 <ttx> jaypipes: Other announcements/comments ?
21:09:58 <jaypipes> ttx: nope
21:10:02 <ttx> Raise your hand if you have a question on Glance.
21:10:30 <ttx> #topic Nova status
21:10:34 <ttx> Ah, Nova...
21:10:41 <vishy> oh, nova, we love you so much
21:10:43 <vishy> :)
21:10:44 <ttx> Last feature branches for Diablo also need to be merged by end of day, August 22 !!
21:10:54 <ttx> That leaves very little time: "propose early, review often".
21:11:04 <ttx> the new OpenStack motto.
21:11:12 <soren> I like it.
21:11:23 <ttx> vishy: admin-account-actions (Essential) was pushed post-diablo-4, which makes me a very sad bunny.
21:11:39 <ttx> I don't really like the idea of an essential spec being pushed post-FeatureFreeze.
21:12:21 <ttx> vishy: do we know the story there ?
21:12:22 <vishy> hmm
21:12:25 <vishy> no
21:12:33 <vishy> i didn't know it got pushed
21:12:40 <vishy> pvo: ?
21:13:00 <ttx> https://blueprints.launchpad.net/nova/+spec/admin-account-actions -- for those following at home
21:13:04 <ttx> westmaas: ?
21:13:11 <soren> ttx: thanks for that :)
21:13:33 <westmaas> there is some work on it from ozone this sprint
21:13:38 <westmaas> _cerberus_: yes?
21:14:00 * _cerberus_ is looking
21:14:15 <_cerberus_> Not on our end, actually
21:14:20 <comstud> hmmm
21:14:21 <ttx> i could use more detail on "some work" and "this sprint"
21:14:22 <jk0> this sprint is mostly keystone stuff
21:14:36 <westmaas> working on it ttx, sorry
21:15:12 <jk0> I don't think any of us devs have looked at this BP yet
21:15:13 <westmaas> actually is /hosts done already?
21:15:24 <glenc> FYI, portions of this have been completed, but the /hosts stuff has not been worked on
21:15:30 <westmaas> oh.
21:15:44 <jk0> oh, right, this is /hosts -- a lot of that is done and there are a couple things in this sprint being worked on
21:15:57 <_cerberus_> It's still up in the air, actually
21:16:05 <westmaas> ttx perfectly clear now?
21:16:08 <comstud> lol
21:16:24 <_cerberus_> ;-)
21:16:27 <jk0> it's on our radar
21:16:38 <ttx> jk0: when does that sprint end ? Is "what is being worked on" sufficient to please whoever finds this "essential" ?
21:16:58 <jk0> ttx: we do two week sprints, just started yesterday
21:17:00 <westmaas> ttx: a week from friday
21:17:23 <comstud> ttx: I can't see any way that BP would be complete in time
21:17:28 <_cerberus_> +1
21:17:29 <ttx> conveniently non-aligned with our feature freeze :)
21:17:46 <ttx> comstud: right, that's what I think too
21:18:00 <ttx> comstud: question is, is it still "essential" to this release ?
21:18:15 <ttx> comstud: as in "stop the press, everyone works on that instead" ?
21:18:33 <ttx> comstud: given the level of engagement around it, I'd say, it's not essential
21:18:35 <comstud> I don't feel that it is
21:18:46 <ttx> vishy: opinion ?
21:18:53 <vishy> seems more rs essential than os essential to me
21:18:56 <glenc> IMHO it's essential for a service provider to deploy, but probably not for everyone
21:18:58 <comstud> It's a rackspace requirement, and we can work
21:18:59 <westmaas> my feeling is no
21:19:04 <comstud> vishy: right
21:19:07 <glenc> and our deadline is somewhat later
21:19:34 <ttx> vishy: looks like reprioritization is in order, before deferring :)
21:19:44 <vishy> agreed
21:20:03 <glenc> vishy: can we sync? much of the stuff in that spec is completed, but the /hosts is not
21:20:10 <ttx> #action vishy to reprioritize admin-account-actions which is likely to miss diablo
21:20:14 <vishy> sure
21:20:19 <vishy> we could split it into two blueprints
21:20:26 <glenc> that's what I'm thinking
21:20:28 <vishy> and mark one completed
21:20:33 <vishy> and the other for essex?
21:20:40 <ttx> vishy: works for me
21:20:45 <glenc> yup
21:20:51 <ttx> vishy: there are also 4 new specs proposed to d4 (the four at the bottom with undefined prio)
21:21:02 <vishy> glenc: you want to handle the rewrite?
21:21:08 <vishy> ttx: looking
21:21:09 <ttx> at https://launchpad.net/nova/+milestone/diablo-4
21:21:21 <ttx> vif-driver-802-1qbh and scheduler-for-802-1qbh are from Cisco
21:21:24 <glenc> I will
21:21:31 <ttx> SumitNaiksatam: how close is this from being proposed ?
21:21:49 <SumitNaiksatam> hi, there is a dependency issue
21:22:04 <SumitNaiksatam> the code relies on Quantum modules
21:22:13 <ttx> SumitNaiksatam: ew
21:22:25 <vishy> sumit: is it just a driver and scheduler?
21:22:41 <SumitNaiksatam> yes VIF driver and a scheduler, two modules
21:22:52 <vishy> SumitNaiksatam: then they could live in the quantum source tree
21:22:56 <vishy> and be loaded via a flag
21:23:09 <SumitNaiksatam> ok
21:23:10 <ttx> vishy: +1
21:23:20 <SumitNaiksatam> i do already have flags
21:23:21 <vishy> you don't need to have the code in nova for things like --scheduler_driver=xxx.xxxx
21:23:31 <SumitNaiksatam> ok
21:23:40 <SumitNaiksatam> that sounds like a good solution
21:23:40 <vishy> you could say --scheduler_driver=quantum.some.cool.Scheduler
21:23:47 <SumitNaiksatam> yep, got it
21:24:05 <ttx> vishy: hyper-v-update sounds pretty useful, could even be post-d4 from where I'm standing
21:24:22 <vishy> ttx: agreed that sounds like bug fixes to me
21:24:47 <vishy> the security group one is a just an interesting feature, not a huge deal if it doesn't go in
21:24:52 <vishy> so I will low it
21:24:54 <ttx> right, low
21:25:19 <ttx> vishy: there is "add diff disk support" in the hyperv stuff
21:25:30 <ttx> but it sounds like feature catchup
21:25:38 <ttx> vishy: medium ?
21:25:41 <vishy> sure
21:25:51 <vishy> target to freeze?
21:26:13 <ttx> let it to d4, we'll postpone it if needed
21:26:16 <vishy> k
21:26:22 <ttx> vishy: how is finalize-nova-auth going ?
21:26:31 <vishy> should i untarget the SumitNaiksatam ones?
21:26:33 <vishy> good.
21:26:39 <vishy> I think we have one more branch to go in
21:26:48 <ttx> vishy: I think so yes. Will do if not done
21:27:04 <vishy> I got buy-in from the rs deploy teams that it won't cause them issues to have no auth by default
21:27:14 <vishy> and it doesn't sound like anyone is using the os_api auth and accounts
21:27:19 <vishy> so those will go away
21:27:43 <vishy> that is the api endpoints for controlling accounts and users
21:27:44 <soren> How will this affect the EC2 API? If at all.
21:28:01 <vishy> soren: I pushed an extension into keystone to allow it to auth ec2 creds
21:28:26 <vishy> soren: my thoughts are to basically do no auth checking by default.
21:28:28 <soren> So every request will need to go through keystone?
21:28:54 <vishy> if you want auth checking, you can a) install keystone or b) use the old pipeline, with users and projects in auth manager
21:29:11 <soren> Ok.
21:29:15 <ttx> danwent: what about linuxnet-vif-plugging and implement-network-api ?
21:29:16 <vishy> does that work?
21:29:30 <danwent> linuxnet-vif-plugging is in review
21:29:37 <dolphm_> vishy, that's intuitive
21:29:41 <danwent> I believe all concerns have been addressed, just waiting for final approval.
21:29:43 <soren> vishy: b) is the status quo, right?
21:29:54 <soren> vishy: Just same ol', same ol'?
21:30:03 <soren> vishy: If yes, then yes :)
21:30:08 <danwent> implementation of quantum network api needs to be merge propped in the next few days.
21:30:13 <soren> I won't have to change anything. That's easy.
21:30:15 <vishy> b) yes, I'm trying to take it away as the default though, because I want to remove the old auth manager completely in essex
21:30:32 <ttx> danwent: indeed.
21:30:37 <danwent> code is working, but will probably cut down on what I merge prop to reduce the scope of the review. just the core stuff.
21:30:51 <ttx> ryu_ishimoto: How is nova-quantum-vifid going ?
21:31:05 <danwent> he's ready to merge prop, I believe.
21:31:06 <vishy> soren: maintaining two auth systems for people in production will be a pain, so I'm trying to encourage people not to deploy with the old stuff
21:31:22 <soren> vishy: sure
21:31:29 <ttx> danwent: the sooner the better
21:31:33 <ryu_ishimoto> ttx: I've made some changes yesterday and preparing for merge prop right now
21:31:40 <ttx> ryu_ishimoto: perfect !
21:31:51 <ryu_ishimoto> ttx: I willl make sure to do so before the end of the week
21:31:54 <ttx> everyone else: if one spec assigned to you on https://launchpad.net/nova/+milestone/diablo-4 simply won't make it by Monday, please let me know ASAP.
21:32:06 <danwent> ttx: this is our highest priority nova issue, so we'd like that prioritized.
21:32:26 <danwent> if you have to cut some quantum stuff, the vif-id stuff should be the last thing cut
21:32:32 <ttx> danwent: it's High priority, so theoretically gets priority in reviews.
21:32:39 <danwent> ttx: thanks.
21:32:59 * ttx knows we won't have all 28 d4 BPs in
21:33:46 <ttx> so vishy should get ready to be hit with networking code review :)
21:33:53 <ttx> vishy: Announcements, comments ?
21:34:46 <vishy> I hope everyone has lots of time for review this weekend
21:34:50 <vishy> going to be a crunch :)
21:35:00 <jk0> speaking of that
21:35:01 <ttx> vishy: Monday is OK too.
21:35:06 <jk0> we could use a few more nova core members
21:35:22 * jk0 looks at jkoelker
21:35:27 <comstud> heh
21:35:33 <ttx> jk0: nominate, nominate !
21:35:40 <jk0> :)
21:35:59 <ttx> Questions for Nova PTL ?
21:36:32 <clayg> vishy: vsa's branch?
21:37:04 <comstud> vishy: What is the air-speed velocity of an unladen swallow?
21:37:14 <vishy> so I've been talking with vsa about their branch
21:37:35 <vishy> trying to get them to back out a few changes
21:37:43 <vishy> so it isn't so tightly coupled with nova
21:38:06 <Vek> comstud: air speed != velocity
21:38:18 <comstud> Vek: fail.
21:38:29 * jk0 flys the plane over Vek's head
21:38:37 <comstud> Yeah
21:38:41 <vishy> I'm not totally convinced that vsa's are the way of the future, but I think it is reasonable to have it in experimentally if they can decouple it a bit more
21:38:49 <Vek> heh. Velocity is a vector quantity; air speed is a scalar quantity :)
21:38:55 <Vek> anyway...
21:39:08 <vishy> so they are working on it now
21:39:11 <ttx> vishy: ok
21:39:17 <comstud> Vek: you fail. google the question to find the reference.
21:39:23 <ttx> clayg: does that answer your question
21:39:26 <ttx> ?
21:39:28 <vishy> african, or american?
21:39:36 <comstud> african or european
21:39:41 <vishy> dang
21:39:41 <creiht> vishy: any word on other volume changes?
21:39:43 <clayg> ttx: i'm ok with that answer for now
21:39:47 <vishy> memory is faulty
21:39:51 <comstud> vishy: close enough :)
21:40:16 <vishy> creiht: talked with piston today, we're going to try and finish up the branch for volume types at the openstack hack-up on thursday
21:40:22 <creiht> cool
21:40:54 <ttx> vishy: let me know when we can move to the next topic.
21:41:02 <vishy> i think we're good
21:41:11 <ttx> #topic Incubated projects news
21:41:18 <ttx> devcamcar, dolphm: o/
21:41:53 <ttx> News, questions on Keystone/Dashboard ?
21:42:13 <ttx> ...
21:42:29 <ttx> ..
21:42:40 <ttx> .
21:42:41 <Vek> .
21:42:49 <ttx> #topic Documentation report
21:42:49 <glenc> …
21:43:04 <ttx> I received a postcard from annegentle: """Documentation report:
21:43:16 <ttx> We're looking for a good week for a doc sprint after the August 22 freeze date - can be remote.
21:43:25 <ttx> Please send suggestions and be on the look out for a doc sprint week announcement.
21:43:34 <ttx> We'd like man pages for all services and CLI tools, XenServer deployment instructions (deshantm is working on those), zones "how-to", finalize flags docs, and review networking docs, adding HA info.
21:43:50 <ttx> Also, the openstack-manuals project hopes to move to git before the Design Summit (by the end of September).
21:44:00 <ttx> Full notes from the Doc Team meeting are at http://eavesdrop.openstack.org/meetings/openstack-meeting/2011/openstack-meeting.2011-08-15-20.07.html """
21:44:14 <zykes-> openstack-manuals is ?
21:44:18 <ttx> No return address.
21:44:36 <ttx> openstack-manuals is the project maintaining the source to docs.openstack.org
21:44:46 <ttx> #topic Open discussion
21:44:57 <jk0> o/
21:45:15 <jk0> can we start shooting a quick notice to the ML when adding new deps to nova/glance/etc?
21:45:32 <ttx> jk0: oh, that sounds like a great idea.
21:45:36 <zykes-> ml ?
21:45:40 <jk0> mailing list
21:45:43 <zykes-> ah
21:45:48 * Vek agrees
21:46:04 <Vek> tnstaafl
21:46:16 <jaypipes> jk0: ++
21:46:22 <ttx> If we could avoid adding new dependencies late in the development cycle, that would be great too
21:46:33 <dabo> ttx: my thoughts exactly
21:46:33 <ttx> it puts a lot of pressure on our downstreams
21:47:01 <ttx> For example, if you add a new dep now, Ubuntu needs to package it and push it to main -- after their FeatureFreeze
21:47:12 <Vek> which reminds me, there's been a slight change to glance-registry.conf, so make sure you synchronize...
21:47:40 <Vek> not a dep, per se, but in a similar category of breaking change.
21:47:54 <jaypipes> Vek: we need to figure out a way of making changes like that in glance upgrades...
21:47:59 <ttx> PTLs: so we /could/ use something like a DependencyFreeze
21:48:15 <jaypipes> Vek: https://blueprints.launchpad.net/openstack-ci/+spec/glance-upgrade
21:48:20 <Vek> ttx: would have to come after feature freeze, though...
21:48:39 <ttx> Vek: not necessarily. Not all features add dependencies.
21:48:44 <Vek> jaypipes: *nod*
21:48:58 <ttx> sounds like a good design summit discussion.
21:49:02 * glenc thinks coconuts are not migratory
21:49:06 <Vek> ttx: true, but there's always the potential for it...
21:50:08 <ttx> Design Summit is still planned for Oct 3-5 in Boston. Registration should open as soon as I get the time to learn Django, or find a victim to do it for me.
21:51:07 <ttx> jk0: could you shoot an email to the ML saying that from now on, new deps should be announced (before they get merged)
21:51:12 <ttx> ?
21:51:14 <jk0> you got it
21:51:28 <ttx> #action jk0 to push new dep email policy to ML
21:51:31 * Vek will also send an email about his glance .conf change shortly
21:51:42 <ttx> Anything else ?
21:52:32 <ttx> ok then.
21:52:35 <ttx> #endmeeting