22:02:15 <danwent> #startmeeting
22:02:16 <openstack> Meeting started Tue Aug 16 22:02:15 2011 UTC.  The chair is danwent. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:02:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
22:02:21 <somik> salv: living the good life :)
22:02:27 <danwent> Sumit: I thought he had that every meeting
22:02:35 <danwent> #general topics
22:02:46 <danwent> #info please make sure you're signed the openstack CLA
22:03:07 <danwent> if you're contributing code.  need to sign both the individual and a corporate one.
22:03:15 <danwent> Thanks to rick and mark for clearing this up on the ml
22:03:20 <salv> if you have already  contributed to nova/swift/glance, you should have already signed it.
22:03:39 <danwent> any else general?
22:03:58 <danwent> btw, forgot to send out the agenda:  http://wiki.openstack.org/Network/Meetings
22:04:06 <danwent> guess I was in a hurry to get started
22:04:11 <danwent> #topic melange
22:04:12 <danwent> Troy?
22:04:24 <troytoman> we have been working on integration this week
22:04:36 <danwent> do we expect this to land in D4?
22:04:40 <troytoman> just trying to make sure that Melange can service the IP needs for Nova
22:04:42 <danwent> (in nova?)
22:04:46 <troytoman> looks good so far
22:04:55 <danwent> Ok, great.
22:05:00 <troytoman> I think we'll merge prop the Melange folder late this week
22:05:15 <troytoman> we want to at least propose it before the D4 deadline
22:05:40 <danwent> Ok, cool.  I am not sure we'll be able to integrate the quantum manager with melange in that time frame... that may have to wait.
22:05:47 <troytoman> we actually got our first VMs up in a test environment with the integrated Quantum/Melange network manager
22:06:03 <troytoman> but that code might not be done by D4
22:06:05 <danwent> troy: ah, you tweaked it yourself?  great
22:06:05 <zykes-> what's the deal with quantum / melange ?
22:06:14 <zykes-> make sure ips' and so on arent taken 2 times ?
22:06:34 <danwent> zykes:  http://launchpad.net/quantum
22:06:46 <danwent> zykes: http://launchpad.net/melange
22:06:46 <troytoman> danwent: yes we have created a branch that integrates melange and are doing some testing with it
22:07:10 <danwent> troy: melange link isn't right... what am i missing?
22:07:18 <troytoman> after the merge prop we are going to work on Notifications and Usage
22:07:43 <danwent> http://wiki.openstack.org/Melange
22:08:04 <danwent> troy: can you send out a pointer to the branch?
22:08:06 <troytoman> https://blueprints.launchpad.net/nova/+spec/melange-ipam
22:08:35 <troytoman> try to do that by tomorrow
22:08:45 <danwent> troy: thanks.
22:08:59 <danwent> that's all for melange?
22:09:10 <troytoman> i've added blueprints for notification and usage for both melange and quantum
22:09:16 <troytoman> it that's it
22:09:19 <danwent> #topic donabe
22:09:25 <danwent> we have an update this week!
22:09:26 <danwent> debo?
22:09:29 <debo> Hi
22:09:37 <debo> I have put up a prelim
22:09:40 <debo> version of hte API framework
22:09:45 <debo> based on the glance code
22:10:11 <debo> and we have simple CRUD boilerplate for nouns like tenants, network containers,
22:10:33 <danwent> https://code.launchpad.net/~netstack-core/donabe/diablo
22:10:39 <debo> thanks Dan
22:10:40 <danwent> debo: great.
22:11:11 <danwent> some kind of blueprint/write-up describing the API entities, etc. would be helpful for those just trying to get the big picture.
22:11:12 <somik> debo: do we have some blueprint(design spec) that we can use as a starting point for reviews
22:11:14 <debo> Rick and I felt that it would be good to start discussions and do some framework dev at the same time
22:11:18 <danwent> I think Rick said that we'll get that soon.
22:11:38 <debo> Dan, I agree ... as I mentioned maybe by next week I should have a simple writeup
22:11:45 <danwent> Great.  ok, anything else on donabe?
22:12:06 <debo> Nothing more ... please send me your comments about the framework if you have any
22:12:11 <debo> glance vs something .....
22:12:16 <danwent> to the netstack list, i presume
22:12:25 <danwent> #topic quantum
22:12:48 <danwent> #info goal is to apply for incubation at next week's PPB meeting
22:13:05 <danwent> here's a pointer to the proposed application: http://wiki.openstack.org/Projects/IncubatorApplication/Quantum
22:13:22 <danwent> definitely let me know if I'm missing anything or we think it is not representative
22:13:33 <danwent> (I spent a lot of time googling linked in profiles :) )
22:13:42 <danwent> but I may have missed some people.
22:14:10 <danwent> On the topic of reviews, we got the Cisco branch merged
22:14:15 <debo> somik: Gimme a week .... Rick/Dan suggested I give a quick update 1 hr ago :)
22:14:32 <danwent> congrats to the team on doubling the number of full-fledged plugins
22:14:41 <danwent> at this rate, we'll have 2^32 plugins in no time
22:14:48 <debo> in 32 weeks?
22:14:52 <jamesurquhart> danwent: Ha!
22:14:55 <danwent> :)
22:15:24 <danwent> there are a few other misc reviews for quantum... free brownie points to whomever picks them up
22:15:24 <SumitNaiksatam> thanks a ton guys for the great reviews
22:15:32 <SumitNaiksatam> on the cisco branch
22:15:33 <RamD> Netstack team: Thanks a lot
22:15:43 <danwent> also, I think there are some additional reviews coming down the pipe on the Cisco branch, correct?
22:15:44 <SumitNaiksatam> Dan, Salv, Somik, much appreciated
22:15:50 <RamD> sumit: :-) +1
22:15:52 <salv> you're welcome
22:16:06 <SumitNaiksatam> danwent: yes very much
22:16:08 <SumitNaiksatam> :-)
22:16:35 <edgar_magana> yeah sumit: +1 thanks for the comments!
22:16:38 <SumitNaiksatam> salv: we are fixing the merge in the prop today
22:16:42 <danwent> Ok, on a related topic: ignoring changes to nova for a second, what issues targeted for the D4 milestone do we consider blockers?
22:16:46 <salv> thanks!
22:16:51 <SumitNaiksatam> apologies!
22:16:52 <danwent> https://launchpad.net/quantum/+milestone/diablo-4
22:17:11 <danwent> We essentially have a week for D4
22:17:16 <rohita> yes dan..we proposed one today..but it seems we are out of sync with the trunk..hopefully we'll get it fixed..cc:salv
22:17:19 <salv> nova integration can become a blockere for auth
22:17:24 <danwent> after that we are in integration freeze, which means no major new changes.
22:17:51 <danwent> salv:  API v1.0 seems like a definitely must have
22:18:03 <salv> danwent: therefore, for auth, verification of ownership for interface could be a non-major change
22:18:05 <salv> on API:
22:18:10 <danwent> are there any other definitely "must haves" for Quantum D4?
22:18:13 <salv> changes are ready for merge propo
22:18:32 <danwent> salv: great.  we'll definitely want to give that review high priority.
22:18:45 <SumitNaiksatam> danwent: we have a bunch of things lined up, how do we got about those?
22:18:58 <SumitNaiksatam> these are specific to our plugin
22:19:04 <salv> Would it be ok to merge prop it without unit tests for CLI? I was aiming at completing those tests first and then merge prop the API
22:19:11 <danwent> Sumit:  if they are ready to go, I would merge prop them.
22:19:35 <danwent> salv: tests and minor tweaks can definitely come in during integration freeze, though if you have them ready, we can do it earlier.
22:19:46 <SumitNaiksatam> danwent: what about the ones which will be ready by in the next few days?
22:19:48 <salv> okay, I'll merge prop tomorrow
22:19:56 <danwent> Sounds like we'll have a lot of code to review in the next week or so.  Let's make sure everyone is pitching in on reviews.
22:20:07 <salv> Review days?
22:20:13 <danwent> Even if you haven't reviewed before, now's a great time to start.
22:20:17 <somik> salv: review sundays :)
22:20:31 <danwent> salv: I was thinking the same thing...  let's see if we think its needed.
22:21:14 <salv> We probably need them. With a few reviews in the pipeline, some of them are already in starvation
22:21:18 <danwent> we can perhaps have a review day after the deadline for getting nova changes in.
22:21:54 <danwent> #action #salv, schedule a review day
22:22:33 <danwent> this is the less fun side of being a "core dev"... but on the plus side you get to learn a lot about parts of the code base that may be new... a great way to get up to speed on the project.
22:22:53 <danwent> Ok, anything else that is a must have for d-4 quantum?  Then we'll talk about nova
22:22:58 <salv> danwent: and what would the "fun side" be?
22:23:10 <danwent> writing code :)
22:23:34 <SumitNaiksatam> what is the deadline for getting the merge prop in for D4 (for quantum)?
22:23:35 <danwent> salv:  you're attending the netstack meeting while on vacation.... you dont' seem like one to talk :P
22:23:45 <salv> danwent: I may argue you don't have to be a core member for that. Anyway, I don't see any blocker on my side.
22:24:02 <salv> SumitNaiksatam: We should release D-4 on wed 25
22:24:14 <danwent> salv:  definitely.  anyone can review.  core devs SHOULD review though, its part of the responsibility.
22:24:23 <troytoman> Deadline for D-4 is Monday (at least for Nova)
22:24:39 <danwent> yes.  generally, anything "big" should be in by friday.
22:25:08 <danwent> by "in", i mean proposed
22:25:26 <danwent> Somik can spend his sundays revewing code, right?
22:25:45 <danwent> But if you consider something a "must have" please speak up now.
22:26:01 <danwent> Ok, onto the topic of quantum related code in nova.
22:26:07 <somik> danwent: yup uptil we get them merge propped by friday
22:26:25 <salv> SumitNaiksatatam: how much stuff have you got lined up for merge prop?
22:26:26 <danwent> the nova team is clearly really crunched for review cycles
22:26:27 <somik> but that means I would need other dev to be responsive to my comments too :)
22:27:06 <SumitNaiksatam> salv: lots, some of it is ready, some of it we need to work on some more
22:27:08 <danwent> if there is a well-defined interface by which a "driver" can be loaded without being part of nova core, they are probably going to push for that.
22:27:42 <danwent> hence the comments during the nova meeting today. The same logic could be applied to the Quantum Manager.
22:27:42 <salv> SumitNaiksatam: In order to understand the review effort for D-4 we probably need something more quantitative than "lots" :-)
22:28:14 <danwent> The linuxnet vifplugging is already reviewed, just needs to be approved.
22:28:31 <salv> Trey approved it about one hour ago
22:28:33 <SumitNaiksatam> salv: I believe RamD exchanged some emails on that, but we can go back to that thread and discuss
22:28:43 <danwent> ryu's work to expose vif-id doesn't have a pluggable interface, so that needs to go into nova core
22:28:52 <danwent> salv: ah great.... i'm way behind on email :)
22:29:05 <RamD_> Salv: There are two main merge props. One queued today by Rohit A
22:29:20 <salv> SumitNaiksatam: good, I'll check the email later on. I'm behind on my email as I'm official on holyday :)
22:29:24 <danwent> Ryu: that will merge prop today/tomorrow?
22:29:34 <RamD_> One followed by Ying on API Extensions now that we have Extension framework merged
22:29:40 <SumitNaiksatam> salv: no worries :-)
22:30:13 <SumitNaiksatam> danwent: on the vif-driver, vishy's suggestion to package the vif-driver within quantum should be fine, right?
22:30:19 <salv> I think that plugins can be "free" from standar release cycle deadlines. But this is just my opinion.
22:30:27 <danwent> Hopefully the cisco team can repay the favor with some other reviews during the D-4 crunch :)
22:30:41 <SumitNaiksatam> salv: +1
22:30:45 <SumitNaiksatam> danwent: +1
22:30:45 <danwent> too many threads at once
22:30:47 <salv> Hence, I'd gice the API ext work an higher priority
22:30:48 <edgar_magana> Sure Dan count me in as reviewer
22:31:02 <somik> salv: plugins are really not tied to quantum as we have a framework where you can plug something developed out of band
22:31:13 <danwent> Ok, first: Sumit, yes, the vif-driver approach should be fine.
22:31:25 <SumitNaiksatam> danwent: ok thanks!
22:31:38 <salv> I'd also say that thanks to the interface, there's no chance a plugin can break Quantum :)
22:31:46 <danwent> salv: yes... generally speaking I think that plugins don't necessarily have the same requirements compared to core code.
22:32:08 <salv> Okay, so do we agree we will give priority to reviews pertaning core code?
22:32:23 <danwent> but at the same time, an administrator picking up quantum will expect to be able to get a stable release of both core and plugin with major release.
22:32:25 <somik> for that matter, I would say API extensibility framework has to be in core but extensions can be plugged-in out of band
22:32:34 <danwent> salv:  I think that's a good policy in general.
22:32:41 <somik> and promoted to API or "required" extensions at a later date post review
22:33:37 <danwent> That said, in the case of the Cisco extension I'd like to get that in for the diablo release
22:33:49 <RamD_> danwent: +1 stable...both core and all plugins for D4
22:34:28 <RamD_> Cisco Extensions definitely for Diable :-)
22:34:33 <salv> danwent: "diablo release" or D-4?
22:34:39 <danwent> In theory someone could release and rev a plugin independent of the quantum core, but if the plugin is shipped with the main quantum distro, I'd like it to adhere to basic release policies.
22:34:55 <salv> agrred
22:35:03 <danwent> salv:  D-4 is the last chance to get major changes in for diablo....
22:35:19 <danwent> the rest should just be integration....
22:35:24 <danwent> and testing...
22:35:27 <danwent> and documentation :)
22:36:07 <danwent> Ok, any other issues to discuss with quantum + nova?
22:36:37 <salv> Were we discussing Quantum + nova?
22:36:58 <danwent> was trying to.... though there were several conversations at once
22:37:47 <danwent> salv: did you have anything else you wanted to discuss on that topic?   There's a thread on the netstack list about the interface ownership communication between nova + quantum.
22:38:04 <salv> Let's move to the remaining topics
22:38:05 <danwent> dont' need to rehash that there though... please respond via email if you have thoughts.
22:38:25 <danwent> ah, one other topic I had about nova + quantum...
22:38:36 <danwent> is tyler here?
22:39:03 <asomya> danwent: Don't think so
22:39:13 <danwent> I was curious about the client packaging, and whether we could use that for the QuantumManager in nova, or whether we should keep with the current (ugly) approach of having a copy of the client lib in nova.
22:39:29 <danwent> asomya:  k, will try and sync via email.
22:39:40 <danwent> Update on the GUI work?
22:40:07 <asomya> A few changes.. I implemented all the changes suggested by Devin Carlen and rolled everything up into one django-openstack module
22:40:24 <danwent> asomya: wow... very cool.
22:40:43 <asomya> just waitin for the setup script to get merged into quantum so that I can update the pip requirements in the dashboard and push a dashboard merge request :)
22:41:04 <danwent> yup, saw that.  I reviewed... needs one more person to sign off.
22:41:07 <danwent> anyone?
22:41:09 <salv> asomya: API v1.0 merge prop will have an impact on the Quantum GUI as well.
22:41:47 <asomya> salv: yes but that  shouldn't require any major code changes.. just the way I read dicts returned
22:41:57 <asomya> should  be easy to refit
22:41:58 <RamD_> danwent: I'll review as well
22:42:09 <salv> asomya: very easy, I just wanted to give you the heads-up!
22:42:12 <danwent> yet another reason to prioritize the API review once it is proposed.  sounds good.
22:42:22 <asomya> salv: thanks for the heads up :)
22:42:24 <danwent> RamD: thx, that would be great.
22:42:40 <salv> One more thing from me: can someone fix the pip-requires adding webtest, so we can have jenkins back?
22:42:55 <danwent> Salv: heckjoe took care of that this morning
22:43:15 <salv> danwent: I did not see that! See, after all I'm on vacation :)
22:43:27 <danwent> salv: no worries :)
22:43:39 <danwent> I'll have to track down the duplicate bug and close it, as he filed another bug on it.
22:43:49 <danwent> Salv: on API auth.
22:44:01 <salv> The good news
22:44:28 <salv> I have a branch (the one attached to the auth blueprint) in which I have keystone integration for authentication and a very trivial
22:44:46 <salv> authorization module which ensures a tenant operates only on his own networks, and hence ports
22:44:50 <salv> The bad news
22:45:06 <salv> We need to verify ownership for interfaces, and that depends on the nova integration work
22:45:36 <danwent> yup.  does it make sense to merge the first branch, then track the second independently, as it is dependent on the quantum manager?
22:45:48 <danwent> or would you prefer to keep them coupled?
22:46:00 <salv> danwent: that would be my plan as well (separate things)
22:46:08 <danwent> Ok, great.
22:46:10 <salv> I will merge prop the auth work as it is on thursay
22:46:34 <danwent> sounds great.  email thread on the netstack list is covering the remaining issue of how to report interface ownership to quantum.
22:46:52 <danwent> Ok, sounds like tyler isn't here, so we'll try to sync up on packaging via the email list.
22:47:09 <danwent> #action #danwent, email list about packaging
22:47:16 <danwent> Any updates on the CI infrastructure?
22:47:39 <danwent> or other testing issues?
22:48:15 <danwent> #topic open discussion
22:48:52 <danwent> is everybody talked out? :)
22:49:06 <salv> I'm here, but I don't have anything else on my plate
22:49:09 <danwent> ok, sounds good.
22:49:14 <asomya> about the nova vif-exposure.. I can't find any threads on the netstack alias realted to this.. can someone forward me the discussion so I can make changes if required in the dashboard
22:49:47 <danwent> asomya:  ryu has a BP on this in nova, its liked from the BP in quantum
22:50:05 <asomya> danwent: thanks
22:50:18 <danwent> https://blueprints.launchpad.net/quantum/+spec/nova-quantum-vifid
22:50:53 <danwent> if you have feedback, please provide it ASAP, as given the nova review crunch, he's hoping to merge prop this today/tomorrow
22:51:02 <danwent> ok, sounds like we're all done.  thanks folks.
22:51:11 <danwent> #endmeeting