22:04:21 <danwent> #startmeeting
22:04:22 <openstack> Meeting started Tue Aug 23 22:04:21 2011 UTC.  The chair is danwent. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:04:23 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
22:04:35 <danwent> agenda: http://wiki.openstack.org/Network/Meetings
22:05:01 <danwent> #topics nestack general topics
22:05:21 <danwent> #info congrats to the whole team.... quantum was accepted as an official OpenStack incubated project today
22:05:29 <ttx> congrats !
22:05:36 <pvo> allright :)
22:05:40 <SumitNaiksatam> hearty congrats!
22:05:40 * markvoelker cheers and looks around for champagne
22:05:43 <asomya> nice
22:05:51 <rohitagarwalla> congrats
22:06:01 <danwent> with the significant participation from folks from multiple different companies... I think it was an easy call for them.  Great work folks... take a minute to relax, then get back to working on D-4 reviews :)
22:06:02 <edgarmagana> Great News!!
22:06:31 <danwent> mark: we'll have to bring some to the essex summit to toast :)
22:07:00 <markvoelker> danwent: I dunno...last time I tried to bring drinks on a plane the TSA got frisky. =p
22:07:11 <danwent> in other news, we'll be moving to the new github/gerrit setup post diablo
22:07:17 <danwent> if you're curious, read up on: http://wiki.openstack.org/GerritWorkflow
22:07:36 <danwent> best to identify any concerns you have early and we can work with the openstack team to figure out solutions
22:07:39 <SumitNaiksatam> post diablo - cheers to that as well! :-)
22:07:39 <salv> danwent: do we have a leader for the migration effort?
22:07:46 <salv> i.e.: somebody to bugger with question?
22:07:50 <danwent> salv: are you volunteering ;)
22:07:51 <danwent> ?
22:08:03 <danwent> jaypipes said he would help out
22:08:05 <salv> not really, I'd like to focus on blueprints for essex release :-)
22:08:12 <pvo> mtaylor would be another guy to ping.
22:08:19 <mtaylor> yes
22:08:20 <mtaylor> what?
22:08:25 <danwent> salv: no problem.... I was planning on driving this
22:08:29 <pvo> you helping with gerrit and migration to git
22:08:38 <danwent> sent an email to mtayler and heckj this morning.
22:08:46 <mtaylor> yes. also jeblair will be involved
22:08:50 <danwent> mtayler -> mtaylor
22:09:06 <mtaylor> danwent: and - I haven't forgotten about your email about tarballs - I just had some world explosion earlier this morning I'm still cleaning up
22:09:19 <bhall> danwent: I can help too if you want
22:09:20 <danwent> #action danwent: send out email to folks helping with move to github
22:09:26 <danwent> bhall: thx
22:09:42 <danwent> mtaylor: no worries... tuesdays are always very busy days, I understand :)
22:09:47 <_0x44> jaypipes: ping
22:09:50 <mtaylor> danwent: (sorry, I've got like, 5 todo list items for you guys)
22:10:01 <danwent> mtaylor: we appreciate the help
22:10:19 <danwent> one other general netstack point: essex summit signup is now open
22:10:31 <danwent> #info sign up for essex summit if you can: http://summit.openstack.org/
22:10:55 <danwent> we'll definitely be having discussions about blueprints for quantum, and it is generally a great chance to meet team members face to face.
22:11:07 <danwent> so you can put a face to the reviewers name :)
22:11:16 <salv> mine is particuarly ugly...
22:11:26 <danwent> spots are limited and I think they ran out last time, so don't delay
22:11:54 <danwent> salv: but your code is beautiful, so it makes up for it, right? :P
22:12:09 <danwent> Ok, it troy around?
22:12:17 <troytoman> yes
22:12:21 <somik> About Essex Summit: Developers get a free pass to attend the conference I believe.
22:12:23 <danwent> #topic melange
22:12:24 <salv> danwent: you're too kind. Anyway seats are going away fast. 1 per minut.
22:12:45 <salv> At this pace, the essex summit would be a sold out in 3 hours!
22:12:47 <troytoman> we did the initial merge prop for Melange and have gotten a great deal of feedback.
22:13:18 <troytoman> we're working on creating an OpenStack commons code area to address some of the concerns
22:13:30 <troytoman> we're also cleaning up the cli etc.
22:13:51 <danwent> cool.  over the weekend I did a first cut at melange support for the quantum manager.
22:13:51 <troytoman> it's too big of a change to get into Nova in Diablo but we should be setup for early Essex
22:14:24 <salv> danwent: we were just granted feature-freeze exception for quantum manager, is that correct?
22:14:25 <troytoman> plan is to focus on the merge prop and the quantum/nova integration
22:14:44 <danwent> Ok.  and if we get the quantum manager code in nova, it should still be possible to run nova with melange, i believe, you will just need to download melange separately... is that correct?
22:14:57 <danwent> salv:  correct
22:15:14 <troytoman> i believe so
22:15:23 <danwent> I just created a new version of the qmanager branch that is not stacked on top of melange... still needs testing:
22:15:38 <danwent> https://code.launchpad.net/~danwent/nova/qmanager-new
22:15:46 <danwent> but you can look through the diff to get a sense of what it does
22:15:55 <danwent> feedback appreciated.
22:16:16 <danwent> ok troy, thanks for the update.  I must say, the melange code has been rock solid in my testing against it.
22:16:25 <danwent> any time there was a bug, it was in my code calling it :)
22:16:44 <troytoman> i hope we can start getting some scale testing done on the integration soon
22:17:00 <troytoman> we should be in good shape for that
22:17:03 <danwent> agreed.
22:17:10 <danwent> ok, anything else on melange?
22:17:41 <danwent> #topic donabe
22:18:04 <danwent> is debo or someone else working on donabe here?
22:18:22 <jamesurquhart> I'm here, but don't have an update.
22:18:36 <jamesurquhart> I'll see if I can get Rick or Debo to send an update to the alias.
22:18:42 <danwent> #action #debo send update on donabe to email list
22:18:48 <danwent> james: thx
22:18:51 <danwent> #topic quantum
22:19:14 <danwent> first off, congrats to everyone on incubation...
22:19:30 <danwent> we've been making great progress on getting through the D-4 reviews
22:19:46 <danwent> great work from many different folks on the team
22:19:53 <danwent> https://code.launchpad.net/quantum/+activereviews
22:20:13 <danwent> my understanding is that the cisco reviews are all stacked on each other, so they aren't quite as massive as they look.
22:20:18 <danwent> is that correct?
22:20:30 <SumitNaiksatam> yes
22:20:45 <SumitNaiksatam> dont be too alarmed :-)
22:21:01 <danwent> Sumit: great.  As I mentioned in the email this morning, I'm confident that we can get these all into diablo, even if they aren't quite done by the D-4 deadline
22:21:06 <danwent> https://code.launchpad.net/~salvatore-orlando/quantum/quantum-api-alignment/+merge/70788
22:21:10 <salv> I think the consolidation branch is stacked on top of the other three, which are independent
22:21:16 <SumitNaiksatam> yes
22:21:34 <SumitNaiksatam> there is one on the VIF-driver and Scheduler which is independent of the others
22:21:35 <danwent> https://code.launchpad.net/~salvatore-orlando/quantum/quantum-api-alignment/+merge/70788
22:21:37 <salv> I had a good deal of feedback, especially from Simik
22:21:49 <salv> Somik, sorry.
22:22:13 <salv> Concerns have been addressed and updated code pushed to the branch. I.m pretty sure we can have it merged by thirsday.
22:22:18 <danwent> Ok, anything we need to discuss here?
22:22:30 <danwent> sounds like you're on top of it.
22:22:30 <somik> salv: I think  both of your branches are pretty close, i'll do the final review soon.
22:22:51 <salv> somik: thanks.
22:22:53 <somik> salv: Great work on both those branches!
22:23:04 <danwent> any significant concerns with any of the reviews that we need to discuss here, or can we just keep plugging away?
22:23:37 <danwent> sounds like we're in good shape.
22:23:42 <salv> Not from the reviews I've done. Rohit updated the code after my review, and I think it should not be too much of an issue to merge that branch,
22:23:54 <salv> I have not received a reply on the vif-scheduler review, though.
22:24:17 <SumitNaiksatam> thanks Salv, yes I am in the process of fixing that
22:24:25 <salv> good.
22:24:25 <edgarmagana> salv: Rohit and I made some changes based on your reviews.. Thanks a lot!
22:24:27 <SumitNaiksatam> vif-driver/scheduler that is
22:24:51 <SumitNaiksatam> salv: that particular branch is independent of other cisco branches
22:24:51 <danwent> ok, great work folks.
22:24:53 <edgarmagana> We even increased our pylint score  :-)
22:24:55 <rohitagarwalla> thanks salv again for the review...and good to hear that the branch is in good shape for merge
22:24:58 <SumitNaiksatam> so it can go in even later
22:25:17 <danwent> Ok, onto talking about Nova Integration with Quantum
22:25:18 <salv> SumitNaiksatam: very good
22:25:38 <danwent> so Ryu's branch to add an extension to nova to expose vif uuids went in.
22:25:51 <danwent> this should give us what we need for the GUI, is that correct arvind?
22:26:16 <asomya> yup.. I integerated that into the dashboard waiting a merge on openstackx  https://github.com/cloudbuilders/openstackx/pull/16
22:26:32 <danwent> cool!
22:26:45 <salv> Does this extension also allow us to track to which instance a particular VIF belongs?
22:26:58 <danwent> salv: I believe so
22:27:15 <salv> danwent: something worth looking at for our issue with authorization
22:27:55 <danwent> yeah... we discussed that.  Could definitely be used for that, at least in the short-term.
22:28:17 <salv> great
22:28:33 <danwent> QuantumManager got an extension to try and get into diablo... so more coding for me :)
22:28:48 <danwent> https://code.launchpad.net/~danwent/nova/qmanager-new
22:29:02 <danwent> works with two modes for IPAM, melange, and the traditional nova DB IPAM.
22:29:24 <salv> danwent: great choice
22:29:27 <danwent> it also supports a tushar's extension to allow specifying networks when creating a VM.
22:29:39 <danwent> that could be something that we leverage in the GUI as well in the future.
22:30:09 <danwent> the os-create-server-ext extension
22:30:31 <danwent> other than that, wanted to touch on packaging, is tyler here?
22:30:59 <danwent> once we get all of the existing reviews in for diablo, we'll need to figure out how to switch the directory structure around.
22:31:04 <markvoelker> danwent: nope...this meeting time doesnt' work with his schedule unfortunately
22:31:40 <danwent> ok, i encourage people to check out the branch: https://code.launchpad.net/~tylesmit/quantum/quantum-packages
22:31:59 <danwent> I have some questions that i'll be sending to the list soon.
22:32:29 <danwent> Only other agenda item is to start thinking about documentation.... we've done an awesome job writing code, now we need to make sure people other than us can use it :)
22:32:47 <danwent> Both docs for administrators (i.e., quantum users) as well as for developers.
22:32:56 <salv> On this regard there was an interesting thread in the Openstack ML on documentation for openstack API
22:33:08 <danwent> savl: indeed, thanks for bringing that up
22:33:19 <salv> vishy was proposing to embed the documentation in source code, and I agree with this approach.
22:33:32 <salv> Maintaning a separate wiki page for API spec has been quite cumbersome for me.
22:33:42 <danwent> salv:  +1 having an approval process to update an API spec seems very valuable
22:34:06 <danwent> that way people are much more likely to see changes that are relevant to them.
22:34:20 <salv> +1 on the approval process. Second troubling issue was getting formal feedback and approval on the contents of the wiki page :)
22:34:35 <markvoelker> I'd encourage folks to participate in that thread if they have opinions... =)
22:34:50 <salv> If I'm not wrong Keystone already has documentation in source tree, in rst format
22:35:10 <danwent> salv: I think this is a great idea.  Can you create a blueprint/bug for this?
22:35:16 <salv> plan to have the same thing for Quantum API. Will be a blueprint with integration freeze as target a good idea?
22:35:25 <salv> danwent: sorry did not see your last line
22:35:35 <salv> Okay, please put an action for that
22:35:35 <danwent> salv: if you can do it quickly, I think that would make sense.
22:35:54 <danwent> #action #salv will create a blueprint to put API spec into the source tree
22:36:00 <salv> Sure, I think it can be achieved by next tuesday
22:36:13 <danwent> salv: thanks for bringing that up
22:36:56 <danwent> ok, and just on general docs, I think we have some work helping the rest of the nova team understand how quantum fits in... some of this material has already been created, we just need to present it in an organized form.
22:37:34 <danwent> now that we have a mechanism for nova/quantum integration (actually... two mechanisms), we can create some tutorials which will help a lot.
22:37:43 <danwent> ok, anything else on quantum?
22:37:47 <asomya> quick update on the dashboard: it's complete with vif plugging  .. just waiting on a couple of merges 1) Merge to the main dashboard trunk https://github.com/4P/openstack-dashboard/pull/92 and 2) The openstackx class to grab VIFS https://github.com/cloudbuilders/openstackx/pull/16
22:38:20 <danwent> that was quick :)  nice work asomya
22:38:36 <danwent> #topic open discussion
22:38:48 <danwent> There's a openstack meetup in the bay area tonight
22:39:14 <salv> I'd love to attend, but my teleport is broken :)
22:39:17 <danwent> http://www.meetup.com/SVForum-CloudSIG/events/18687151/?a=md1.2p_grp&rv=md1.2p
22:39:37 <danwent> salv:  you'll be in boston though, right?
22:39:43 <markvoelker> You west coasters have all the fun...we east coasters just get earthquakes and hurricanes this week. =p
22:39:54 <salv> danwent: yes, my passport has been renewed!
22:39:58 <danwent> yeah, that earthquake was crazy
22:40:02 <danwent> salv: good to hear :)
22:40:05 <danwent> ok, anything else?
22:40:08 <salv> Tyler and Arvind, which are not part of the core team, are giving a great contribution in terms of reviews (and code)
22:40:26 <danwent> would they like to be part of the core team?
22:40:28 <salv> shall we consider an extension of the core team?
22:40:31 <danwent> (wink, wink?)
22:40:41 <danwent> I'm definitely in favor.
22:40:42 <somik> +1
22:40:45 <salv> if they agree, it's +1 from me
22:40:46 <asomya> danwent: do we have to bribe someone for that :)
22:40:46 <rohitagarwalla> +1
22:40:56 <SumitNaiksatam> +1
22:41:06 <bhall> +1
22:41:11 <edgarmagana> +1
22:41:14 <ying> +1
22:41:15 <danwent> Ok, seems like approval to me.
22:41:28 <salv> if nobody complains in 10 seconds, it's approved
22:41:43 <danwent> this is great point.  please chime up if you are not a core but want to nominate yourself... or if you're shy, just talk to someone who will then nominate you
22:41:43 <salv> approved!
22:42:20 <danwent> sometimes people act like they are already in core, and we forget that they are not :)
22:42:23 <danwent> ok, anything else?
22:42:23 <salv> Another little thing on documentation: it would be great if we can provide use cases and reference architectures for quantum.
22:42:42 <salv> For instance, how to build the network topology for a three-tier app
22:43:00 <somik> salv: once the quantum manager gets merged in, that would be the next step.
22:43:09 <somik> but you are correct.
22:43:20 <salv> somik: good, we had a blueprint for doing something similar
22:43:30 <salv> https://blueprints.launchpad.net/quantum/+spec/use-case-milestones
22:43:36 <danwent> salv: agreed.  That demo link I sent out showed what is probably one of the most common use cases.
22:43:59 <SumitNaiksatam> danwent: demo link?
22:44:15 <salv> yeah, I must have missed it as well...
22:44:16 <danwent> salv: I actually cleared that out once we started using launchpad milestones
22:44:26 <danwent> it was buried in my update email to the openstack list...
22:44:56 <SumitNaiksatam> oh ok will search
22:44:58 <salv> found it: http://wiki.openstack.org/QuantumOVSDemo
22:44:58 <danwent> have been meaning to do a screencast, but until then the text will have to do:  http://wiki.openstack.org/QuantumOVSDemo
22:45:13 <SumitNaiksatam> thanks guys!
22:45:45 <danwent> Showing how we can use quantum to do cool things that aren't possible with existing nova will be key to helping people understand and get excited about quantum.
22:46:02 <salv> danwent: that's very useful
22:46:17 <danwent> for example, it would be really cool to do a demo that shows the cisco plugin, with extensions, doing something not exposed in nova
22:47:00 <danwent> that code is a bit outdated now... i will update it to use real melange, but you should get the idea.
22:47:20 <danwent> highlighting different use cases in this way will definitely help.
22:47:24 <danwent> anything else?
22:47:57 <salv> Just one little thing: who's doing the milestone release on thursday EOD?
22:48:07 <danwent> I was planning on doing it
22:48:12 <danwent> but its not a big deal
22:48:44 <salv> danwent: great. I just wanted to make sure that it was EOD PST! That would be Friday Morning for me :)
22:48:48 <danwent> the diable-rbp release is coming up pretty soon after it, so I'm not too worried about what does / does not make it into D-4
22:48:54 <danwent> salv:  haha
22:49:21 <danwent> if there's anything that is looking really tight, email me.   we're small enough that we can fudge the times by a bit if there's a good reason
22:49:35 <danwent> ok, keep up the great work on D-4 reviews folks, and congrats again on incubation :)
22:49:47 <danwent> #endmeeting