22:01:50 <danwent> #startmeeting
22:01:51 <openstack> Meeting started Tue Aug 30 22:01:50 2011 UTC.  The chair is danwent. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:01:52 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
22:01:53 <rohitagarwalla> o/
22:01:58 <danwent> agenda: http://wiki.openstack.org/Network/Meetings
22:02:01 <somik> o/
22:02:07 <ddutta> :)
22:02:20 <danwent> #topic general status
22:02:36 <danwent> don't' forget to sign up for openstack essex summit : http://wiki.openstack.org/Summit/Essex
22:02:59 <danwent> is troy around?
22:03:30 <danwent> ddutta mentioned that there's not donate update today, but they're hoping for an API spec writeup very soon
22:03:43 <danwent> ok, will skip melange for now.  we can circle back.
22:03:49 <danwent> #topic quantum
22:04:05 <danwent> so we're now past "feature freeze"
22:04:15 <ddutta> next week for sure!
22:04:21 <danwent> which means the only things that should be dropping into trunk should be bug fixes and tests.
22:04:37 <danwent> now is the time to really be testing all of your use cases and make sure they are working….
22:05:01 <danwent> Sept 10th is "release branch point" release, after which only serious bugs will be committed on the branch.
22:05:04 <danwent> any questions/thoughts?
22:05:25 <danwent> currently, anyone can assign a bug to diablo-rbp...
22:05:27 <danwent> https://launchpad.net/quantum/+milestone/diablo-rbp
22:05:34 <troytoman> o/
22:05:51 <salv> We should try not to have unassigned bugs on rbp milestone at this stage
22:05:51 <danwent> hey troy, can we circle back to melange in a bit, or do you have to run?
22:06:06 <troytoman> i'll be here
22:06:11 <danwent> troy: thx
22:06:29 <danwent> particularly if they are high priority or above, which means they should be fixed before diablo-rbp
22:06:30 <salv> I think if we cannot find takers by end of the week, we should probably untarget those bugs
22:06:48 <danwent> salv: agreed.
22:07:03 <danwent> right now I want to focus on getting things stable as quickly as possible.
22:07:21 <danwent> We've done a good job of clearing out the merge pipeline… merges now should be simple and targeted.
22:08:00 <danwent> so if you have a "pet bug" you're looking to fix for diablo-rbp, make sure it is created, targeted at diablo-rbp, and have someone assigned to it.
22:08:23 <danwent> only two active reviews, since we got the cisco code merged: https://code.launchpad.net/quantum/+activereviews
22:08:39 <salv> What should we do with the auth branch. Technically it is a feature, so we should delay it to Essex now.
22:08:43 <danwent> salv's keystone branch is just waiting on final input from ziad
22:08:48 <SumitNaiksatam> thanks Dan for the review and merge
22:09:09 <danwent> salv: it has an exception, so technically it can go in, but we don't have client code that uses it
22:09:25 <salv> But I'd say that it is a feature which can be easily turned off, so we should not worry about integration.
22:09:26 <danwent> as far as I know, so I'm not sure there is much of a point of pushing it for diablo
22:09:32 <salv> And, as Dan said, it has an exception :)
22:09:45 <danwent> salv: yeah, I'm not worried… just wondering if it is useful until we modify the client lib
22:09:56 <danwent> and I'd rather not mess with the client lib right now.
22:10:09 <danwent> is anyone working on keystone support in the client lib?
22:10:36 <salv> I don't think so.
22:10:38 <danwent> #action #danwent create blueprint for keystone support in client lib… currently unassigned.
22:10:54 <danwent> salv:  I'm fine with it going if we can get it in the next few days
22:11:07 <salv> I'm waiting for a reply from Ziad.
22:11:08 <danwent> its pretty decoupled from everything else and is definitely a step toward where we want to be.
22:11:27 <danwent> salv: k, if we don't hear back from him fairly soon, we can just bump it to essex.  I'm fine either way.
22:11:30 <somik> I agree, auth is pretty isolated adn can be easily turned off
22:12:06 <danwent> code is already reviewed from a netstack-core perspective too, so its good to go once ziad looks at it.
22:12:10 <salv> for client library, do we want a bug or a blueprint? Not a lot of difference, just trying to understand whether we'd like to address this before rbp
22:12:33 <salv> I was talking about auth token in client library, of course
22:12:38 <danwent> salv: I think is probably a bit much to address before rbp, unless we have someone volunteering to get it done ASAP….
22:12:59 <danwent> I want to minimize changes in areas that affect everyone, and the client lib affects a lot of people.
22:13:36 <danwent> bug is fine, as I don't think there's a lot of design work to be done and written up in a blueprint
22:13:44 <salv> Let's get it out of rbp then. Negative side effect is that cli won't work on Quantum when keystone integration is enabled.
22:14:04 <danwent> salve: sounds good.
22:14:38 <danwent> ok, on quantum manager, it sounds like we're getting good reviews from nova core, so I think we're in good shape there.
22:15:05 <salv> Very good.
22:15:12 <danwent> I was also thinking that we will want to consider a CLI utility that can query Ryu's nova vif-id extensions to list the available interfaces for a tenant.
22:15:46 <salv> Weren't you already planning a change to nova-manage?
22:15:47 <danwent> #action #danwent, create bug for utility to view vif-ids in nova
22:16:38 <danwent> salv: right now we're being pretty conservative with changes to nova manage…. to try not to clutter things up to much.  That's definitely an option though.
22:17:00 <salv> danwent: agreed.
22:17:33 <danwent> Ok, sounds like heckj has a fix for the cheetah issue on the build system
22:17:50 <heckj> danwent: yep - in and solved, Verified earlier today
22:17:57 <danwent> and congrats to arvind and team…. the quantum dashboard work just got merged into dashboard!
22:18:03 <salv> thank a lot heckj
22:18:07 <danwent> heckj: much appreciated
22:18:10 <salv> cheers to the GUI team
22:18:18 <heckj> salv: sorry to leave it wait until today, I lost track from the weekend...
22:18:29 <danwent> on quantum packaging....
22:18:51 <salv> heckj: np. That will teach us to think twice before adding a dependency
22:19:01 <danwent> tyler is not available today, but we're trying to figure out whether it will be feasible to do the code rearranging needed for packaging during diablo
22:19:18 <danwent> he will be sending an email out hopefully tomorrow about this.
22:19:40 <danwent> if so, we will need to try and get all diablo-rbp work in early, so we can swap the branch over the the new directory structure.
22:19:57 <danwent> of course, we would make sure the new structure is available early for testing
22:20:04 <danwent> any questions/thoughts on packaging?
22:20:39 <danwent> Last point is documentation.  I contacted Anne Gentle (lead of OpenStack packaging) about getting the ball rolling there.
22:21:17 <danwent> will be filling out BP with some more specific thoughts based on her input.  Docs aren't fun, but they will be very important to helping people understand quantum.
22:21:25 <danwent> Ok, anything else on quantum?
22:21:42 <danwent> #topic open discussion
22:21:53 <salv> Troy is still waiting...
22:21:56 <danwent> ah, troy, can you talk about melange?
22:22:04 <troytoman> sure.
22:22:04 <danwent> salv: hehe, same thought
22:22:21 <troytoman> most work is focused on addressing comments we got from the nova team.
22:22:34 <troytoman> expect most of that work to be done this week.
22:23:02 <danwent> troy: if I want to be testing against the latest melange code, I assume the right thing to do is to pull from your teams nova branch that includes melange?
22:23:07 <troytoman> otherwise we are working on getting it integrated with quantum so we can do some scale testing
22:23:16 <troytoman> danwent: yes
22:23:22 <troytoman> we are pushing updates there
22:23:48 <danwent> great.  I still need to test the QuantumManager with melange again before we really push it into nova...
22:23:55 <troytoman> there are some areas where nova still gets IPs from it's DB
22:23:58 <danwent> I tested it a while back, but there have been some changes.
22:24:14 <troytoman> we will need to refactor those calls to go through the network manager.
22:24:26 <danwent> great.
22:24:29 <troytoman> haven't sorted out exactly how/who to do that yet but should figure that out this week as well
22:24:51 <troytoman> we have moved several things in the openstack-commons
22:25:08 <troytoman> we will probably propose to change quantum to leverage some of those common elements as well
22:25:26 <troytoman> but, we are getting that code finalized before sorting that out
22:26:04 <danwent> great.  anything else?
22:26:20 <troytoman> nope
22:26:26 <danwent> #topic open discussion (for real this time)
22:26:45 <danwent> not to jinx it, but this could be our shortest meeting ever :)
22:27:04 <salv> Do you want me to start talking about random things :)
22:27:24 <danwent> I was worried someone would do that!
22:27:27 <danwent> ok, thanks folks!
22:27:32 <danwent> #endmeeting