19:01:32 <mtaylor> #startmeeting
19:01:33 <openstack> Meeting started Tue Sep  6 19:01:32 2011 UTC.  The chair is mtaylor. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:01:34 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:01:42 <mtaylor> how's everybody doing today?
19:02:36 <mtaylor> I was not here last week - did we have a meeting? the wiki page doesn't seem to have been updated with any info
19:02:44 <bengrue2> There was no meeting.
19:02:48 <jaypipes> o/
19:03:00 <jeblair> hi
19:03:21 <bengrue2> Congrats on your position on the PPB, mtaylor.
19:03:35 <mtaylor> bengrue: thanks!
19:03:37 <jeblair> yes indeed!
19:03:59 <mtaylor> ah. so - there's one action item from two weeks ago
19:04:05 <mtaylor> #topic Actions from last meeting
19:04:16 <mtaylor> "mtaylor Add how to contribute section to ci.openstack.org"
19:04:28 <mtaylor> yup. didn't do that. I'm going to blame burningman
19:05:02 <mtaylor> #action mtaylor Add how to contribute section to ci.openstack.org
19:05:25 <mtaylor> I believe there was an additional piece of docs that we were looking at adding to ci.openstack.org too ...
19:05:35 <mtaylor> jaypipes: do you remember what it was - I'd love to add it here
19:05:55 <jaypipes> mtaylor: packaging?
19:06:02 <mtaylor> probably
19:06:13 <mtaylor> #action mtaylor add packaging docs to ci.openstack.org
19:06:17 <mtaylor> great
19:06:43 <jaypipes> mtaylor: I asked todd to put a CNAME in for infrastructure.openstack.org. Please follow up with him on that...
19:06:54 <mtaylor> yes. I saw the email about that
19:06:59 <mtaylor> #topic open discussion
19:07:09 <jaypipes> mtaylor: and we'll point ci.openstack.org -> infrastructure.openstack.org and have all CI/packaging/QA stuff in one place...
19:07:15 <mtaylor> we really weren't on last time's items anymore
19:07:29 <mtaylor> yes. I think we should be able to get that up and going rsn
19:07:50 * jaypipes would like to get a quick update from jeblair about the progress of openstack-deploy-rax for the benefit of bengrue and others...
19:07:51 <mtaylor> #action mtaylor infrastructure.openstack.org web config
19:08:03 <mtaylor> #topic update on openstack-deploy-rax
19:08:38 <jeblair> hi
19:08:43 <jaypipes> bengrue: jeblair has been working with Anso folks on getting a deployment cluster using real deployment modules to run functional tests.
19:09:01 <jeblair> the openstack-deploy-rax job is running, but it seems to fail or hang periodically
19:09:35 <jaypipes> bengrue: the openstack-deploy-rax is the job on Jenkins: https://jenkins.openstack.org/job/openstack-deploy-rax/
19:09:41 <jeblair> i suspect that there are still problems in the puppet config that need to be ironed out
19:09:54 <jeblair> sleepsonthefloor is working on that
19:10:08 <bengrue2> cool.
19:10:34 <jeblair> that jobs triggers the openstack-test-rax job which will run a test suite (right now, it just runs one simple test)
19:10:40 <jeblair> soren is working on that
19:11:04 <soren> Right.
19:11:32 <jeblair> i've set up the deployment job to run the puppet modules from openstack/openstack-puppet
19:11:49 <jeblair> a new github repo integrated with gerrit, and the idea is that it will be community maintained
19:13:06 <jeblair> currently there are some local-only changes to try to get to a working state, but in the future, anyone will be able to propose a change to that repo, the openstack-deploy-core group can approve changes, and they will automatically be used by the deploy job
19:14:06 <jeblair> and there is a parallel setup for openstack-chef.  dan prince has an immediate interest in that
19:14:36 <jeblair> we aren't using that repo or configuring openstack-deploy-rax with chef at the moment, but that's on the roadmap
19:14:40 <mtaylor> jeblair: are we triggering any deployments using openstack-chef?
19:14:42 <mtaylor> oh - heh. :)
19:15:02 <mtaylor> jeblair: is dprince using openstack-chef as part of openstack_vpc?
19:15:06 <jeblair> same group has code review privs for that repo
19:15:32 <jeblair> i don't know
19:15:39 <mtaylor> awesome.
19:15:49 <jeblair> dprince: are you around?
19:15:50 <jaypipes> mtaylor: yes, AFAIK, he is doing so from the openstack-chef cookbooks...
19:16:11 <mtaylor> yeah. I thought that was happening ... so even though it's not bare-metal - there may be some testing of things there
19:17:03 <jeblair> mtaylor: emprically, it looks like the answer to your question is no
19:17:18 <jeblair> in that https://github.com/dprince/openstack_cookbooks
19:17:18 * mtaylor thinks we're going to have a fun combinations game to play in the future- needing to test latest openstack-chef against known-good nova/swift/glance to test chef changes, and then using known good chef to test nova/swift/glance deploy :)
19:17:27 <jeblair> has been updated more recently than https://github.com/openstack/openstack-chef
19:17:38 <mtaylor> great
19:17:47 <mtaylor> well - perhaps we can get him to switch over to using openstack-chef :)
19:17:49 <jeblair> mtaylor: yes, we will need something like that
19:17:56 <carlp> It was my intention to try and put some effort into those issues as I move along with our deployment at DreamHost
19:18:10 <mtaylor> carlp: the combinations issues?
19:18:21 <carlp> mtaylor: yes
19:18:26 * mtaylor hugs carlp
19:18:36 <jeblair> mtaylor: considering he asked for the repo and i let him know it was ready, i would hope that wouldn't take _too_ much convincing on our part.
19:19:03 * mtaylor just got back from burningman and may be hugging people a lot for a while
19:19:33 <jaypipes> jeblair, mtaylor: Jim and I had a conversation with dprince about using openstack-chef instead of his own private repo last Wednesday...
19:20:24 <mtaylor> jaypipes: sweet
19:20:28 <bengrue2> how'd that go?
19:20:30 * mtaylor is going to action him
19:20:47 <bengrue2> was there resolution, or was it just exploration?
19:20:57 <mtaylor> #action dprince make openstack_vpc use openstack/openstack-chef instead of dprince/openstack_cookbooks
19:21:06 <jaypipes> bengrue: the resolution was that he would start using openstack-chef instead of his own personal repo, IIRC
19:21:19 <bengrue2> okay.
19:21:22 <jeblair> that was certainly the impression i had
19:21:35 <jaypipes> bengrue: if we have to tie in everyone's random personal GH forks, that will get tiring ;)
19:22:06 <bengrue2> Sure.  Was just looking for clarity.
19:22:06 <jaypipes> bengrue: and AFAIK, openstack-chef was actually constructed *from* Dan's openstack-cookbooks repo, right jeblair ?
19:22:13 <jeblair> yep.
19:22:18 <jaypipes> k, cool.
19:22:45 <bengrue2> So he's turning his repo from upstream to downstream?
19:23:06 <bengrue2> (Don't cross the streams, Ray.)
19:23:09 <jeblair> that's been happening a lot lately.
19:23:18 <bengrue2> A sign of success, I'd say
19:24:27 <mtaylor> ++
19:24:51 <mtaylor> ok. any other topics that folks would like to discuss?
19:24:59 <jaypipes> indeed
19:25:00 <bengrue2> None here at this time.
19:25:37 <carlp> One quick thing...
19:25:49 <carlp> Who can I work with to get the NetStack CI stuff setup?
19:26:06 <mtaylor> carlp: me. and I've actually got bandwidth for you this week
19:26:25 <carlp> mtaylor: sweet.  Let me know what times work best for you, I believe you have my email
19:26:40 <mtaylor> carlp: well... I say that - do you just mean jenkins stuff, or are we talking about git/gerrit as well
19:26:44 <mtaylor> ?
19:27:20 <jeblair> cc me as well, monty and i back each other up
19:28:10 <carlp> mtaylor: Little bit of both
19:28:20 <mtaylor> k. cool. then the three of us should totally chat
19:30:26 <carlp> it's a plan
19:30:48 <mtaylor> love it.
19:30:53 <mtaylor> anybody got anything else?
19:31:37 <bengrue2> (no.)
19:32:04 <mtaylor> ok. well - thanks everybody!
19:32:09 <mtaylor> #endmeeting