21:03:26 <ttx> #startmeeting
21:03:27 <openstack> Meeting started Tue Sep  6 21:03:26 2011 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:03:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:03:42 <ttx> Welcome to our weekly team meeting... Today's agenda is at:
21:03:45 <ttx> #link http://wiki.openstack.org/Meetings/TeamMeeting
21:03:52 <ttx> quite a lot to go through today
21:03:58 <ttx> #topic Actions from previous meeting
21:04:05 <ttx> * vishy to email the list about the other critical bug and request help on reviews and bug fixing
21:04:19 <vishy> did that
21:04:33 <ttx> #topic Swift status
21:04:41 <notmyname> swift moved to gerrit today
21:04:50 <ttx> notmyname: you confirm we'll delay 1.4.3 for a couple days ?
21:04:56 <notmyname> and the 1.4.3 release is pushed back until friday/monday
21:05:37 <ttx> Looking at: https://launchpad.net/swift/+milestone/1.4.3 -- looks pretty ready to me
21:05:49 <ttx> notmyname: anything else ?
21:05:53 <notmyname> nope
21:06:01 <ttx> Raise your hand if you have questions on Swift...
21:07:45 <ttx> #topic Glance status
21:07:49 <ttx> jaypipes: o/
21:07:49 <jaypipes> https://launchpad.net/glance/+milestone/diablo-rbp
21:07:59 <ttx> On the features side, looks like you still need to land 3 blueprints ?
21:08:03 <jaypipes> lots of bug fixing to do. most features OK.
21:08:11 <ttx> * support-ssl (test fails)
21:08:15 <ttx> * pluggable-auth (needs fixing)
21:08:21 <ttx> * protected-properties (blocked by pluggable-auth)
21:08:22 <ttx> ?
21:08:28 <jaypipes> the user- and system-controlled properties should now be unblocked. need to get with Vek to discuss who should handle that...
21:08:59 <jaypipes> ttx: or at least, unblocked when pluggable-auth is fixe.d
21:09:22 <jaypipes> ttx: there is some talk of API extensions needed, but I'm pretty sure that will not be done in Diablo.
21:09:43 <jaypipes> ttx: and will be done early in Essex, with the main split of the API endpoint into a registry and mover API...
21:09:43 <ttx> jaypipes: those features need to land now... any ETA ?
21:09:44 <Vek> jaypipes: I'm committed this sprint, so I don't think I'll be getting to it...
21:10:21 <jaypipes> ttx: give me a day to talk with pvo and westmaas about bandwidth for the user- and system-properties one. other ones should be OK.
21:10:25 <jaypipes> ttx: for the features.
21:10:37 <glenc> jaypipes, we have the system proprerties scheduled for our sprint that starts next week
21:10:50 <ttx> glenc: that's a bit late for me
21:10:54 <jaypipes> glenc: might be too late.
21:11:13 <jaypipes> glenc: we would need to get started on it earlier than that
21:11:15 <ttx> Last stop for features is RBP
21:11:28 <ttx> you're already on borrowed time
21:11:34 <jaypipes> glenc: which means done by 8th... :(
21:12:19 <jaypipes> ttx: I will get with glenc offline on that.
21:12:23 <ttx> ok
21:12:23 <glenc> please
21:12:32 <ttx> jaypipes: On the bugs side, you have 10 targeted bugs
21:12:42 <ttx> I guess I'll just push them to "2011.3" if they don't get fixed in time for RBP ?
21:13:10 <jaypipes> ttx: the critical and High I really want in. Medium to Low may get pushed.
21:13:18 <ttx> ok, noted
21:13:22 <ttx> Note that starting at RBP only bugs that are targeted to release will get backported to the release branch
21:13:33 <ttx> So don't hesitate to ping the PTL or me to make sure essential bugs are covered.
21:13:41 <ttx> jaypipes: Other announcements/comments ?
21:14:23 <jaypipes> ttx: yes, understood.
21:14:30 <ttx> Raise your hand if you have a question on Glance.
21:15:00 <jaypipes> ttx: yes, will do. thx. last week was a bit of a complete loss for jeblair and myself :(
21:15:16 <ttx> jaypipes: yes, I saw that :/
21:15:32 <ttx> bad timing
21:15:41 <ttx> #topic Nova status
21:15:53 <ttx> vishy: hey
21:15:58 <vishy> yo
21:15:59 <ttx> Looking at: https://launchpad.net/nova/+milestone/diablo-rbp
21:16:05 <ttx> 3 "features" still on the roadmap:
21:16:12 <ttx> * implement-network-api (needs review)
21:16:19 <danwent> two approves
21:16:27 <ttx> Apparently all comments have been addressed -- _cerberus_, _0x44: could you doublecheck ?
21:16:29 <vishy> dan should be good
21:16:36 <danwent> I believe the feedback for the other two reviews have been incorporated, but waiting on confirmation from the reviewers
21:16:41 <ttx> * aws-api-validation (needs fixing)
21:16:44 <ttx> * hyper-v-update (in progress)
21:16:53 <ttx> vishy: I propose to convert those last two to bugs, as they are not really "features" -- would that work for you ?
21:16:54 <vishy> hyperv we push (havent' heard anything from jordan)
21:17:03 <_0x44> ttx: I just responded again to aws-api-validation
21:17:08 <vishy> validation is a bug for sure
21:17:39 <ttx> hyperv's description is a bit scary in corners
21:18:19 <ttx> ...changes to nova-compute and service.py...
21:18:30 <ttx> but without code linked it's a bit hard to know
21:18:58 <ttx> if it really makes changes to service.py I'd like it to land before RBP (or never)
21:19:08 <vishy> yeah i don't think it is coming in
21:19:18 <vishy> so i think essex is probably fine
21:19:27 <_cerberus_> ttx: yeah, i can check again
21:19:54 <ttx> vishy: will refurbish as bug
21:19:59 <vishy> k thx
21:20:33 <ttx> #action ttx to refurbish aws-api-validation and hyper-v-update as bugs and untarget them
21:20:42 <vishy> stool don't have a person to do: https://bugs.launchpad.net/bugs/834189
21:20:42 <uvirtbot> Launchpad bug 834189 in nova "XenServer and KVM handle local storage differently" [Critical,Triaged]
21:20:54 <ttx> yes, you've 6 targeted bugs, and 4 of them are unassigned
21:21:00 <_0x44> ttx: I'll look at it also
21:21:03 <vishy> I think allowing an option for kvm to do the resize like xen is good enough
21:21:28 <ttx> vishy: lower Importance, maybe ?
21:21:51 <vishy> i guess we could go down to high.  I really think that should be in for release though
21:21:58 <ttx> We also need assignees for:
21:22:07 <ttx> https://bugs.launchpad.net/bugs/833331
21:22:08 <uvirtbot> Launchpad bug 833331 in nova "OSAPI v1.1 needs to document config-drive as an extension" [Medium,Confirmed]
21:22:19 <ttx> https://bugs.launchpad.net/bugs/827807
21:22:21 <uvirtbot> Launchpad bug 827807 in nova "in multi_host nova-network mode, nova-network doesn't reassociate reassociate the floating ips on reboot" [Medium,Triaged]
21:22:25 <ttx> https://bugs.launchpad.net/bugs/838386
21:22:27 <uvirtbot> Launchpad bug 838386 in nova "Test suite requires kombu and carrot to be installed" [Low,Triaged]
21:22:32 <ttx> Any takers ?
21:22:57 <_0x44> ttx: 833331 should be me, probably. When is RBP due by?
21:22:57 <soren> I could take that last one.
21:23:08 <vishy> i thought cbehrens had a fix in for that last one
21:23:19 <comstud> ttx: i think Daviey was working on that somewhat (838386)
21:23:23 <ttx> _0x44: Thursday. that can be fixed after RBP though
21:23:26 <vishy> he was definitely discussing it with Daviey in the channel
21:23:35 <comstud> i gave him a fix..
21:23:35 <vishy> ah there you are forgot u were comstud here
21:23:37 <ttx> _0x44: will just require a backport to the release branch.
21:23:41 <comstud> doesn't appear he's linked a branch or claimed the bug
21:23:52 <comstud> vishy :)
21:23:56 <ttx> _0x44, soren: please assign yourselves
21:24:08 <soren> ttx: Will do and will talk to Daviey tomorrow.
21:24:19 <ttx> vishy: anything else ?
21:24:25 <vishy> nope
21:24:29 <ttx> Questions for Nova PTL ?
21:24:37 * Vek has known comstud as comstud for a decade or two...
21:24:40 <nati> Hi PLZ review https://code.launchpad.net/~ntt-pf-lab/nova/single-default-gateway/+merge/74159
21:24:54 <nati> We fixed some bugs
21:25:00 <ttx> vishy: do we really want that in Diablo ^ ?
21:25:15 <nati> it is in RDP milestone
21:25:34 <nati> It was added last meeting
21:25:42 <ttx> oh
21:25:50 <ttx> I see :)
21:26:06 <nati> And also it is important bug fix when we use multi nic
21:26:07 <ttx> then yes: ^ review early please
21:26:21 <ttx> #topic Incubated projects news
21:26:22 <nati> so please review it :D
21:26:44 <ttx> devcamcar, danwent: o/
21:26:52 <danwent> quantum is focusing on rbp…. adding more unit tests
21:26:55 <ttx> anyone from keystone around ?
21:26:57 <devcamcar> ttx: dashboard isn't incubated anymore :)
21:27:04 <ttx> devcamcar: in fact, it is.
21:27:04 <danwent> no major features are outstanding
21:27:12 <ttx> devcamcar: we are still in Diablo :P
21:27:17 <devcamcar> ttx: touche!
21:27:43 <devcamcar> we are building a presentation for essex summit to outline what we'll be up to
21:27:44 <danwent> quantum:  keystone integration is also being added during rbp
21:28:01 <ttx> devcamcar: had a question for you btw -- does Dashboard support more than Nova and Quantum at this point ?
21:28:15 <danwent> if people are planning network related blueprints for essex summit, please keep us in the loop
21:28:22 <devcamcar> we'll be focusing on our approach to user interaction and the revamps both visually and in flows for dashboard
21:28:26 <annegentle> devcamcar: how is work going on the doc updates noted in https://bugs.launchpad.net/openstack-manuals/+bug/813072?
21:28:27 <uvirtbot> Launchpad bug 813072 in openstack-dashboard "Dashboard documentation needs to be updated for changes in configuration relating to Keystone integration." [Critical,In progress]
21:28:50 <devcamcar> ttx: we have support for swift as well (and glance implicitly)
21:29:02 <devcamcar> we'll be adding some features that are glance specific soon, for uploading images, etc.
21:29:08 <ttx> devcamcar: great!
21:29:13 <devcamcar> annegentle: starting next week we're going to throw some resources at that
21:29:30 <annegentle> devcamcar: great, throw them with good aim :)
21:29:40 <ttx> devcamcar, danwent: anything else ?
21:29:45 <devcamcar> ttx: nope
21:29:55 <danwent> we'll be working on docs too…. let me know if you want to help :)
21:29:56 <danwent> nothing else
21:29:58 <ttx> #topic Proposing sessions for the Design Summit
21:30:13 <ttx> First, if you haven't registered for the summit yet, the waiting list is still open but will close sometime this week
21:30:20 <ttx> or next week
21:30:26 <ttx> So please make sure you register at http://summit.openstack.org -- we try to prioritize known contributors
21:30:39 <ttx> For registered attendees, now it's time to propose sessions !
21:30:47 <ttx> For the main tracks, we'll have 3 different session types:
21:30:58 <ttx> * Brainstorm sessions (55 min.) - used to discuss and come up with a solution for complex issues
21:31:10 <ttx> * Rubberstamp sessions (25 min.) - used to present and review an already-designed plan
21:31:22 <ttx> * Discovery sessions (25 min.) - where experts go into deep detail into a section of code or feature
21:31:38 <ttx> that last type is new ^
21:31:39 <blamar> /me wonders which is the 'brawling' session
21:31:43 <blamar> :)
21:31:50 <ttx> Anyone can go to http://summit.openstack.org to propose session topics (click on "Proposed Sessions")
21:32:05 <ttx> Note that we no longer *require* the creation of a blueprint for every session
21:32:20 <ttx> This is only useful if the session talks about a specific feature / code drop and you already have a plan
21:32:36 <ttx> So blueprints should be filed in support of "Rubberstamp" sessions (you can link to them from the session proposal)
21:32:48 <vishy> ttx: sorry, lost internet for a minute
21:32:55 <ttx> Sessions will be reviewed by PTLs for each track and myself, check back the site to see status and comments.
21:33:13 <ttx> vishy: you didn't miss that much
21:33:23 <ttx> Details at: http://wiki.openstack.org/Summit
21:33:29 <ttx> Questions ?
21:33:59 <vishy> ttx: in regards to that branch, I would love comments from pvo / tr3buchet as they are using multinic quite a bit.  I haven't needed it yet
21:34:26 <blamar> ttx: deadline for submission and is there a deadline for approval?
21:34:27 <vishy> I don't see a problem pushing it to essex unless it is really causing issues for people that will be stuck on diablo for a long time
21:34:40 <ttx> blamar: let me check the timeline
21:34:49 <vishy> ttx: although it could be considered a bug fix, although it is perhaps a bit risky
21:35:38 <ttx> Propose sessions (Sep 6 - Sep 27), Review sessions (Sep 12 - Sep 29), Schedule sessions (Sep 27 - Oct 2)
21:35:51 <blamar> ttx: ty
21:35:52 <ttx> blamar: so at least until Sep 27...
21:36:04 <ttx> blamar: but to increase your chances you should submit early
21:36:10 <pvo> vishy: sorry,which branch?
21:36:37 <ttx> no other questions ?
21:37:05 <ttx> #topic Discuss creating an OpenStack Common package
21:37:10 <ttx> blamar: floor is yours.
21:37:47 <blamar> Basically just wanted to talk about OpenStack common, and what needed to be done to get a package made for it in PyPi and Ubuntu
21:38:05 <blamar> Not something I just wanted to "do" without at least bringing it up, and seeing if it was something that needed to go through the PPB
21:38:24 <vishy> pvo: the single_default gateway above
21:38:26 <blamar> The level of code duplicate across Glance, Nova, and Keystone is pretty bad.
21:38:26 * Vek thinks we need something like this
21:38:50 <jk0> the melange merge is already starting to use it
21:38:57 <Vek> yeah, lot of DRY violations...
21:39:07 <jk0> or at least, what's available at the moment in openstack-skel
21:39:22 <blamar> jk0: That's true, but the other part of it is that I *don't* want openstack common to just be copy/paste from Nova
21:39:31 <blamar> jk0: it should be tested, and re-thought-out
21:39:32 <jk0> right, I'm just saying
21:39:48 <jk0> melnage would be a good place to test it
21:39:56 <jk0> they are willing/already trying to do this
21:40:02 <blamar> jk0: I'd really like it to be difficult to get code into OpenStack Common..because it would need to be tested and be the pristine copy
21:40:45 <Vek> makes sense...
21:41:23 <soren> I'm very much in favour of an openstack-common sort of thing as well.
21:41:46 <blamar> Anyway, I'm not sure really where to go from here. I have a branch which is bare-bones based off Jay Pipes common
21:41:48 <blamar> https://code.launchpad.net/~blamar/openstack-common/my-common
21:42:24 <blamar> It's basically nothing but some SQLAlchemy common code, but I'd like to start working with openstack-common as soon as Essex opens
21:43:06 <blamar> So maybe I can throw some emails/review requests out to the list and gather feedback on guidelines for including stuff in Common?
21:43:38 <ttx> blamar: sure -- it's not the first time that was pushed though -- the issue has always been resources to commit to it
21:43:41 <soren> It would be good to gauge PTL buy-in to this.
21:44:05 <soren> No point in building it if noone wants to change their respective projects to use it.
21:44:16 <ttx> #action blamar to discuss openstack-common on the ML
21:44:19 <blamar> ttx: Absolutely, at this point I truly believe we're wasting more resources on code duplication than we would on diverting effort to openstack-common
21:44:21 <soren> (which IIRC is why it didn't go anywhere last time somone tried to push it)
21:44:32 * glenc thinks someone should take the PTLs out back and "explain" it to them
21:44:55 * Vek knows a couple of black belts...
21:44:59 <ttx> blamar: anything else ?
21:45:01 <jk0> I don't think we had PTLs the last time this was seriously considered
21:45:09 <blamar> ttx: done, thanks!
21:45:15 * vishy is bought-in
21:45:28 <ttx> #topic Discuss creating API doc repos
21:45:33 <ttx> annegentle: shoot!
21:45:33 <soren> jk0: Not formally, perhaps.
21:45:38 <annegentle> bang!
21:45:42 <ttx> aw
21:45:47 <annegentle> just wanted to circle back here on my proposal to the mailing list today
21:45:48 <soren> Texans.
21:45:53 <soren> :)
21:46:05 <annegentle> I think I'm understanding the review process better, thanks to notmyname et al
21:46:06 <annegentle> hee
21:46:32 <annegentle> it appears that we could have a openstack-doc-core team for reviews, which I think is nice
21:47:01 <annegentle> and, separating out the API docs makes the main manuals project much less "build heavy"
21:47:19 <annegentle> so I hope y'all (that's Texan, right?) are okay with the move to Github and separation.
21:47:26 <blamar> annegentle: I'm not sure on the delineation between using the project code name and the ...other...name? Why name it openstack/nova-api and not openstack/compute-api?
21:47:45 <annegentle> blamar: ah, good point! Especially for the api, compute-api makes perfect sense
21:48:00 <annegentle> identity-api? storage-api?
21:48:02 <blamar> annegentle: I feel like we use the codename too much, but I might be alone on that.
21:48:12 <blamar> auth-api, image-api, storage-api?
21:48:15 <annegentle> blamar: no, you're onto something
21:48:30 <annegentle> and image-api
21:48:54 <annegentle> #action annegentle to email the mailing list with new naming possibilities
21:49:29 <ttx> annegentle: anything else ?
21:49:31 <annegentle> anything else?
21:49:34 <annegentle> ha beat me to it :)
21:49:49 <annegentle> just wanted to make sure I've covered the bases. Or some other Texas metaphor.
21:50:12 <glenc> that dog'll hunt
21:50:26 <Vek> haha :)
21:50:29 <annegentle> LOL
21:50:45 <ttx> #topic Open discussion
21:51:12 <ttx> So I heard temperature finally dropped in Texas ?
21:51:25 <Vek> sure, it's 91 today.
21:51:29 <cynb> I had a goosebump this morning
21:51:37 <annegentle> yes!
21:52:11 <ttx> anything, anyone ?
21:52:42 <Vek> hope everyone had a good labor day/equivalent holiday, if they had one...
21:54:04 <ttx> ok then. That's all for today
21:54:13 <ttx> #endmeeting