22:01:12 <danwent> #startmeeting
22:01:13 <openstack> Meeting started Tue Sep 6 22:01:12 2011 UTC. The chair is danwent. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:01:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
22:01:22 <salv-orlando> Hello!
22:01:23 <danwent> where's salv?
22:01:28 <danwent> ah… just in time :)
22:01:33 <danwent> agenda: http://wiki.openstack.org/Network/Meetings
22:01:46 <danwent> #topic general topics
22:02:07 <danwent> salv had a good question about pep8 versions: https://answers.launchpad.net/quantum/+question/169676
22:02:19 <danwent> different pep8 versions give different errors.
22:02:32 <danwent> nova uses 0.6.1, but many distros ship with 0.5.0
22:02:54 <danwent> our thinking was to use 0.6.1, and enforce this by having run_tests.sh check what version you're running with. any concerns?
22:03:07 <bhall_> danwent: sounds fine to me
22:03:13 <salv-orlando> I'm ok with 0.6.1
22:03:31 <dendrobates> danwent: what ships with 0.6.1?
22:03:32 <danwent> should be a simple pip install if your system doesn't have it already… we'll put that command in the output of run_tests.sh
22:04:07 <danwent> dendrobates: not much is my understanding…. but i view nova as the project we should be following
22:04:24 <danwent> do people want to explore if pep8 0.6.1 is problematic on their platforms
22:04:32 <danwent> and then email the list, otherwise we'll make the shift?
22:04:50 <danwent> should be pip install pep8==0.6.1, i believe
22:04:57 <dendrobates> I say we follow nova
22:05:10 <danwent> great.
22:05:14 <dendrobates> by nova you mean the jenkins server, tight?
22:05:22 <dendrobates> er right?
22:05:25 <danwent> i'm basing this on what salv looked at.
22:05:28 <danwent> salv?
22:05:46 <danwent> I assume it is what is enforced by jenkins
22:05:53 <dendrobates> mtaylor: ???
22:05:54 <salv-orlando> nova has pep8 = 0.6.1 in pip-requires
22:06:08 <dendrobates> ok
22:06:11 <salv-orlando> I guess the Jenkins slave runs the same version of pep8
22:06:16 <salv-orlando> but cannot confirm that
22:06:36 <danwent> ok, well anyone with concerns should try this out and see if its a problem for them… otherwise we'll plan in shifting sometime this week.
22:06:48 <danwent> ok, another other general topics?
22:07:08 <danwent> #topic melange
22:07:28 <danwent> Troy is out today, but he let me know that he had no major updates other than that the team continues to work on feedback from the nova reviews
22:07:53 <danwent> for those that are curious, the latest melange code should be pulled from their branch of nova: https://code.launchpad.net/~raxnetworking/nova/melange
22:08:07 <danwent> any comments/questions on melange?
22:08:33 <danwent> #topic donabe
22:08:39 <debo_os> Donabe updates - thoughts on donabe model at http://bazaar.launchpad.net/~netstack-core/donabe/diablo/view/head:/doc/donabe-update-090611.pdf
22:08:39 <danwent> debo/dendrobates?
22:08:43 <dendrobates> hi
22:08:53 <dendrobates> we have started putting docs in lp:donabe
22:09:31 <dendrobates> I would like to have a public donabe planning meeting next week to discuss ideas
22:09:40 <danwent> great
22:09:52 <dendrobates> would this same time be good on a different day?
22:10:07 <dendrobates> any objections?
22:10:09 <salv-orlando> would work for me as long as it is not a friday
22:10:09 <debo_os> I am ok on Wed
22:10:20 <markvoelker> East coast would like an earlier time, but I can make this time. =)
22:10:21 <danwent> fine for me
22:10:32 <dendrobates> markvoelker: :)
22:10:44 <dendrobates> ok, next wed at this time
22:10:53 <dendrobates> I'll send out an invite and agenda
22:11:00 <danwent> thx
22:11:08 <danwent> anything else on donate?
22:11:12 <danwent> donabe
22:11:21 <dendrobates> that's aa
22:11:24 <dendrobates> all
22:11:27 <danwent> stupid auto-correct in my new IRC client
22:11:35 <danwent> #topic quantum
22:11:38 <salv-orlando> danwent: if you want to donate I can give you mi account number
22:11:57 <danwent> :)
22:12:01 <debo_os> :)
22:12:09 <bhall_> salv-orlando: acct number and address please.. I'll send a check for a larger amount and you just need to send the rest back
22:12:23 <danwent> please send me an email about how you got a large sum of money.....
22:12:36 <danwent> damn…. I was the second one to make the scammer joke
22:13:07 <danwent> Ok, we have a good number of reviews outstanding
22:13:13 <danwent> thankfully many of them are pretty small.
22:13:39 <danwent> I want to go over the outstanding bp/bugs targeted to diablo-rbp and determine if we need them in or not.
22:13:49 <danwent> will go in order: https://launchpad.net/quantum/+milestone/diablo-rbp
22:13:54 <danwent> let's try to keep this quick :)
22:14:06 <danwent> Quantum Manager is reviewed in Nova… should be getting in soon.
22:14:16 <danwent> salv: https://blueprints.launchpad.net/quantum/+spec/api-doc-in-trunk
22:14:22 <salv-orlando> it#s approved now!
22:14:27 <salv-orlando> well done Dan
22:14:47 <danwent> haha…. I always need to check my inbox right before providing a status :)
22:14:49 <danwent> thx
22:15:17 <danwent> salv: still expecting to propose a branch for the API spec, correct?
22:15:41 <salv-orlando> I'm working on it and struggling a bit with docbbok
22:15:49 <danwent> yeah… db is definitely a pain.
22:15:51 <salv-orlando> no major hassles, just boring
22:16:04 <danwent> thankfully, this is something that could probably go in after "freeze"
22:16:07 <danwent> as it is not a code change.
22:16:14 <salv-orlando> I was goign to ask you that
22:16:20 <danwent> definitely
22:16:30 <danwent> next up: https://blueprints.launchpad.net/quantum/+spec/quantum-api-auth
22:16:30 <salv-orlando> ok, so we agree to have it done by release date
22:16:38 <salv-orlando> I think we can merge it.
22:17:00 <danwent> #agreed api doc in source repo can wait until after freeze
22:17:08 <salv-orlando> It has 3 approve votes. I just wanted to make sure everybody is all right with it.
22:17:22 <danwent> salv: I think its good to go. great work.
22:17:50 <danwent> salv: client changes still need review, but seem pretty straightforward. should be a quick review.
22:18:12 <danwent> Mark: anything we're tracking for the dashboard work, or is that all in?
22:18:49 <asomya> One final commit to fix some PEP 8 compliance and a few tests
22:18:55 <salv-orlando> I think the Dashboard uses quantum client library, is that correct?
22:18:55 <danwent> very cool.
22:19:05 * markvoelker thinks asomya types faster than me today
22:19:22 <asomya> salv: that is correct
22:19:34 <asomya> and I refitted it for the API changes
22:19:45 <salv-orlando> we will probably need to do a slight update to pass the Keystone token to the Client object constructor
22:20:04 <salv-orlando> I guess from the dashboard you can retrieve the Auth token of the currently connected user...
22:20:23 <asomya> salv: yeah the keystone auth token is already available in the dashboard
22:20:42 <salv-orlando> good, we'll just need to pass it to the client library. We can discuss the details offline.
22:20:51 <danwent> Ok, with respect to quantum packaging we decided to bump that to essex…. we still needed to finalize a few things and the change was just too big to try and slide in at the last minute.
22:21:15 <danwent> Two pylint bugs: salvatore, is your bug the one we're currently using?
22:21:22 <danwent> https://bugs.launchpad.net/bugs/822813
22:21:23 <uvirtbot> Launchpad bug 822813 in quantum "Improve pylint score" [Low,In progress]
22:21:30 <danwent> https://bugs.launchpad.net/bugs/829011
22:21:31 <uvirtbot> Launchpad bug 829011 in quantum "Pylint errors caused by the ext framework" [Medium,New]
22:21:45 <salv-orlando> wow... uvirtbot!
22:21:56 <danwent> Salv: do you want to get these in for diablo?
22:21:57 <salv-orlando> I've untargeted this
22:22:08 <salv-orlando> the last one.
22:22:18 <danwent> ok, great. just wanted to confirm.
22:22:21 <salv-orlando> The previous one are minor fixes, altough it resulted in a large diff
22:22:38 <salv-orlando> but if we don't have enough spare cycle for review, we can defer it to essex
22:22:54 <salv-orlando> maybe we can start the essex development cycle with a good pylint cleanup:)
22:22:54 <danwent> yeah, at this point review bandwidth is my primary concern
22:23:03 <danwent> sounds like a plan
22:23:12 <danwent> https://bugs.launchpad.net/bugs/834017
22:23:13 <uvirtbot> Launchpad bug 834017 in quantum "Client library should leverage "detail" actions" [Medium,New]
22:23:13 <salv-orlando> okay let's untarget the both of them
22:23:43 <salv-orlando> I don't see this as a priority. Opinions?
22:23:47 <danwent> seems like this one is not critical....
22:24:06 <danwent> my bias is always to untarget to minimize risk if it doesn't fix anything that is broken or improve test coverage
22:24:24 <salv-orlando> Agreed
22:24:31 <danwent> ok, sounds good.
22:24:31 <danwent> https://bugs.launchpad.net/bugs/837752
22:24:33 <uvirtbot> Launchpad bug 837752 in quantum "Multi-nic support not functioning (for Cisco Plugin)" [Critical,In progress]
22:24:40 <danwent> sumit?
22:24:44 <danwent> this one sounds important :)
22:24:59 <ying> Sumit is not here today
22:25:07 <salv-orlando> looks quite Critical for the cisco plugin
22:25:08 <ying> we will take care of this bug.
22:25:18 <salv-orlando> I'm booked for reviewing it, will do that tomorrow
22:25:20 <danwent> ok, but I assume this one should go in…. will keep it targeted.
22:25:29 <danwent> https://bugs.launchpad.net/bugs/838006
22:25:31 <uvirtbot> Launchpad bug 838006 in quantum "Keystone support in Client library" [High,In progress]
22:25:35 <danwent> think we're keeping this one.
22:25:45 <danwent> https://bugs.launchpad.net/bugs/834013
22:25:47 <uvirtbot> Launchpad bug 834013 in quantum "API: create operations should return 202" [Low,In progress]
22:25:47 <salv-orlando> yeah we already have good reviews, should be a straight one
22:26:10 <danwent> seems pretty simple and since it is an API alignment thing, I'm in favor of keeping it.
22:26:17 <salv-orlando> diff is small
22:26:19 <danwent> doesn't seem to pose a risk of breaking plugins.
22:26:24 <danwent> ok, let's keep it
22:26:26 <salv-orlando> definitely not
22:26:32 <salv-orlando> change is confined into API layer
22:26:35 <danwent> https://bugs.launchpad.net/bugs/841982
22:26:36 <uvirtbot> Launchpad bug 841982 in quantum "API: list ports op apparently succeeds even if network does not exist" [Low,In progress]
22:26:38 <salv-orlando> completely covered by unit tests
22:26:54 <salv-orlando> I'll follow your advice and fix it in dblayer
22:26:55 <danwent> this is is already reviewed… i had a small suggestion, but I think we can keep it targeted.
22:26:58 <danwent> great.
22:27:10 <salv-orlando> it's a one-liner after all
22:27:13 <danwent> https://bugs.launchpad.net/bugs/834008
22:27:14 <uvirtbot> Launchpad bug 834008 in quantum "Remove weak pattern in API" [Undecided,In progress]
22:27:15 <danwent> :)
22:27:20 <danwent> i think this is already committed
22:27:25 <danwent> just need to update bug
22:27:31 <salv-orlando> right
22:27:37 <danwent> https://bugs.launchpad.net/bugs/842190
22:27:38 <uvirtbot> Launchpad bug 842190 in quantum "CLI: get rid of cheetah for output generation" [Undecided,In progress]
22:27:48 <salv-orlando> This is the unexpected one
22:28:03 <danwent> my thinking is that is should stay targeted for diablo-rbp
22:28:11 <salv-orlando> I have a bad feeling about adding this dependency for somethign where cheetah is not really needed
22:28:16 <danwent> though it will take some cycles to review and test
22:28:17 <salv-orlando> we already had issues with jenkins
22:28:45 <salv-orlando> Change is confined into CLI, and covered by unit tests
22:28:46 <danwent> ok, my vote is to keep it targeted so our diablo deliverable doesn't have to depend on cheetah
22:28:56 <danwent> any other thoughts?
22:29:21 <danwent> ok, sounds like we'll keep it targeted.
22:29:46 <salv-orlando> is that all?
22:29:49 <danwent> we also have some unit tests commits from rohit that do not have a bug. I'd like to see them go in to improve our coverage.
22:29:57 <danwent> but those reviews should be best effort.
22:30:01 <salv-orlando> agreed.
22:30:14 <danwent> I think there may be another cisco branch with cisco plugin tests as well.
22:30:34 <danwent> ah, looks like that isn't targeting lp:quantum yet though
22:30:45 <danwent> rather another cisco branch. my mistake.
22:30:52 <danwent> ok, anyone aware of anything else?
22:30:58 <dendrobates> danwent: which branch?
22:31:11 <danwent> https://code.launchpad.net/~tylesmit/quantum/unit_tests/+merge/74274
22:31:12 <salv-orlando> https://code.launchpad.net/~tylesmit/quantum/unit_tests/+merge/74274
22:31:15 <danwent> :)
22:31:16 <salv-orlando> sorry
22:31:43 <danwent> pretty much any other changes being pushed to lp:quantum should be serious bug fixes if they weren't mentioned today.
22:31:56 <danwent> we'll open up essex once we release diablo-rbp
22:32:18 <danwent> any questions/concerns with the diablo release process?
22:32:20 <RamD> danwent: I think this for a bug fix coverage..
22:33:12 <danwent> RamD: Ok, so you take is that this is needed for diablo?
22:33:30 <RamD> danwent: yes
22:33:38 <danwent> is this handling the multi-nic issue, or is it another bug?
22:33:51 <RamD> yes, multi-nic issue
22:33:52 <danwent> if its another bug, let's get it filed and targeted for diablo-rbp
22:33:57 <danwent> ah, ok.
22:34:01 <dendrobates> this needs to be finished and proposed asap
22:34:07 <RamD> yep I'll verify with tyler and will do
22:34:11 <dendrobates> or maybe it was mistakenly targeted
22:34:49 <danwent> ok, let's get this cleared up and correct on launchpad if anything is mistaken.
22:35:04 <danwent> https://code.launchpad.net/~cisco-openstack/quantum/lp837752
22:35:11 <danwent> is the branch associated with the multi-nic bug
22:35:34 <dendrobates> naming your branches the bug number they are addressing is very helpful
22:35:40 <RamD> ok will discuss here and take care of that
22:35:57 <danwent> Ok, just wanted to give a quick update on documentation.
22:36:12 <danwent> I'm hoping to have a blueprint proposing an outline for docs by next week.
22:36:32 <danwent> hopefully we can finish reviews this week, and have some doc writing cycles in the weeks after that :)
22:36:43 <danwent> Also, on the design summit: http://summit.openstack.org/
22:36:57 <danwent> the gates our open now for propels.
22:37:00 <danwent> auto-correct
22:37:03 <danwent> proposals
22:37:12 <salv-orlando> I love your auto-correct
22:37:24 <danwent> hopefully it doesn't know my bank account number :)
22:37:56 <danwent> please use the netstack list to socialize proposals for summit sessions and blueprints, so we don't have multiple people working on the same thing in isolation
22:37:57 <salv-orlando> We are discussing internally what should be our priorities for Essex, and then will submit some blueprints for Quantum
22:38:10 <danwent> salv: great.
22:38:19 <salv-orlando> on netstack in general, are we thing about adding some more services to the suite?
22:38:39 <salv-orlando> IE: anybody coming with proposal for firewall, NAT, DC bridging, etc.
22:38:43 <salv-orlando> ?
22:38:44 <danwent> salv: I suspect that will be a topic of much discussion :)
22:39:13 <danwent> everyone is likely to approach this from a slightly different angle, so i'd like to get cross pollination prior to the summit if possible.
22:39:13 <debo_os> +1
22:39:16 <RamD> salv: absolutely. few more ideas here as well
22:39:19 <salv-orlando> Well... let's get it started!
22:39:38 <salv-orlando> (on the ML of course)
22:40:01 <danwent> one note. talked to TTX. for quantum summit proposals, we should select the tracker "incubated"
22:40:12 <danwent> but make sure that "quantum" is in the title of the session.
22:40:23 <danwent> if we have enough, they will create a track for it
22:40:31 <salv-orlando> what does that mean? what is a tracker? (Apologies for ignorance)
22:40:49 <danwent> its one of the things you have to select when submitting your proposal
22:40:57 <danwent> tracker would be "glance"
22:41:06 <danwent> "nova", "swift", "dashboard", etc.
22:41:37 <RamD> danwent: How about netstack...not all the BP will fall under quantum, right
22:42:03 <salv-orlando> I think the same applies to the whole of netstack
22:42:04 <danwent> RamD: that's fine as well…. I had asked ttx about quantum specifically.
22:42:22 <danwent> in the end, there will be an intelligent eye grouping things, so netstack should work as well.
22:42:39 <RamD> Oh cool..Its better to have all the network and network services related in a seperate track Netstack..just a thought
22:43:10 <danwent> yeah, ttx said that the current trackers are just "suggestions" and that they will group intelligently based on what emerges.
22:43:34 <danwent> container stuff may be tricky though, as it may have broader applicability
22:43:58 <danwent> Ok, anything else on summit?
22:44:09 <salv-orlando> who's coming :) ?
22:44:22 <danwent> anybody who is anybody :P
22:44:29 <danwent> I will be there
22:44:44 <RamD> salv: will be there as well
22:44:52 <salv-orlando> I'll meet you there, then
22:44:59 <mtaylor> danwent, dendrobates: sorry - stepped out for a sec
22:45:16 <somik> salv-orlando: hope you double checked that passport of yours ;)
22:45:25 <mtaylor> danwent, dendrobates: jenkins does not install anything via pip
22:45:52 <danwent> ah, so someone manually installed pep8 version 0.6.1?
22:46:10 <mtaylor> danwent: we have a deb package of pep8
22:46:19 <mtaylor> danwent: and the puppet modules for the jenkins slaves install pep8 via apt
22:46:48 <danwent> and its not specifically pep8 v0.6.1? what OS are they running?
22:46:55 <danwent> I think natty at least defaults to 0.5.0
22:46:56 <mtaylor> danwent: do we need a different version of pep8?
22:47:05 <mtaylor> danwent: they're all running natty
22:47:09 <mtaylor> one sec... looking
22:47:17 <danwent> we're trying to conform with nova, which seems to use 0.6.1 based on the pip-requires.
22:48:01 <danwent> also, mtaylor, while you are here, I wanted to pick your brain about moving quantum to github/gerrit. Any blockers?
22:48:04 <mtaylor> we're running pep8 v0.5.0 on the nova builders
22:48:26 <mtaylor> BUT - I can totally backport 0.6.1 and have it installed on all of the build slaves if that's important
22:48:36 <danwent> interesting… maybe all of the 0.6.1 errors are caught by reviewers :)
22:48:45 <salv-orlando> I don't think we're dying to have it running :)
22:48:57 <salv-orlando> running pep8 0.6.1 I meant
22:48:59 <danwent> mtaylor: don't worry about it for now.
22:49:12 <mtaylor> danwent: ok.
22:49:23 <mtaylor> danwent: re: git/gerrit - there are no blockers -it's just a matter of coordinating with jeblair
22:49:39 <mtaylor> danwent: we may also want to make sure that the launchpad teams are all set up the way we want...
22:49:48 <danwent> #action: #danwent contact #jeblair about move to github
22:50:07 <danwent> mtaylor: ok great. Just let me know what i need to do :)
22:50:24 <danwent> #topic open discussion
22:50:51 <danwent> anything?
22:51:15 <salv-orlando> Not from me.
22:51:21 <danwent> sounds good.
22:51:24 <danwent> happy reviewing folks :)
22:51:28 <danwent> #endmeeting