22:02:30 <danwent> #startmeeting
22:02:31 <openstack> Meeting started Tue Sep 13 22:02:30 2011 UTC.  The chair is danwent. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:02:32 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
22:02:59 <danwent> agenda: http://wiki.openstack.org/Network/Meetings
22:03:34 <danwent> #topic melange update
22:03:53 <danwent> troy is out but send me an update.  I will copy-paste :)
22:04:03 <danwent> The Melange merge prop is now open for review for Essex. Most comments from the initial reviews have been fully addressed including moving a fair amount of code to openstack commons. We'll be pushing to get reviews done and move this forward.
22:04:14 <danwent> We also have a related pull request out for the Openstack Common changes.
22:04:14 <danwent> Full integration will be dependent on some Nova refactoring to isolate IP address access to the network manager. We have a developer starting on that work and hope to have it done within the next two weeks.
22:04:23 <danwent> Trey, did you  have anything to add on this front?
22:04:33 <danwent> or anyone else have questions on melange?
22:04:44 <tr3buchet> nope, we're trucking through it. hoping to get it done in the next coupel of weeks
22:04:49 <tr3buchet> couple
22:04:52 <danwent> sweet
22:05:10 <danwent> #topic donabe update
22:05:16 <dendrobates> I planned on having a donabe meeting this week, but it is talking longer to document the model, so we are going to push it to next week.
22:05:32 <danwent> apparently I have to restart my session to make the auto-correct fully disable… it translated donabe to donate again.
22:05:45 <dendrobates> also, debo, has started some of the sample integration work
22:06:26 <edgarmagana> Hi everybody
22:06:34 <danwent> great…. anything else?
22:06:34 <dendrobates> debo_os: have you pushed yet?
22:06:43 <debo_os> not yet
22:06:54 <debo_os> push in a short while
22:07:00 <dendrobates> awesome
22:07:02 <debo_os> sorry will push in a short while
22:07:04 <dendrobates> that's all
22:07:11 <danwent> great, thanks
22:07:16 <danwent> #topic quantum update
22:08:01 <danwent> thanks to everyone for the reviews prior to the diablo branch point
22:08:08 <danwent> I think I have performed the correct launchpad gymnastics to switch from diablo to essex
22:08:21 <danwent> lp:quantum should now be pointing to essex branch
22:08:44 <danwent> we'll talk in a bit about the switch to github, as that complicates things a bit.
22:09:05 <danwent> but again, if you have anything that you think needs to target diablo, please speak up…. earlier is much better than later.
22:09:30 <danwent> the diablo release milestone is: https://launchpad.net/quantum/+milestone/2011.3
22:09:55 <danwent> right now we just have documentation issues targeted.  I for one am behind on getting my documentation outline out.
22:10:11 <danwent> will try to block out some time tomorrow for that.
22:10:28 <danwent> salv, any update on getting API docs in repo?
22:10:43 <salv> work in progress, estimated to finish this thursday
22:10:50 <danwent> great.
22:11:00 <salv> document will look like any other openstack manual,
22:11:15 <danwent> you're living in docbook hell? :)
22:11:25 <salv> I hate docbook
22:11:32 * annegentle sobs
22:11:33 <annegentle> :)
22:11:39 <danwent> all doc systems are terrible though...
22:11:43 <salv> But I have to say the rackspace template makes life much easier
22:11:46 <annegentle> pick your poison
22:11:49 <danwent> exactly
22:12:06 <danwent> Ok, next up:  github / gerrit transition.
22:12:40 <danwent> this will be tricky… we essentially need to pick a point when we can get all work into trunk, then have them convert trunk over to github.
22:12:43 <jaypipes> danwent: can't we just use CVS?
22:12:45 <salv> Last time we spoke about this I remember we proposed to start Essex lifecycle in github
22:12:50 * jaypipes runs and hides
22:12:56 <danwent> jaypipes :)
22:12:58 <bhall_> jaypipes: you take that back
22:13:06 <jaypipes> bhall_: :)
22:13:09 <danwent> salv: yes, diablo will stay completely in launchpad / bzr
22:13:21 <soren> jaypipes: Or stick the source code in a Word document that we send back and forth over e-mail.
22:13:28 <danwent> but for work like your pylint fixes, we'll need to get that somewhere where it can be converted over.
22:13:46 <jaypipes> in all seriousness, switching from bzr/LP to git/Gerrit doesn't take all that long or require all that much effort besides reading http://wiki.openstack.org/GerritWorkflow.
22:13:55 <jaypipes> it shouldn't be a huge deal :)
22:14:09 <salv> jaypipes: agreed.
22:14:13 <danwent> jaypipes: is it only trunk that gets coverted over?
22:14:17 <danwent> converted
22:14:20 <jaypipes> soren: yes, that's a much better method. I'll add that as a wishlist to the openstack-ci project ;)
22:14:30 <salv> Anybody volunteering to read that document?
22:14:32 <jaypipes> danwent: yep! so definitely need to have a merge freeze
22:14:34 <danwent> soren: I would prefer a non-proprietary document format.
22:14:44 <jaypipes> danwent: yes, sorry, LibreOffice3
22:14:45 <danwent> salv: already have
22:14:46 <bhall_> salv: I've read it already :)
22:15:01 <danwent> brad, I think you had some proposals for converting over?
22:15:14 <bhall_> I was thinking we could target friday morning for moving over
22:15:17 <salv> Thanks guys! It was in my todo list, but got buried under other hundreds of todos
22:15:21 <bhall_> so everyone can get their environment setup on friday
22:15:25 <salv> friday 23rd?
22:16:02 <bhall_> 9/16 .. is that too close?
22:16:04 <danwent> maybe its best to get an inventory of what we need to get merged into trunk.
22:16:16 <danwent> salv: start-up time frames…. everything gets compressed :)
22:16:37 <danwent> an inventory let's us figure out what we need to review and merge.
22:16:46 <danwent> the packaging work is one big concern for me.
22:16:55 <bhall_> danwent: yup, me too
22:16:57 <salv> bhall: that depends i and how many bugs are we putting in diablo
22:16:58 <danwent> as it seems like we're not super close to having that ready.
22:17:03 <jaypipes> danwent: please do proactively work with mtaylor on the packaging concerns.
22:17:09 <salv> meant to say "if and how many"
22:17:47 <bhall_> ok.. 23rd works for me.  less about what the date is and more about picking one
22:17:50 <danwent> jaypipes:  sorry, to be clear: we have a branch that rearranges the quantum code a bit to be more amenable to packaging.  that branch is not yet in trunk and I am wondering whether we should try and merge it before making the switch.
22:17:52 <bhall_> that should give us enough time to inventory, etc
22:18:31 <salv> bhall: if there isn't any bugs targeting 2011.3 fri 9/16 would be better, as this would give us more time to update our development environments
22:18:41 <bhall_> ok
22:19:37 <danwent> I am fine with targeting 9/16… I don't see a flood of bugs coming in for diablo.
22:19:47 <bhall_> is tyler around? maybe he can comment on packaging status
22:19:48 <danwent> and we have until 9/22 to wrap up diablo bugs.
22:19:55 <danwent> tyler has a conflict during this time.
22:19:56 <bhall_> but shooting for 9/16 sounds good to me
22:19:58 <bhall_> oh ok
22:20:03 <SumitNaiksatam> we are testing :-)
22:20:23 <danwent> sumit: are you referring to the packaging, or quantum in general?
22:20:34 <SumitNaiksatam> not packaging
22:20:47 <SumitNaiksatam> quantum and the cisco plugin related stuff
22:20:51 <danwent> #action bhall  check with tyler about packaging and switch to github
22:21:01 <danwent> sumit: gotcha
22:21:09 <somik> SumitNaikasatam: hope you guys dont create a flurry of bugs then :)
22:21:17 <SumitNaiksatam> hope not
22:21:27 <danwent> I'm pretty sure quantum is bug free by this point :P
22:21:27 <SumitNaiksatam> definitely not a flurry :-)
22:21:44 <danwent> ok, so we're good with a planned 9/16 switch date?
22:21:46 <salv> danwent, bhall: please do not forget that the API doc is going in trunk :)
22:21:59 <salv> don't you want to review it before merging?
22:22:28 <danwent> we will need that in both the diablo release and the essex....
22:22:55 <salv> It might be more convenient if we wait for that to be in trunk, and then switch.
22:23:08 <danwent> easiest thing would probably be for it to go into essex while code is still in lp, then just pull that commit into the diablo branch on lp
22:23:10 <salv> Then we can probably say we will switch 1 nanosecond after merging the API doc branch
22:23:12 <danwent> salv: yeah, I agree.
22:23:21 <bhall_> that sounds like a good plan
22:23:37 <salv> +1
22:23:40 <danwent> but with reviewing that doc, is 9/16 feasible?
22:24:02 <danwent> salv, you said that doc would be available on thurs?
22:24:06 <bhall_> depends on what salv means by thursday I guess
22:24:20 <salv> Merge proposal expect on thursday, possibly PDT morning
22:24:24 <danwent> thursday his time is early for us
22:24:26 <salv> I need to complete the operation list
22:24:37 <danwent> Ok, let's still target 9/16 then.
22:24:57 <danwent> #action #bhall, contact openstack infrastructure team about targeted 9/16 transition to github/gerrit.
22:25:41 <danwent> #action #salv get API spec merge prop by thurs, if possible.
22:25:53 <danwent> ok, anything else about github/gerrit?
22:26:14 <bhall_> don't think so .. once we switch I can send an email with instructions/etc
22:26:32 <danwent> great
22:26:45 <danwent> Ok, wanted to bring up topic of design summit blueprints.
22:27:31 <danwent> I know that a lot of blueprints are not finalized to the last minute, but I want to encourage folks that if they know they plan on submitting a blueprint in a netstack area to send a quick heads up to the list (even if the blueprint itself isn't ready).
22:28:01 <salv> Agreed. I'm preparing an email on Quantum API v1.1
22:28:02 <danwent> this will just help us avoid having 8 different blueprints for the same thing being created in complete isolation...
22:28:19 <carlp> on that subject: I hope to have our CI machines ready with Monty by the summit.  Do we want to have a discussion about that with all the key parties in one room with a whiteboard?
22:28:33 <carlp> should I file a blueprint for that?
22:28:36 <danwent> carlp: that would be great.
22:28:48 <danwent> I think you no longer technically have to file a blueprint
22:29:09 <danwent> you can just ask for a session, though if you want to write up anything ahead of time, a blueprint is the ideal place.
22:29:27 <carlp> ok, I can do that
22:29:57 <salv> talking about sessions, any news about the agenda for the summit? (I missed the previous meeting)
22:30:02 <danwent> as I heads up, I'll also be creating a blueprint that is around a framework for inserting higher-level services into quantum (not on any specific higher-level service, more just general guidelines for anyone doing that)
22:30:47 <danwent> design summit agenda won't be set until very late… after all blueprints are in, which is end of sept (28th?) I think.
22:30:56 <danwent> (someone correct me if i'm wrong)
22:31:21 <SumitNaiksatam> btw, did anyone get a confirmation number for registering for the design summit?
22:31:21 <edgarmagana> danwent:  we (cisco) are also working on a BP for services
22:31:27 <danwent> I think they plan on finalizing the agenda for the openstack conference (i.e. not developer focused) earlier.
22:31:40 <salv> That's understandable. Do we know at least if incubation projects can apply for their own sessions?
22:31:42 <edgarmagana> danwent: we can work together on the draft version
22:32:00 <danwent> egdar: cool.  I suspect others are as well.  would be good to start sharing ideas on the ML.
22:32:07 <salv> +1
22:32:08 <danwent> edgar: definitely.
22:32:27 <danwent> salv: there will be a netstack tracker, which is what we should all use when submitting our session.
22:32:30 <edgarmagana> danwent: by Friday we expect to be ready to send the first bunch of ideas
22:32:32 <salv> let's not end up with 3 independet blueprints as we did for Cactus :)
22:32:41 <danwent> edgar: you're ahead of me then :)
22:32:54 <danwent> salv: diablo?
22:32:58 <danwent> salv: that's exactly the goal.
22:33:03 <salv> Diablo, right.
22:33:14 <danwent> salv: ah, seems so long ago now, huh :)
22:33:33 <danwent> Ok, any other thoughts on blueprints or the summit?
22:33:56 <salv> I think higher-layer services and API improvements are the most important items
22:33:59 <edgarmagana> Sumit: I think Ram got the list of the confirmed folks (we are in)  :-)
22:34:06 <danwent> #agreed  send pointer to ML if you plan on working on a netstack bp that is generally applicable.
22:34:17 <salv> then I'm pretty sure a lot of other interesting ideas will came along!
22:34:33 <danwent> salv: agree, I think that will be the focus.
22:34:41 <danwent> but you never know what else might come up.
22:34:43 <edgarmagana> +1
22:34:54 <danwent> ok, one last topic: pep8
22:35:32 <danwent> it seems like our hudson server is now running with a newer version of pep8 (0.6.1 i'm guessing) which is causing build errors (there are some violations in the cisco plugin that don't seem to show up with pep8 0.5.0)
22:35:40 <danwent> or at least that is my best guess of what is going on.
22:35:50 <salv> danwent: confirmed.
22:35:53 <danwent> So I'm going to file an issue that enforces a single version of pep8
22:36:08 <danwent> we'll start doing that for essex though
22:36:12 <danwent> sound good?
22:36:14 <salv> they are very trivial, pep8 0.6.1 complains if there's a space or newline between the end of a seq/dict and the marker
22:36:29 <SumitNaiksatam> keep it at 0.5 for now :-)
22:36:46 <danwent> sumit:  does your team have an issue with going to 0.6.1 in the future?
22:36:52 <SumitNaiksatam> nope
22:36:58 <salv> I'm fine with any version, just let's make sure there is only one version
22:36:58 <danwent> ok, great.
22:37:04 <danwent> yup :)
22:37:08 <SumitNaiksatam> haven't checked the 0.6 violations though
22:37:12 <danwent> ok, anything else quantum specific?
22:37:28 <danwent> #topic open discussion
22:37:38 <salv> will there be a space for demos at the summit?
22:38:02 <danwent> salv: definitely
22:38:03 <SumitNaiksatam> good question salv, we were also wondering
22:38:04 <dendrobates> salv: there hasn't been in the past
22:38:18 <dendrobates> but you could include it in a session
22:38:21 <danwent> salv: we have a session for quantum where we plan to do an overview and a quick demo
22:38:34 <danwent> I think there is one for donabe as well?
22:38:37 <danwent> debo?
22:38:40 <danwent> dendro?
22:38:48 <salv> danwent: great. Let me know if I can help in any way with setting up the demo.
22:38:54 <SumitNaiksatam> danwent/dedrobates: but no booths?
22:39:04 <danwent> haha… definitely no booths
22:39:37 <danwent> let's hope openstack summits never become a trade show
22:39:45 <danwent> with people scanning your badge :)
22:39:56 <salv> danwent: I hate that thing
22:40:01 <danwent> ok, anything else?
22:40:22 <salv> especially when attractive girls approach you at the bar, just for scanning your badge :(
22:40:41 <salv> nothing else from me.
22:40:42 <danwent> k, great work finishing up the reviews.  If you find an issue that you think needs to be fixed for diablo, please file a bug against diablo and email the netstack list so it can get quick attention.
22:40:48 <danwent> salv :)
22:41:01 <danwent> ok, thanks folks.
22:41:06 <danwent> #endmeeting