20:00:12 <jbryce> #startmeeting
20:00:13 <openstack> Meeting started Tue Sep 20 20:00:12 2011 UTC. The chair is jbryce. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:00:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:00:25 <johnpur> o/
20:00:28 <mtaylor> )?(
20:00:30 <jmckenty> o/
20:00:31 <jmckenty> ?
20:00:41 <jmckenty> frowning cyclops?
20:00:50 <jaypipes> o/
20:01:09 <jbryce> agenda can be found online: http://wiki.openstack.org/Governance/PPB
20:01:44 <jbryce> there weren't really any previous actions beyond sending the guideline draft out for public comment which has been done
20:01:45 <vishy> o/
20:01:51 <jbryce> #topic project APIs
20:02:19 <jmckenty> status update? Are we working off of http://wiki.openstack.org/Governance/Proposed/APIManagement or is there further discussion?
20:02:31 <jbryce> The etherpad has had some pretty good activity on it. Seems like people are reviewing.
20:02:44 <jbryce> I don't know how long we want to leave it open before we decide to say this is the first pass of guidelines
20:03:13 <jbryce> the only point that we haven't really settled is if there's a need for an api coordinator. i kind of liked thierry's response on the ppb mailing list
20:03:28 <ttx> I like it too. :)
20:04:08 <jmckenty> +1
20:04:09 <jbryce> basically don't make it an official governance position and leave it free for highly interested parties like jorge to get involved as heavily as they want
20:04:33 <jbryce> does anyone have a differing opinion on it?
20:05:03 <johnpur> +1, there is a need for api coordination, but should be done by an interested person
20:05:10 <ttx> or group
20:05:16 <pvo> o/
20:05:21 <johnpur> if there are more than 1 person interested, so much the better
20:05:27 <jbryce> ok. we'll just leave it at that for now
20:05:59 <jbryce> how long do we want to leave the guidelines open for review?
20:06:01 <jmckenty> Can we amend the proposal to remove the position and then vote on it?
20:06:16 <jmckenty> Have the guidelines been pushed to the full community list?
20:06:21 <jbryce> jmckenty: yes
20:06:26 <jbryce> http://etherpad.openstack.org/RFC-API-Guidelines
20:06:31 <jmckenty> Yeah, I've seen it
20:06:35 <jmckenty> couldn't remember from where
20:06:38 <jbryce> there were some comments on the mailing list and quite a few in the doc itself
20:06:43 <jmckenty> I'd love to see it discussed in Boston
20:06:54 <jmckenty> but I'm not attached
20:07:05 <ttx> jmckenty: you can make it happen by submitting a session proposal !
20:07:12 <jbryce> that's fine with me to if we want to just leave it open for 2 more weeks
20:07:22 <jmckenty> ttx: I never got back a conclusive answer from my last session proposal
20:07:25 <jmckenty> after three attempts
20:07:37 <jmckenty> I was just going to show up and yell like last time
20:07:51 <jmckenty> standard procedures only seem to work if you have admin access to the schedule
20:07:56 <johnpur> jmckenty: why stop now?
20:08:02 <jmckenty> YaaS
20:08:05 <ttx> jmckenty: let's discuss that offline
20:08:05 <jmckenty> Yelling as a Service
20:08:06 <jbryce> ok
20:08:10 <jbryce> back to the topic....
20:08:14 <jmckenty> sorry
20:08:20 <johnpur> hehe
20:08:30 <jbryce> #info No need to establish official API coordinator now.
20:08:40 <jbryce> #info Guidelines will remain open for comment through Essex summit
20:08:53 <jbryce> any other discussion on the API topic?
20:09:00 <jmckenty> Can you restate that as API Guidelines?
20:09:04 <jmckenty> just so it's obvious in the minutes
20:09:28 <jbryce> sure, but it should show up under the project APIs heading
20:09:36 <jbryce> irc://irc.freenode.net/#info API Guidelines will remain open for comment through Essex summit
20:09:46 <jmckenty> ah, gotcha, thanks
20:09:46 <jbryce> gah...autocomplete
20:10:02 <jbryce> #topic FITs Working Group Update
20:10:10 <jbryce> jmckenty: want to take this one?
20:10:18 <jmckenty> I sent out an initial proposal to the FITs mailing list
20:10:20 <jmckenty> linking to http://etherpad.openstack.org/FITS
20:10:36 <jmckenty> It's intended to be heretical
20:10:46 <jmckenty> and provoke NOW the possible future arguments
20:11:22 <jmckenty> Specifically, the proposals to measure and certify performance and stability as part of FITs
20:11:46 <jmckenty> And, the proposal that "Built on OpenStack" means including everything in core
20:12:00 <johnpur> jmckenty: how do you intend the debate to happen?
20:12:05 <jmckenty> which, I admit, is devilishly difficult
20:12:22 <jmckenty> johnpur: The FITs list has representatives from most of the commercial partners on it
20:12:30 <jmckenty> well, the ones that are working on "Built on OpenStack" products
20:12:37 <jmckenty> as opposed to "Powered by OpenStack" services
20:12:48 <pvo> jmckenty: so if I'm only using a single component, you can't say "Built on Openstack" if i'm not using every core piece?
20:13:08 <jmckenty> I'm hoping to get a decent clarification of the various points of view before the summit, and then open it up to PPB and community input
20:13:11 <jmckenty> pvo: correct
20:13:17 <jaypipes> "Currently, systems deployed using vanilla OpenStack will meet or exceed these targets." Hmm, that's not correct, AFAIK.
20:13:31 <jmckenty> The 1,000 VM, 1,000 user targets? I think it is
20:13:40 <jaypipes> the concurrency target.
20:13:51 <jmckenty> Oh, hmm. I suppose I shouldn't count NASA Nebula as a vanilla openstack system
20:13:51 <notmyname> jmckenty: you have no storage targets in there. where's the swift love? :-)
20:14:00 <pvo> jmckenty: I dont' see the distinction of "Built with Intel" and "Using Intel"
20:14:02 <jmckenty> API calls include swift and networking
20:14:16 <jmckenty> Built with Intel is Super Micro, using Intel is AWS
20:14:23 <jmckenty> It's in the Trademark policy that way
20:14:26 <jaypipes> jmckenty: what about keystone and glance
20:14:46 <notmyname> jmckenty: ah I see it
20:14:54 <jmckenty> If it's using the OpenStack API, it'll be using keystone for the other api calls and glance for nova compute launches
20:14:59 <jmckenty> at least, that's how I was thinking about it
20:15:03 <jmckenty> 5 core project, right?
20:15:08 <jmckenty> Nova, Swift, Glance, Keystone and Dashboard
20:15:13 <pvo> I'm not sure there is a real distinction... at least that I can see.
20:15:18 <ttx> "Dashboard"
20:15:18 <jmckenty> http://openstack.org/brand pvo
20:15:22 <jmckenty> right
20:15:25 <jmckenty> bourbon
20:15:30 <notmyname> jmckenty: to further what jaypipes said, I'd encourage being really heretical and even defining things so that maybe not everything in core fits
20:15:45 <vishy> jmckenty: could have a minimum amount of swift storage provided 1PB ?
20:15:47 <jmckenty> notmyname: my thinking was to kick them out of core if they don't fit
20:15:53 <jmckenty> vishy: good call
20:16:19 <pvo> "Built for" != "Built on"
20:16:25 <notmyname> jmckenty: I'm not saying that yet, but it could clarify a few debates that might arise. at least to show where the boundries are
20:16:28 <jmckenty> I think having "core" == "required for Built on OpenStack" provides a really rigid framework for answering what OpenStack IS
20:16:42 <devcamcar> o/
20:17:00 <jmckenty> What the hell is up with the cyclops frowning? Did I miss a memo?
20:17:02 <notmyname> vishy: jmckenty: is that raw storage or customer (usable) storage? is it not "openstack" if it uses the same code but doesn't have as many hard drives plugged in as a different cluster?
20:17:03 <devcamcar> i'm here now gang, had a meeting run over
20:17:22 <jmckenty> notmyname: it has to be certified to be ABLE to do that, not that it has to be deployed that way
20:17:23 <jbryce> rather than trying to pick specific trademark names, i think it's more important to define what each of the projects would need to meet independently
20:17:29 <jmckenty> that was the thinking, anyway
20:17:38 <jbryce> then we can determine what the appropriate mixes of the various projects are
20:17:43 <notmyname> jmckenty: I can go with that
20:17:49 <vishy> notmyname: if we're defining minimum requirements to fit trademark, seems like we can define a minimum usable storage
20:17:53 <jmckenty> jbryce: should we group the definition that way, then?
20:17:53 * jaypipes thinks that the FITS should be broken down into a FITS for the API and a FITS for performance/scalability.
20:18:05 <johnpur> i guess i have a different view, don't see how scale should be a part of the definition
20:18:09 <jmckenty> and a third bucket for what's required to be in it?
20:18:14 <jbryce> some people will only run object storage, but i still want customers to be able to figure out if that's really openstack object storage
20:18:18 <notmyname> vishy: but as jmckenty said, the ability, not necessarily the actual deployment
20:18:19 <jmckenty> johnpur: we're proposing scale as a proxy for quality
20:18:19 <jbryce> same thing for compute
20:18:27 <vishy> jaypipes: I suppose if we have multiple official divisions
20:18:34 <johnpur> openstack in a box is not openstack?
20:18:53 <zns1> Would we commit to providing a FITS testing lab?
20:19:08 <jmckenty> zns1: I think we would commit to certifying a number of them
20:19:13 <vishy> * openstack-api-compatible * openstack-performance-certified ?
20:19:15 <jmckenty> I know at least three labs that are interested
20:19:23 <notmyname> johnpur: it can be. the code must be proven to have the ability to run at scale (but of course that gets in to the hardware nuances)
20:19:24 <jmckenty> Intel Cloud Builders being one, obviously
20:19:26 <jaypipes> re: this question: "Can we be heretical and require products to be written substantially in python in order to be �Built on OpenStack�?", I would absolutely say No. The implementation does not matter, IMHO. If an implementation implements the API faithfully and performs at some determined level of scalability, then it should not matter what language it is written in.
20:19:51 <zns1> jaypipes: +1
20:19:56 <jmckenty> jaypipes: -0
20:20:03 <jmckenty> I agree with the No, but not the reasons for it
20:20:22 <jmckenty> I think the language discussion should be part of the PPB decision to adopt a project, not part of FITs
20:20:30 <jmckenty> for all the reasons that have been previously hashed over
20:20:41 <notmyname> jmckenty: is FITs to determine what components should be part of openstack or what deployments can use the name "we're openstack"?
20:20:46 <devcamcar> jmckenty: +1
20:20:57 <jmckenty> notmyname: the latter
20:21:03 <jmckenty> but I'm suggesting they should be coupled
20:21:05 <jaypipes> zns1: I actually don't think we should commit to providing a testing lab. I think it should be done via an independent organization (but nothing wrong with partner organizations ponying up for the work)
20:21:15 <jbryce> so what is the path forward to defining this? for those who want to get involved, should they just start commenting on the etherpad, mailing list traffic, discuss at summit?
20:21:30 <jmckenty> If they're passionately interested, let's get them added to the Fits mailing list
20:21:31 <notmyname> jmckenty: johnpur: then perhaps the scale concerns are mor important
20:21:34 <johnpur> jbryce: my question exactly
20:21:37 <jbryce> i don't want to take up too much time getting into the details right now
20:21:42 <jmckenty> it's private so that the vendor participants can let down their hair a bit
20:21:54 <jbryce> we could set up a separate irc meeting to go into detail too
20:22:10 <jmckenty> Agreed. I'd also suggest a big session at the summit
20:22:26 <jmckenty> The target is resolved by end-of-year, correct?
20:22:29 <jbryce> #info contact jmckenty to get involved in ongoing FITS discussion
20:22:33 <jaypipes> jmckenty: where is the mailing list?
20:22:33 <jbryce> jmckenty: correct
20:22:39 <jmckenty> lists.openstack.org
20:22:48 <jmckenty> Stephen Spector is the admin, currently.
20:22:58 <vishy> jmckenty: not sure it fits there...
20:23:01 <jaypipes> wah?! I thought that list server was deleted....
20:23:05 <vishy> bwahahah
20:23:07 <jmckenty> k
20:23:11 <jmckenty> no wonder
20:23:17 <jmckenty> my posts have been bouncing
20:23:22 <jmckenty> I'll set up a new one
20:23:46 * jmckenty grumbles about doing things the "right" way again
20:23:48 <johnpur> can i ask what the process for "completion" is?
20:23:53 <jmckenty> PPB vote
20:24:01 <jmckenty> and then presumably ratification by OpenStack LLC
20:24:03 <mtaylor> no, I don't believe we deleted that server
20:24:09 <mtaylor> jmckenty: (lists.openstack.org)
20:24:11 <jmckenty> since the proposal is to make it a part of the official trademark policy
20:24:19 <jbryce> johnpur: this working group will come up with a proposal and then it would be a PPB vote to approve
20:24:26 <johnpur> thx
20:24:34 <jbryce> mtaylor: i think you're right. i got josh's message earlier, so it seems to be working at some level
20:24:40 <jmckenty> oh, other FITs issues - delay on updates, etc.
20:24:45 <notmyname> jmckenty: may have missed this. will there be a public comment time?
20:24:50 <jmckenty> definitely
20:24:53 <notmyname> good :-)
20:25:03 <jmckenty> I'm hoping to use the mailing list to clarify different perspectives
20:25:15 <jmckenty> and then get the broader community to provide feedback
20:25:15 <johnpur> i agree with jmckenty, the etherpad is highly controversial...
20:25:35 <jmckenty> Well, that definition bars everyone's product except mine
20:25:36 <jmckenty> :)
20:25:38 <johnpur> just wondering how to get to a real definition, with this as the starting point
20:25:42 <jmckenty> Which I'm up front about
20:25:45 <jmckenty> it's a starting point
20:25:53 <jbryce> johnpur: edit the etherpad
20:26:16 <johnpur> jbryce: haha... thanks.
20:26:21 <jmckenty> FITs is either == core, == "supercore", or == any component
20:26:31 <jbryce> seriously i think it would be good to have an irc on irl at the summit meeting
20:26:43 <jk0> ++
20:26:48 <jmckenty> ++
20:26:53 <devcamcar> ++
20:26:56 <johnpur> even core questions of "openstack is iaas only" is a point of huge debate
20:26:58 <jbryce> can you set that up jmckenty?
20:27:04 <jaypipes> jmckenty: I actually don't see why FITS has anything to do with core, supercore, or any of that.
20:27:16 <notmyname> johnpur: with obvious right and wrong answers ;-)
20:27:19 <jbryce> #action jmckenty to schedule FITS-specific meeting
20:27:31 <jmckenty> yup
20:28:06 <johnpur> email to spector to get additional folks on the working group?
20:28:11 <jbryce> my thought is that it needs to be any component and whether specific collections of components get a special label is secondary to having established technical verification of the individual components
20:28:16 <notmyname> jaypipes: because what is in core openstack is the openstack project leads to what other people call openstack
20:28:21 <jbryce> johnpur: sounds like it
20:28:32 <jmckenty> email me is easier, I can make sure all the participants know who else is on there, so they can be judicious about what they discuss
20:28:40 <jmckenty> or spector and cc me?
20:28:51 <jmckenty> there's no announcement to the list of new members, I'm nervous about lurkers
20:29:04 <jbryce> let's move on
20:29:11 <jaypipes> notmyname: I get that, I'm just not sure why the definition of a FITS should have any opinion at all on *what* is in OpenStack core. It should just test what *is* in OpenStack core (API and functionality)
20:29:28 <jmckenty> moving on
20:29:40 <jbryce> this could easily eat multiple hours. = )
20:29:43 <jbryce> #topic Academic participation
20:29:44 <johnpur> jaypipes: +1
20:30:03 <jmckenty> Brief update - I've dropped the ball on this, but I've seen folks on the LinkedIn network picking it up
20:30:04 * jaypipes would also prefer this FITS discussion be a lot more open in the future
20:30:25 <jmckenty> would like to delegate the academic coordination to someone else :)
20:30:39 <jmckenty> Volunteers?
20:30:54 * jbryce hears the distinct sound of crickets
20:30:55 <jaypipes> jmckenty: perhaps reed on our team would be a good source here.
20:31:12 <jmckenty> two seconds, finding link...
20:31:13 <jaypipes> jmckenty: reed == stefano maffulli
20:31:22 <jmckenty> http://www.linkedin.com/groupItem?view=&gid=3239106&type=member&item=71336544&qid=cebce5ab-f06c-49ca-ba53-3e0960e91c61&trk=group_most_popular-0-b-ttl&goback=%2Egmp_3239106
20:31:33 <jmckenty> stefano could definitely help coordinate
20:31:38 <jmckenty> I was going to suggest Todd
20:31:41 <jmckenty> Deshane
20:31:47 <jaypipes> sure
20:31:53 <jmckenty> he wrote up a pretty decent outline
20:31:53 <jmckenty> http://etherpad.openstack.org/openstack-academic-initiative
20:32:24 <jmckenty> I was going to forward him the contacts from folks who have already reached out to me (about a dozen institutions)
20:32:28 <jbryce> if he wants to start working on it, i think that's great
20:32:34 <jmckenty> and see if he can coordinate a mailing list and a session at the summit
20:32:38 <jaypipes> ++
20:32:40 <jmckenty> Anyone know him IRL?
20:32:47 <jbryce> not i
20:33:00 <pvo> I do.
20:33:01 <pvo> I'll ping him.
20:33:04 <jmckenty> Thanks pvo
20:33:41 <ewanmellor> Sorry I'm late.
20:33:41 <jmckenty> That's it for me on that topic, I'd suggest we defer any formal PPB proposal for a few months
20:33:54 <jmckenty> until we've had a chance to canvas the interested parties
20:34:14 <jbryce> #info Going to contact Todd Deshane about coordinating academic involvement. Stefano Maffulli may help as well
20:34:28 <jbryce> #topic Git+Gerrit migration update
20:34:38 <jaypipes> mtaylor: you're up
20:34:46 <mtaylor> yay!
20:34:48 <mtaylor> it's going great
20:35:12 <mtaylor> we've got just about everyone migrated except for nova - who are migrating after diablo is cut
20:36:00 <devcamcar> dashboard will migrate to gerrit the week after the boston summit
20:36:13 <jmckenty> mtaylor: can you do gerritt training at the summit, over beer or in the evenings?
20:36:15 <mtaylor> I keep meaning to loop in with python-novaclient as well
20:36:20 <jbryce> i know there was a pretty voluminous discussion on the mailing list on gerrit usage. have we been able to get specific feedback out of that for improvements?
20:36:20 <mtaylor> jmckenty: yup
20:36:35 <mtaylor> jbryce: yes, we have several bugs filed
20:36:47 <pvo> jmckenty: sent Todd an email.
20:37:32 <jmckenty> pvo: thanks.
20:37:40 <mtaylor> jbryce: I expect a few more as we get the wave of nova folks on - but by and large people seem to be getting the hang of it
20:38:23 <vishy> mtaylor: with your experience with nova devs, you expect bug reports and not complaints? Maybe we've changed at last ;)
20:38:52 <mtaylor> vishy: not unless I respond to the complaint with "I take bug reports" :)
20:39:08 <mtaylor> great way to triage the importance of something :)
20:39:53 <vishy> mtaylor: you are brave. My response is: I accept patches...
20:40:08 <mtaylor> I keep thinking we're going to see a new gerrit version drop any time now with the single-page-diff patch in it.
20:40:13 * jaypipes responds "I take beer"
20:40:51 <jbryce> any other questions around git+gerrit? or feedback?
20:41:19 <jmckenty> just to confirm,
20:41:25 <ttx> mtaylor: we have discovery sessions at the summit. You could propose one on the CI code
20:41:28 <jmckenty> everything is on github.com/openstack/* right?
20:41:44 <jmckenty> as far as official repos
20:41:50 <jmckenty> on or soon to be on
20:41:54 <mtaylor> jmckenty: yes
20:41:58 <jmckenty> cool, thanks
20:42:05 <mtaylor> jmckenty: the migration process includes setting up the mirroring to there
20:42:12 <jmckenty> I can turn off my bzr-to-github mirror hudson job now
20:42:31 <mtaylor> jmckenty: yes you can! see how much service we provide! :)
20:42:43 <jmckenty> lovin it, thank you
20:43:04 <jbryce> #topic open discussion
20:43:16 <mtaylor> ttx: should we do a session on the CI code? or on git/gerrit usage? or on both?
20:43:41 <johnpur> git/gerrit would be good
20:44:08 <ewanmellor> jmkenty: Just to jump back to the Academic Initiative topic: Todd Deshane works for Citrix / Xen.org. I can give you contact details.
20:44:17 <jbryce> i think usage for sure...the CI code would be good for those who want to make the workflow even better
20:44:27 <jbryce> ewanmellor: i think pvo sent him a note already
20:44:27 <ttx> mtaylor: discovery sessions are abot code, but you can probably show off both
20:44:28 <ewanmellor> jmckenty: Figure out who jmkenty is, and get back to me ;-)
20:45:01 <jmckenty> thanks
20:45:10 <ewanmellor> Ah cool. Thanks pvo.
20:45:18 <pvo> ewanmellor: np.
20:46:11 <jbryce> will everyone be generally available on tuesday evening for some in person beers?
20:46:31 <johnpur> jbryce is buying! heck yeah
20:46:33 <jbryce> tuesday evening of the design summit that is
20:46:38 <pvo> "generally"
20:46:48 <jbryce> correct. i am buying
20:47:02 <jmckenty> not unless it's late
20:47:04 <jaypipes> jbryce: of course.
20:47:09 <jbryce> but you all have to agree to tequila shots as well
20:47:14 <ewanmellor> Will gladly take jbryce's shilling.
20:47:15 <jmckenty> I've got an all-team celebration for piston peeps.
20:47:20 <johnpur> jbryce: +1
20:47:28 <jmckenty> can we do it at 9pm or later?
20:47:46 <jk0> we can start early and just keep it going :)
20:47:47 * mtaylor is only coming if everyone does a pickleback shot
20:48:14 <jmckenty> jk0: that works, too
20:48:31 <jbryce> i think i'd prefer to do it a little earlier if we can fit it before your dinner
20:48:46 <jbryce> 9pm might be past my bedtime
20:49:00 <jbryce> i'm getting old
20:49:05 <pvo> jk0: but its EST
20:49:07 <zns> jbryce: yes for Tuesday meet & drink
20:49:12 <jbryce> any other items to discuss?
20:49:13 * ewanmellor googles "pickleback shot"
20:49:26 * medberry will pass on the pickleback shot
20:49:26 <jk0> pvo: good point. we lose an hour, so we'll need to start *extra* early
20:49:35 <mtaylor> ewanmellor: you know you want to do a shot of well whiskey followed by a shot of pickle juice!
20:50:09 <johnpur> about.com says it is a "hipster" drink
20:50:13 * ewanmellor will do anything once
20:50:29 <jbryce> thanks everyone!
20:50:33 <jbryce> #endmeeting