17:59:14 <zns> #startmeeting Keystone Team Meeting
17:59:15 <openstack> Meeting started Tue Oct 18 17:59:14 2011 UTC.  The chair is zns. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:59:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:01:18 <zns> Hi - anyone here for the first Keystone meeting?
18:01:50 * heckj lurking for it
18:02:00 <heckj> didn't have anything specific though, just thought I'd sit in
18:03:21 <zns> heckj: cool. Welcome! It's our first one and we decided to do only yesterday, so the word may not have spread yet. But I'm going to be available online for questions. I'll also publish the roadmap to test that it makes it into the meeting logs too.
18:03:45 <zns> #topic Essex Roadmap
18:03:52 <heckj> I did have a question related to tenantID when you're ready
18:04:31 <zns> Fire away. I see dolphm just joined too.
18:05:03 * dolphm salutes.
18:05:32 <heckj> I forwarded a bug to the dash team to add in representing a tenant by Name in the dash (it currently just shows an ID). ohnoimdead (Tres) did some digging on it over the weekend, reported back that Keystone doesn't present a name with the tenantID
18:05:52 <heckj> Wondered how we could get that more accessible for display in the dash to resolve that bug
18:06:06 <dolphm> heckj: what call doesn't show the name with the id?
18:06:48 <heckj> looking up the code to find out - Tres's sending me the branch he worked on
18:07:56 <dolphm> is there an LP bug for this?
18:07:57 <zns> For the record, since we have been asked by many regarding the API:
18:07:59 <heckj> relevant bug: https://bugs.launchpad.net/openstack-dashboard/+bug/875231
18:07:59 <zns> - v2.0 API is final. Only extensions to it will be pubished.
18:07:59 <zns> - Any core changes needed/requested will trigger next version (v2.1)
18:07:59 <zns> - During F summit, we will discuss v3 and if any extensions should be promoted to v3 (core)
18:08:00 <uvirtbot> Launchpad bug 875231 in openstack-dashboard "req: display username and tenant in syspanel" [Undecided,New]
18:08:50 <heckj> Tres related that (through openstackX?) any of the calls to getting users only returned the ID's, not the combined data sets
18:08:52 <zns> Extensions can still be released at any time (so RBAC and other work scheduled will be as extensions to v2.0).
18:09:22 <dolphm> heckj: the bottom line is that whenever there is both a backend-managed ID and a user-managed Name, both should always be returned together
18:09:35 <dolphm> heckj: so if that's not happening somewhere, it's a bug
18:09:52 <heckj> cool - I'll dig it up, and if it's not happening now, I'll open a bug proper for it and link it up
18:10:00 <dolphm> heckj: thanks
18:10:29 <zns> ROADMAP
18:10:29 <zns> #1 - Essentials (E-1)
18:10:29 <zns> Implementation on 2.0 API+Extension
18:10:29 <zns> Documentation sprint
18:10:29 <zns> RBAC prototype
18:10:44 <dolphm> zns: (this meeting is already productive, yay!)
18:11:28 <dolphm> what is the date for E-1?
18:13:35 <dolphm> http://wiki.openstack.org/EssexReleaseSchedule
18:13:50 <zns> That's the latest roadmap.
18:14:01 <zns> Oops - got kicked off for too much text...
18:14:11 <dolphm> so, in terms of sprinting, we're either not going to do a doc sprint, or we're not going to touch RBAC by E1
18:15:07 <zns> We'll prototype the RBAC API in E1 only; so basically give the other core teams sample API responses with capabilities and roles in them. Those would be hardcoded so we can iterate on the API, but no implementation.
18:15:08 <heckj> What did you have in mind re: the Documentation sprint?
18:15:52 <zns> heckj: we've heard frustration that documentation is lacking. We want to improve that with things like; consolidating docs, clearly identifying quickstart, install, admin, and design docs.
18:17:39 <zns> I'm going to clean this up and we're going to put blueprints in and target them to milestones as well.
18:18:16 <heckj> I'd be happy to take a swing at the RST docs to improve this and submit it as pullreq - you'll likely need to correct me as I'm not super-familiar with the internals, but picked up some detail at the design summit
18:19:02 <zns> What is not clear also, but important, is that we will focus on stability for E3. We want to be stable for the last few milestones and we'll start on the F blueprints during the last milestone.
18:19:23 <zns> heckj: super! Much appreciated. That would be helpful.
18:19:38 <dolphm> zns: stable by e3 or by end of e3?
18:20:15 <dolphm> zns: in other words, other projects are squashing bugs in e4/rc... are we squashing bugs for e3/e4/rc then?
18:20:43 <zns> heckj: see also http://wiki.openstack.org/GerritJenkinsGithub. We're using that instead of pull requests.
18:21:15 <heckj> zns: yeah, that's what I meant. I've used it previous, just still call it pull request because I'm lame :-)
18:21:46 <zns> dolphm: stable by end of E3. Schedule:
18:21:47 <zns> http://wiki.openstack.org/EssexReleaseSchedule
18:21:47 <zns> Schedule:
18:21:47 <zns> - E1: implement 2.0 API & doc sprint
18:21:47 <zns> - E2: RBAC (big feature)
18:21:47 <zns> - E3 (Jan 5th-Feb 1st): stabilizing/performance, etc... actively working code
18:21:48 <zns> - E4 (Feb 2-March 1st): bug fixing, supporting users – prep for RC
18:21:48 <zns> - E5 (March 1st-April 5): starting on BPs, prototypes for F
18:21:49 <zns> - F Summit: April 19th
18:22:11 <zns> heckj: not lame. Hopeful maybe? I miss pull requests :-)
18:22:31 <heckj> zns: yeah, me too. Whole different discussion though.
18:22:48 <heckj> zns: looks like a good schedule
18:23:01 <zns> dolphm: so while other projects quash bugs in E4, they should be writing against a pretty stable Keystone release.
18:23:52 <zns> Also means we get a head start on F1. But that's what we need to commit to for a while to avoid the chaos we had (I caused!) for Diablo.
18:24:30 <zns> #topic Documentation Sprint
18:24:49 <zns> heckj asked and I answered, so we've covered this topic. Any questions on it?
18:24:59 <annegentle> hey would you all (including heckj) consider writing the admin/quickstart  and install docs in openstack-manuals rather than RST?
18:25:06 <annegentle> RST is more for dev docs than admin guidance
18:25:13 <annegentle> though I did take the RST install info as a start
18:25:22 <annegentle> the RST install should be for dev environments not production
18:25:31 <annegentle> make sense?
18:25:32 <heckj> Happy to, once I'm comfortable with the content - it's a little faster for me to knock out RST
18:25:39 <dolphm> annegentle: makes sense to me
18:25:53 <annegentle> heckj - yeah and if you want to author RST and then convert to DocBook we could do that on the sidelines possibly?
18:26:11 <dolphm> i rewrote the README yesterday, trying to cut as much as possible that's been moved elsewhere (i.e. docs.openstack.org)
18:26:13 <annegentle> heckj: just want to ensure the audience is appropriately served in the source
18:26:19 <annegentle> dolphm: oh thanks for doing that
18:26:23 <zns> annegentle: so RST for dev manuals (setting up a test/debug environment, documenting the code and design, etc?). Sounds fine to me. Any other projects following that model?
18:26:24 <heckj> I'm going to fill in the blanks that exist in RST now, get familiar with the underpinnings by making Ziad and Dolph read me crap, than I can take a stab at install/configure docs in docbook
18:26:37 <heckj> zns: all of them, actually
18:26:44 <zns> dolphm: just saw that. Thanks!
18:27:20 <zns> heckj: all of what?
18:27:43 <annegentle> zns: yep, all projects follow the RST>Dev Docs, DocBook> Ops/Admin model
18:27:48 <heckj> zns: answering your question - all the other projects have dev docs in RST, formal docs in Docbook
18:28:00 <heckj> (what annegentle said)
18:28:07 <zns> cool.
18:28:11 <zns> #agreed dev manuals in RST. All other manuals in openstack-manuals..
18:29:16 <zns> Anything else on documentation sprint?
18:29:36 <zns> #topic Open Bugs
18:30:06 <zns> I know Yogi has tackled a few since he came back from the summit. Anyone have any high priority bugs they are blocked on?
18:31:16 <zns> OK. Nothing particular on bugs. We'll work them as they come up.
18:31:22 <dolphm> how should we be prioritizing bug fixes? (besides spec mal-compliance)
18:32:15 <zns> I'll work with Joe on prioritizing what's in the backlog. But if you have anyone blocked or asking for a bug to be fixed, we should prioritize unblocking them.
18:32:42 <zns> So: if someone is actively asking, we help them. Otherwise, they get prioritized with all other work.
18:32:48 <zns> #topic Open Discussion
18:33:05 <dolphm> alright
18:33:11 <zns> I'm rushing the agenda a bit becuase I have to leave early.
18:33:17 <zns> * apologizes *
18:33:19 <dolphm> lol
18:33:42 <dolphm> and that wraps it up for today
18:33:53 <zns> Any other items to bring up, log in the minutes, or  add to the agenda for next week?
18:34:56 <annegentle> just a note of appreciation, thanks for the efforts
18:35:01 <zns> OK. I'll be online during the PPB meeting in a bit too.
18:35:11 <zns> annegentle: you are wlecome!
18:35:16 <zns> heckj, dolphm, annegentle: thank you for attending :-)
18:35:40 <zns> See you next week.
18:35:42 <zns> #endmeeting