#openstack-meeting Meeting

Meeting started by bcwaldon at 18:05:23 UTC (full logs).

Meeting summary

  1. Future Meetings (bcwaldon, 18:05:37)
    1. ec2 api team should be separate (vishy, 18:09:34)
    2. ACTION: vishy to identify and set up ec2-specific api team (bcwaldon, 18:09:39)

  2. Team Definition (bcwaldon, 18:15:53)
    1. Team is for public and private rest apis (vishy, 18:16:59)
    2. Team is for public and private http apis (excluding compatibility apis) (vishy, 18:17:29)
    3. ACTION: bcwaldon to send summary email to the list mentioning meeting times (bcwaldon, 18:19:21)

  3. Blueprint triaging (bcwaldon, 18:19:38)
    1. https://blueprints.launchpad.net/~nova-api (bcwaldon, 18:19:49)

  4. OpenStack Compute API Versioning (bcwaldon, 18:24:53)
    1. essex api will be v2.0 (vishy, 18:40:51)
    2. essex will expose the api at /v2 (vishy, 18:41:01)
    3. it will be backwards compatible with v1.1 because it is not a true major version (vishy, 18:41:41)
    4. ACTION: bcwaldon to design blueprints for the versioning changes (bcwaldon, 18:52:32)
    5. rename v1.1 to v2.0 and release v2.1 with Essex (bcwaldon, 18:53:18)
    6. blueprint separate-volume-api (bcwaldon, 18:58:24)


Meeting ended at 19:01:54 UTC (full logs).

Action items

  1. vishy to identify and set up ec2-specific api team
  2. bcwaldon to send summary email to the list mentioning meeting times
  3. bcwaldon to design blueprints for the versioning changes


Action items, by person

  1. bcwaldon
    1. bcwaldon to send summary email to the list mentioning meeting times
    2. bcwaldon to design blueprints for the versioning changes
  2. vishy
    1. vishy to identify and set up ec2-specific api team


People present (lines said)

  1. bcwaldon (132)
  2. vishy (64)
  3. jorgew (58)
  4. DuncanT (8)
  5. westmaas (7)
  6. ttx (6)
  7. openstack (2)
  8. xtoddx (1)


Generated by MeetBot 0.1.4.