21:02:02 <ttx> #startmeeting
21:02:03 <openstack> Meeting started Tue Nov 8 21:02:02 2011 UTC. The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:04 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:02:06 <soren> o/
21:02:07 <mtaylor> vishy: main difference being that we'll tie both to a single launchpad project
21:02:12 <heckj> 0?
21:02:19 <ttx> Welcome everyone to our weekly meeting... Today's agenda:
21:02:27 <ttx> #link http://wiki.openstack.org/Meetings/TeamMeeting
21:02:38 <ttx> Please all use #info #link #idea #action for a richer summary !
21:02:54 <ttx> At the end of today (or rather very early tomorrow) we should create essex-1 milestone-proposed branches from master
21:03:02 <ttx> (for those following the common milestone plan)
21:03:11 <ttx> This meeting will focus on making sure we can do that :)
21:03:18 <ttx> #topic Keystone status
21:03:28 <ttx> jsavak: looking at:
21:03:33 <jsavak> #link https://blueprints.launchpad.net/keystone/essex
21:03:34 <ttx> #link https://launchpad.net/keystone/+milestone/essex-1
21:03:42 <jsavak> ttx: yup
21:03:45 <ttx> essex-1 looks pretty complete to me...
21:03:46 <jsavak> We're good for e-1.
21:04:00 <ttx> Is there anything else significant added since Diablo that does not appear in the blueprint list ?
21:04:19 <ttx> (feature-wise)
21:04:23 <jsavak> lots more documentation and functional test coverage.
21:04:36 <ttx> ack
21:04:38 <jsavak> Feature wise: no. We have RBAC prototype in a different repo
21:04:52 <ttx> jsavak: Other news ?
21:05:09 <jsavak> diablo backport is complete. Dolph is putting together the back-port release notes now
21:05:47 <Ravikumar_hp> Is unit tests available for keystone to cover essex-1 Rc1?
21:06:00 <ttx> diablo backport: is everyone happy with it ?
21:06:16 <jsavak> ravi: the major piece of functionality is the ssl piece created by liem. There is functional tests for that
21:07:11 <ttx> jsavak: diablo backport: is everyone happy with it ?
21:07:17 <vishy> mtaylor, ttx: finished scrollback I'm ok with the lplan
21:07:29 <jsavak> I believe so, but need to verify
21:07:32 <mtaylor> vishy: thanks!
21:07:51 <ttx> Raise your hand if you have other questions on Keystone...
21:07:52 <jsavak> #action jsavak to verify that everyone is happy with diablo-backport
21:07:55 <vishy> I think we're still missing one item in diablo backport
21:08:05 <jsavak> vishy: what item?
21:08:51 <vishy> jsavak: https://review.openstack.org/#change,1375
21:09:01 <annegentle> I believe the Keystone documentation blueprint is still incomplete from a coverage standpoint - to ensure sysadmins can deploy it
21:09:04 <vishy> (we may need something similar for glance/swift as well
21:09:26 <heckj> annegentle: +1
21:09:27 <vishy> unless we feel that tenant_name is the central artifact in diablo
21:09:35 <jsavak> vishy: ok - I'll pass this on.
21:09:44 <ttx> jsavak: I'll branch essex-1 milestone-proposed from master early tomorrow morning.
21:09:52 <jsavak> ttx: thanks
21:10:00 <ttx> #topic Swift status
21:10:00 <jsavak> anne: +1
21:10:05 <ttx> notmyname: o/
21:10:08 <notmyname> hi
21:10:25 <ttx> Still no proposed release date for 1.4.4 ?
21:10:32 <notmyname> well, let's talk about that
21:10:45 <notmyname> how does early in the week of Mov 21 work for you?
21:10:49 <notmyname> Nov
21:11:04 <ttx> works for me
21:11:33 <notmyname> ttx: ok. then lets say either Nov 21 or 22 (for final release, we'll have QA'd it by the preceding friday)
21:11:56 <ttx> branch at end of Nov 18, final release Nov 22 ?
21:12:06 <notmyname> sounds good
21:12:17 <notmyname> #info swift 1.4.4 to be release on November 22
21:12:28 <ttx> cool
21:12:34 <ttx> notmyname: Anything else ?
21:12:36 <notmyname> yup
21:12:39 <notmyname> one more thing
21:12:54 <notmyname> we've found a potential memory leak in eventlet
21:13:08 <notmyname> gholt has patched eventlet and we are testing it now
21:13:20 <Ravikumar_hp> notmyname: is swift 1.4.4 not part of any Diablo release ? Is it standalone release
21:13:38 <notmyname> if his patch fixes it, we'd recommend bumping the required version of eventlet once it's included in the mainline
21:13:41 <ttx> Ravikumar_hp: Swift 1.4.4 is a release, part of the Essex development timeframe
21:13:51 <notmyname> Ravikumar_hp: and stable and prod-ready
21:14:16 <notmyname> I've talked to a few people already about the eventlet bug. I just want to make sure people know what's coming
21:14:22 <mtaylor> notmyname: ++ on eventlet
21:14:29 <ttx> great, thx for the heads-up.
21:14:32 <notmyname> mtaylor: all props go to gholt
21:14:41 <ttx> Questions on Swift ?
21:14:42 <mtaylor> gholt++
21:15:14 <ttx> #topic Glance status
21:15:19 <ttx> jaypipes: yo
21:15:25 <ttx> #link https://launchpad.net/glance/+milestone/essex-1
21:15:46 <jaypipes> Waiting on one final code review for some documentation stuff, but good to cut milestone-proposed
21:15:56 <ttx> One blueprint left unimplemented: https://blueprints.launchpad.net/glance/+spec/protected-images ?
21:16:06 <jaypipes> ttx: refresh your browser...
21:16:12 <ttx> jaypipes: that's cheating.
21:16:16 <jaypipes> lol
21:16:32 <ttx> jaypipes: Does the list on essex-1 page reflect the new features for Glance since Diablo ?
21:16:40 <jaypipes> ttx: yes
21:16:41 <ttx> anything missing that we should retrospectively add ?
21:16:43 <ttx> ok
21:16:46 <jaypipes> ttx: nope.
21:17:05 <Ravikumar_hp> jaypipes: Is Glance API documentation v2.0 is complete and finalised?
21:17:27 <ttx> jaypipes: OK, wil cut with tomorrow's status, with or without that last bugfix
21:17:28 <jaypipes> Ravikumar_hp: still in RFC period, still getting feedback from a few folks
21:17:56 <ttx> jaypipes: Anything else ?
21:18:19 <jaypipes> Ravikumar_hp: And I've created a number of blueprints that address how to implement 2.0 API: https://blueprints.launchpad.net/glance/+spec/api-2
21:18:47 <jaypipes> ttx: no, just to say please go to https://docs.google.com/document/d/1klPuEJbU7yxSLalhucFPw4dTVFi6aXIh7lO5c-O8wQw/edit and provide feedback on the proposed 2.0 Images API
21:19:03 <ttx> #help please go to https://docs.google.com/document/d/1klPuEJbU7yxSLalhucFPw4dTVFi6aXIh7lO5c-O8wQw/edit and provide feedback on the proposed 2.0 Images API
21:19:19 <ttx> Questions on Glance ?
21:19:39 <heckj> how is the glance API aligning with Keystone? Dependency?
21:20:14 <jaypipes> heckj: It's not related to the proposed 2.0 Images API... in other words, that's an implementation detail.
21:20:47 <vishy> jaypipes: don't know if you noticed, but at some point in keystone tenant -> tenant_id, tenant_name
21:20:58 <jaypipes> vishy: yep, noticed...
21:21:03 <vishy> jaypipes: we're going to use tenant_id as the canonical version
21:21:09 <ttx> ok, moving on to Nova
21:21:18 <ttx> #topic Nova status
21:21:25 <jaypipes> vishy: TENANT_ID is a string, right?
21:21:27 <vishy> jaypipes: seems like we should do the same thing across projects to avoid breakage
21:21:31 <vishy> jaypipes: correct
21:21:34 <vishy> so nova status
21:21:35 <ttx> vishy: https://launchpad.net/nova/+milestone/essex-1
21:21:37 <vishy> we need reviews!
21:21:40 <jaypipes> ya, we'll use the tenant ID.
21:21:41 <ttx> badly
21:21:54 <vishy> I'm drafting an email to the list to request reviews.
21:22:21 <ttx> vishy: soren is starting to extract stats that could lkead to suggesting new core members (and cleaning up stale ones)
21:22:41 <ttx> 4 BPs still needing review:
21:22:46 <vishy> i'm pushing the ha nova network one to e2
21:22:50 <jaypipes> seems a small list of bugs... where did all the nati2 bugs get targeted?
21:22:50 <ttx> https://blueprints.launchpad.net/nova/+spec/quantum-dhcp-parity
21:22:51 <ttx> https://blueprints.launchpad.net/nova/+spec/osapi-console-log
21:22:51 <ttx> https://blueprints.launchpad.net/nova/+spec/pci-passthrough
21:22:51 <ttx> https://blueprints.launchpad.net/nova/+spec/openstack-api-ssl
21:23:12 <ttx> jaypipes: they weren't targeted to a specific milestone
21:23:20 <vishy> i actually don't think we will have code for that one
21:23:41 <jaypipes> ttx: the nati2 bugs or just in general bugs?
21:23:48 <soren> vishy: Which one?
21:24:02 <vishy> the ha nova network xenserver
21:24:06 <ttx> the nati2 bugs ?
21:24:06 <soren> Ah.
21:24:19 <vishy> it is hopefully just configuration and instructions for setup
21:24:19 <ttx> Nothing like 3 discussions mixed.
21:24:46 <ttx> vishy: agreed to defer xenapi-ha-nova-network to essex-2
21:24:51 <ttx> vishy: what about the other ones ?
21:24:54 * jaypipes wondering where all the nova bugs have been targeted, that's all...
21:25:15 <jaypipes> surely there's more than 5 bugs fixed in E1 for Nova?
21:25:30 <vishy> jaypipes: i don't know if the bugs have been targetted proplerly
21:25:44 <ttx> jaypipes: i will target the FixCommitted to essex-1 tomorrow
21:25:49 <vishy> ttx: do you have a secret trick for finding them...yeah
21:25:52 <ttx> since that doesn't happen automatically
21:25:59 <vishy> so osapi needs fixes, just pinged jake
21:26:15 <ttx> mtaylor: sounds like an improvement we could make
21:26:47 <mtaylor> ttx: arro??
21:27:07 <vishy> pci is going to be deferred allso
21:27:09 <ttx> #action ttx to see with mtaylor about setting up target milestone on FixCommitted bug automatically on master merge
21:27:20 <mtaylor> ttx: ah. target FixCommitted to the current milestone?
21:27:20 <vishy> my review hasn't been addresed yet
21:27:21 <mtaylor> cool
21:27:35 <ttx> vishy: deferring
21:28:13 <vishy> looks like the console stuff will be refactored
21:28:26 <vishy> so that one is deferred too
21:28:39 <ttx> deferring
21:29:06 <westmaas> vishy: definitely want to hear about osapi fixes needed, can we tag those in some way if bugs are filed?
21:29:15 <vishy> quantum might land
21:29:24 <ttx> vishy: You are left with openstack-api-ssl and quantum-dhcp-parity
21:29:28 <vishy> looks like it is just missing some reviews
21:29:34 <vishy> so lets leave that for now
21:29:37 <ttx> vishy: sure
21:29:55 <ttx> vishy: You're OK to cut milestone-proposed even if those aren't in ?
21:29:59 <vishy> sure
21:30:01 <ttx> (tomorrow morning)
21:30:10 <ttx> Also one targeted bug: https://bugs.launchpad.net/bugs/886224 (bcwaldon)
21:30:10 <vishy> doesn't look like ssl will make it
21:30:12 <uvirtbot> Launchpad bug 886224 in nova "Compute Manager makes too many calls to Glance on instance create" [Low,In progress]
21:30:31 <ttx> vishy: would be good to have though
21:30:40 <ttx> vishy: let's give it a few more hours chance ?
21:30:46 <Ravikumar_hp> vishy: Is there any DB changes for Nova in Essex and if so ,is the changes frozen?
21:30:47 <vishy> sure
21:31:00 <vishy> Ravikumar_hp: there will be db changes
21:31:05 <vishy> they all go through migrations though
21:31:13 <ttx> vishy, bcwaldon: bug 886224 is not milestone-critical, right
21:31:13 <uvirtbot> Launchpad bug 886224 in nova "Compute Manager makes too many calls to Glance on instance create" [Low,In progress] https://launchpad.net/bugs/886224
21:31:20 <vishy> no
21:31:37 <ttx> ok
21:31:37 <vishy> there is one bug which is kind of critical, but I haven't even gotten a clear repro
21:31:41 <bcwaldon> ttx: right, and it's seeing some functional failures
21:31:45 <bcwaldon> ttx: we can target to essex-2
21:31:50 <ttx> doing so
21:31:54 <bcwaldon> ttx: thx
21:32:06 <ttx> vishy: bug # ?
21:32:10 <vishy> if i can track it down before the milestone it would be great
21:32:35 <vishy> bug 855350
21:32:36 <uvirtbot> Launchpad bug 855350 in xorg "long reprobes slow down boot/login (dup-of: 854986)" [Undecided,New] https://launchpad.net/bugs/855350
21:32:38 <uvirtbot> Launchpad bug 854986 in xserver-xorg-video-intel "[eDP1] 5 second delay between Xorg starting and the greeter starting (Dell Latitude E6410)" [High,Confirmed] https://launchpad.net/bugs/854986
21:32:39 <vishy> oops
21:32:44 <ttx> 862653 'VDI resize failed' errors on nova-compute (XenServer) ?
21:32:50 <vishy> bug 855030
21:32:51 <uvirtbot> Launchpad bug 855030 in nova "Encountering sporadic AMQPChannelException" [Undecided,Incomplete] https://launchpad.net/bugs/855030
21:32:53 <bcwaldon> vishy, ttx: this needs to get in to milestone -> 886281
21:32:56 <vishy> there we go :_
21:33:07 <vishy> bug 886281
21:33:07 <uvirtbot> Launchpad bug 886281 in nova "zone_manager uses LOG which isn't defined" [Medium,Triaged] https://launchpad.net/bugs/886281
21:33:25 <bcwaldon> I'm going to approve it after my tests finish
21:33:30 <bcwaldon> +1 that is
21:33:48 * ttx adds it to the list then
21:33:55 <vishy> bcwaldon: ok where is the code?
21:34:01 <bcwaldon> https://review.openstack.org/#change,1424
21:34:09 <bcwaldon> one line change
21:34:15 <ttx> vishy: the AMQPException is definitely nice to have if you can nail it
21:34:47 <vishy> ttx: yes working on it :)
21:34:52 <vishy> it is a tricky bugger
21:34:57 <ttx> no kidding
21:35:24 <ttx> vishy: Anything else ?
21:35:33 <vishy> i think that is it
21:35:41 <ttx> Nova subteam leads: anything you want to mention ?
21:36:12 <_0x44> Yes
21:36:14 <bcwaldon> I'm here to answer any questions about the compute api, if there are any
21:36:32 <_0x44> -db meeting didn't happen yesterday due to lack of attendance, so we rescheduled it for Thursday at 00:00UTC
21:36:42 <bcwaldon> whoops, sorry I missed that :(
21:37:18 <_0x44> bcwaldon: It's okay, if it happens again we're moving the db to be backed by flat files and perl scripts.
21:37:22 <_0x44> bcwaldon: :D
21:37:25 <bcwaldon> excellent
21:37:32 <ttx> Questions on Nova ?
21:37:54 <vishy> _0x44: ugh my bad
21:38:12 <ttx> The gCal is your friend.
21:38:14 <_0x44> vishy: I assumed you were at cloud-expo handling the press :)
21:38:15 <comstud> vishy: i'll be looking at that amqp thing again more tonight/tomorrow
21:38:16 <jsavak> nova quesiton here -
21:38:29 <jsavak> can we get review of RBAC prototype functionality in #link https://github.com/ziadsawalha/keystone/
21:38:30 <vishy> comstud: cool. I'm going to try and repro it on two boxes today
21:38:36 <comstud> same
21:38:38 <comstud> i got oneiric installed
21:38:51 <comstud> i can't reproduce it on squeeze
21:38:54 <ttx> vishy: if you have a fix for the AMQP thing we can backport it to the milestone-proposed branch: it's set to release Thursday.
21:39:05 <vishy> ttx: good deal
21:39:15 <vishy> comstud: i think it only happens on multi-machine install
21:39:22 <vishy> comstud: i can't repro it on 1 box
21:39:42 <comstud> You could with parallel tests, though, i thought
21:39:53 <comstud> I can't even get that with squeeze.
21:39:55 <_0x44> vishy: ttx: Yeah, good call, sending one now.
21:40:49 <vishy> comstud: not convinced that is the same issue. I will let you know what i discover
21:40:49 <ttx> _0x44: if you keep http://wiki.openstack.org/Meetings up to date, I'll keep the gCal up to date :)
21:40:53 <comstud> I'm sure it's not an OS distro thing.. I'm just stuck trying anything I can to reproduce it with tests
21:40:57 <comstud> Ah k
21:41:06 <ttx> ok, we need to move on
21:41:36 <ttx> #help nova devs to review RBAC prototype functionality at https://github.com/ziadsawalha/keystone/
21:41:42 <ttx> #topic Horizon status
21:41:54 <jsavak> ttx: thanks
21:41:58 * heckj puts on his devcamcar hat
21:42:09 <ttx> #link https://launchpad.net/horizon/+milestone/essex-1
21:42:18 <ttx> Two incomplete blueprints still targeted at essex-1:
21:42:29 <ttx> https://blueprints.launchpad.net/horizon/+spec/frontend-testing
21:42:33 <ttx> https://blueprints.launchpad.net/horizon/+spec/javascript-unit-tests
21:42:50 <heckj> we're most ready for the cut tomorrow - a few bugs with the modular architecture work in the queue right now
21:42:51 <ttx> heckj: should they just be postponed to essex-2 ?
21:43:08 <heckj> Yes - good starts, but we'll retarget those back
21:43:31 <ttx> I'l push them back if they are not complete tomorrow morning.
21:43:53 <heckj> ttx: thanks - I can't seem to edit them directly
21:44:17 <ttx> ask devcamcar to add you in the Horizon Drivers group.
21:44:23 <heckj> K
21:44:33 <ttx> So I assume Horizon is OK to branch tomorrow
21:44:44 <heckj> ttx: yep, we're looking pretty good
21:44:48 <ttx> if anything critical comes in, we can backport to the created milestone-proposed branch
21:45:27 <ttx> The idea being to exercise the temporary release automation from jeblair/mtaylor tomorrow early
21:45:46 <ttx> heckj: Anything else ?
21:46:14 <heckj> lots of good new feature - listed on the blueprints, so I won't repeat. Good progress on all fronts.
21:46:19 <heckj> Questions re: Horizon?
21:46:45 <ttx> Good. Looks like all affected core projects are good to go for essex-1.
21:46:52 <ttx> #topic Incubated projects and other Team reports
21:47:00 <ttx> danwent: o/
21:47:10 <ttx> that's call good timing.
21:47:13 <danwent> :)
21:47:16 <ttx> ed*
21:47:27 <danwent> we're just wrapping up essex-1
21:47:40 <danwent> thanks for folks from nova for reviews on quantum manager
21:47:52 <ttx> danwent: Melange was just accepted for Incubation, btw, so you're not alone anymore.
21:47:55 <danwent> still have a good number of quantum-only reviews to finish
21:48:06 <danwent> ah, great. it was getting loney here :)
21:48:19 <medberry> It's always loony here.
21:48:39 <danwent> :)
21:48:41 <danwent> https://launchpad.net/quantum/+milestone/essex-1
21:48:49 <ttx> danwent: shows a lot of "needs code review"
21:48:52 <danwent> all major features are implemented or in review, so we're doing pretty well.
21:49:08 <danwent> yeah, some of those are out of date. will update
21:49:30 <danwent> we also had a big packaging branch come in, which stalled some of the other reviews.
21:49:32 <ttx> danwent: remember that fore core the features actually need to land a bit earlier, to allow for one/two days of baking into milestone-proposed
21:49:46 <danwent> k
21:49:51 <ttx> danwent: not that it affects you right now, just for potential future :)
21:50:02 <danwent> yup, we're definitely shooting for core, so will keep in mind
21:50:05 <ttx> Any other team lead wanting to report status ?
21:50:39 <troytoman> we'll start reporting on Melange next week
21:50:50 <ttx> CI/QA/Doc/Community ?
21:50:51 <annegentle> ttx: I have a late entry to the agenda
21:51:00 <zul> so melange is core now as well?
21:51:02 <annegentle> #topic draft APIs
21:51:11 <ttx> annegentle: ow
21:51:13 <medberry> zul, melange is now incubated
21:51:17 <annegentle> We have three projects that need to have draft API docs (for a new API version) published during the Essex timeframe. (Quantum, Glance, and Nova)
21:51:18 <troytoman> Melange is incubated
21:51:24 <annegentle> ttx: sorry for the late entry :)
21:51:48 <annegentle> I'd like to get ideas about where those should be published - and whether there's a special treatment for "RFC" vs. "Draft" designations.
21:51:50 <ttx> What's the point of preparing all those open tabs if people change things at the last minute ! :)
21:51:55 <annegentle> Do these need drafts need to be published to http://docs.openstack.org/api, or is that site for "final" APIs for end-users? Do these API drafts need their own site for the RFC period?
21:52:21 <annegentle> I can also ask on the mailing list but wanted to bring it up here for ideas.
21:52:52 <ttx> annegentle: you need feedback from the PTLs, and some of them already disappeared. So maybe ML
21:53:14 <annegentle> ttx: okay.
21:53:39 <ttx> #action annegentle to raise ML thread about draft APIs
21:54:03 <ttx> #topic Open discussion
21:54:24 <zul> nova-ec2-api team just formed woot!
21:54:44 <ttx> zul: cool !
21:54:57 <ttx> Now I didn't tag all those bugs "ec2" for nothing.
21:54:59 <annegentle> zul: great to hear!
21:55:07 <bcwaldon> zul: awesome! I would love for all members of the nova-ec2-api team to attend nova-api meetings
21:55:08 <tr3buchet> hollar!
21:55:33 <ttx> bcwaldon: or at least one
21:55:45 <bcwaldon> ttx: If I ask for all, I should get at least one ;)
21:56:06 <ttx> hopefully.
21:56:24 <medberry> bcwaldon, when/where is nova-api meetings?
21:56:35 <ttx> medberry: http://wiki.openstack.org/Meetings
21:56:38 <bcwaldon> medberry: had one last friday here, havent established a recurring time yet
21:56:46 <medberry> nod. tx.
21:56:49 <bcwaldon> medberry: it will be at that link ttx posted once we figure it out
21:57:05 <ttx> medberry: I live in the future.
21:57:16 <ttx> (and there are no roads)
21:57:41 <medberry> :)
21:58:06 <ttx> Last note: you should have received a survey from the rax events team about your experience at the design summit / conference
21:58:24 <ttx> Please make sure to fill it so that everyone knows the wifi really sucked.
21:59:01 <ttx> and on those words...
21:59:06 <ttx> #endmeeting