21:04:05 <annegentle> #startmeeting
21:04:06 <openstack> Meeting started Mon Nov 14 21:04:05 2011 UTC.  The chair is annegentle. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:04:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:04:15 <annegentle> Let's start 'er up. :)
21:04:40 <annegentle> I'll walk through the Agenda here: http://wiki.openstack.org/Meetings/DocTeamMeeting
21:04:42 <annegentle> #link http://wiki.openstack.org/Meetings/DocTeamMeeting
21:05:06 <annegentle> The action item from last time was in September! So we did meet in October at the Design Summit, the action item was to set that up.
21:05:22 <annegentle> #topic Status updates
21:05:42 <annegentle> Just some items to report about the openstack-manuals project.
21:05:48 <annegentle> #info The openstack-manuals project now has a stable/diablo branch so we can publish admin guides to both http://docs.openstack.org/diablo and http://docs.openstack.org/trunk
21:06:02 <annegentle> Razique and I have been working through a good workflow for backporting fixes to Diablo.
21:06:11 <annegentle> So far it's a bit confusing but we're getting there.
21:06:24 <annegentle> So we are updating both sites simultaneously
21:06:48 <annegentle> Also, we can now use a revision history table to publish an atom feed of updates to a guide.
21:06:54 <annegentle> #info: We can now use a revision history table to publish an atom feed of updates to a guide.
21:07:10 <annegentle> We're currently trying it on the Compute API document at http://docs.openstack.org/api/openstack-compute/1.1/content/
21:07:21 <annegentle> So if you click through on that link, there's now an orange RSS feed icon
21:07:31 <annegentle> it goes to here: #link http://docs.openstack.org/api/openstack-compute/1.1/atom.xml
21:07:44 <annegentle> which is generated from source XML in the book file itself
21:08:08 <annegentle> #info The atom feed is generated from a revision history table in the book XML file.
21:08:10 <nati2> Cool!
21:08:35 <annegentle> I'd like to get this on all books, so I'll send an email to the mailing list for feedback. Right now the placement of the RSS icon is a little off to me.
21:09:04 <annegentle> #action Anne to send email to mailing list about how to make an RSS feed available for a manual
21:09:31 <annegentle> #info On Friday 11/11/11 we held a Hackathon in Austin and experimented with epub output through our toolchain.
21:09:55 <joesavak> woo hoo
21:09:58 <annegentle> We can get epub - still have to do some post-processing for mobi (which is Kindle's format) and don't get our nice cover pages.
21:10:07 <annegentle> But it is super cool and the team did a ton of work in a day!
21:10:39 <annegentle> Would love ideas for what to publish to epub- all the books? Just the Starter Guide? Another narrative book? Lots of ideas welcomed.
21:11:41 <joesavak> i say do them all
21:12:07 <annegentle> I moved around the figures/ source so that the reference to figures in the DocBook source will be epub compatible today.
21:12:18 <annegentle> so we could do them all once the covers are figured out.
21:12:44 <annegentle> #topic Reviews
21:13:10 <annegentle> Reviews are going well, I'm always impressed by Razique and heckj jumping in on reviews, appreciate the work there.
21:13:41 <annegentle> I'm also trying to keep my eye on reviews in other projects that contain doc work, so additional eyes are always helpful.
21:13:49 <annegentle> #topic Doc bugs
21:14:07 <annegentle> I'm creating doc bugs out of doc comments, hence the jump in bugs.
21:14:33 <annegentle> #link https://bugs.launchpad.net/openstack-manuals
21:14:43 <annegentle> if you want to take a look at the backlog.
21:14:54 <annegentle> #topic Open discussion
21:15:00 <annegentle> What else is on your minds?
21:15:21 <joesavak> api.openstack.org blueprint
21:15:52 <joesavak> https://blueprints.launchpad.net/openstack-manuals/+spec/api.openstack.org
21:15:54 <annegentle> Ah yes, thanks joesavak. So for deshantm_laptop and others, we are trying to come up with a blueprint for the site that helps people learn the APIs.
21:16:21 <deshantm_laptop> cool
21:16:24 <joesavak> jheck is putting together wireframes - we'll be asking for feedback soon
21:16:30 <annegentle> We welcome input on it, definitely.
21:17:24 <annegentle> # info There's a blueprint for the site that helps people learn the APIs.
21:17:29 <annegentle> #link https://blueprints.launchpad.net/openstack-manuals/+spec/api.openstack.org
21:17:52 <annegentle> #info Blueprint for site that helps people learn the OpenStack APIs forthcoming, with wireframe design, feedback welcome.
21:18:01 <annegentle> gotta get the notes right! :)
21:18:06 <joesavak> lol
21:18:18 <annegentle> deshantm_laptop: I'd love to hear how the 10/26 Xen doc day went!
21:18:47 <deshantm_laptop> annegentle: For what I heard it went really well
21:19:11 <deshantm_laptop> I'll dig up the blog post on it
21:19:27 <deshantm_laptop> i had a thought about the api stuff though
21:19:59 <deshantm_laptop> XCP provides a decent way to access the API on a live system
21:20:16 <deshantm_laptop> it is clickable
21:20:26 <deshantm_laptop> let me see if I can find an example
21:20:55 <annegentle> deshantm_laptop: oh very cool, would love to see the example.
21:21:04 <annegentle> so far we're looking at dev.twitter.com as an example site.
21:21:09 <deshantm_laptop> by the way, xen.org is migrating to a new wiki too
21:22:25 <annegentle> deshantm_laptop: ah good to know
21:22:53 <annegentle> okay, that was all I had for today.... until we meet again next month.
21:23:41 <deshantm_laptop> annegentle: I'll email you offline when I find the info
21:24:53 <annegentle> deshantm_laptop: ok, thanks!
21:25:04 <annegentle> Alright, then - thanks for meeting!
21:25:07 <annegentle> #endmeeting