21:03:05 <ttx> #startmeeting
21:03:06 <openstack> Meeting started Tue Nov 15 21:03:05 2011 UTC. The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:03:07 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:03:11 <ttx> Welcome to our weekly general meeting... Today's agenda:
21:03:16 <ttx> #link http://wiki.openstack.org/Meetings/TeamMeeting
21:03:36 <ttx> #info The main focus for today is looking at essex-2 plans and make sure they are current
21:03:45 <ttx> #info Next week we'll extend that focus to the rest of the Essex plans, as the demand for clear roadmap is getting stronger
21:03:53 <ttx> #topic Keystone status
21:03:59 <ttx> zns: Looking at:
21:04:04 <ttx> #link https://launchpad.net/keystone/+milestone/essex-2
21:04:12 <ttx> zns: Do you agree with those 6 targets ?
21:04:55 <ttx> Including global-templates, keystone-swift-acls and service-endpoint-location ?
21:05:30 <zns> Yes.
21:05:38 <ttx> OK, I'll set the series goal for those last three to "Essex" then
21:05:50 <ttx> zns: Anything else on your essex-2 radar that is missing from the list ?
21:06:34 <zns> We still have an outstanding *concern* about stability/documentation. Dolph is in California now trying to help nail that down. It's nebulous right now.
21:06:58 <ttx> zns: Who is supposed to work on endpoint-identifiers ? The spec has no assignee.
21:07:23 <zns> Dolph or Yogi.
21:07:39 <zns> Maybe put Yogi there for now?
21:07:48 <ttx> zns: yes, or some team like "Rackspace Integration"
21:08:00 <ttx> it's ok to change assignees later.
21:08:02 <zns> works. Rackspace Integration. You got it?
21:08:13 <ttx> yep
21:08:18 <ttx> Also does anyone know the current state of service-endpoint-location ? Started ? Not started ?
21:09:02 <ttx> will try to find someone at HP to update that
21:09:25 <ttx> Our second keystone topic for today is the state of the stable/diablo branch
21:09:39 <ttx> I'd like to make sure every downstream is fine with it the way it stands, before it's tagged
21:09:47 <ttx> (and a tarball is made of it)
21:09:48 <zns> ttx: is that what anotherjesse is speaking to at the PPB next week?
21:10:30 <ttx> zns: hmmm... no? I asked anotherjesse to be present to /this/ meeting to discuss it.
21:10:36 <anotherjesse> i'm here
21:10:41 <anotherjesse> just dropped for 3 minutes
21:10:52 <zns> Ah. OK. Good.
21:10:52 <anotherjesse> the stable/diablo proposed branch works for us
21:11:09 <ttx> anotherjesse: great news
21:11:25 <ttx> Ideally I'd like to hear devcamcar as well
21:11:27 <joesavak> +1
21:11:31 <joesavak> (yay)
21:11:34 <jaypipes> ttx: wasn't there a patch applied to diablo/stable before trunk?
21:11:36 <anotherjesse> ttx: agree to devcamcar would be good
21:11:57 <anotherjesse> ttx: perhaps the canoncial guys as well?
21:11:59 <ttx> jaypipes: not sure what you mean
21:12:20 <jaypipes> ttx: thought I saw something this morning about a changeset being applied to keystone's stable/diablo before hitting trunk...
21:12:29 <jaypipes> that was causing a block?
21:12:47 <jaypipes> maybe I'm going crazy (definitely could be true)
21:12:51 <dolphm> jaypipes: yes, that was my mistake... i put them into both branches together, and jenkins issues caused them to land backwards
21:13:02 <ttx> jaypipes: it's not causing a block. There is a change that was pushed to both branches... but only merged successfully in stable/diablo
21:13:03 <jaypipes> oh, ok, sanity restored :)
21:13:08 <jaypipes> got it.
21:13:12 <jaypipes> ok, carry on
21:13:42 <ttx> #action ttx to contact Canonical folks to make sure stable/diablo keystone looks good for them
21:14:01 <ttx> let's see if we can get devcamcar by the end of this meeting
21:14:05 <ttx> zns: Anything else ?
21:14:12 <zns> ttx: not from me.
21:14:15 <zns> Tx
21:14:18 <devcamcar> ttx: i'm here now
21:14:35 <ttx> devcamcar: did you have the opportunity to test Keystone stable/diablo branch ?
21:15:25 <devcamcar> ttx: we've been using it internally for a bit now and it's good to go as far as we can tell
21:15:46 * ttx sees red lights turn to green with pleasure.
21:15:53 <dolphm> good to hear
21:16:00 <zns> awesomeness
21:16:10 <ttx> dolphm: I'll try to get Ubuntu folks to sign off on it as well
21:16:16 <ttx> and then we should be good
21:16:19 <dolphm> great
21:16:21 <ttx> Daviey: around ?
21:16:31 <ttx> Other questions for Keystone ?
21:17:09 <ttx> s/Ubuntu/distro/ actually
21:17:24 <ttx> not necessarily limited to Ubuntu
21:17:33 <ttx> #topic Swift status
21:17:39 <ttx> notmyname: o/
21:17:42 <notmyname> hi
21:17:54 <ttx> Looks like we are on track for branching to milestone-proposed on Friday and releasing next Tuesday ?
21:18:13 <notmyname> everything looks good. a few more patches to merge
21:18:16 <ttx> #link https://launchpad.net/swift/+milestone/1.4.4
21:18:30 <notmyname> our internal QA will be taking a whack at it starting soo
21:18:52 <notmyname> should be a good release. good features and bug fixes
21:18:59 <ttx> notmyname: if anything is blocking, make sure to use the 1.4.4 target sothat it appears on the page
21:19:13 <ttx> so that I know that it's blocked without having to ping someone about it :)
21:19:30 <ttx> notmyname: Anything else ?
21:19:34 <notmyname> I think we're good. I'll check again in the morning, but it looks good
21:19:43 <notmyname> the memory leak I mentioned last week
21:19:49 <notmyname> just wanted to give an update
21:20:35 <notmyname> we (meaning mostly gholt) have been looking at a lot of stuff. we've patched several things in swift and eventlet. the eventlet patch is good, but probably not the major problem we were seeing
21:20:44 <notmyname> testing is continuing
21:20:52 <notmyname> but things are looking promising
21:21:22 <ttx> cool, continue to keep us posted
21:21:24 <notmyname> the eventlet summary is that you should upgrade when the patch hits mainline, but not huge rush there (especially if you aren't using it under very high load like we are)
21:21:47 <jaypipes> notmyname: symptoms?
21:21:48 <notmyname> last thing
21:22:01 <notmyname> jaypipes: proxy servers running out of memory
21:22:10 <jaypipes> k.
21:22:18 <notmyname> jaypipes: after <redacted> req/sec for a while
21:22:20 <jaypipes> notmyname: just proxy servers? not the other servers?
21:22:26 <notmyname> ya
21:22:30 <jaypipes> got it.
21:22:39 <notmyname> well, they see the highest load since there are much less of them
21:22:52 <notmyname> last thing from me:
21:23:01 <jaypipes> notmyname: and they also have to deal with disconnects with the end client the most, right?
21:23:19 <notmyname> I'm working on setting up a swift-focused meetup in the bay area in early december. stay tuned for details
21:23:35 <ttx> Other questions on Swift ?
21:23:49 <notmyname> jaypipes: it's mostly the asymmetry in the deployment. but disconnects are an issue too
21:24:07 <jaypipes> notmyname: no more questions, but I'll follow that stuff closely since Glance uses quite a bit of Swift code...
21:24:18 <jaypipes> thx
21:24:23 <ttx> Good transition !
21:24:24 <ttx> #topic Glance status
21:24:27 <jaypipes> lol
21:24:33 <ttx> #link https://launchpad.net/glance/+milestone/essex-2
21:24:41 <jaypipes> Danger Will Robinson.
21:24:44 <ttx> jaypipes: 11 blueprints ! Sounds ambitious.
21:24:57 <jaypipes> Yeah, E2 was a bit of a dumping ground
21:25:10 <jaypipes> ttx: I'll take a gander through them and retarget some to E3.
21:25:11 <ttx> does that mean you need to refine it a bit ?
21:25:15 <ttx> ok
21:25:30 <jaypipes> ttx: mostly was a braindump for me making blueprints after feedback on the API 2 drafts.
21:25:34 <ttx> You should have assignees for all those you keep for E2
21:25:38 <jaypipes> yup.
21:25:46 <jaypipes> ttx: I'll clean up by next week.
21:25:50 <ttx> #action jaypipes to refine E2 list and set assignees
21:26:03 <ttx> Another question: Do you agree https://blueprints.launchpad.net/glance/+spec/swift-location-credentials is complete and already delivered in essex-1 ?
21:26:29 <jaypipes> looking...
21:27:12 <jaypipes> ttx: yep, I'll update that one.
21:27:18 <ttx> jaypipes: Anything else ?
21:27:44 <jaypipes> ttx: just that draft 3 of the API 2 proposal is in progress... thx to all who responded with feedback
21:27:46 <ttx> jaypipes: I'm on it (the update)
21:27:52 <jaypipes> ttx: ok, thx
21:28:54 <ttx> Questions on Glance ?
21:29:14 <ttx> (a bit tricky this I have to reactivate e1 to retarget things to it)
21:29:56 <ttx> #topic Nova status
21:30:02 <ttx> vishy: yo
21:30:08 <ttx> #link https://launchpad.net/nova/+milestone/essex-2
21:30:26 <ttx> vishy: There are a few BPs in there assigned to a generic Nova subteam...
21:30:38 <vishy> hi
21:30:40 <ttx> Which sounds like a recipe for nobody actually doing it.
21:30:50 <vishy> ttx: yes I'm trying to clean those up currently
21:30:56 <ttx> I'm ok to keep the team as the "Drafter", but I'd prefer to have a more precise developer name or group assigned to actually write the code for it
21:31:10 <ttx> (at least for the current milestone�
21:31:11 <ttx> )
21:31:20 <vishy> woah
21:31:28 <ttx> woah?
21:31:39 <vishy> yes I will contact all of the teams and get those updated
21:31:55 <vishy> (my irc client didn't like the encoding on your last comment)
21:32:11 <ttx> #action vishy to turn team-owned E2 blueprints into more precise assignments)
21:32:13 <Vek> heh
21:32:17 <ttx> � �
21:32:36 <ttx> vishy: There are a few things started, without a target, that may actually apply to essex-2:
21:32:45 <ttx> https://blueprints.launchpad.net/nova/+spec/remove-virt-driver-callbacks (blamar?)
21:32:49 <ttx> https://blueprints.launchpad.net/nova/+spec/internal-uuids (Titan team?)
21:32:54 <ttx> https://blueprints.launchpad.net/nova/+spec/nova-volume-snapshot-backup-api (Nova volume ?)
21:33:25 <ttx> vishy: do you know if those should be complete by E2 ?
21:33:37 <vishy> targeted
21:33:41 <vishy> yes they should all be
21:33:43 <soren> Whiteboard of https://blueprints.launchpad.net/nova/+spec/remove-virt-driver-callbacks says it's done.
21:33:58 <soren> Gerrit agrees: https://review.openstack.org/#change,1100
21:34:09 <vishy> yes was merged
21:34:17 <ttx> soren: too bad it wasn't set to Implemented then
21:34:25 * ttx goes to steal more LP karma
21:34:38 <ttx> yay
21:34:51 * Vek thinks ttx still won't surpass tr3buchet's karma
21:34:53 <ttx> vishy: last thing: what priority should https://blueprints.launchpad.net/nova/+spec/melange-notifications have ?
21:34:55 <vishy> darn you beat me
21:35:06 <vishy> i think we are obsoleting that one
21:35:25 <vishy> since melange moved to path to incubation
21:35:44 <ttx> #action vishy to confirm melange-notifications obsolescence and remove it from E2
21:35:51 <ttx> I also wanted to ask about reviews...
21:35:51 <tr3buchet> ttx: i had planned on updating the melange blueprints to that effect
21:35:53 <vishy> tr3buchet is working with melange guys to get that stuff removed (and recreated in the melange project?)
21:36:11 <ttx> you can actually reassign a blueprint to another project.
21:36:16 <tr3buchet> ttx: i've confirmed that any of the melange stories which are associated with nova-network are removable
21:36:23 <ttx> tr3buchet: if needed, ping me off-meeting
21:36:33 <tr3buchet> will do
21:36:35 <ttx> There are 60 open reviews on Nova, apparently due to too many stale reviews
21:36:51 <ttx> With LP we had some convenient way to shelve out of sight those things needing work before being reproposed, by setting back to WorkInProgress
21:37:06 <ttx> Should we find some way to emulate that with Gerrit ? (mtaylor, jeblair ?)
21:37:15 <westmaas> ttx: is your script that generates ordered reviews still usable after the sqitch?
21:37:23 <westmaas> switch*
21:37:33 <ttx> westmaas: no. But I guess I could make it extract data from Gerrit
21:37:38 <mtaylor> ttx: you can abandon a review
21:37:47 <vishy> ttx: ooh, i like the idea of WiP
21:37:52 <mtaylor> ttx: we have a todo list item to add a work in progress state
21:38:12 <Vek> mtaylor: can you abandon a review that someone else has proposed, though?
21:38:22 <mtaylor> Vek: I believe that _I_ can :)
21:38:24 <devcamcar> mtaylor: i've been meaning to ask you - i don't get notifications for gerrit merge proposals (i have checked like every-darn-thing)
21:38:25 <ttx> mtaylor: I just want the "open" reviews to reaklly be the dashboard of reviewable things.
21:38:33 <mtaylor> ttx: I agree
21:38:38 <devcamcar> mtaylor: but can ask in a bit :)
21:38:40 <westmaas> ttx: I liked that view, not sure if others did, nor do I know the level of work needed to make it work
21:38:48 <mtaylor> devcamcar: hrm. let's circle back on that after the meeting
21:38:54 <ttx> westmaas: I'll have a shot at it.
21:39:08 <Vek> mtaylor: glance isn't sending notifications of new reviews either, but I'm getting them for nova.
21:39:28 <ttx> westmaas: code was at https://code.launchpad.net/~ttx/+junk/reviewlist fwiw :)
21:40:15 <ttx> #action mtaylor to raise prio on implementing a WiP state
21:40:28 <ttx> #action ttx to see how reviewslist can be revived
21:40:28 <mtaylor> Vek: are you subscribed to the glance project ?
21:40:39 <ttx> vishy: Anything else ?
21:40:42 <mtaylor> Vek: in https://review.openstack.org/#settings,projects ?
21:40:46 <mtaylor> devcamcar: ^^
21:40:49 <Vek> mtaylor: dunno what that means. I remember I used to get them, now I don't...
21:41:02 <vishy> ttx: the thing you emailed me about?
21:41:02 <ttx> Vek, mtaylor, devcamcar -> off-meeting please
21:41:05 <bhall> mtaylor: I have the same issue.. I subscribe to nova reviews but it keeps losing my setting
21:41:11 <mtaylor> ok. off meeting
21:41:14 <vishy> ttx: for targetting blueprints differently
21:41:15 <mtaylor> find me in openstack-dev in a sec
21:41:21 <ttx> vishy: want to mention that ?
21:41:36 <vishy> ttx: seems like it would be good to mention it in an info
21:41:42 <ttx> vishy: we can JFDI and write an email too :)
21:41:49 <vishy> email is fine
21:41:53 <vishy> continue
21:42:02 <ttx> Nova subteam leads: anything you want to mention ?
21:42:40 <ttx> Questions on Nova ?
21:43:20 <ttx> #topic Horizon status
21:43:25 <ttx> devcamcar: o/
21:43:28 <devcamcar> o/
21:43:29 <ttx> #link https://launchpad.net/horizon/+milestone/essex-2
21:43:37 <ttx> Looks good -- though you should have assignees.
21:43:53 <ttx> If you know for example the team at Nebula will take care of it, but don't know who exactly will do it, you should assign to some Nebula group
21:44:06 <ttx> and then you can change to someone more precise when you know who.
21:44:16 <ttx> I just need to know who I can ping for status updates :)
21:44:18 <devcamcar> have assignees for blueprints, though the huge number of UX bugs that were filed recently haven't been triaged yet
21:44:24 <ttx> "null" never answers to me.
21:44:28 <devcamcar> fair enough
21:44:34 <devcamcar> i'll get assignees on those
21:44:48 <devcamcar> we're tearing into the visual re-design, may have some cool screenshots by next week's meetings
21:44:59 <ttx> devcamcar: again, you can set a supergroup if you know "someone in that group" will do it
21:45:35 <ttx> #action devcancar to get assignees for the E2 plan
21:45:45 <ttx> #action devcamcar to get assignees for the E2 plan
21:45:53 <ttx> devcamcar: Anything else ?
21:46:09 <devcamcar> ttx: nope, pretty quiet week for us, just tearing everything apart and putting it back together :)
21:46:17 <ttx> devcamcar: sounds like fun
21:46:20 <devcamcar> oh yea
21:46:20 <ttx> Questions for Horizon ?
21:47:18 <ttx> devcamcar, mtaylor: we need to get the repo split (python-module / ref impl) done by E2, btw
21:47:43 <devcamcar> ttx: i seriously will fight you guys to the death on that, no offense
21:47:55 <mtaylor> devcamcar: oh? heckj lied to us then
21:47:57 <devcamcar> it makes development about an order of magnitude more difficult
21:48:07 <devcamcar> mtaylor: that is certainly possible
21:48:11 <ttx> devcamcar: I thought there was an agreement around that
21:48:24 <devcamcar> that's how it used to be
21:48:25 <ttx> mtaylor: back to the bribe table
21:48:30 <devcamcar> used to be 2 separate projects
21:48:39 <devcamcar> i combined them because of what a gargantuan pain it was
21:48:51 <devcamcar> both on the dev and on the support side
21:48:54 <mtaylor> devcamcar: the issue is that it makes distribution/packaging harder - but this might be a longer conversation than in here
21:49:04 <mtaylor> (plus, you didn't have me automating your life away back then :) )
21:49:16 <devcamcar> mtaylor: agreed, is a longer conversation
21:49:17 <ttx> #action mtaylor devcamcar to discuss and converge to a common view on the need to split repos for horizon (or not)
21:49:32 <devcamcar> i'm not completely opposed but it can't be like it was before
21:49:36 <devcamcar> too painful
21:49:51 <mtaylor> I agree. I want to solve problems, not create them
21:49:57 <mtaylor> although I know some people probably disagree :)
21:50:02 <ttx> I know some distros are waiting for the dust to settle before packaging Horizon.
21:50:20 <ttx> so I'd like the decision taken in time for E2
21:50:34 <mtaylor> I imagine we can sort it out in short order - just probably not in here
21:50:41 <ttx> agreed
21:50:43 <ttx> #topic Incubated projects and other Team reports
21:50:51 <ttx> danwent, troytoman: o/
21:50:56 <danwent> #info Quantum essex-1 dropped last week (https://launchpad.net/quantum/+milestone/essex-1). Major new items included packaging support (RPM/DEB), DHCP support in Quantum Manager, keystone middleware, and devstack integration. If you are interested in packaging Quantum for your distro, please contact us.
21:51:16 <danwent> other than that, essex-2 is now open: https://launchpad.net/quantum/+milestone/essex-2
21:51:34 <danwent> we'll be coordinating with Trey and the nova-network folks on some more work that needs to be done on QuantumManager in nova.
21:51:48 <ttx> danwent: you mean you include packaging code in Quantum itself ?
21:52:05 * ttx downloads tarball.
21:52:10 <danwent> yes, the ability to generate debs/rpms
21:52:12 <bhall> yep
21:52:21 <danwent> is that not kosher? :)
21:52:29 <soren> eep
21:52:32 <soren> Not quite :)
21:52:33 <ttx> danwent: it's generally frowned upon
21:52:44 <soren> It's less of a problem nowadays, but it's still frowned upon.
21:53:06 <ttx> #action distro people to look into Quantum packaging integration effort to see if it can work with them
21:53:09 <danwent> Ok, who should we work with on this?
21:53:13 <danwent> great
21:53:19 <ttx> danwent: I'll make them contact you
21:53:42 <danwent> sounds good
21:53:51 <ttx> troytoman: any news on Melange side ?
21:54:04 <troytoman> wrt melange, have mostly been focused on getting the project set up on launchpad and moving over blueprints
21:54:19 <troytoman> this week will engage with mtaylor on gerrit integration
21:54:44 <ttx> troytoman: I'll have a circular look and see if anything needs to be set up additionally
21:55:00 <ttx> #action ttx to look up Melange setup and help where needed
21:55:03 <troytoman> thanks ttx
21:55:16 <ttx> troytoman: do we have code up yet ?
21:55:51 <troytoman> it is on github but needs to be moved into the openstack repo
21:55:57 <ttx> ok
21:56:00 <ttx> Any other team lead with a status report ?
21:56:09 <annegentle> me!
21:56:19 <ttx> annegentle: go for it!
21:56:29 <annegentle> A couple of doc items to report, we met yesterday for our monthly meeting.
21:56:31 <annegentle> A new feature in the doc tool chain lets us publish an RSS feed for a manual based on a hand-maintained revision history.
21:56:55 <annegentle> See it at http://docs.openstack.org/api/openstack-compute/1.1/content/ and I'll also send an email to the mailing list to solicit feedback.
21:57:14 <annegentle> On Friday 11/11/11 a few Rackers held a Hackathon in Austin and experimented with epub output through our toolchain.
21:57:44 <annegentle> Just a few bugs to work through for "prettiness" but a decent output to add to the tool box.
21:58:14 <ttx> sounds cool
21:58:14 <annegentle> Lastly, we have a new blueprint for a site that helps people learn the OpenStack APIs, with wireframe design coming soon and feedback is welcome. https://blueprints.launchpad.net/openstack-manuals/+spec/api.openstack.org
21:58:35 <ttx> sounds �ol.
21:58:52 <ttx> #topic Open discussion
21:58:59 <ttx> Anything, anyone ?
21:59:18 <ttx> Poll: is #openstack-dev channel too noisy with all the notifications for all the projects sent there ?
21:59:49 <jaypipes> ttx: not IMHO
21:59:54 <annegentle> I think it's okay
22:00:02 <jk0> yeah, it's not bad
22:00:28 <ttx> ok then.
22:00:43 <ttx> Time to give the floor to the network dudes.
22:00:48 <ttx> #endmeeting