22:01:09 <danwent> #startmeeting
22:01:10 <openstack> Meeting started Tue Nov 15 22:01:09 2011 UTC.  The chair is danwent. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:01:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
22:01:12 <edgarmagana> Hola!
22:01:18 <ttx> edgarmagana: hola!
22:01:21 <danwent> hello all!
22:01:22 <salv> Hi all!
22:01:31 <somik> Hello folks!
22:01:31 <GheAway> hi everyone
22:01:35 <danwent> #info agenda : http://wiki.openstack.org/Network/Meetings
22:01:44 <tylesmit> hi
22:01:53 <danwent> hey tyler, glad you could make it
22:01:55 <debo_os> hi
22:02:08 <danwent> ok, troy, you around?
22:02:08 <carlp> long time no see everyone
22:02:36 <danwent> this is the part where I skip the melange update and start on quantum, only to have troy then appear
22:02:43 <danwent> #topic quantum status
22:03:08 <danwent> #info great work on essex-1, it was released on thursday
22:03:14 <danwent> now we're on to essex-2
22:03:37 <danwent> we already have some reviews of things we decided not to do in essex-1: https://review.openstack.org/#q,status:open+project:openstack/quantum,n,z
22:04:02 <danwent> particularly, Salvatore's API framework stuff would be good to get reviewed ASAP, so we can make progress on other API work.
22:04:33 <danwent> salv says that this was refactored for the packaging work since the last set of reviews, so we should re-review and retest.
22:05:00 <salv> I'm not particularly concerned but the more the eyes, the better the code
22:05:13 <danwent> #info please target any essex-2 work using launchpad: https://launchpad.net/quantum/+milestone/essex-2
22:05:57 <danwent> A few areas that I think are missing blueprints for essex-2 are 1) jenkins + system test, 2) dashboard work.
22:06:08 <danwent> carlp, can you comment on plans for jenkins/system test?
22:06:14 <carlp> danwent: sure
22:06:30 <carlp> so we have the jenkins slave in place, and there are two nodes ready for testing
22:06:38 <carlp> At this point what we need are tests :)
22:07:02 <danwent> Ok, so let's get a BP for that.
22:07:11 <carlp> I think I already set one up
22:07:31 <danwent> great… is it targeted for essex-2?  (i.e., do i need to refresh) :P
22:07:42 <carlp> An excellent question
22:08:05 <carlp> I have this one: https://blueprints.launchpad.net/quantum/+spec/quantum-functional-tests
22:08:29 <carlp> it's kind of the master, I believe the quantum-functional-test-environment is what needs to be targeted to this release
22:09:05 <danwent> yes, that makes sense.
22:09:07 <danwent> I'll target it.
22:09:26 <carlp> Salvatore had some plans in Boston, but I don't know if they made it to code or even a BP
22:10:10 <salv> sorry I droppe for a bit.
22:10:12 <danwent> carlp: are you planning on creating functional tests yourself, or are you looking for others to do that?
22:10:14 <salv> Plans around what?
22:10:49 <carlp> To start with, I did not want to create some functional tests myself.  I was going to leave that to the experts :)
22:11:10 <carlp> That said, my long term goal is to become an expert
22:11:10 <danwent> Ok
22:11:31 <carlp> salv: plans around functional testing
22:11:37 <danwent> #todo #danwent create BP and find owner for initial set of functional tests targeted at essex-2
22:11:58 <salv> carlp: Ok. I haven't made any progress on that, and I don't think I'll have cycles to work on testing before essex-3
22:12:09 <carlp> ok, good to know
22:12:13 <edgarmagana> do the functional tests include both plugins?
22:12:24 <danwent> yeah, salv is pretty loaded with API work this cycle
22:12:25 <salv> I honestly hoped somebody else would pick the whole testing story (functional/integration/and scale)
22:12:54 <danwent> yup, we're looking for volunteers.  nicira will definitely be picking up some of the work, but would be great if others pitched in.
22:13:24 <danwent> edgar:  original plan was to just use OVS so there was no dependency on physical network gear
22:13:25 <carlp> I would like to do that, my day job has been eating a lot more of my time recently than I would like.  That will probably change as we get closer to the end of the year
22:13:43 <edgarmagana> dan: thanks!
22:13:46 <danwent> I believe mark voelker was planning on replicating a jenkins environment that had the right cisco hardware
22:14:15 <carlp> edgarmagana: The environment I've built can support OVS and the new VLAN manger.  Other stuff will need different environments.
22:14:41 <edgarmagana> FYI. Mark is on temporal LOA (He just became a father)
22:14:42 <salv> carlp: the new VLAN manager being the one I'm trying to build? :)
22:14:45 <carlp> I recall that as well, and if you're around Mark, shoot me an email and I'll help get you started
22:14:52 <carlp> salv: I believe so, yes
22:14:55 <danwent> edgar:  yup, you all should see the awesome pic
22:15:02 <salv> carlp: ok.
22:15:13 <edgarmagana> carlp: got it
22:15:28 <danwent> http://t.co/oV5vUZC
22:15:59 <danwent> Ok, anything else on jenkins work?
22:16:14 <carlp> Nope, I think that is about it
22:16:34 <danwent> k, salv: API work for essex-2, particular around "operational status"
22:16:51 <salv> Okay, the plan is to put into Essex-2 two items:
22:16:55 <salv> 1) Operational Status
22:17:00 <salv> 2) Filters for request
22:17:30 <salv> While I see Item #2 technically more challenging, it is actually easier as I just need to "borrow" code from Openstack API
22:17:45 <danwent> Great.  I talked with Anne.  She sent an email to the main openstack list about how to handle repos for future versions of API specs.
22:18:06 <salv> Item #1 is instead technically less challenging, but there's more discussion on it. I received good feedback on the spec I proposed, but (shame on me) never updated it.
22:18:14 <danwent> Do you plan on flushing out the API changes as modifiecations to the API docs in the repo, or do you want to publish them some other way?
22:18:53 <salv> danwent: good question. I will do whatever Openstack API has done for transition from 1.0 to 1.1
22:19:06 <salv> but I need to sync up with Anne on that
22:19:25 <danwent> great
22:19:27 <salv> #action Salvatore to sync up with Anne on best way for updating API doc
22:19:54 <danwent> Ok, anything else on API?
22:19:59 <salv> Now, on the operational status, the only thing we haven't probably thoroughly discussed is what the API should do if the plugin does not support
22:20:01 <danwent> Ying, were you looking at doing "tags"?
22:20:06 <salv> the concept of Operational status
22:20:23 <salv> but we can discuss that on the mailing list.
22:20:39 <danwent> sorry salv:  yes, ML is probably best for design discussions
22:20:57 <danwent> salv, anything else on API front?
22:21:02 <ying> danwent: I will check on tags for API,
22:21:09 <salv> no, that is all on the API
22:21:17 <danwent> ying: great.  is there already a BP for this?
22:21:37 <danwent> if not, please create one and target it
22:21:47 <ying> danwent: no, not yet.
22:22:01 <danwent> #action #ying create blueprint for API tags work
22:22:30 <danwent> Ok, mark is not here, but perhaps arvind or tyler can comment on plans around Quantum + Dashboard?
22:22:54 <tylesmit> I don't see Arvind here, and I'm not in the loop on Dashboard.
22:23:01 <danwent> thanks tyler
22:23:21 <danwent> #action #danwent send email to ML about dashboard work for essex-2
22:23:43 <danwent> I think this is a really important area to make progress on in essex-2, as dashboard is the most visible way to demo Quantum
22:24:12 <danwent> Ok, somik, do you need to fill-out the BP for the authz work?
22:24:36 <somik> I have a placeholder BP with the non ideal mechanism to handle authZ
22:24:54 <somik> but I will fill out the ideal way, where we would require nova changes as well.
22:25:15 <danwent> #action #somik complete authz blueprint, send out for feedback
22:25:26 <danwent> And last but not least, nova parity.
22:25:43 <danwent> Brad will be working on L3 gateway + NAT using the nova-network mechanism, right?
22:26:13 <danwent> this is the same mechanism supported by the VLANManager, but QuantumManager needs some updates to work correctly with it.
22:26:55 <danwent> #action: #danwent confirm with #bhall about L3 + NAT work
22:27:09 <danwent> and debo, you're planning on working on the cloudpipe VPN stuff?
22:27:41 <danwent> apparently everyone is ignoring me :)
22:27:54 <salv> Update from me on nova-parity: I'm working on security groups and about to push a driver for implementing them on XenAPI
22:28:06 <danwent> #action #danwent work with #debo_os on cloudpipe vpn
22:28:10 <salv> will circulate an email in the next days about how to do that through Quantum
22:28:13 <mestery> We're not ignoring you Dan :)
22:28:24 <bhall> danwent: yup
22:28:37 <danwent> salv: cool.  there's been a lot of chatter around security groups, so yes, probably good to raise that to the ML.
22:28:47 <salv> danwent: we're not ignoring you, we're trolling you :)
22:28:49 <bhall> danwent: bp is filed (sent you a link already)
22:28:55 <danwent> mestery:  ah, now that you've spoken, can we start assigning tasks to you? :P
22:29:09 <danwent> bhall: k, thanks.
22:29:38 <debo_os> danwent: sorry, I had stepped out for 2m. Yes I am going to do the CP work
22:29:48 <danwent> debo_os: great.
22:30:02 <danwent> debo_os: let's target BP for essex-2, just so we keep tracking it.
22:30:11 <danwent> work may be split across essex-2 and essex-3
22:30:18 <debo_os> danwent: sure, that works
22:30:21 <danwent> ok, any other nova-parity work?
22:31:05 <bhall> I think thats it for e2 that I'm aware of
22:31:19 <danwent> Yup, a pretty full plate
22:31:54 <danwent> There's also a proposal to fold plugins.ini into Quantum.conf .  We didn't want to do this right before the milestone release, but is anyone violently opposed?
22:32:25 <danwent> the goal is just to have few config files, and be able to specify all config by specifying a path to a file (not a hardcoded file location)
22:32:32 <danwent> few -> fewer
22:33:29 <danwent> Ok.  We'll definitely give the ML a heads up before doing it, as it make break some automation scripts.
22:33:44 <danwent> And finally, I will be doing some super fun documentation work in essex-2.
22:34:04 <bhall> danwent: I have some notes for you on installing from packages/etc
22:34:13 <carlp> danwent: and we love you for that :)
22:34:14 <bhall> may have taken some of the fun out of your work, sorry
22:34:15 <danwent> mainly focusing on getting all content out of the README and into "official" documentation
22:34:29 <salv> danwent: you're the quantum hero :0
22:34:42 <edgarmagana> salv: +1
22:34:55 <danwent> well, if you really loved me you'd write some docs :P
22:35:03 <danwent> and don't forget that salv wrote the API spec
22:35:08 <danwent> that was a beat
22:35:10 <danwent> beast
22:35:30 * salv just remembered I'm supposed to do the wadl
22:35:35 <annegentle> danwent and salv have you gotten Oxygen licenses? If not let me know. That might take some pain out :)
22:35:41 <danwent> anyway, I will send an email to the list with info on how to modify the docs.  hopefully people will see that it is easy and fun, then decide to pitch in :)
22:35:58 <danwent> annegentle: no, but that would be fantastic
22:35:59 <salv> annegentle: yup, I have one
22:36:27 <annegentle> great, cool
22:36:34 <danwent> salv: didn't nachi provide a wadl description?
22:36:41 <salv> Oh right!
22:36:51 <danwent> I didn't end up having time to confirm that it was correct, but it definitely should be a good starting point
22:36:57 <salv> Did we merged it into the doc repository?
22:37:06 <annegentle> salv: I'll send you the Oxygen Rackbook framework which should help with WADL authoring too
22:37:08 <danwent> salv: don't think so… so thanks for remembering it.
22:37:28 <danwent> salv: can you add an item to track this work (even if you don't assign it to yourself?)
22:37:48 <salv> annegentle: that would be supergreat as I previously could use Oxygen only as a cool XML editor and was pretty much disappointed I couldn't do proper authoring
22:38:04 <salv> danwent: targeting essex-3, yes I can
22:38:18 <danwent> great
22:38:32 <danwent> Ok, anything else folks are looking at targeting for essex-2?
22:38:52 <salv> I want to raise awareness on a long-standing bug
22:38:53 <salv> https://bugs.launchpad.net/quantum/+bug/837535
22:38:54 <uvirtbot> Launchpad bug 837535 in quantum "plugins do not comply with quantum_plugin_interface" [Medium,In progress]
22:38:58 <uri_> so will L3 + NAT not be integrated w Quantum during essx2?
22:38:59 <danwent> essex-2 ends 12/15
22:39:15 <martines> i, you there?
22:39:23 <martines> s/i/hi
22:39:33 <bhall> uri_: do you mean in nova?
22:39:33 <danwent> uri_: that should already be targeted
22:39:51 <martines> sorry folks, wrong focus :(
22:39:52 <danwent> https://blueprints.launchpad.net/quantum/+spec/nova-parity-nat
22:40:14 <uri_> was trying to understand from above, if L3 integrates w Nova or Quantum in the essx2 timeframe
22:40:37 <danwent> salv: yes, I think targeting the bug makes sense.
22:40:54 <salv> danwent: k, thanks
22:41:24 <bhall> uri_: nova for e2
22:41:30 <danwent> uri_: in essex-2, which is completed Dec. 15th, we're targeting the QuantumManager being able to support L3 gateways + NAT with Quantum networks.
22:41:48 <danwent> these L3 gateways + NAT will be implemented using the exact same mechanism that the nova-network VLANManager uses
22:42:07 <danwent> this is so we can quickly get to parity with nova networking, which is one of our primary goals for essex.
22:42:48 <uri_> thx
22:42:48 <danwent> salv:  to be clear, the plan for that bug is to change the definition of the plugin API to match the "de facto" standard?
22:43:26 <salv> danwent: this looks the simplest way so far
22:43:33 <danwent> salv: yup, I agree
22:43:59 <danwent> Ok, and one last topic is that during the main openstack meeting, ttx mentioned that storing packaging code with the main project source is "not preferred"
22:44:17 <danwent> I think their goal is to have all packaging code separate, maintained by the distro itself.
22:44:36 <danwent> however, this definitely doesn't mean all the packaging work will be lost
22:45:10 <danwent> I think we'll probably just end up moving some of the packaging only files out once external distros have completely taken up the task of packaging Quantum
22:45:18 <tylesmit> Correct me if I'm wrong, but doesn't that pretty much just mean not having a unified setup.py?
22:45:59 <danwent> tylesmit: I'm guessing it refers to the setup.py files and the corresponding config files, but to be honest I'm not sure.
22:46:13 <danwent> ttx + soren said they would contact us with thoughts.
22:46:45 <danwent> we'll keep the list looped into the discussion
22:46:59 <danwent> Ok, any other quantum questions/topics?
22:47:28 <danwent> #topic open discussion
22:47:33 <danwent> ok, anything more generally?
22:47:46 <danwent> Did folks see the DNS-as-a-service proposal?
22:48:03 <salv> saw the email, did not read it yet
22:48:06 <danwent> http://etherpad.openstack.org/HkEvt4crw9
22:48:06 <carlp> Heard it was proposed, haven't looked
22:48:28 <danwent> anyway, just wanted to make sure folks were aware.  I don't know of anyone else currently working on this type of stuff.
22:48:48 <danwent> #info DNS-as-a-service proposal: http://etherpad.openstack.org/HkEvt4crw9
22:48:52 <danwent> Ok, anything else?
22:49:17 <danwent> ok, that's a wrap.  have a good one folks.
22:49:20 <danwent> #endmeeting