21:03:15 <ttx> #startmeeting
21:03:16 <openstack> Meeting started Tue Nov 22 21:03:15 2011 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:03:17 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:03:26 <ttx> Welcome everyone to our weekly meeting...
21:03:36 <ttx> Today's agenda is at: http://wiki.openstack.org/Meetings/TeamMeeting
21:03:49 <ttx> #topic Keystone status
21:03:56 <devcamcar> o/
21:03:57 <ttx> dolphm, jsavak: o/
21:04:07 <ttx> Looking at:
21:04:13 <ttx> #link https://launchpad.net/keystone/+milestone/essex-2
21:04:30 <ttx> dolphm, jsavak: Still on track ?
21:04:51 <dolphm> i believe so
21:04:54 <ttx> rbac-keystone was pushed back to essex-3 ?
21:05:00 <jsavak> yup
21:05:01 <dolphm> doing some testing with devstack to wrap it up
21:05:13 <jsavak> ttx: yes - rbac was pushed in favor of more stability work
21:05:30 <ttx> How disruptive is rbac ?
21:05:57 <jsavak> ttx: rbac must be delivered in e-3 as keystone freezes then for essex (all but bug fixes)
21:05:59 <ttx> Was a bit concerned as it sounded very disruptive and landing it early was probably a good plan :)
21:06:34 <jsavak> ttx: yup. That's why we need it delivered soon. There is middleware rbac implemented we are waiting on feedback for
21:06:50 <ttx> ok, early in essex-3 is probably good too.
21:07:01 <ttx> Do you know who in "HP Cloud Engineering" is working on those Keystone essex-2 blueprints ?
21:07:16 <jsavak> Jason Raoult & Liem
21:07:25 <jsavak> not sure their handles
21:07:38 <ttx> not sure they are on irc
21:08:00 <ttx> Would be good to get them to refresh status on their blueprint, if needed
21:08:09 <dolphm> they've mentioned their corporate firewall in the past, regarding IRC :)
21:08:19 <ttx> .oO
21:08:31 <jsavak> i'll send them a note
21:08:38 <ttx> Looking at the essex roadmap at: https://blueprints.launchpad.net/keystone/essex
21:08:51 <ttx> Do you expect other features in the essex cycle or is it almost a complete plan ?
21:08:52 <Ravikumar_hp> ttx: I will also send a note to Jason
21:09:02 <ttx> Ravikumar_hp: thanks!
21:09:08 <jsavak> ravi, i'll leave it to you. ;)
21:09:16 <Ravikumar_hp> ok
21:09:28 <koolhead17> corporate firewall  :(
21:09:43 <jsavak> ttx: more bug fixes- but no feature adds are expected.
21:09:53 <ttx> cool.
21:10:01 <ttx> Second topic is the tagging of stable/diablo to 2011.3.1
21:10:12 <ttx> That was delayed due to missing files in the resulting tarball, which are fixed now
21:10:25 <ttx> Any last-minute objection before the tag and tarball are done ?
21:10:46 <jsavak> tag + tar ~= tar + feather?
21:10:48 <Daviey> If it is confirmed to work with dashboard, then +1 here.
21:10:52 <Daviey> (and nova ofc.)
21:11:09 <ttx> devcamcar: I guess you're still ok with it ^
21:11:30 <Vek> jsavak: that would make it a featherball, though, rather than a tarball...
21:11:49 <ttx> OK, will do that tomorrow then.
21:11:51 <jsavak> vek: ah
21:11:56 <devcamcar> ttx: we have a bug to fix on the horizon side
21:11:58 <dolphm> ttx: thanks
21:11:58 <devcamcar> let me find it
21:12:09 <Vek> though I suppose it'd be less sticky...
21:12:21 <Daviey> devcamcar: Would you mind sending me the bug number please?
21:12:23 <devcamcar> https://bugs.launchpad.net/horizon/+bug/891442
21:12:25 <uvirtbot> Launchpad bug 891442 in horizon "renaming of api_key causes several unhandled exceptions" [Critical,Confirmed]
21:12:27 <Daviey> ta
21:12:40 <devcamcar> that's the only issue i'm aware of
21:12:48 <ttx> devcamcar: but that's a fix on your side, right
21:12:55 <devcamcar> yes
21:12:56 <ttx> jsavak, dolphm: Anything else ?
21:13:02 <devcamcar> i do wish you guys would stop renaming things though :)
21:13:04 <jsavak> ttx: nothing from me
21:13:08 <ttx> devcamcar: amen
21:13:24 <ttx> Questions for Keystone ?
21:13:33 <jsavak> devcamcar: yup. Me too.
21:13:49 <Vek> I have a note...
21:13:55 <ttx> Vek: shoot
21:14:05 <dolphm> devcamcar: is that bug due to changes in keystone or novaclient?
21:14:33 <Vek> it looks like quantum copied auth_token.py entirely when they created their keystone plugin, which means that it didn't get my fix to reduce the number of calls to keystone.
21:14:50 <devcamcar> dolphm: i'm actually not sure
21:14:57 <devcamcar> gabriel's notes: "There is a conflation of password and api_key in novaclient which is inappropriate. If you take a look at python-keystoneclient, I actually separated the two because there are cases (at least in keystone) where they need to be handled differently."
21:15:15 <dolphm> Vek: ah, yeah... that's an issue i'd like to address
21:15:53 <devcamcar> so long story short, i'm not sure where the problem is exactly. there seems to be a lot of confusion around password vs api key
21:15:58 <Vek> indeed :)
21:16:07 <devcamcar> if you guys have comments you can add to that bug report, it would be appreciated
21:16:41 <ttx> #action Keystone devs to help with bug/891442
21:16:54 <dolphm> devcamcar: can i ping you after this?
21:17:01 <ttx> ok, let's move to Swift now
21:17:02 <devcamcar> dolphm: for sure
21:17:11 <ttx> #topic Swift status
21:17:15 <ttx> notmyname: o/
21:17:19 <notmyname> hi
21:17:21 <ttx> #link https://launchpad.net/swift/+milestone/1.4.4
21:17:22 <notmyname> I have news
21:17:38 <ttx> everybody likes news.
21:17:42 <notmyname> swift 1.4.4 is delayed. it will be released next tuesday instead of today
21:18:02 <ttx> in order to include final fix for bug 887288, right
21:18:03 <uvirtbot> Launchpad bug 887288 in swift "proxy memory usage grows" [Critical,Fix committed] https://launchpad.net/bugs/887288
21:18:03 <notmyname> we are (literally right now) reviewing a patch that finally fixes the memory leak issue we saw
21:18:32 <notmyname> rather than doing 1.4.4 today and 1.4.5 next week, we figured it would be better to include it in 1.4.4 and delay by one week
21:18:42 <soren> Where do you currently think the leak is?
21:18:51 <soren> In Swift itself?
21:19:03 <soren> Is it our own fault? Or Python's? Or something else's?
21:19:16 <notmyname> soren: there were a few issue that were found, both in swift and eventlet
21:19:23 <notmyname> soren: but the biggest offender is https://review.openstack.org/#change,1801
21:19:26 <notmyname> in swift
21:19:49 <notmyname> it has to do with python garbage collection
21:20:04 <notmyname> yay! it was just merged
21:20:24 <notmyname> just got the email from jenkins
21:20:48 <notmyname> this issue is one involving sockets keeping memory when a client disconnects
21:20:58 <notmyname> (disconnects early)
21:20:59 <ttx> notmyname: if it's successful, please backport to milestone-proposed
21:21:27 <notmyname> ttx: ya, I need to aks you how to do that. later this afternoon or tomorrow good for you?
21:21:58 <jaypipes> notmyname: http://wiki.openstack.org/GerritJenkinsGithub#Submit_Changes_in_master_to_milestone-proposed
21:22:04 <ttx> notmyname: see
21:22:06 <ttx> ah
21:22:09 <notmyname> thanks
21:22:10 <ttx> jay was fatser
21:22:14 <ttx> or faster
21:22:18 <jaypipes> I'm fatter as well
21:22:19 <ttx> I blame the late hour.
21:22:24 <notmyname> I'll try to get that soon
21:22:31 <ttx> notmyname: Anything else ?
21:22:39 <notmyname> nope
21:22:43 <ttx> Questions on Swift ?
21:23:22 <ttx> #topic Glance status
21:23:26 <ttx> jaypipes: yo
21:23:30 <jaypipes> ttx: oy
21:23:38 * ttx looks at https://launchpad.net/glance/+milestone/essex-2 with anxiety
21:23:51 <ttx> .. you made it !
21:23:54 <jaypipes> ttx: nothing really to report... I retargeted blueprints to E3
21:24:12 <jaypipes> ttx: working on fixing bugs... if anyone in glance-core has some free time, there's a bunch of reviews needed
21:24:14 <ttx> jaypipes: looks good and on track to me
21:24:32 <jaypipes> also, I'm 50% done with the next draft of the 2.0 API proposal... incorporating a bunch of feedback from HP and Jorge.
21:24:44 <ttx> jaypipes: now looking at the general essex plan at: https://blueprints.launchpad.net/glance/essex
21:24:59 <ttx> Two blueprints are in plan but without a milestone set:
21:25:04 <ttx> https://blueprints.launchpad.net/glance/+spec/glance-xml
21:25:07 <ttx> https://blueprints.launchpad.net/glance/+spec/gzip-compression
21:25:15 <ttx> Should we unset the series goal for them, until someone commits to do them ?
21:25:23 <jaypipes> ttx: I'll handle that. thanks for the heads up.
21:25:32 <ttx> thx
21:25:36 <ttx> jaypipes: Anything else ?
21:25:50 <jaypipes> ttx: I'm thinking I need to create a blueprint for this dang 2.0 API proposal :) and make the other crap dependent on it!
21:26:10 <ttx> yes that could help in showing the relationship.
21:26:13 <Vek> jaypipes: isn't there already one on that page ttx pasted?
21:26:26 <ttx> https://blueprints.launchpad.net/glance/+spec/api-2 ?
21:26:28 <jaypipes> Vek: that's the implementation of the proposal.
21:26:33 <Vek> ah.
21:26:58 <ttx> Questions on Glance ?
21:27:36 <ttx> #topic Nova status
21:27:41 <ttx> vishy: yo
21:27:46 <vishy> hi
21:27:46 <ttx> #link https://launchpad.net/nova/+milestone/essex-2
21:27:46 <jaypipes> if anyone that works on devstack is here, would appreciate a look into this: https://bugs.launchpad.net/devstack/+bug/893692
21:27:48 <uvirtbot> Launchpad bug 893692 in devstack "stack.sh fails with ImportError in glance add" [Undecided,New]
21:28:14 <vishy> so I'm collecing status updates for all of the blueprints
21:28:14 <ttx> vishy: looks globally on track to me
21:28:23 <vishy> looks like we're pretty good for the higher priority ones
21:28:38 <ttx> vishy: do you agree to have quantum-nat-parity in the essex plan ?
21:28:42 <ttx> https://blueprints.launchpad.net/nova/+spec/quantum-nat-parity
21:28:46 <ttx> If yes, what priority ?
21:29:13 <vishy> tr3buchet: are you here?
21:29:13 <danwent> ttx: this is actually a very small feature
21:29:16 <vishy> that is fine for low
21:29:28 <ttx> I tried to ping bhall for updated status
21:29:30 <danwent> just letting QuantumManager talk to existing linux_net.py L3 + NAT code
21:29:31 <tr3buchet> vishy: yes
21:29:41 <ttx> is it "not started" ?
21:29:48 <vishy> i just approved it
21:29:52 <bhall> ttx: sorry, just saw your message
21:29:52 <vishy> w/ low
21:30:14 <ttx> bhall: started ? not started ?
21:30:23 <bhall> starting soon
21:30:33 * ttx sets "Not started" :)
21:30:34 <vishy> so i sent an email encouraging subteam leads to start targeting e-3
21:30:44 <vishy> hopefully we will see that one a little bit clearer
21:30:57 <vishy> I'm trying to focus on major features changes in by e-3
21:31:04 <vishy> so we can stabilize e-4
21:31:06 <tr3buchet> ttx: isn't that the one we discussed, and me not being able to set status?
21:31:30 <ttx> tr3buchet: yes
21:31:43 <vishy> we stil have 2 essential blueprints not targetted
21:31:48 <vishy> those have to get in by e-3
21:31:55 <ttx> right, I wanted to askj you about them
21:32:02 <ttx> https://blueprints.launchpad.net/nova/+spec/separate-nova-volumeapi
21:32:04 <vishy> I would love a volunteer to do this one: separate-nova-volumeapi
21:32:05 <ttx> https://blueprints.launchpad.net/nova/+spec/disk-configuration-parity
21:32:29 <vishy> actually i need a voulunteer for both
21:32:39 <ttx> #help volunteer needed for separate-nova-volumeapi and disk-configuration-parity
21:32:46 <vishy> pvo: is there anyone on your team that can take disk-configuration-parity?
21:33:15 <westmaas> what time frame, vish?
21:33:24 <ttx> e3. January 26.
21:33:29 <vishy> westmaas: need it by e3
21:33:42 <vishy> (and the sooner the better of course)
21:34:29 <westmaas> sorry, I don't know that we can commit today, but pvo and I will talk next week and see if we think we can work on it, will report back next week if no one else has taken it
21:34:36 <westmaas> I know he expressed some interest
21:34:41 <vishy> westmaas: do you know if there are any more proposals coming for https://blueprints.launchpad.net/nova/+spec/internal-uuids ?
21:34:48 <westmaas> yes, lots
21:34:51 <tr3buchet> vishy: i can follow up with the guys here about the disk-configuration-parity blueprint, a lot of us are out this week
21:35:00 <vishy> westmaas: will they all make it by e-2?
21:35:16 * ttx watches the titan teal explode the column width at http://wiki.openstack.org/releasestatus/
21:35:20 <ttx> team*
21:35:26 <vishy> tr3buchet, westmaas: thanks.  It isn't a lot of changes
21:35:42 <westmaas> vishy: yes should be in by e2
21:35:45 <westmaas> hoping next week
21:36:11 <ttx> vishy: Anything else ?
21:36:13 <westmaas> ttx: haha sorry :)
21:36:28 <vishy> i think that is it for now
21:36:32 <ttx> Nova subteam leads: anything you want to mention ?
21:36:36 <vishy> looks like most people are out this week
21:36:46 <vishy> oh one more thing
21:36:53 <vishy> I still have no one taking on the operational support team
21:37:09 <vishy> i think admin functionality is going to suffer if no one takes it
21:37:10 <ttx> vishy: did you follow up on adding the most active subteam leads to "nova-drivers" ?
21:37:25 <vishy> ttx: I haven't added them to drivers yet no
21:37:50 <vishy> I will add them
21:38:25 <vishy> at least tr3buchet sleepsonthefloor and bcwaldon
21:38:32 <vishy> since they are doing a lot of blueprint management
21:38:34 <ttx> vishy: I would raise a ML thread about "is operational support important in Nova", wait for a few people to take the bait and then close the net.
21:38:59 <Vek> heh.
21:39:08 <ttx> Questions on Nova ?
21:39:29 <tr3buchet> not unless maybe sorens testing thread
21:39:32 <tr3buchet> should be discussed a bit
21:39:39 <devcamcar> good idea
21:39:52 <soren> Ah. /me defers his trip to the bath room
21:39:54 <devcamcar> there was some discussion around fake db vs sqlalchemy/mox
21:40:02 <devcamcar> i think fake db makes a lot of sense
21:40:09 <devcamcar> if you're talking about unit tests
21:40:21 <devcamcar> you want to test the actual db implementations separately (integration tests)
21:40:34 <tr3buchet> right
21:40:44 <devcamcar> otherwise you run tests against one db driver (sqlalchemy is all we have today, but tomorrow?) and get a false sense of security
21:40:48 <vishy> soren's plan is +1 from me
21:40:49 <tr3buchet> i guess my only worry is keeping the fakes true to the originals
21:40:57 <soren> Ok, once more:
21:40:58 * ttx gives you 5 minutes and then you'll continue on #openstack-dev :)
21:40:59 <devcamcar> unit tests with fake db, integration tests for each db implementation seems reasonable
21:40:59 <tr3buchet> but otherwise i'm for it
21:41:07 <soren> I'll provide a test suite that you can run against the real and fake db drivers.
21:41:28 <soren> Why is that not enough reassurance that the fake will be true to the real drivers?
21:41:29 <devcamcar> +1
21:41:42 <tr3buchet> oops, i guess i missed that
21:41:48 <soren> Ok, good :)
21:42:01 <tr3buchet> yeah that solves that then
21:42:04 <soren> \o/
21:42:08 <devcamcar> with 3 minutes to spare!!
21:42:14 <ttx> everyone seems to agree. Where is conflict ?
21:42:15 <tr3buchet> high fives all around
21:42:19 * ttx is disappointed.
21:42:20 <soren> I'd be scared shitless without a test suite for it. :)
21:42:23 <devcamcar> i just saw a f'ing unicorn dude
21:42:28 <tr3buchet> yeah good, cause that's how i felt
21:42:28 <soren> devcamcar: shoot it!
21:42:36 <ttx> that's because Sandy is not around.
21:42:37 <devcamcar> good eats tonight
21:42:41 <tr3buchet> yeah true
21:42:43 <ttx> ok then.
21:42:45 <ttx> #topic Horizon status
21:42:52 <ttx> #link https://launchpad.net/horizon/+milestone/essex-2
21:42:58 <ttx> devcamcar: Not so many things completed yet, still feeling confident ?
21:43:07 <devcamcar> all bugs / blueprints assigned
21:43:08 <devcamcar> ttx: yes
21:43:16 <devcamcar> most of the bugs are quick fixes
21:43:22 <devcamcar> we are actually making some great progress
21:43:38 <devcamcar> we rebased the css/javascript ui bits around bootstrap, which was a big piece of plumbing
21:43:43 <devcamcar> http://twitter.github.com/bootstrap/
21:44:02 <devcamcar> lots to be done still on visual design, but structurally we are looking good
21:44:09 <devcamcar> http://c213515.r15.cf1.rackcdn.com/516c58fe8dd6651259c55d909e65b3b8.png
21:44:16 <devcamcar> work in progress screenshot
21:44:34 <devcamcar> color schemes are not final, and table refactors not done, but this is a working version that uses the bootstrap framework
21:44:40 <devcamcar> so actually things are going quite well
21:45:12 <ttx> Looking at the general essex plan at: https://blueprints.launchpad.net/horizon/essex
21:45:22 <ttx> Looks good to me -- is it a near-complete list ?
21:45:45 <devcamcar> ttx: yes
21:45:45 <ttx> devcamcar: also, do you confirm that https://blueprints.launchpad.net/horizon/+spec/dashboard-plugin-support is superseded and should be removed from the list ?
21:46:08 <devcamcar> ttx: yes, superseded by a  superior implementation
21:46:15 * ttx removes
21:46:31 <devcamcar> there's still a few blueprints trickling in
21:46:41 <ttx> devcamcar: Anything else ?
21:46:44 <devcamcar> such as migrating to django 1.4 in essex-4
21:46:55 <devcamcar> now that we have some confidence around the release date
21:46:56 <devcamcar> but nothing major
21:47:01 <devcamcar> that's it!
21:47:03 <ttx> devcamcar: adding more as they come up is ok, but having a 80% complete plan by now is also good
21:47:15 <devcamcar> ttx: definitely at 80% at least
21:47:21 <ttx> Questions for Horizon ?
21:47:32 <koolhead17> hi devcamcar
21:47:43 <devcamcar> koolhead17: howdy!
21:47:47 <ttx> koolhead17: got a question ?
21:47:50 <koolhead17> devcamcar: am awesome
21:47:52 <koolhead17> ttx: yes
21:48:06 <ttx> speak!
21:48:27 <koolhead17> i wanted to know if the dependency of dash with quantum and glance going to continue?
21:48:36 <koolhead17> as in the dash package
21:48:51 <devcamcar> koolhead17: hopefully not, we are still evaluating the best way to tackle that
21:49:04 <devcamcar> so i'd say we are in discussion phase of how best to accomplish that
21:49:10 <devcamcar> it's certainly our goal
21:49:30 <devcamcar> sorry, bit of a non-aswer :)
21:49:32 <koolhead17> devcamcar: https://bugs.launchpad.net/horizon/+bug/888385
21:49:34 <uvirtbot> Launchpad bug 888385 in horizon "Failure when installing Dashboard - python tools/install_venv.py" [High,Confirmed]
21:49:56 <koolhead17> all because quantum here :(
21:50:03 <koolhead17> devcamcar: thanks :D
21:50:24 <Daviey> devcamcar: I think the real question is, will quantum be a hard depends of horizon?
21:50:25 <devcamcar> koolhead17: your idea is probably the only practical solution though
21:50:27 <mtaylor> koolhead17, devcamcar: I was going to look at that bug above and for ways to deal with it some
21:50:44 <mtaylor> but I haven't gotten to it yet
21:50:48 <ttx> talking about quantum...
21:51:03 <devcamcar> Daviey: no, we'll figure out a way.  i'm not positive we'll solve this problem in essex-2 though
21:51:26 <ttx> #topic Incubated projects and other Team reports
21:51:28 <koolhead17> devcamcar: i want to run dash on my small 512 RAM box, i dont want to install quantum/glance on it :D
21:51:33 <Daviey> devcamcar: can it just be removed until it's redady to..
21:51:39 <Daviey> okay, nevermind :)
21:51:42 <ttx> danwent, troytoman: o/
21:51:46 <danwent> hello
21:51:57 <devcamcar> Daviey, koolheady17: i will discuss with you outside meeting soon
21:52:01 <danwent> quantum dev is back up and humming at full speed for essex-2: https://launchpad.net/quantum/+milestone/essex-2
21:52:07 <koolhead17> devcamcar: awesome!! :D
21:52:09 <mtaylor> devcamcar, koolhead17: one of the other issues that will help there is getting python-glanceclient and python-quantumclient split out so that you can just install client api libraries
21:52:23 <danwent> release is probably too full given the time left, so we'll be working to make sure dev work is feasible and moving to e-3 if not
21:52:52 <ttx> danwent: yep, that's a large plate already
21:53:02 <koolhead17> mtaylor: +1
21:53:08 <danwent> mtaylor: we've already done some of the work to make it possible to install quantum client separately
21:53:17 <danwent> happy to chat more about it offline
21:53:40 <ttx> Any other team lead with a status report ?
21:53:41 <danwent> ttx: other than that, we'll be sycing with the horizon folks about some new features we'd like to integrate
21:53:46 <danwent> syncing
21:53:54 <mtaylor> danwent: ++
21:53:56 <danwent> that's alls
21:54:08 <ttx> danwent: sounds good
21:55:02 <ttx> #topic Open discussion
21:55:21 <ttx> In other news, the "OpenStack" devroom at FOSDEM had been merged with other projects in a large, 2-day "Open source virtualization and cloud" devroom
21:55:31 <ttx> The CFP should be sent... tomorrow.
21:56:00 <ttx> mtaylor: as far as CI goes, I'd like us to fix translations and set up the client splits for E2, does that match your schedule ?
21:56:17 <mtaylor> ttx: I will make it match my schedule
21:56:43 <ttx> Anything else, anyone ?
21:57:57 <ttx> looks like we are 3 minutes short
21:57:59 <ttx> #endmeeting