15:01:01 <zul> #startmeeting
15:01:02 <openstack> Meeting started Tue Nov 29 15:01:01 2011 UTC.  The chair is zul. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:03 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:01:16 <zul> welcome to the the nova ec2 api team meeting
15:01:23 <zul> Agenda:
15:01:28 <zul> 1) Discuss ec2 api issues
15:01:33 <zul> 2) Open Bugs
15:01:45 <zul> 3) Openfloor
15:02:03 <zul> #topic Discuss ec2 api issues
15:02:53 <zul> so i have been running the aws-cloud testsuite and trying to figure out how to report issues.
15:03:24 <zul> It seems to me that tests are not intuiative enough so I was thinking of writing a patch to make the tests a bit more informatiive
15:03:40 <zul> So that is on my todo list.
15:04:01 <zul> Last week I didnt really make any progress on the ec2 bug list because i got distracted with work related stuff
15:04:13 <Daviey> sounds good
15:04:16 <ttx> o/
15:04:21 <zul> Also there has been several gerrit review for ec2 related problems
15:05:09 <zul> mwhooker has submitted a gerrit review branch for aws compatiabblity tests
15:05:17 <medberry> o/
15:05:25 <zul> its at: https://review.openstack.org/1860
15:05:28 <zul> hey medberry
15:05:45 <zul> Please help review it
15:06:15 <zul> anyone else have any comments
15:06:39 <Daviey> zul: add an action?
15:06:46 <zul> oh i forgot one thing smoser pointed me to a branch that might help with speeding up the ec2 metadata server
15:07:02 <zul> Daviey: so the action points would be:
15:07:14 <zul> #action review https://review.openstack.org/1860
15:07:33 <zul> #action review aws-cloud testsuite to make it better
15:08:08 <Daviey> zul: How complete is the testsuite?
15:08:09 <Daviey> Are we testing S3?
15:08:26 <zul> Daviey: the aws-cloud one or the one in the gerrit review
15:08:57 <zul> the aws-cloud tests both ec2  and s3
15:09:07 <zul> although i havent used it to test s3
15:09:24 <Daviey> great
15:10:09 <zul> i would like to see it act like the nova testsuite but it just prints a summary at the end so I think I might be missing something
15:10:17 <zul> so any other comments?
15:10:36 <zul> ...
15:11:02 <zul> ok then
15:11:12 <zul> #topic Open Bugs
15:11:33 <zul> so we still have a lot of open bugs that are ec2 specific:
15:12:06 <zul> https://bugs.launchpad.net/nova/+bugs?field.tag=ec2
15:12:11 <zul> an example of a new one is:
15:12:20 <zul> https://bugs.launchpad.net/nova/+bug/897164
15:12:22 <uvirtbot> Launchpad bug 897164 in nova "neither EC2 api nor openstack API expose the hostname" [Undecided,New]
15:13:23 <zul> so right now they are just sitting there until someone actually does something with them, I think as a group we should start attacking them and get essex to support ec2 better
15:13:37 <zul> comments?
15:14:01 <Daviey> agreed
15:14:20 <zul> heh ok
15:14:38 <medberry> zul, are you just grepping for EC2 in the bug name or are they being tagged somehow?
15:14:49 <zul> medberry: they are tagged ec2
15:15:02 * medberry sees the tag...
15:15:14 <zul> i try to go through the bug list once a week usually before the meeitng and tag any bugs that I might be missing
15:15:25 <medberry> nod.
15:15:29 <zul> and hopefully its a frenzy to fix the ec2 bugs ;)
15:15:39 <zul> which right now it is not
15:16:20 <zul> so developers who need to use ec2 need to get excited about fixing them
15:16:25 <zul> hint hint
15:17:02 <zul> comments...
15:17:11 * zul sees tumbleweeds run on by
15:18:22 <zul> so with that
15:18:27 * ttx wonders who actually does
15:18:31 <zul> #topic Open Floor
15:18:45 <medberry> ttx, I see a lot of tumbleweeds roll by....
15:18:55 <ttx> zul: you might need to actively engage people that work with EC2 api and encourage them to join this meeting :)
15:19:14 <zul> ttx: agreed
15:19:20 <Daviey> I suspect a vast minoirty of those that care about ec2 actually know, or can attend this meeting
15:19:21 <zul> mwhudson was at the first meeting at least
15:19:34 <zul> maybe change the meeting time?
15:19:42 <Daviey> I suspect awarness
15:19:46 <medberry> I think soliciting and advertising
15:19:46 <ttx> zul: first, collect the names of people interested
15:19:49 <medberry> jinx
15:20:04 <medberry> (time slot isn't especially bad)
15:20:10 <ttx> (or good)
15:20:28 <medberry> zul, I'll mention it to justinlw
15:20:30 * Daviey glares at medberry for soliciting!
15:20:56 <zul> i suspect alot of the people who are interested in the ec2 api are on the west coast and this wouldnt be a good time for them
15:21:02 * medberry puts on polarized glasses and hires a solicitor.
15:21:50 <Daviey> zul: No, i think it requires a blog post and more visability on the mailing list.
15:22:03 <zul> good idea
15:22:27 <zul> #action zul to write a blog post about the team meeting
15:23:14 <zul> any other comments?
15:23:18 <medberry> a "where's chuck" meme in the #openstack-meeting picture with #startmeeting EC2 API on Google + couldn't hurt....
15:23:32 <zul> hehe
15:23:44 <zul> thankfully that is dead i think ;)
15:24:37 <zul> if no one has anything else then i think thats it
15:24:48 <zul> at least i have nothing else
15:25:12 <Daviey> works for me
15:25:31 <zul> thanks for coming
15:25:33 <zul> #endmeeting