20:10:27 <jmckenty> #startmeeting
20:10:28 <openstack> Meeting started Tue Dec  6 20:10:27 2011 UTC.  The chair is jmckenty. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:10:29 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:10:45 <jmckenty> #topic cloud-audit background
20:10:48 <anotherjesse> jmckenty: I guess I see evidence gathers similar to monitoring plugins - which aren't normally kept in the core project ...
20:10:57 <jaypipes> anotherjesse: agreed.
20:11:19 <zns> jmckenty: Could the gatherers be created in an openstack-common type library (which seems always to be on the verge of getting started - maybe this could move it along)? Or how deep is the introspection you need?
20:11:29 <jmckenty> I also agree they should be built as plugins, but I was hoping to have them somewhat symmetrical across projects
20:11:36 <jmckenty> zns - exactly what I'm hoping for
20:11:54 <vishy> common config looks like it might kick off openstack-common
20:11:57 <jmckenty> e.g., that cloudaudit's requirements are a good use-case for openstack-common
20:12:26 <jaypipes> _0x44: FYI, typo in https://github.com/piston/openstack-cloudaudit/blob/master/cloudaudit/evidence_engine/idle_session_lock.py ( grep for eivdence)
20:12:31 <zns> +10 to common config. How can I help, get some, …?
20:12:51 <mtaylor> vishy: common config and also melange, which depends on openstack-common
20:12:52 <_0x44> jaypipes: Grazie...
20:12:53 <anotherjesse> zns: keystone middleware should be there -but this is getting off the topic
20:13:20 <vishy> zns: have you been following the ML?
20:13:24 <vishy> there is a proposal in
20:13:41 <zns> anotherjesse: no disagreement from me.
20:13:46 <vishy> jmckenty: is there anything specific you need from the ppb?
20:13:49 <zns> vishy: obviously behind...
20:13:51 <anotherjesse> jmckenty: it seems like before proposing to the pbb it would be good to bring it to the ML?
20:14:10 <jmckenty> we're not proposing
20:14:19 <zns> vishy: I'll trawl through the emails and catch up...
20:14:33 <jmckenty> this is pre-proposal, just checking with the PPB on status of openstack-common
20:14:40 <jmckenty> and whether it's going to be in Essex
20:15:36 <vishy> jmckenty: well it isn't exactly an official project
20:15:50 <vishy> jmckenty: but it looks like projects will be depending on it
20:16:19 <ttx> vishy: it's a rather specific case, we might need to fast-track it.
20:16:24 <vishy> I don't know if we have a process for this.  It is kind of like an external library
20:16:25 <anotherjesse> jmckenty: afaik there are several code "projects" (the common config, perhaps keystone middleware, perhaps a base for openstack cli tools - that novaclient, keystoneclient, … can use) - and then a place for blueprints about the project as a whole
20:16:48 <jmckenty> so as a specific point,
20:17:00 <jmckenty> the root_wrapper stuff ttx has been working on for nova
20:17:09 <ttx> vishy: imho openstack-common is more an expression of commonality between projects.
20:17:16 <jmckenty> is a key requirement (or something equiv) for evidence gatherers
20:17:20 <ttx> vishy: not a new project per-se
20:17:29 <vishy> ttx: good so we don't need to vote it in
20:17:31 <mtaylor> ttx: yes, but it's still a project with a lifecycle and will need reviewers and a core team
20:17:32 <jmckenty> and hopefully would move into openstack-common
20:17:35 <vishy> we just need to make it work.
20:17:48 <ttx> mtaylor: sure, I'm just finding excuses for fast-tracking it.
20:18:01 * mtaylor doesn't think we need to vote it in - but we may have to deal later with issues - I think we're fine for right now
20:18:22 <vishy> core could initilaly be all core members?
20:18:28 <vishy> *initially
20:18:30 <jmckenty> ttx and vishy - are you happy to make openstack-common a dependency for nova, and move root_wrapper into it?
20:18:37 <vishy> yup
20:18:39 <mtaylor> at the moment, I've got the poc members and anotherjesse in the openstack-common-core team
20:18:43 <vishy> and common config
20:19:02 <mtaylor> well, I've invited openstack-poc, the invitation hasn't yet been accepted
20:19:05 <ttx> jmckenty: the reason why it's done in Nova is that the other projects don't really need privilege escalation
20:19:05 <jmckenty> great - that will unblock us on cloudaudit
20:19:14 <jmckenty> ttx - they will for cloudaudit plugins, though
20:19:17 <jmckenty> that's my point
20:19:22 <mtaylor> was also going to add markmc and jvoelker, since they've been doing the most hacking on the project so far
20:19:33 <ttx> jmckenty: in which case, yes, it would make a good candidate for openstack-common.
20:20:12 <ttx> s/nova-rootwrap/openstack-rootwrap
20:20:19 <jmckenty> :)
20:20:28 <jmckenty> I'm happy - any other topics?
20:20:38 <jmckenty> I would ask for a foundation update, but we've got no Jonathan
20:20:49 <jmckenty> I could give a FITS update - which is that it's hung on foundation updates
20:20:53 <mtaylor> jmckenty: I'd like to check in with folks on the CLA stuff I mentioned in the CI meeting
20:21:30 <jmckenty> k
20:21:39 <jmckenty> #topic Management of CLA
20:21:40 <mtaylor> so - in case you weren't in the CI meeting ...
20:21:47 <jmckenty> I overhead it
20:21:54 <jmckenty> proposed that gerritt manages CLA, right?
20:22:11 <mtaylor> gerrit has a facility for managing CLA signing and not allowing proposals from people who haven't signed it
20:22:17 <jmckenty> That only addresses individual contributor CLA and not organizational CLA
20:22:18 <vishy> +1
20:22:19 <mtaylor> this seems nicer than asking reviewers to check a wiki page
20:22:21 <mtaylor> yes
20:22:26 <zns> yes
20:22:40 <jmckenty> +1 notionally, would like to see how we manage org. CLA as well
20:22:46 <zns> * wonders if he should have been checking a wiki page before accepting reviews! *
20:23:04 <vishy> is there a discussion necessary?
20:23:07 <anotherjesse> zns: ya - I had thought it was done for us - but that is it is just the mailmap that was checked
20:23:13 <vishy> sounds like our tools just fell behind
20:23:15 <jmckenty> mtaylor - can we do this without requiring anyone to resign their CLA?
20:23:29 <mtaylor> jmckenty: I believe so
20:23:30 <mtaylor> jmckenty: I think we can pre-seed the database
20:23:55 <mtaylor> jmckenty: although I want to double-check that before I 100% commit to being able to do it
20:24:01 <notmyname> does this need to be something we decide on as a PPB or just something that needs to be done?
20:24:19 <jmckenty> I think changes to how CLA is managed is a PPB issue
20:24:25 <jmckenty> but only if it's a substantive change
20:24:26 <mtaylor> I think it might be a ppb decision, since it affects how we'd be telling folks to contribute
20:24:34 <jmckenty> and this seems like simple tools issues
20:24:43 <anotherjesse> go for it +1
20:24:47 <vishy> +1
20:24:52 <mtaylor> ok. well, I mean, we can certainly do a POC, show some folks and then move forward
20:24:54 <mtaylor> awesome
20:25:02 <jmckenty> #vote CLA will be managed by Gerritt
20:25:07 <vishy> +1
20:25:08 <mtaylor> +1
20:25:13 <zns> +1
20:25:15 <notmyname> +1
20:25:16 <anotherjesse> +1
20:25:16 <jk0> +1
20:25:20 <devcamcar> +1
20:25:24 <anotherjesse> ship it
20:25:25 <ttx> I think currently it's not managed at all. +1
20:25:44 <jmckenty> I think we've got quorum and that seems like enough votes...
20:25:55 <jmckenty> #agreed CLA to be managed by Gerritt
20:25:57 <ttx> (tarmac used to check the list up, I'm pretty sure the current Ci doesn't)
20:26:07 <mtaylor> awesome. thanks guys.
20:26:17 <jmckenty> Any other topics?
20:26:22 * jmckenty loves finishing meetings early
20:26:23 <anotherjesse> lunch?
20:26:24 <vishy> lunch!
20:26:26 <vishy> +1
20:26:30 <mtaylor> +1
20:26:35 <jmckenty> #endmeeting