21:01:42 <ttx> #startmeeting
21:01:43 <openstack> Meeting started Tue Dec  6 21:01:42 2011 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:44 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:01:52 <ttx> Welcome everyone to our weekly general meeting...
21:02:05 <ttx> Nothing special on today's agenda: http://wiki.openstack.org/Meetings/TeamMeeting
21:02:06 <heckj> \o
21:02:15 <ttx> #topic Actions from previous meeting
21:02:23 <ttx> * ttx and vishy to discuss how to solve Nova's team structure
21:02:34 <ttx> So we've discussed that... vishy has a few changes coming up, I think
21:02:43 <ttx> vishy: care to share your plans ?
21:02:58 <comstud> solve implies there's a problem.  did I miss the problem?
21:03:10 <comstud> i guess i did..i missed last meeting
21:03:10 <comstud> :)
21:03:13 <vishy> ttx!
21:03:21 <vishy> sorry: stepped away for a sec
21:03:22 <ttx> vishy!
21:03:29 <joesavak> lol
21:03:37 <vishy> I will be drafting an email to explain it
21:03:48 <vishy> we're going to deprecate a few teams and move them to a wanted list
21:03:50 <ttx> vishy: ok, don't want to spoil your effects :)
21:04:01 <vishy> and probably change the ml structure
21:04:23 <lloydde> I just figured out the o/
21:04:29 <ttx> vishy: and have a weekly Nova-specific meeting ?
21:04:32 <vishy> so I guess the result is email on the way!
21:04:40 <vishy> yes, team lead meeting once a week
21:04:50 <vishy> have to determine where on the schedule that fits
21:04:58 <ttx> k, thx!
21:05:01 <ttx> * ttx to check the need for MP jenkins jobs on novaclient
21:05:10 <ttx> So those are still needed, bug 899056 tracks that
21:05:10 <uvirtbot> Launchpad bug 899056 in openstack-ci "python-novaclient needs milestone-proposed Jenkins jobs" [High,Confirmed] https://launchpad.net/bugs/899056
21:05:23 <ttx> * ttx or vishy to start a discussion on release PPA
21:05:31 <ttx> I started a thread on the ML, here is a summary:
21:05:35 <ttx> http://www.mail-archive.com/openstack@lists.launchpad.net/msg05890.html
21:05:45 <ttx> If you don't agree, I encourage you to voice your opinion there :)
21:06:08 <ttx> Let's move on to project status...
21:06:14 <ttx> #topic Keystone status
21:06:24 <ttx> joesavak: o/
21:06:26 <joesavak> #link https://blueprints.launchpad.net/keystone/+spec/portable-identifiers
21:06:27 <ttx> #link https://launchpad.net/keystone/+milestone/essex-2
21:06:41 <joesavak> portable ids is looking good for e-2. Good progress
21:07:26 <ttx> One week left to merge those E2 features, are all the others still on track ?
21:07:53 <joesavak> I've seen some reviews by HP - but not sure if they close out their BPs
21:07:56 <ttx> joesavak: in particular service-endpoint-location, which is marked Not Started...
21:08:13 <ttx> joesavak: should keystone-documentation and keystone-swift-acls be considered completed ?
21:08:45 <joesavak> not sure on those. ping heckj
21:08:54 <joesavak> ping hp
21:09:12 <heckj> the docbook stuff hasn't been finished - I've made no progress there recently
21:09:16 <zns> ttx, joesavak: the reviews from HP don't address the blueprints.
21:09:21 <heckj> don't know the swift-acls though
21:10:12 <ttx> heckj: is the doc thing an "always in progress" thing ? In which case I'd rather have it out of the plan
21:10:28 <ttx> I mean, we don't have a "Bugfixing" blueprint either.
21:10:53 <heckj> ttx: it was a specific effort to bring the documentation to date to enable an install. It's horrifically lacking at this point
21:11:14 <ttx> heckj: ok, if there is a way to complete it, I'm fine with it
21:11:38 <ttx> heckj: so wit hthat description, it's not complete yet, is it going to be ok by next week ?
21:11:41 <lloydde> update the title to "Document Keystone Install"?
21:11:54 <ttx> lloydde: good idea
21:12:15 <heckj> ttx: I'm not likely to be able to get it done by E2 deadline
21:12:30 <ttx> ok, pushing back to E3 then.
21:12:46 * heckj nods
21:12:58 <ttx> joesavak: Anything else ?
21:13:14 <joesavak> not from me...
21:13:34 <ttx> #action joesavak/zns to sync with HP for updated status on their blueprints
21:13:46 <joesavak> i'll ping them now
21:13:46 <ttx> Questions for Keystone ?
21:13:59 <ttx> joesavak: just update the status based on the result
21:14:12 <joesavak> will do
21:14:32 <ttx> #topic Swift status
21:14:37 <ttx> notmyname: o/
21:14:40 <notmyname> hi
21:14:46 <ttx> What news ?
21:14:55 <notmyname> I don't think I have any
21:15:04 <notmyname> meetup tomorrow night in sunnyvale
21:15:06 <notmyname> that's it
21:15:10 <mtaylor> notmyname: how's the go rewrite going?
21:15:36 <notmyname> mtaylor: I'm still working on the erlang/go interpreter ;-)
21:15:51 <ttx> Other questions on Swift ?
21:16:15 <ttx> notmyname: not likely to have 1.4.5 before the end of the year ?
21:16:30 * ttx is planning vacations.
21:16:35 <notmyname> ttx: unlikely
21:17:00 <ttx> #topic Glance status
21:17:05 <ttx> jaypipes: yo
21:17:15 <jaypipes> ttx: oy
21:17:16 <ttx> #link https://launchpad.net/glance/+milestone/essex-2
21:17:38 <ttx> jaypipes: Looks like you have a new target: multi-process-server
21:17:55 <ttx> Is that one still on track for the December 13 deadline ?
21:18:06 <jaypipes> ttx: I'll push that one to E3. Stuart McLaren is working on that at HP.
21:18:26 <jaypipes> ttx: for the other bugs, a lot of them are packaging-related. I'll work with monty on getting some status updates on those.
21:18:47 <ttx> jaypipes: ok
21:19:07 <ttx> jaypipes: you're getting ready for a very busy E3.
21:19:15 <jaypipes> ttx: yeah I know...
21:19:46 <ttx> jaypipes: pushed
21:20:21 <ttx> #action jaypipes to get status updates from mtaylor on Glance packaging issues
21:20:29 <ttx> jaypipes: Anything else ?
21:20:44 <jaypipes> ttx: nope. expect the 2.0 API 3rd draft by end of today...
21:20:57 <jaypipes> ttx: that is the main blocker for a lot of E3 blueprints, BTW,.
21:21:10 <ttx> jaypipes: is everything going as you want on that front ?
21:21:24 <jaypipes> ttx: on the 2.0 API proposal front?
21:21:28 <ttx> yep
21:21:48 <ttx> #info expect the 2.0 API 3rd draft by end of today
21:21:50 <jaypipes> ttx: yes, got great feedback so far. just putting the final touches on it based on some Ozone team feedback.
21:22:01 <ttx> Questions on Glance ?
21:22:37 <ttx> #topic Nova status
21:22:42 <ttx> vishy: yo
21:22:48 <vishy> hi!
21:22:50 <ttx> #link https://launchpad.net/nova/+milestone/essex-2
21:23:12 <ttx> Looks generally good, though lots of stuff is blocked in review
21:23:23 <ttx> vishy, tr3buchet: I see two new targets: compute-network-info and network-info-model
21:23:26 <vishy> O
21:23:35 <ttx> Do those warrant two separate blueprints ?
21:23:41 <vishy> I'm a little concerned about the first essential blueprint
21:23:50 <ttx> vishy: yes, me too
21:23:53 <vishy> https://blueprints.launchpad.net/nova/+spec/nova-volume-snapshot-backup-api
21:23:59 <ttx> Gaurav did not update his proposed change since Nov 15.
21:24:00 <vishy> haven't seen any updates for a while
21:24:18 * ttx looks behind him as apparently vishy is copying his notes
21:24:22 <vishy> so I wonder if someone else should take it over and fix the testing issues
21:24:52 <ttx> vishy: +1
21:25:03 <ttx> (giving appropriate credit where due)
21:25:30 <ttx> vishy: question is... who ?
21:25:41 <vishy> ok, I can't think of anyone else who can take it offhand
21:25:49 <vishy> I might have to grab that one myself
21:25:51 <ttx> hehe
21:26:06 <vishy> I will also contact david-perez and see if he can get the other one up to date?
21:26:14 <vishy> branch point is next tuesday?
21:26:24 <ttx> #action vishy to find a victim or complete by himself nova-volume-snapshot-backup-api
21:26:27 <ttx> yes
21:26:33 <ttx> and yes
21:26:58 <vishy> i think that tr3buchet's network ones are on track
21:27:00 <ttx> #action vishy to sync with david-perez on finishing up nova-vm-state-management
21:27:36 <ttx> sure, was just wondering if that warranted two blueprints, and if yes, one is missing priority.
21:27:45 <ttx> Should quantum-nat-parity be considered completed ? (bhall)
21:28:05 <ttx> westmaas: are you seeing the end of internal-uuids ?
21:28:06 <danwent> ttx: yes, my understanding is that it is in.
21:28:23 <ttx> danwent: ok, marking completed
21:28:30 <danwent> thx
21:28:36 <ttx> oh, someone already did.
21:28:47 <danwent> bhall said he was going to :)
21:28:54 <ttx> "Brad Hall 2 hours ago"
21:28:56 <vishy> yes i think everything else is on track
21:28:58 <bhall> :)
21:29:13 <ttx> Looking at the reviews situation... A few hours ago we had 55 nova/master reviews opened
21:29:24 <ttx> I'd like to consider an abandon policy for stale reviews. Something like:
21:29:36 <ttx> Abandon all changes with a -2 that were not updated in the last x days
21:29:43 <ttx> Abandon all changes with a -1 that were not updated in the last y days
21:29:51 <Vek> +1
21:30:06 <ttx> x=7 and y=14 would bring down the number of reviews to a more manageable 22
21:30:15 <ttx> Would that work ?
21:30:44 * Vek won't typically look at a -1 or -2 review, waiting for the OP to upload a fresh one...
21:31:14 <wwkeyboard> And anything older than those numbers will need to be rebased anyways
21:31:19 <vishy> ttx: I definitely think -2 is fine
21:31:26 <vishy> for 7 days
21:31:38 <vishy> I suppose they can resubmit right?
21:31:54 <vishy> can we get it to automatically do that?
21:31:55 <ttx> nothing should prevent them to.
21:32:00 <Vek> vishy: I wonder if they might have to generate a new change-id?
21:32:13 <ttx> vishy: I'll ask mtaylor/jeblair
21:32:14 <vishy> mtaylor, jeblair? ^^
21:32:20 <bhall> Vek: yes, they would I believe
21:32:38 <vishy> that is kind of annoying, if that is the case then we might want to make the -1 a little longer
21:32:39 <mtaylor> reading
21:32:58 <ttx> vishy: I guess multiple -1s could be considered as well
21:33:29 <mtaylor> you do not have to regen a change id for abandonded changes
21:33:34 <mtaylor> they can be un-abandoned
21:33:42 <bhall> ah, good to know
21:33:50 <mtaylor> also, we have a todo list item for a work-in-progress state, so this would just be a workaround until then
21:33:55 <ttx> vishy: ideally the tool can autoabandon, but having a policy that nova-core can apply in the mean time also helps.
21:34:06 <Vek> ttx: +1; a -2 or 2 or more -1s seems like a good call for that.  I'd still have 7 days for -2 and, say, 14 for -1s
21:34:10 <vishy> can we force abandon changes?
21:34:17 <vishy> I can't find a button for it
21:34:41 <ttx> vishy: I thought you core dudes could... but maybe not.
21:35:24 <ttx> maybe it's just a question of filtering default views
21:35:39 <ttx> reviewday could do that.
21:35:51 <ttx> vishy: Anything else ?
21:35:58 <vishy> nope
21:36:16 <ttx> #action ttx to discuss options for getting a sane list of reviews with CI guys
21:36:26 <ttx> Nova subteam leads: anything you wanted to add ?
21:36:41 <ttx> Everyone: Questions on Nova ?
21:37:25 <ttx> #topic Horizon status
21:37:31 <ttx> devcamcar: o/
21:37:38 <devcamcar> o/
21:37:40 <ttx> #link https://launchpad.net/horizon/+milestone/essex-2
21:38:01 <ttx> One week left, you look a bit behind schedule, especially Tres Henry (with 3 non-started things on his plate)
21:38:17 <devcamcar> two of the three are going to have to be punted to essex-3
21:38:30 <ttx> devcamcar: do you already know which ?
21:38:42 <devcamcar> yes, i'm actually updating them now
21:38:46 <ttx> kewl
21:38:51 <devcamcar> https://blueprints.launchpad.net/horizon/+spec/boot-from-volume
21:39:00 <devcamcar> https://blueprints.launchpad.net/horizon/+spec/instance-power-state
21:39:03 <devcamcar> those two are being punted
21:39:35 <ttx> ok, the rest is on track to get merged in before EOD next Tuesday ?
21:39:46 <devcamcar> should be
21:39:57 <ttx> you have a huge list of essex-2-targeted bugs
21:40:02 <devcamcar> we may have to punt a few of the ux changes to essex-3
21:40:14 <devcamcar> most of those are small fixes and a ton of those are getting fixed every day
21:40:23 <ttx> works for me :)
21:40:33 <devcamcar> yea, we are actually making a ton of progress
21:40:56 <devcamcar> new modal system is done: http://c213515.r15.cf1.rackcdn.com/29e0c2820346b6b68edc8067044e2ac5.png
21:41:08 <devcamcar> improved side nav: http://c213515.r15.cf1.rackcdn.com/4b3d78edecca73daded75202a1750ee4.png
21:41:12 <ttx> devcamcar: about the ux changes, either push the blueprint completion to E3, or split it in two (if the two subsets makke sense separated)
21:41:33 <devcamcar> ttx: i will push the blueprint to e3. i think that makes more sense
21:41:40 <ttx> ok
21:41:48 <ttx> devcamcar: Anything else ?
21:42:01 <devcamcar> we also added tenant management when using keystone in db only mode: http://c213515.r15.cf1.rackcdn.com/6226b6a06b8489c59dcd402b41986cee.png
21:42:06 <devcamcar> ttx: that's about it
21:42:10 <tr3buchet> vishy: ttx: sorry i had stepped out. those 2 blueprints are on track.
21:42:22 <ttx> tr3buchet: thx
21:42:43 <ttx> Questions for Horizon ?
21:43:12 <ttx> #topic Incubated projects and other Team reports
21:43:20 <ttx> danwent, troytoman: o/
21:43:26 <danwent> hello
21:43:28 <troytoman> o/
21:43:43 <ttx> Everything going well in Quantum/Melange world ?
21:43:44 <danwent> on quantum.  our e-2 nova blueprints are done.  two bugs that we'd like to get in for e-2.
21:44:01 <danwent> I didn't seem to be able to target bugs to a release though… is that something you or vish have to do?
21:44:21 <ttx> danwent: no, you should be able to do that for Quantum
21:44:31 <danwent> ttx: sorry, i'm talking about nova
21:44:54 <ttx> danwent: yes, we can do it, just paste bug numbers
21:45:10 <ttx> so two bugs in nova ?
21:45:20 <danwent> https://bugs.launchpad.net/bugs/885265
21:45:20 <danwent> https://bugs.launchpad.net/nova/+bug/899767
21:45:20 <uvirtbot> Launchpad bug 885265 in quantum "quantum 420 error leaves instance in BUILD state" [High,New]
21:45:22 <uvirtbot> Launchpad bug 899767 in quantum "live_migration does not perform vif unplugging " [High,In progress]
21:45:37 <danwent> in quantum itself:  https://bugs.launchpad.net/quantum/+milestone/essex-2
21:45:51 <danwent> have a lot of code to review… and some bugs to squash
21:45:54 <ttx> do you have someone working on the first one on nova side ?
21:46:10 <Vek> what the heck is a 420?
21:46:25 <ttx> (is Brad Hall working on the nova side of the fix as well ?)�
21:46:25 <danwent> http error code… don't get any ideas Vek :P
21:46:42 <danwent> ttx: yes, I will assign bhall to the nova side as well. sorry
21:46:49 <ttx> danwent: i'm on it
21:47:20 <danwent> only other point to bring up was a discuss I read about on Rob H's blog about dependencies on Quantum by other openstack projects
21:47:34 <ttx> danwent: you'll use a milestone-proposed branch for E2 ?
21:47:42 <danwent> ttx: yes
21:47:50 <Vek> "Policy not Fulfilled"?
21:47:51 <ttx> danwent: ok, let me know if you've questions on that.
21:47:52 <danwent> we now have the github permissions
21:48:17 <danwent> Vek: ask salvatore.. he defined our error codes.  I thought you were hinting at another meaning of that number
21:48:34 * ttx gets curious
21:48:52 <danwent> anyway, back to the dependenices question.  I'd like to figure out a way that quantum can be a "soft dependency" for things like horizon + nova while it is incubation.
21:48:57 <danwent> ttx: i'm sure google can help
21:49:26 <ttx> danwent: it does !
21:49:29 <danwent> so if anyone has thoughts on the dependency issues, please contact me, or the netstack list as a whole.  that's all from me.
21:49:38 <troytoman> wrt Melange, we have moved the repo into Github/gerrit thanks to jeblair
21:49:56 <troytoman> spent time this week working on documentation that is now in the repo
21:49:57 <Vek> the only documentation I can find for 420 so far also documents 418--"I'm a Teapot" :)
21:50:06 <Vek> anyway, I digress...
21:50:31 <ttx> troytoman: nothing blocking you ?
21:50:34 <troytoman> we still have to resolve an issue wound whether to use an openstack common repo or pull that code into Melange
21:50:47 <troytoman> we have a work around so it is not a blocker right now
21:50:57 <mtaylor> troytoman: I believe we've made progress in agreeing to make openstack-common a real thing
21:51:12 <danwent> vek: http://docs.openstack.org/incubation/openstack-network/developer/quantum-api-1.0/content/Faults.html
21:51:19 <mtaylor> troytoman: and you can, of course, add a tag or a commit hash to the pip-requires line ... so I think we're making good progress there
21:51:22 <danwent> props to salvatore for some great docs :)
21:51:30 <troytoman> mtaylor: looks like it. so we'll hope that plays out
21:51:46 <troytoman> trying to see if we'll be ready to do an E-2 release or wait for E-3
21:52:01 <troytoman> otherwise, we're moving forward
21:52:44 <ttx> troytoman: for the first one feel free to do an out of band release/tag, no need to sync on the same date
21:52:51 <ttx> Any other team lead with a status report ?
21:52:58 <wwkeyboard> danwent: those non-standard error codes have already caused bugs in nova, I can't imagine what they are going to do for our consumers.
21:53:13 <troytoman> ttx: sounds good
21:53:15 <ttx> troytoman: I mean, if you're ready one day after the E2 date, go for it and tag it E2 :)
21:53:21 <ttx> don't wait 6 weeks.
21:53:45 <Vek> yeah, "Policy not Fulfilled" != "NetworkNotFound"
21:53:54 <danwent> wwkeyboard: I definitely understand.  I'll chat with Salvatore about this for the next rev of the API.
21:54:14 <ttx> CI / doc / stable / packagers ?
21:54:34 <mtaylor> sup?
21:54:44 <wwkeyboard> danwent: thank you! let me know what I can do to help
21:54:51 <ttx> mtaylor: if you have anythin to announce, go for it
21:55:11 <mtaylor> stuff rocks
21:55:14 <ttx> Otherwise I'll switch to open discussion.
21:55:31 <ttx> #topic Open discussion
21:55:46 <ttx> If you are around Brussels in February, please submit talks to the FOSDEM "Open Source Virtualization and Cloud" devroom
21:55:54 <ttx> We want OpenStack to be all over it
21:56:12 <ttx> #info please submit talks to the FOSDEM "Open Source Virtualization and Cloud" devroom
21:56:18 <ttx> #link https://lists.fosdem.org/pipermail/fosdem/2011-November/001354.html
21:56:44 <ttx> Anything else, anyone ?
21:58:09 <ttx> I guess not.
21:58:12 <ttx> #endmeeting