20:03:49 <annegentle> #startmeeting
20:03:50 <openstack> Meeting started Mon Dec 12 20:03:49 2011 UTC.  The chair is annegentle. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:03:51 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:04:17 <annegentle> Welcome to the Doc / Web team meeting, we meet monthly about documentation and the OpenStack website.
20:04:30 <annegentle> #topic API quick start and reference page
20:04:39 <annegentle> This is probably a repeat from the weekly team meeting, but we welcome input on http://heckj.github.com/api-site-mock/
20:05:06 <annegentle> The idea is to provide a reference site for developers consuming OpenStack APIs.
20:06:05 <annegentle> We're soliciting ideas for integrating extension information.
20:06:18 <annegentle> Which leads to the next topic, the extension documentation.
20:06:25 <annegentle> #topic Extension documentation
20:06:38 <annegentle> Jorge posted to the mailing list last week, seeking feedback on http://http://docs.rackspace.com/openstack-extensions
20:06:59 <annegentle> whoops weird double http on that one :)
20:07:12 <annegentle> #info seeking input on http://heckj.github.com/api-site-mock/
20:07:25 <annegentle> #info seeking input on http://docs.rackspace.com/openstack-extensions
20:07:45 <annegentle> feedback on the Extensions site can be funneled to Jorge
20:08:04 <annegentle> and for the API site, heckj mostly did the mockup
20:08:48 <annegentle> I don't have much to add on those two. We are seeking more ways to get design feedback. The Dashboard team especially needs it, so we're working on inventive ways to gather input.
20:09:07 <annegentle> One idea is to hold a monthly review meeting via webinar-ish methods.
20:10:11 <annegentle> Ideally we'll loop in more of the actual audience for these sites than the devs of the sites, ya know?
20:10:19 <bcwaldon> won't most of the community that cares be on the mailing list?
20:10:25 <annegentle> #info Looking for more ways to get reviews and input on designs.
20:10:59 <annegentle> bcwaldon: I'm thinking of it as not all of Rackspace's customers who will migrate to the next Compute API aren't on the OpenStack list, for example.
20:11:11 <bcwaldon> annegentle: very true
20:11:24 <bcwaldon> annegentle: but should they be involved at this level?
20:11:28 <dubsquared> I think it's a fair ask to assume that a lot of the visitors to the site might be new to the project, or are just looking ffor one specific piece off info?
20:11:32 <annegentle> bcwaldon: and HP's public cloud customers could give valuable input, that sort of thing
20:11:57 <bcwaldon> annegentle: so you're kind of looking to build a customer advisory board for openstack
20:12:03 <bcwaldon> and this could be one of the discussion topics
20:12:13 <annegentle> dubsquared: visitors to the API site certainly may be new to the project… but I'm envisioning they're just looking for "what can I GET on the Compute API"
20:12:37 <annegentle> bcwaldon: maybe not that lofty a goal, but that would be awesome, to get more "real" customers reviewing sites, info, docs, and the Dashboard UI
20:12:50 <dubsquared> do you mean in that the context of "what can GET do for me?"
20:13:03 <bcwaldon> annegentle: maybe we just approach who we think will be consumers of these resources and ask them?
20:13:11 <dubsquared> what can POST, what can …..?
20:13:11 <bcwaldon> annegentle: I know a group here that might care
20:13:14 <annegentle> dubsquared: yep, really just a minimal reference site
20:13:18 <dubsquared> gotcha ...
20:13:31 <annegentle> bcwaldon: that would be awesome if we found a small group that would like to poke at early designs, ya knkow?
20:13:43 <bcwaldon> annegentle: sure, let me actually ask someone right now...
20:13:51 <annegentle> bcwaldon: excellent, thanks.
20:13:53 <bcwaldon> I'll get back to you after the meeting
20:14:02 <annegentle> do you all think a webinar approach would work well for Dashboard UI?
20:14:28 <annegentle> nearly all open source projects have the difficulty of shoe-horning dev processes into design process or the other way around
20:14:53 <annegentle> so I do think it's an "audience" solution much of the time, meet devs where devs hang out, find users where users hang out.
20:15:30 <annegentle> anyway, the next topic is discussing how to track bugs and content requests for openstack.org
20:15:50 <annegentle> #topic Openstack.org site processes
20:16:11 <annegentle> So the process now is to log a bug against the Launchpad openstack-manuals project and tag it "website"
20:16:45 <annegentle> And even that process is new, so we can change it as needed. One thought is to have an openstack-org Launchpad project for bug and request tracking.
20:16:53 <annegentle> Any preferences?
20:17:41 <annegentle> Seems like we had a lot of excitement about the process surrounding the "security" page but now interest has died down a little? :)
20:17:59 <annegentle> We did the work on the security page, tracking it with this doc bug: https://bugs.launchpad.net/openstack-manuals/+bug/898010
20:18:00 <uvirtbot> Launchpad bug 898010 in openstack-manuals "Security page rev1 on openstack.org" [High,Confirmed]
20:18:36 <dubsquared> that seems to be a reasonable method, as long as it's published as /the/ method :)
20:18:47 <annegentle> We had another bug come in about fonts used in a PDF from the openstack.org site, which we logged, tracked, and completed. So the process seems to work.
20:18:56 <annegentle> dubsquared: yeah, find a process and stick to it! :)
20:20:10 <annegentle> I think Todd and I are fine with either, just a matter of setting up openstack-org on Launchpad and publishing that is "the" way
20:20:24 <annegentle> Also the name "openstack-org" matches the Github repo I believe.
20:20:38 <dubsquared> #winning
20:20:46 <annegentle> hee
20:20:58 <annegentle> welcome Todd
20:21:08 <toddmorey> Hello!
20:21:17 <annegentle> We were just talking about setting up an "openstack-org" Launchpad project for tracking requests/bugs
20:21:44 <annegentle> toddmorey: do you have any preference for the project name?
20:22:03 <toddmorey> I think openstack-org works
20:22:34 <annegentle> Yeah I like it.
20:22:55 <annegentle> #action Anne to set up Launchpad project called openstack-org to track content requests and bug fixes with openstack.org site
20:23:04 <toddmorey> We are also adding an expanded footer that has a small "feedback on this page" form for each webpage on the .org site. Those will then be filtered and added as requests/bugs into launchpad as appropriate
20:23:13 <annegentle> toddmorey: oh nice.
20:23:38 <annegentle> #info Feedback on this page form being added to each openstack.org page to add to Launchpad for tracking
20:24:24 <toddmorey> (so that's a way for casual browsers to also provide quick insights to us without having to know about launchpad.) But we want to have it all end up in the same place and I like the idea of using launchpad.
20:24:29 <annegentle> For now, I think it's just Todd and I who have author privs on the openstack.org site, but maybe we can set up a "core" team like docs-core is set up.
20:24:58 <toddmorey> yes, and we'd like to get some translators going as well for a few key pages to start
20:25:11 <annegentle> toddmorey: ah, nice segue into Translations!
20:25:18 <annegentle> #topic Translation process
20:26:01 <annegentle> My very rough outline for a translation process uses Launchpad at the heart of it for storing files and assigning permissions for translators.
20:26:19 <annegentle> The process is so rough it's untested :)
20:27:10 <annegentle> But I did want to see if there's interest in pursuing such a process. Seems like there's not enough interest for a full-fledged process, but we can keep it around for when the time's right.
20:27:34 <annegentle> Essex may be the release after which we translate docs, I'm not sure.
20:27:58 <annegentle> So I think I'll leave it at that - process outlined, no owners yet.
20:28:16 <annegentle> #info Translation process is rough and untested, when sufficient interest arises we can test.
20:28:30 <annegentle> No actions at this time, I believe.
20:28:56 <annegentle> toddmorey: though for specific openstack.org pages, I wonder if a post to the mailing list would suffice?
20:29:04 <annegentle> toddmorey: a post to request help?
20:29:26 <toddmorey> Yes, that's a good idea.
20:29:38 <annegentle> okay
20:29:51 <annegentle> let's email a bit to pinpoint pages and such
20:30:00 <toddmorey> It's a fairly simple process in the CMS, but once we have volunteers we could provide them instructions or do a quick demo
20:30:04 <annegentle> #Action Anne to email Todd about specific openstack.org pages to translate
20:30:38 <annegentle> Ok, last item before open discussion is about work to move from Cloud Sites to Cloud Servers
20:30:49 <annegentle> #topic Move docs.openstack.org from Cloud Sites to Cloud Servers
20:31:02 <annegentle> So, Rackspace hosts docs.openstack.org, and currently it's set up as a Cloud Sites account.
20:31:30 <annegentle> The Rackspace Doc Tools team is moving to Cloud Servers for the Rackspace content, and wants to move OpenStack content over too.
20:32:01 <annegentle> I'm fine with it as long as the sys admin work is done by Rackspace, ensuring backup and assistance 24/7.
20:32:24 <annegentle> So the research item for the Doc Tools team is to ensure the same level of service.
20:32:37 <annegentle> The benefit is that we can automatically create the landing page
20:32:42 <annegentle> rather than manually
20:32:52 <dubsquared> Who is going to own the support for the site after the move to cloudservers?
20:32:57 <toddmorey> right, me too. as long as the servers have owners and someone to call if docs isn't responding for some reason
20:33:16 <annegentle> dubsquared: the "research item" is "let's make sure we have a Managed Cloud Servers account :)
20:33:22 <dubsquared> word :)
20:33:26 <annegentle> ayup
20:33:38 <annegentle> This move will mean changes to Jenkins builds.
20:33:51 <annegentle> I believe it's just a change to the FTP settings in one location.
20:34:02 <annegentle> And probably an additional build job for this automatic landing page.
20:34:36 <annegentle> #info In research stages for moving docs.openstack.org from Cloud Sites to Cloud Servers, ensuring same SLA as now.
20:34:46 <annegentle> Basically I don't want calls in the middle of the night if the site goes down :)
20:35:06 <annegentle> No action right now, the actions are being taken by joesavak and the Doc Tools team.
20:35:22 <annegentle> So, that's it for December. Any items for open discussion?
20:35:27 <annegentle> #topic Open discussion
20:36:49 <annegentle> A book I'm working on that I'm excited about is https://github.com/annegentle/openstack-manuals/tree/installdocs
20:37:06 <annegentle> it's a new document for installing manually using Cloud Builders packages "diablo-final"
20:37:16 <toddmorey> yay!
20:37:20 <toddmorey> that's awesome
20:37:22 <annegentle> and I just got Compute, Identity, and Dashboard working today.
20:37:26 <toddmorey> and badly needed
20:37:28 <annegentle> whew!
20:37:46 <annegentle> The merge back in is going to be NUTS. But it's a separate document so I think it'll go okay.
20:38:06 <toddmorey> One thought for the website is the current "action item" for each project page is to push them to download code.
20:38:12 <annegentle> #info New install/deploy document draft nearly ready for publishing
20:38:19 <annegentle> #link https://github.com/annegentle/openstack-manuals/tree/installdocs
20:38:32 <toddmorey> We'd like to instead point people to a getting started guide. This install guide sounds like the ticket.
20:38:41 <annegentle> toddmorey: oh yes this is what we'd want to point them to
20:38:45 <jsavak> \o - just joined
20:38:52 <annegentle> Hi Joe!
20:38:59 <jsavak> hi!
20:39:23 <annegentle> Any update on a Managed Cloud Servers account for docs.openstack.org?
20:39:27 <jsavak> i have some info on the cloud servers move -
20:39:35 <annegentle> excellent
20:39:58 <jsavak> yup - after speaking with monty - we are going to create them as regular cloud servers and add them to the puppet scripts for monitoring
20:40:17 <jsavak> zns confirmed this approach
20:40:46 <annegentle> jsavak: will Monty get the notifications on the monitors
20:41:11 <jsavak> not sure. I'll confirm with Monty - but I think it would be whoever gets the jenkins alerts...
20:41:29 <annegentle> jsavak: ok so it's more or less Jenkins that says "broke!"
20:41:40 <annegentle> jsavak: and then is the CI team the "fixers?"
20:41:48 <jsavak> i think so (or hope so)
20:42:05 <annegentle> jsavak: that may not be acceptable… need to figure out if they're really up for an SLA or some sort of terms.
20:42:06 <jsavak> and will confirm
20:42:30 <annegentle> I have some trepidation :)
20:42:58 <jsavak> yup. I think things will be more concrete with openstack foundations, but right now I have trepidation too.
20:43:08 <annegentle> Is plan B for OpenStack to stay on an earlier snapshot of the build tools? Is there no branch for "we still use Cloud Sites?"
20:43:28 <jsavak> no branch was being planned for cloud sites support
20:44:03 <jsavak> the work hasn't started and i'm sure we'll discover a lot of the answers when we get David & Monty together
20:44:04 <annegentle> jsavak: may need to at least visit and discuss that… seems like there are enough difference between the SLAs to look into options.
20:44:34 <annegentle> We can discuss more as you find out more, also.
20:44:40 <jsavak> sounds good
20:44:57 <annegentle> Ok, we can wrap up if there's no other discussion items.
20:45:47 <annegentle> thanks all for coming. We missed our usual "regulars" Joe Heck and Todd Deshane, but thanks y'all for coming!
20:45:53 <annegentle> #endmeeting