21:04:23 <vishy> #startmeeting
21:04:24 <openstack> Meeting started Mon Dec 12 21:04:23 2011 UTC. The chair is vishy. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:04:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:04:37 <vishy> #topic First Nova Subteam Meeting
21:04:41 <vishy> welcome everyone
21:05:03 <vishy> first item on the agenda is figure out how we don't have to do this
21:05:25 <vishy> #topic Best method of communication
21:05:41 <vishy> #info Goals for communication:
21:06:08 <vishy> #info Efficiently managing and targeting blueprints
21:06:26 <vishy> #info Addressing shared blueprints and work across teams
21:06:34 <vishy> #info Ensuring we aren't duplicating work
21:06:42 <vishy> #info Ensuring we aren't blocking each other
21:06:49 <vishy> #info Staying abreast of decisions made by teams
21:06:58 <vishy> #info Staying aligned with the release schedule
21:07:14 <vishy> soren sugested that this could all be done via email
21:07:33 <_0x44> Should there be a sub-team mailinglist?
21:07:47 <vishy> this seems like a possibility but we all have to be better at emailing updates
21:08:10 <vishy> _0x44: based on the relative value of the other mailing lists I'm not sure it is necessary
21:08:28 <vishy> we could just hit openstack mailing list with a [subteam] heading if necessary
21:08:39 <vishy> other options are:
21:08:39 <bcwaldon> vishy: I like that approach
21:08:49 <vishy> regular meetings (maybe biweekly)
21:08:52 <_0x44> I personally think a lot of the db discussions would have been better done on a mailing list instead of an IRC meeting as the only people who attend have been myself, bcwaldon, and monsyne dragon.
21:08:58 <vishy> shared place to put updates
21:09:14 <bcwaldon> I bet we would get better participation through email anyways
21:09:30 <vishy> _0x44: agreed. I was trying to avoid the bikeshedding that sometimes occurs on the ml
21:09:41 <vishy> by shrinking the commenters to people who are actually going to work on it
21:09:47 <vishy> but I'm not sure if that really worked
21:09:58 <vishy> i think it has been pretty effective for nova-api
21:10:05 <vishy> (which had the most bikeshedding imo)
21:10:17 <bcwaldon> I know there are people that work on the nova apis that don't come to nova-api team meetings, but I'm not sure if that's because they dont care about doing it right or what
21:10:48 <vishy> #idea the team leads are probably enough to prevent bikeshedding
21:11:14 <bcwaldon> vishy: yeah, as long as we empower the team leads enough to shut down bikesheders
21:11:15 <vishy> #idea so we can return to ML discussions if the team leads are willing to keep the discussions focused and directed.
21:11:38 <_0x44> vishy: +1 to that.
21:11:46 <vishy> does anyone have alternative proposals or other suggestions?
21:12:15 <bcwaldon> vishy: how about we encourage email correspondence through the list and say meetings can be scheduled when its absolutely necessary
21:12:28 <vishy> bcwaldon: I like it
21:12:30 <bcwaldon> but to include those in other timezones, we absolutely need to shoot for email
21:12:46 <bcwaldon> when I say *other*, I mean non-US timezones
21:13:07 <bcwaldon> I would love to see if participation picks up from non-US timezones if we eradicate all these meetings
21:13:08 <vishy> so cross team communication can include multiple headers or will be with the [subteam] heading if it applies to everyone
21:13:29 <vishy> so If i'm emailing the team leads, I'm going to use the [subteam] heading, so eyes out for those
21:13:41 <_0x44> I like that, especially since the person doing the most work on db clean up right now isn't able to attend the -db meeting.
21:14:08 <bcwaldon> vishy: does it make sense to have team-specific mailing lists
21:14:09 <vishy> #action vishy to email the list explaining use of the list by subteams.
21:14:13 <bcwaldon> I know we've already gone back and forth on that one
21:14:23 <vishy> bcwaldon: no, we have those and i think it is not necessary
21:14:30 <bcwaldon> can you explain why
21:14:49 <vishy> bcwaldon: my last email suggested using [api] header for example for nova-api related discussion
21:14:59 <vishy> bcwaldon: it isolates information
21:15:09 <bcwaldon> kind of like the meetings do
21:15:17 <vishy> bcwaldon: people can ignore messages they don't care about
21:15:18 <bcwaldon> so what's the point of having logical teams on launchpad?
21:15:28 <bcwaldon> I've got ~50 people on nova-api that have never said a word
21:15:37 <vishy> bcwaldon: perhaps there isn't a lot of value
21:15:43 <vishy> bcwaldon: aside from having a team lead
21:15:58 <bcwaldon> that's what I'm thinking
21:16:09 <vishy> bcwaldon: I don't know that we need to remove the teams though
21:16:23 <vishy> we can just shut down the ml after everyone has switched over to using the main ml
21:16:28 <bcwaldon> I think what's most important here is that people that care about different topics can have a way to communicate with one another
21:16:34 <vishy> bcwaldon: actually
21:16:43 <vishy> bcwaldon: the subteams on launchpad are great for tracking blueprints
21:16:49 <bcwaldon> vishy: good point
21:16:51 <vishy> bcwaldon: so i think they still have value
21:16:55 <bcwaldon> absolutely
21:17:30 <vishy> #info subteams will not use separate mailing lists, but still have value for blueprint tracking
21:17:38 <vishy> ok next topic
21:17:53 <vishy> #topic Blueprint management and targetting
21:18:16 <vishy> #info we need to get better at assigning and targetting blueprints
21:18:38 <vishy> there is a lot of stuff still assigned to teams with no actual person assigned
21:18:43 <vishy> how can we improve that
21:18:45 <vishy> suggestions?
21:18:55 <bcwaldon> so the problem I see a lot on the project is that we're great at reacing to what features are proposed to be added
21:19:04 <bcwaldon> but when we have a feature that a specific company isn't driving, it just sits
21:19:15 <bcwaldon> since we don't have resources to allocate to those kinds of features
21:19:34 <vishy> bcwaldon: I agree. Unfortunately a lot of the stuff is important to others
21:19:42 <vishy> bcwaldon: for example separate-volume-api
21:19:48 <_0x44> I have to run
21:19:52 <bcwaldon> bye _0x44
21:19:53 <bcwaldon> !
21:19:54 <_0x44> Sorry
21:20:00 <vishy> _0x44: ok thx, will send out update
21:20:22 <bcwaldon> vishy: so we're back to more of a technical-debt problem
21:20:31 <bcwaldon> how can a product organization prioritize technical debt
21:20:37 <bcwaldon> when there are so many tempting features
21:20:51 <vishy> bcwaldon: I don't think there are that many tempting features left
21:21:04 <vishy> bcwaldon: we don't have that much feature work targeted
21:21:13 <bcwaldon> maybe at this point
21:21:19 <bcwaldon> this feeling has been around a while
21:21:21 <bcwaldon> I'm digging down deep
21:21:22 <vishy> bcwaldon: so i feel like we should all be moving to technical debt, cleanup, bugfixing, perf testing
21:21:29 <bcwaldon> vishy: absolutely!
21:23:11 <vishy> bcwaldon: looks like it is me and you now
21:23:16 <bcwaldon> just the two of us
21:23:18 <bcwaldon> we are nova
21:23:24 <vishy> haha
21:23:57 <bcwaldon> so yes, we do need to get better at assigning blueprints
21:24:11 <bcwaldon> how about I go over the nova-api blueprints and send out an email to the team
21:24:18 <vishy> that would be cool
21:24:31 <vishy> I will take a look at the state of the other ones
21:24:57 <bcwaldon> ok
21:25:00 <bcwaldon> what other problems can I solve for you
21:25:36 <vishy> i guess that is it
21:25:53 <bcwaldon> actually
21:25:55 <bcwaldon> let me ask a question
21:25:57 <vishy> #action bcwaldon to clean up nova-api blueprints and email about targeting
21:26:17 <bcwaldon> for the openstack-api-ssl bp, there has been a review in gerrit forever
21:26:26 <vishy> #action vishy to look over other blueprints and send out specific email to [subteam] highlighting issues
21:26:28 <bcwaldon> how would you suggest we move forward with that
21:26:35 <vishy> bcwaldon: is that an hp one?
21:26:40 <vishy> sometimes you have to kick them
21:26:50 <vishy> i kicked them about the vm state one and they updated it
21:26:51 <bcwaldon> vishy: we're in a public forum!
21:26:56 <bcwaldon> ok, I'll ping them
21:27:11 <bcwaldon> do you want to be my assignee for separate-nova-volumeapi
21:27:14 <mtaylor> vishy: can I kick anybody for you?
21:27:40 <vishy> bcwaldon: I guess it should be me, but I want to talk with you about where exactly we should move the parts
21:27:54 <vishy> bcwaldon: we discussed it briefly but i will probably bug you about it more
21:27:58 <bcwaldon> yeah, I need to talk to you about adminapi
21:28:03 <bcwaldon> we can hop on skype
21:28:06 <vishy> lets finish this meeting
21:28:10 <bcwaldon> yes
21:28:12 <vishy> #topic open discussion
21:28:17 <vishy> any questions comments?
21:28:20 <vishy> thoughts?
21:28:22 <vishy> complaints?
21:28:22 <bcwaldon> mtaylor: this is directed at you
21:28:26 <vishy> is anyone even here?
21:28:28 <vishy> :)
21:28:43 <bcwaldon> just the two of us
21:28:43 <mtaylor> o/
21:28:46 <bcwaldon> we can make it if we try
21:29:08 * mtaylor is just lurking
21:29:18 <vishy> #endmeeting