21:02:14 <ttx> #startmeeting
21:02:15 <openstack> Meeting started Tue Dec 13 21:02:14 2011 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:16 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:02:24 <ttx> Welcome everyone to our weekly general meeting !
21:02:35 <ttx> Today's agenda: http://wiki.openstack.org/Meetings/TeamMeeting
21:02:48 <ttx> #info This is the last day before cutting milestone-proposed branches for Nova/Glance/Keystone/Horizon E2
21:02:57 <ttx> #topic Actions from previous meeting
21:03:07 <ttx> * joesavak/zns to sync with HP for updated status on their blueprints
21:03:18 <ttx> joesavak/zns: in particular, I'd like to know if keystone-swift-acls should be considered completed
21:03:38 <joesavak> I think it should. From what i understand the BP scope is beta only
21:04:08 <joesavak> per HP:
21:04:09 <joesavak> "Swauth ACLs are implemented and checked in by Liem.  He expanded upon the contribution of another user to make things more modular, add user based ACLs, and memcache."
21:04:40 <ttx> ok, will mark completed then
21:04:47 <ttx> * vishy to find a victim or complete by himself nova-volume-snapshot-backup-api
21:04:55 <ttx> That was done, just needs a final review, afaict
21:05:01 <vishy> yes yes
21:05:11 <ttx> we'll mention it during nova status
21:05:13 <ttx> * vishy to sync with david-perez on finishing up nova-vm-state-management
21:05:18 <ttx> That's done
21:05:26 <ttx> * ttx to discuss options for getting a sane list of reviews with CI guys
21:05:35 <ttx> That's not done yet, pushing back:
21:05:41 <ttx> #action ttx to discuss options for getting a sane list of reviews with CI guys
21:05:55 <ttx> * jaypipes to get status updates from mtaylor on Glance packaging issues
21:06:17 <ttx> we'll mention that during the glance status, if Jay arrives before then
21:06:22 <ttx> #topic Keystone status
21:06:32 <ttx> #link https://launchpad.net/keystone/+milestone/essex-2
21:06:46 <ttx> zns, joesavak: What's the status of portable-identifiers ? I see two reviews in progress.
21:07:07 <joesavak> yes - there'll be another review coming in for the user portable identifiers
21:07:16 <joesavak> once the 3 are reviewed, then we're good
21:07:34 <ttx> joesavak: Are they all going to make it today ?
21:07:43 <ttx> or should we defer that feature for E3 ?
21:07:53 <joesavak> ttx: no - we believe it should be tomorrow. Can we cut keystone e2 tomorrow?
21:08:43 <ttx> ideally I will create the branch tomorrow morning... so we have two options if you want this in E2
21:09:17 <ttx> we can wait a bit before branching, or you can backport them to milestone-proposed
21:09:26 <ttx> in this case, I'd rather defer or wait a bit
21:09:43 <joesavak> my preference is to wait a bit
21:09:45 <zns> ttx: good progress. We will need till tomorrow.
21:09:52 <ttx> joesavak: ok.
21:10:05 <joesavak> ttx: thanks
21:10:13 <ttx> #info wait to cut milestone-proposed branch for Keystone until tomorrow morning US time :)
21:10:27 <ttx> You also have two E2-targeted bugs left (that should be fixed by tomorrow):
21:10:33 <ttx> Bug 900916 (Support D5 API Contract, Critical, zns)
21:10:33 <uvirtbot> Launchpad bug 900916 in keystone "Support D5 API Contract" [Critical,In progress] https://launchpad.net/bugs/900916
21:10:42 <joesavak> a review is in for that
21:10:57 <ttx> and Bug 878759
21:10:58 <uvirtbot> Launchpad bug 878759 in keystone "better manual page with description needed for keystone." [Low,In progress] https://launchpad.net/bugs/878759
21:11:09 <zns> ttx: we are waiting on feedback. We have some already, but this is ready to go in.
21:11:21 <joesavak> I need to get info from koolhead to see if this is closed.
21:11:27 <ttx> not sure that last one is critical anyway
21:11:32 <joesavak> I don't think it is
21:11:35 <ttx> will keep it on list until tomorrow
21:11:48 <ttx> Quick look at the E3 plan at https://launchpad.net/keystone/+milestone/essex-3
21:12:04 <ttx> joesavak/zns: Would be good to get the disruptive stuff early in the milestone
21:12:09 <ttx> rbac-keystone in particular
21:12:25 <ttx> so that the other projects can catch up with the feature if needed
21:12:33 <joesavak> agreed
21:12:41 <ttx> joesavak/zns: Anything else ?
21:12:53 <joesavak> not from me
21:12:55 <ttx> Questions for Keystone ?
21:13:21 <ttx> #topic Swift status
21:13:26 <ttx> notmyname: o/
21:13:27 <notmyname> hi
21:13:49 <notmyname> I don't think I have anything, but I'm happy to answer questions
21:14:02 <ttx> Questions on Swift ?
21:14:37 <ttx> apprently not, that was fast :)
21:14:46 <ttx> jaypipes: around ?
21:15:27 <ttx> let's skip to give him a chance to join. Otherwise I'll abuse bcwaldon as a hotswap
21:15:33 <ttx> #topic Nova status
21:15:40 <bcwaldon> ttx: I'm here if you need me
21:15:43 <ttx> vishy: heya
21:15:50 <vishy> hi
21:15:52 <ttx> #link https://launchpad.net/nova/+milestone/essex-2
21:16:03 <ttx> vishy: Given how ambitious the plan was, I'd say the results are not too bad :)
21:16:14 <ttx> We need nova-volume-snapshot-backup-api in <-- please review
21:16:34 <ttx> missing +2s
21:16:47 <vishy> yes
21:17:01 <vishy> the security groups one we need to push
21:17:02 <ttx> Looks like xenapi-security-groups will be deferred to E3, unless someone from Citrix has a last-minute surprise
21:17:19 <ttx> vishy/westmaas: What's the state for internal-uuids ? Just a review away from completion ? Or are there more in the giant pipe ?
21:17:25 <vishy> not bad all of the essential and highs.
21:17:36 <vishy> one miss on the mediums and a few lows
21:17:40 <vishy> that seems reasonable
21:17:51 <westmaas> ttx, one last merge
21:18:04 <westmaas> https://review.openstack.org/#change,2244
21:18:06 <ttx> westmaas: ok, so would be nice to get that one in
21:18:44 <westmaas> we think the tests are a false positive, its re-running now
21:18:49 <ttx> #info last minute E2 reviews needed for: https://review.openstack.org/#change,2244 and https://review.openstack.org/#change,1202
21:18:50 <vishy> cool
21:18:51 <westmaas> and then we can close that bp out
21:18:56 <vishy> if the tests pass i will approve it
21:18:59 <ttx> The remaining six are Low ones, which will probably be deferred to E3, unless something fast happens tonight:
21:19:05 <ttx> (pci-passthrough, openvz-driver, aws-api-validation, deleting-compute-node-table, openstack-api-ssl and consolidate-testing-infrastructure)
21:19:20 <ttx> vishy: OK to cut the milestone-proposed branch early tomorrow morning with what's in ?
21:19:26 <vishy> yup
21:19:40 <ttx> #info milestone-proposed will be cut wed morning with what's in
21:19:47 <ttx> Two bugs on the E2-targets so far:
21:19:56 <ttx> Bug 899767 (danwent)
21:19:58 <uvirtbot> Launchpad bug 899767 in quantum "live_migration does not perform vif unplugging " [High,In progress] https://launchpad.net/bugs/899767
21:20:11 <danwent> ttx, this has two +1s
21:20:41 <ttx> would be good to get in before branching as well, will spare a backport
21:20:59 <danwent> we also have two other fixes related to Quantum that are being reviewed.  working with trey and the nova-network team on those.  I expect them in by tonight.
21:21:16 <ttx> #help please also review https://review.openstack.org/#change,2253,patchset=1
21:21:45 <ttx> Bug 901594 (ttx)
21:21:46 <uvirtbot> Launchpad bug 901594 in nova "Change in hostname exposition renders EC2 API unusable" [High,In progress] https://launchpad.net/bugs/901594
21:21:55 <ttx> This one is ready for review, but there is still some discussion on whether it's appropriate...
21:22:00 <ttx> vishy: made your mind yet ?
21:22:01 <danwent> #help other quauntum reviews https://review.openstack.org/#change,2265  and https://review.openstack.org/#change,2266
21:22:18 <ttx> danwent: do we need those in E2 for quantum to work ok ?
21:22:35 <ttx> if yes, would be good to target the corresponding bugs to E2
21:22:39 <danwent> ttx:  first one prevents melange from working correctly, so I thin it is important.
21:22:49 * ttx adds
21:23:00 <danwent> otherone was found by Aaron Lee… not sure what it impacts.
21:23:06 <ttx> ..if only there was a bug ref
21:23:07 <vishy> approved the first one
21:23:21 <tr3buchet> danwent: i knocked out a few of them, but got busy again
21:23:22 <danwent> ttx:  yes, great shame...
21:23:35 <ttx> danwent: can't track what's not in a bug or blueprint
21:23:39 <vishy> ttx: I think I'd like to leave it for now
21:23:40 <danwent> really appreaciate all of the help trey…
21:23:54 <danwent> ttx: yes, I will smack the appropriate party :P
21:24:04 <vishy> ttx: we can revert for essex if euca doesn't merge smoser's patch
21:24:20 <vishy> (and the dns support from wikimedia doesn't make it in)
21:24:21 <ttx> vishy: ok, will abandon and downgrade prio then
21:24:40 <ttx> Anything blatantly missing from this E2 buglist, things that *need* to be fixed before we can release the milestone ?
21:24:52 <vishy> ttx: more importantly, does anyone know?
21:25:28 <smoser> vishy, what is "dns support from wikimedia" ?
21:25:34 <ttx> #action ttx to reprioritize 901594
21:25:45 <ttx> vishy: do we have a blueprint for that ?
21:27:36 <smoser> i suspect its not a full work around, as i'm not terribly likely to want to use an openstack provided dns server just because i want to run an instance.
21:28:09 <ttx> vishy: still with us ?
21:28:33 <ttx> Intermission: Nova subteam leads: anything you wanted to add ?
21:28:48 <vishy> yes
21:28:49 <vishy> sorry
21:28:59 <vishy> there is a blueprint yes
21:29:21 <ttx> vishy: cannot find it, did they commit to a given milestone ?
21:29:40 <vishy> it ressurected itself
21:29:40 <vishy> https://blueprints.launchpad.net/nova/+spec/public-and-private-dns
21:29:53 <vishy> i had marked it deferred because I didn't think it was happening
21:30:10 <ttx> vishy: E3 ?
21:30:36 <vishy> what about e3?
21:30:51 <ttx> #action vishy to properly resurrect public-and-private-dns and target it
21:31:03 <ttx> An early look at E3: https://launchpad.net/nova/+milestone/essex-3
21:31:08 <ttx> vishy: Do you have all you want in there ?
21:31:27 <vishy> I'm going to do a scrub today and send out an email to subteam leads
21:31:32 <ttx> Maybe you should communicate a bit more clearly than you don't really want new features after E3, that may trigger vocations :)
21:31:49 <ttx> vishy: Anything else ?
21:32:01 <vishy> good call
21:32:38 <ttx> Questions on Nova ?
21:32:51 <Vek> "vocations"?  Well, the US *does* need more jobs, but...
21:33:04 * Vek ducks
21:33:21 <ttx> Let's switch to the next project
21:33:23 <ttx> #topic Horizon status
21:33:29 <ttx> devcamcar: o/
21:33:33 <devcamcar> o/
21:33:38 <ttx> #link https://launchpad.net/horizon/+milestone/essex-2
21:33:59 <ttx> So you have 2 blueprints still in progress...
21:34:10 <devcamcar> ttx: one is in review right now
21:34:28 <devcamcar> https://blueprints.launchpad.net/horizon/+spec/cert-download
21:34:33 <devcamcar> so that one will land
21:34:44 <devcamcar> https://blueprints.launchpad.net/horizon/+spec/improve-visual-design
21:35:04 <devcamcar> encompasses a number of other fixes and as such will probably get moved to e3, though most of it is done
21:35:21 <ttx> devcamcar: can I cut the milestone-proposed branch around 1am your time if all features are in ?
21:35:25 <devcamcar> yes
21:35:44 <ttx> devcamcar: ok, just keep the blueprint status updated. Will wait if any of those are not marked implemented
21:35:53 <devcamcar> will do
21:36:02 <ttx> You also have 11 E2-targeted bugs
21:36:16 <ttx> The critical ones that aren't fixed today and happen tomorrow can be backported to milestone-proposed oce it's created
21:36:24 <ttx> once*
21:36:28 <devcamcar> sounds good!
21:36:48 <ttx> ok
21:36:55 <ttx> A quick look at: https://launchpad.net/horizon/+milestone/essex-3
21:37:03 <ttx> Sounds ambitious like always, but sane :)
21:37:21 <devcamcar> indeed!
21:37:33 <devcamcar> we will have an additional full time resource during e3 as well
21:37:46 <ttx> #info horizon MP branch will be cut around 1am / 2am Pacific if all targeted blueprints are marked completed or deferred
21:38:11 <ttx> #info RelMgt will wait if any of those is still marked "Good progress"
21:38:25 <ttx> cool ! and welcome :)
21:38:29 <ttx> devcamcar: Anything else ?
21:38:46 <devcamcar> that's all! thanks
21:38:57 <ttx> Questions for Horizon ?
21:39:12 <ttx> jaypipes: still not around ?
21:39:53 <ttx> let's try to see if bcwaldon and me can make a convincing Mr Pipes.
21:40:02 <bcwaldon> I'll do my best
21:40:03 <ttx> #topic Glance status
21:40:10 <ttx> #link https://launchpad.net/glance/+milestone/essex-2
21:40:16 <ttx> Looks like protected-images will not make it ?
21:40:34 <bcwaldon> yep, I'm going to push that back to E3. It was temporarily abandoned
21:40:50 <bcwaldon> just made a note asking the author what the status is
21:40:54 <ttx> OK, so we have nothing to wait for, I can cut the milestone-proposed branch early tomorrow morning ?
21:41:10 <bcwaldon> ttx: yeah, there is one bug I want to get in
21:41:24 <ttx> bugs can still get in once the branch is cut
21:41:31 <bcwaldon> ok, then sure
21:41:35 <bcwaldon> we're all good
21:41:39 <ttx> (just needs to be targeted to E2 and proposed to milestone-proposed
21:41:40 <ttx> )
21:41:42 <bcwaldon> completed 100% of our blueprints!
21:41:46 <bcwaldon> 1/1
21:41:48 <ttx> tss
21:41:55 <ttx> You also have 7 E2-targeted bugs left.
21:42:14 <ttx> not sure how many of those actually are E2-critical
21:42:16 <bcwaldon> some of those have reviews in progress that stalled out
21:42:27 <bcwaldon> I'll untarget some of them
21:42:31 <bcwaldon> I dont think any are critical
21:42:52 <ttx> bcwaldon: there were a number of them around packaging that Jay was supposed to discuss with mtaylor
21:43:01 <ttx> bcwaldon: I bet we need bug 901534 fixed
21:43:02 <uvirtbot> Launchpad bug 901534 in glance "Data loss of properties during normal server snapshot process" [Critical,In progress] https://launchpad.net/bugs/901534
21:43:15 <bcwaldon> yes, thats one I want in
21:43:29 <ttx> ok.
21:43:41 <ttx> #info Glance Mp can be cut tomorrow morning
21:43:54 <ttx> bcwaldon: Anything else ?
21:44:05 <bcwaldon> That's all
21:44:18 <ttx> Questions on Glance ?
21:44:44 <ttx> bhall: thx for the bugs :)
21:44:54 <bcwaldon> bug fixes!
21:45:02 <bhall> ttx: np :)
21:45:15 <ttx> #topic Incubated projects and other Team reports
21:45:21 <ttx> danwent, troytoman: o/
21:45:22 <annegentle> o/
21:45:27 <danwent> hello
21:45:29 <ttx> annegentle: o/
21:45:31 <troytoman> o/
21:45:34 <danwent> anne, go first :)
21:45:40 <annegentle> oh  you're a gentleman :)
21:46:07 <annegentle> We had our Doc Team meeting yesterday. One decision that came out of it was to start a Launchpad project called openstack-org for tracking bugs and content requests for openstack.org
21:46:21 <ttx> cool!
21:46:24 <danwent> +1
21:46:25 <annegentle> #info Anne will create a Launchpad project called openstack-org for tracking bugs and content requests for openstack.org
21:46:44 <ttx> the process for updating was quite opaque so far :)
21:46:46 <lloydde> nice
21:47:48 <annegentle> We are also actively seeking input on the translation process I outlined on the mailing list.
21:48:21 <lloydde> O
21:48:25 <annegentle> Also looking to integrate translation process with translation of select bits of OpenStack.org content
21:48:34 <annegentle> Input welcomed!
21:48:35 <lloydde> oops, I've forwarded it to a couple of big tranlsators
21:49:03 <ttx> annegentle: anything else ?
21:49:06 <annegentle> lloydde: That's fine, just want to test the process and set expectations that it's new.
21:49:28 <annegentle> That's the highlights, Summary available at http://eavesdrop.openstack.org/meetings/openstack-meeting/2011/openstack-meeting.2011-12-12-20.03.html.
21:49:43 * annegentle gives mic to danwent
21:49:47 <danwent> thx
21:49:49 <danwent> https://launchpad.net/quantum/+milestone/essex-2
21:50:02 <danwent> thanks to a big push in the last few days, we're in pretty good shap.
21:50:04 <danwent> shape
21:50:23 <danwent> two bps still in review, one open bp it is a documentation issue
21:50:36 <ttx> danwent: let me know if you need help to cut the MP branch
21:50:41 <danwent> 7 open bugs still, but all in review.
21:50:59 <danwent> ttx:  thanks.  we now have the permissions I believe, but will definitely let you know.
21:51:09 <danwent> that is all on my end.
21:51:26 <ttx> troytoman: your turn
21:51:52 <troytoman> we are planning to do an initial "release" of melange within a week of the E-2 milestone.
21:52:10 <troytoman> we just want enough time to make sure that everything works in a nova/quantum/melange configuration
21:52:25 <ttx> sounds good
21:52:26 <danwent> super simple, right? :)
21:52:38 <troytoman> of course!
21:52:57 <troytoman> ttx: i could use some pointers on how to actually do the release
21:53:11 <troytoman> mtaylor: we still need the repository for melange-client
21:53:34 <ttx> troytoman: ok, I'll point you to the material we have
21:53:44 <troytoman> otherwise, i think we are in good shape
21:53:56 <danwent> ttx: please send pointers my way as well.
21:54:10 <ttx> #action ttx to give danwent/troytoman more information on release process
21:55:03 <ttx> Any other team lead with a status report ?
21:55:35 <ttx> #topic Open discussion
21:55:51 <ttx> We plan to organize a big bug squashing event over two days early in January, where the goal will be to close as many bugs as possible
21:56:06 <ttx> It should happen in physical places like your local OpenStack community, and also online.
21:56:07 <annegentle> Love the bug squash.
21:56:18 <ttx> Stay tuned for more info on that.
21:56:41 <ttx> In other news, only a few days left to submit talks to the FOSDEM "Open Source Virtualization and Cloud" devroom: https://lists.fosdem.org/pipermail/fosdem/2011-November/001354.html
21:56:50 <ttx> (great excuse to come taste great beers)
21:57:05 <ttx> Anything else, anyone ?
21:57:41 <uksysadmin> I've a q (taking advantage) if that's ok on bug -> release process for Diablo?
21:57:56 <ttx> uksysadmin: sure, go ahead
21:58:20 <ttx> (if it fits in the next minute)
21:58:35 <uksysadmin> I run Diablo - on Oneiric from stable packages.  For bug fixes - do I wait for Essex or are there planned updates?
21:59:01 <ttx> uksysadmin: we have a stable/diablo branch with backports of bugfixes
21:59:14 <ttx> uksysadmin: the stable team plans to do a 2011.3.1 at some point
21:59:20 <uksysadmin> ok - cheers
21:59:23 <vishy> bhall: ping
21:59:26 <vishy> oops
21:59:38 <ttx> on that good oops, we close
21:59:40 <vishy> (wrong channel) :)
21:59:43 <ttx> #endmeeting