21:03:09 <ttx> #startmeeting
21:03:10 <openstack> Meeting started Tue Jan  3 21:03:09 2012 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:03:11 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:03:18 <ttx> Happy new year everyone !
21:03:28 <ttx> Enough holiday slacking, now let's get back to work :)
21:03:41 <ttx> Today's agenda: http://wiki.openstack.org/Meetings/ProjectMeeting
21:03:48 <ttx> #topic Actions from previous meeting
21:03:57 <ttx> * zns the raise a thread on the ML about RBAC potentially being deferred to F
21:04:05 <ttx> ML thread at https://lists.launchpad.net/openstack/msg06267.html
21:04:13 <ttx> No comment there...
21:04:25 <zns> Nope. It's a done deal.
21:04:30 <zigo> ttx: May I add Kronos status to the agenda?
21:04:35 <ttx> notmyname, vishy, devcamcar: Deos that mean you don't have any issue with that ?
21:04:55 <vishy> no problem
21:04:57 <ttx> zigo: I'll keep time to talk about that in open discussion.
21:05:10 <zigo> Ok.
21:05:12 <ttx> * ttx to discuss options for getting a sane list of reviews with CI guys
21:05:23 <ttx> So the CI team wants to get a usable review list in Gerrit directly.
21:05:32 <ttx> So I filed a bug to track this at: https://bugs.launchpad.net/openstack-ci/+bug/907764
21:05:33 <uvirtbot> Launchpad bug 907764 in openstack-ci "A usable list of reviews" [Wishlist,Confirmed]
21:05:44 <ttx> * markwash to raise future of Trusted Computing bp on ML to get nova-core consensus
21:05:54 <ttx> Done today @ https://lists.launchpad.net/openstack/msg06466.html
21:06:23 <ttx> #topic Keystone status
21:06:28 <ttx> zns: o/
21:06:39 <ttx> zns: Can you confirm that you intend to use essex-3 as a FeatureFreeze ?
21:06:45 <zns> Good progress. https://launchpad.net/keystone/+milestone/essex-3 is updated as of this AM.
21:06:53 <zns> ttx: confirmed.
21:06:57 <ttx> #info Last feature milestone for Keystone will be Essex-3
21:07:09 <ttx> So that leaves 3 weeks for Essex keystone features.
21:07:31 <ttx> zns: About https://blueprints.launchpad.net/keystone/+spec/service-endpoint-location
21:07:33 <zns> A few of them are listed as bugs in https://launchpad.net/keystone/+milestone/essex-3, BTW. IPv6, for example.
21:07:43 <ttx> Did you get any news from HP ? Is this still planned for Essex-3 ?
21:07:48 <zns> ttx: no update from HP on that.
21:08:11 <ttx> zns: could someone take an action of contacting them ? I can, if you tell me who I should ask
21:08:25 <zns> I just pinged them.
21:08:28 <mtaylor> ttx: need me to poke someone?
21:08:29 <mtaylor> ok. good
21:08:35 <ttx> zns: ok
21:08:40 <ttx> zns: What's the priority/status of:
21:08:45 <ttx> https://blueprints.launchpad.net/keystone/+spec/keystone-internal-authorization
21:08:57 <zns> Medium
21:09:13 <ttx> and "Not started" ?
21:09:21 <zns> … same priority we have for the other refactoring blueprints.
21:09:35 <zns> Yes, we just added it this AM. Will start this week...
21:09:37 * ttx updates
21:09:50 <ttx> zns: Anything else ?
21:10:04 <zns> No
21:10:16 <ttx> Questions for Keystone ?
21:10:29 <Vek> zns: check my comment on bug 856887
21:10:30 <uvirtbot> Launchpad bug 856887 in keystone "Keystone cannot listen on IPv6" [High,Confirmed] https://launchpad.net/bugs/856887
21:11:03 <zns> Vek: saw that. ayoung has volunteered to help us with that.
21:11:06 <Vek> that, by the way, is going to affect pretty much every openstack project, unless they bypass eventlet's built-in name service resolution.
21:11:11 <Vek> excellent.
21:11:52 <ttx> #topic Swift status
21:11:56 <ttx> notmyname: o/
21:12:00 <notmyname> hi
21:12:05 <ttx> notmyname: any news / sight of Swift 1.4.5 yet ?
21:12:39 <notmyname> I've been getting caught up (first day back in the office)
21:12:50 <notmyname> we've been getting reviews caught up
21:13:17 <notmyname> and I'd like to talk to our team about when we feel a release is warranted
21:13:25 <notmyname> I hope to have a better answer next week
21:13:29 <ttx> ok
21:13:32 <ttx> notmyname: Anything else ?
21:14:08 <notmyname> I don't think so
21:14:18 <ttx> Questions on Swift ?
21:15:14 <ttx> Let's skip Glance for the moment, hopefully Jay will join or someone else will volunteer to represent Glance
21:15:23 <ttx> #topic Nova status
21:15:30 <ttx> vishy: hey hey
21:15:47 <ttx> vishy: Last week bcwaldon hinted that Nova would use essex-3 as feature freeze. Can you confirm ?
21:16:01 <ttx> hm, that should read "last year"
21:17:13 <vishy> oops sorry
21:17:14 <vishy> :)
21:17:19 <vishy> confirmed
21:17:26 <ttx> Is it a "disruptive work" freeze, a "major feature" freeze, or a "all features" freeze ?
21:17:34 <vishy> I'd like to call it a soft feature freeze
21:17:41 <vishy> no public api changes ore major changes
21:17:46 <vishy> cleanup features
21:17:48 <vishy> admin apis etc
21:17:53 <vishy> i think are fine in e4
21:18:14 <vishy> a totally isolated extension seems fine as well
21:18:24 <ttx> #info Nova will start a "soft feature freeze" at E3 (no public api changes or major changes)
21:18:45 <ttx> vishy: and a hard feature freeze at E4 ?
21:18:51 <vishy> absolutely
21:18:54 <ttx> sounds good.
21:19:02 <ttx> #link https://launchpad.net/nova/+milestone/essex-3
21:19:12 <ttx> I'd like to review the status of the Essential stuff:
21:19:35 <ttx> https://blueprints.launchpad.net/nova/+spec/volume-type-scheduler (vladimir3p)
21:19:41 <ttx> vladimir3p: not started ?
21:20:10 <ttx> https://blueprints.launchpad.net/nova/+spec/separate-nova-volumeapi (sleepsonthefloor)
21:20:19 <ttx> sleepsonthefloo: just started ?
21:20:31 <ttx> https://blueprints.launchpad.net/nova/+spec/interim-nova-authz-service (vishy)
21:20:43 <ttx> vishy: Good progress, though I can't see any code proposed yet ?
21:20:48 <vishy> I have code
21:20:51 <vishy> working on docs today
21:20:54 <vishy> proposing
21:20:55 <sleepsonthefloo> ttx - yes, just started
21:21:17 <vishy> not sure what happened with the volume type scheduler
21:21:20 <ttx> sleepsonthefloo: on track to meet the Essex-3 deadline ? (in 3 weeks)
21:21:25 <vishy> i will try and get in touch with vladimir3p
21:21:42 <ttx> vishy: yeah. essential not started stuff makes me nervous.
21:21:55 <sleepsonthefloo> ttx - yes
21:22:06 <vishy> ttx: i think it is started
21:22:06 <ttx> #action vishy to ping vladimir3p about volume-type-scheduler status
21:22:10 <vishy> but i will verify
21:22:26 <ttx> vishy: There are also a few blueprints that were proposed for E3/E4 that you might want to confirm:
21:22:35 <ttx> Essex-3:
21:22:40 <ttx> https://blueprints.launchpad.net/nova/+spec/multiple-floating-ip-ranges
21:22:43 <ttx> https://blueprints.launchpad.net/nova/+spec/nova-parity-floating
21:22:47 <ttx> https://blueprints.launchpad.net/nova/+spec/scaling-zones
21:22:51 <ttx> Essex-4:
21:22:56 <ttx> https://blueprints.launchpad.net/nova/+spec/adaptive-network-cfg-injection
21:23:02 <ttx> https://blueprints.launchpad.net/nova/+spec/injecting-network-configuration-file-to-windows-vm
21:23:26 <ttx> vishy: can you look them up soon and set the series goal to essex if OK ?
21:23:34 <tr3buchet> is someone planning on working the multiple-floating-ip-ranges?
21:23:41 <ttx> vishy: (or unset the milestone if not)
21:23:44 <vishy> sure
21:23:58 <vishy> tr3buchet: me
21:24:02 <tr3buchet> kk
21:24:11 <tr3buchet> made a note of it
21:24:13 <vishy> starting it as soon as I prop the initial rbac branch
21:24:43 <ttx> #action vishy to look up unplanned E3/E4 blueprints and confirm/unconfirm them
21:25:00 <ttx> (also set priority for nova-parity-floating and scaling-zones while you're at it)
21:25:16 <ttx> vishy: Anything on your side ?
21:25:43 <vishy> ttx: only a -- Welcome back everyone!
21:25:48 <ttx> Nova subteam leads: comments ?
21:26:06 <tr3buchet> nothing from, i'm still catching up from vacation
21:26:21 <tr3buchet> me ---------^
21:26:34 <ttx> Questions on Nova ?
21:27:13 <ttx> Do we have devcamcar or anyone from Horizon core team to replace him ?
21:28:16 <ttx> Let's do incubation / other teams first
21:28:21 <ttx> #topic Incubated projects and other Team reports
21:28:31 <ttx> danwent, troytoman: o/
21:28:38 <danwent> sorry ttx, I can't stall for devmancar… not much to report on the quantum front.
21:28:47 <ttx> #info About doing Melange/Quantum E3 milestone under release team management, it's still blocked on getting working tarball jobs.
21:28:55 <danwent> we're spinning up a number of good design discussion on the netstack ML for quantum
21:28:58 <ttx> Related CI bugs, for reference:
21:29:09 <ttx> https://bugs.launchpad.net/bugs/907768 and https://bugs.launchpad.net/bugs/897882
21:29:10 <uvirtbot> Launchpad bug 907768 in openstack-ci "Needs working melange-tarball job" [Wishlist,Confirmed]
21:29:40 <danwent> bhall, can you comment on the setup.py?
21:30:00 <bhall> out for review
21:30:16 <bhall> lemme find a link
21:30:20 <ttx> https://review.openstack.org/#change,1988
21:30:27 <danwent> i know monty filed a similar bug.  we'll make sure our change is good for monty, and we'll make sure it gets pushed ASAP.
21:30:46 <bhall> ttx: thanks
21:31:07 <ttx> Any other team lead with a status report ?
21:31:09 <troytoman> on melange, we cut the first release last week for E2
21:31:24 <troytoman> focused on testing/bug fixing and docs
21:31:37 <troytoman> also looking at some performance improvements for E3/E4
21:31:52 <ttx> troytoman: still ok to try to do E3 on the common milestone date ?
21:32:03 <ttx> (target date : January 26)
21:32:09 <troytoman> ttx: yes. that should work
21:33:12 <ttx> ok, back to Glance for a quick status update, unless some PTL shows up
21:33:14 <zns> ttx, troytoman: 26 is the release date. Code is cut 25th. so 'dev' deadline is really more like 24. ttx?
21:33:26 <ttx> zns: yes.
21:33:46 <zns> troytoman: FYI. Bit us in keystone. You have till 24 effectively...
21:33:48 <troytoman> we don't have a lot targeted for E3 (client separation and bug fixes mostly.) so , we should be fine
21:33:55 <ttx> #topic Glance status
21:33:57 <troytoman> good to know the details thought
21:34:28 <ttx> so without a PTL or substitute, I'll just point out the recent announcement that Image API 2.0 work is postponed to F
21:34:52 <ttx> #link https://lists.launchpad.net/openstack/msg06421.html
21:35:30 <annegentle> Doc team will meet next Monday 1/9, 2:00 CST (noon PST).
21:35:36 <ttx> More next week
21:36:05 <ttx> devcamcar: still not around ? If not, we'll skip until next week
21:36:05 <annegentle> A few more updates to the API site mock at http://heckj.github.com/api-site-mock/, including a search box.
21:36:33 <ttx> annegentle: anything more ?
21:36:51 <annegentle> That's all I can think of in docland.
21:36:56 <ttx> #topic Open discussion
21:37:04 <ttx> We plan to have a big bug squashing day for Nova on February 2.
21:37:21 <ttx> The goal is to get rid of as many bugs (closed as invalid or fixed) as possible over a day, as a good way to trim down the list just after E3
21:37:31 <ttx> Other projects are of course welcome to join on that same day.
21:37:43 <ttx> (or set up their own bugsquashing day)
21:37:47 <ttx> #link http://wiki.openstack.org/BugSquashingDay
21:37:52 <ttx> #link http://wiki.openstack.org/BugSquashingDay/20120202
21:38:01 <ttx> vishy: you had a theme for that one ?
21:38:09 <vishy> yup
21:38:17 <vishy> Groundhog Day bug squash!
21:38:30 <vishy> hopefully we don't see our shadow
21:38:31 <Vek> does that mean we'll be doing it over and over again?
21:38:31 <ttx> yeah
21:38:36 <vishy> or we have 2 more weeks of bug squashing
21:38:41 <vishy> !
21:38:42 <ttx> Vek: yes
21:39:04 <vishy> Vek: we're thinking of setting them up every month or two
21:39:04 <ttx> zigo: you wanted to talk about Kronos ?
21:39:30 <Vek> makes sense; I was just making a lame movie reference for the humor effect.
21:39:32 <zigo> Well, basically, I've uploaded XenAPI into SID right before christmas.
21:39:33 <ttx> vishy: the theme and objectives could slightly change though
21:39:44 <zigo> And started to test it with Nova.
21:39:53 <zigo> It kind of works, but there are things to fix.
21:40:04 <zigo> Like this one: http://paste.debian.net/150865/
21:40:17 <zigo> PRODUCT_VERSION from XCP isn't reporting well.
21:40:31 <zigo> I'm not sure how to fix, but I home Mike will help.
21:40:39 <ttx> zigo: did you file bugs for those ? If yes, feel free to paste their links to ahere to attract attention to them
21:41:00 <zigo> I did, but I don't have the # handy.
21:41:09 <ttx> s/to ahere/here
21:41:21 <zigo> Then, I could (with few other fixes) start instances on XCP using Nova.
21:41:35 <zigo> But I have no network connectivity or console access to the VMs.
21:41:53 <zigo> I'd need help from people working on Openstack support for XenServer / XCP.
21:42:20 <zigo> I'm more doing packaging than core dev.
21:42:29 <zigo> And I don't really know who to get in touch with.
21:42:52 <_cerberus_> +++++6
21:42:53 <zigo> ttx: Who's the guys doing XCP + Nova that I should get in touch with?
21:43:12 <vishy> zigo: people are mostly using XenServer atm
21:43:18 <ttx> #help zigo wants Nova/Xen specialists help to get Nova/XCP working on Debian
21:43:38 <vishy> zigo: but I think that most xen experts are from the cloudservers team
21:44:00 <vishy> zigo: People will probably have more time to help after jan26
21:44:24 <zigo> Well, wouldn't it be nice to have all fixed for the release?
21:44:54 <zigo> I'm quite sure we aren't far from a completely working result...
21:45:11 <ttx> jan 26 is, helpfully, not the final release :)
21:45:23 <zigo> :)
21:45:23 <vishy> zigo: release isn't until april, and yes it would be great
21:45:24 <zigo> k
21:45:37 <vishy> zigo: it is just everyone is working like mad on features right now
21:45:38 <vishy> :)
21:45:51 <zigo> Got it.
21:47:00 <ttx> Anything else, anyone ?
21:47:10 <ayoung> beuhler
21:48:25 <ttx> beuhler?
21:48:35 <annegentle> another movie reference :)
21:48:36 <ayoung> nevermind
21:48:49 <ttx> ah :)
21:49:00 <zigo> Is there currently a way in Nova to do accounting/reporting?
21:49:21 <ttx> Google was surprisingly unhelpful with that one.
21:49:24 <zigo> I've noticed that the nova-instance-monitor package is gone...
21:49:30 <markwash> ttx: http://www.youtube.com/watch?v=NP0mQeLWCCo
21:49:53 <ttx> zigo: there is a notification firehose that you can plug your own system on, IIRC
21:50:03 <ttx> zigo: ping dragondm about it
21:50:16 <dragondm> ya
21:50:35 <zigo> dragondm: Is this documented somewhere?
21:50:55 <zns> zigo: there was a proposal a while back that started addressing this (it's where we came up with the tenant concept). See here: https://github.com/openstack/keystone/blob/a02fa988a4bdbfa05197078faa905f13274d82b8/doc/design/tenants.pdf?raw=true
21:51:01 <dragondm> ya. http://wiki.openstack.org/SystemUsageData
21:51:26 <dragondm> zingo ^
21:51:37 <dragondm> er zigo, sorry.
21:51:44 <zigo> I might be interested to work on that...
21:52:22 <ttx> Looks like this discussion can continue over #openstack-dev.
21:52:28 <zigo> That's it, I'm done and going to sleep.
21:52:32 <ttx> #endmeeting