22:01:06 <danwent> #startmeeting
22:01:07 <openstack> Meeting started Tue Jan  3 22:01:06 2012 UTC.  The chair is danwent. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:01:08 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
22:01:21 <danwent> mestery: yes, freezing cold b/c I was in your neck of the woods :)
22:01:34 <danwent> I don't know you how do it :)
22:01:51 <mestery> hahaha
22:02:13 <danwent> ok, most of the action is probably going to be on the ML this week
22:02:21 <danwent> #info agenda http://wiki.openstack.org/Network/Meetings
22:02:47 <danwent> #topic Melange Status
22:03:21 <danwent> hopefully you saw the note about melange being released
22:03:47 <danwent> #info: melange is now up as a full incubated project: http://launchpad.net/melange
22:04:31 <Salv-orlando> Hello!
22:05:03 <danwent> sounds like troy isn't here for any additional updates, but based on comments during main meeting they are focusing on perf improvements and separating out the client lib during E3
22:05:18 <danwent> hey salv!
22:05:23 <danwent> thought you were going to make it :)
22:05:31 <danwent> #topic Quantum Status
22:05:51 <danwent> essex-3 is 3 weeks away: https://launchpad.net/quantum/+milestone/essex-3
22:05:59 <Salv-orlando> Found an open network in the restaurant!
22:06:05 <edgarmagana> hi, little bit late  :-)
22:06:09 <bhall> s/restaurant/pub/
22:06:11 <bhall> :)
22:06:33 <danwent> since this is our last chance to get significant changes into nova, the most critical issues are probably those related to nova parity.
22:07:20 <danwent> right now there are a lot of issue with status 'unknown'.  please update those statuses by next meeting, as everything should at least be started by then.
22:07:43 <danwent> if anyone knows of something that is definitely not going to make it already, please bump it out.
22:08:38 <danwent> Goal from last meeting was to start up ML threads on many of the topics that went cold due to essex-2 release & holiday.
22:08:47 <danwent> See the agenda for a list of all of them.
22:09:07 <danwent> I think I'm about half-way through going through the issues as providing feedback (trying to adhere to rough chronological order).
22:09:18 <danwent> would be great if others could review as well.
22:09:50 <danwent> Salv: one question I sent to the list that I think is pretty important is when we think we will finalize API v 1.1
22:10:25 <danwent> tags where one thing we had talked about that hasn't been done yet.  Has anyone talked to ying?  I think she was going to do that.
22:10:45 <Salv-orlando> Api 1.1 in terms of specification is just 1.0 plus operational status
22:10:46 <danwent> the other things was that wwwkeyboard talked about changing the HTTP error codes.
22:11:02 <danwent> salv: don't filters need to be in 1.1 spec?
22:11:06 <Salv-orlando> Then there are the other things you're listing
22:11:14 <Salv-orlando> Including filters
22:11:24 <wwkeyboard> I thought we were going to hold off on changing error codes?
22:11:38 <Salv-orlando> Sorry i'm slow on mobile
22:12:01 <Salv-orlando> Changing error codes scares me a little
22:12:14 <danwent> wwkeyboard: I don't remember if there was a firm conclusion… woudl have to look at thread.
22:12:21 <Salv-orlando> But if we want to do it this is the tine
22:12:24 <Salv-orlando> Time
22:12:32 <danwent> Salv-orlando: we don't have to do it at all if we don't think its important.
22:12:51 <danwent> the default is that it will stay the same, unless someone is really motivated to change it :)
22:12:53 <wwkeyboard> danwent OK, I thought we were going to wait for the changes in the API spec, but I may be confused
22:13:20 <danwent> wwkeyboard: 1.0 is current spec.  We're putting together and finalizing 1.1, and I was trying to figure out if code changes would be part of that change.
22:13:40 <wwkeyboard> Will they need to be implemented before that?
22:13:49 <wwkeyboard> before the spec is finalized?
22:14:03 <Salv-orlando> I wanted more feedback on error codes. The discussion is still open- even if dornant in the last few weeks
22:14:19 <danwent> dormant ML discussions…. seems like a trend :)
22:15:07 <Salv-orlando> Bottom line is: if we want to follow os api spec we need to change them
22:15:20 <Salv-orlando> We are not compliant at the moment
22:15:25 <danwent> wwkeyboard: I suspect this comes down to whether you are sufficiently motivated to make the change, and whether the rest of the team is convinced its a good thing.  Probably best to bring it up on the ML again, and do it in E-3.
22:15:47 <danwent> Salv-orlando:  ah, didn't realize it was that cut-and-dried
22:16:49 <danwent> salv: so is it your feeling that we should do it?
22:16:54 <Salv-orlando> Danwent: assign me action to resume thread
22:17:19 <cdub> downside only being clients which have hardcoded around existing errors?
22:17:23 <danwent> #action #Salv-orlando resume thread on changing API error codes
22:17:25 <Salv-orlando> I feel we should do it if our, priority is to comply with os API
22:18:04 <Salv-orlando> Cdub: old error codes will still be there for 1'0 clients
22:18:18 <danwent> That seems pretty important to me.  Especially if we want many of the clients to be able to share common code (per email about openstack-common)
22:18:29 <cdub> *nod*
22:18:59 <Salv-orlando> Agreed
22:19:32 <danwent> Ok, I was flying this morning and am behind on some of the ML discussion this morning, so I vote for just continuing the rest of the topics on the ML, unless there's something in particular people want to bring up in IRC.
22:20:07 <danwent> bhall:  can you comment on what ttx brought up during the main meeting?
22:20:10 <danwent> setup.py issues (bugs #897882 and #897943 and #910267)
22:20:11 <uvirtbot> Launchpad bug 897882 in quantum "Quantum needs proper setup.py (was: command 'egg' not found when running install_venv.py)" [High,In progress] https://launchpad.net/bugs/897882
22:20:13 <uvirtbot> Launchpad bug 897943 in quantum "Our setup.py needs to be a real setup.py" [Medium,In progress] https://launchpad.net/bugs/897943
22:20:14 <uvirtbot> Launchpad bug 910267 in quantum "Quantum setup.py does not use setuptools" [High,Triaged] https://launchpad.net/bugs/910267
22:20:21 <danwent> two are from you, one from monty.
22:20:30 <danwent> unclear if they are all the same issue, several different issues, etc.
22:20:37 <bhall> yeah, there is a change out for review: https://review.openstack.org/#change,1988
22:20:42 <danwent> but it seems like its blocking the infrastructure team.
22:20:53 <danwent> Ok, and that handle's monty's issue as well?
22:20:55 <bhall> basically, we need to conform to the rest of the openstack projects (i.e. python setup.py sdist needs to produce a tarball)
22:21:00 <bhall> yes, I believe so
22:21:22 <danwent> Ok.  I will do a review on that tonight.  If someone else from the team could pitch in as well so we're not holding up the CI folks, that would be great.
22:21:45 <danwent> Other Quantum comments before open discussion?
22:22:03 <danwent> #topic open discussion
22:22:11 <davlap> hi folks! just wanted to say hello. i'm going to be helping out with quantum. look forward to working with you all!
22:22:29 <danwent> where are you from davlap?
22:22:33 <danwent> :P
22:22:36 <davlap> :)
22:22:47 <davlap> i work with dan and brad
22:22:58 <mestery> Welcome davlap!
22:23:04 <danwent> welcome to the team davlap!
22:23:13 <davlap> thanks! great to be here!
22:23:14 <wwkeyboard> welcome!
22:23:17 <Salv-orlando> Welcome on board!
22:23:44 <danwent> Ok, any other open discussion?
22:23:44 <bhall> #action danwent figure out hazing ritual for new netstackers
22:23:49 <danwent> haha
22:23:51 <davlap> :)
22:23:53 <cdub> heh
22:24:02 <danwent> I thought being part of netstack WAS hazing :P
22:24:09 <bhall> hah
22:24:16 <carlp> That was my experience :)
22:24:37 <danwent> hey carlp!  btw, will be trying to get you a basic test for CI infrastructure this week.
22:24:50 <danwent> was hoping santa would give me one, but turns out I need to do it myself
22:25:06 <danwent> ok, final call for open discussion
22:25:08 <carlp> danwent: awesome!
22:25:23 <danwent> remember to keep an eye on the ML … lots of action on there this week.
22:25:44 <danwent> Ok, thanks folks!
22:25:49 <danwent> #endmeeting