17:01:36 <jaypipes> #startmeeting
17:01:37 <openstack> Meeting started Wed Jan 18 17:01:36 2012 UTC.  The chair is jaypipes. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:38 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:02:02 <donaldngo_hp> ready
17:02:06 <jaypipes> #topic Outstanding Code Reviews
17:02:20 <jaypipes> #link https://review.openstack.org/#q,status:open+project:openstack/tempest,n,z
17:03:30 <LinuxJedi> jaypipes: might be good to note that when my script goes live on production the bottom three there will get instantly abandoned
17:03:41 <jaypipes> One of the things I was hoping to address today was proper commit messages...
17:03:48 <jaypipes> LinuxJedi: cool :)
17:05:08 <jaypipes> I'd like everyone to work with their respective teams to ensure that when you write commit messages, they have the following:
17:05:31 <jaypipes> a) Reference to the LP Bug that the patch fixes -- Something like "Fixes LP#XXXXX" is fine
17:05:58 <Ravikumar_hp> ok
17:06:07 <jaypipes> b) That the commit message's first line is a short description of the patch, and then later lines have a longer description, if necessary
17:06:32 <jaypipes> c) DO NOT put comments about minor fixups or style corrections in commit messages.
17:07:06 <jaypipes> d) If, during fixing things from a review, you DO make a more major change to the code, then DO update the commit message to include information about that new change
17:07:29 <jaypipes> If we can all focus on the above points, tracking patches to LP bugs will be much easier
17:08:01 <dwalleck_nova> sure, all sounds reasonable to me
17:08:03 <jaypipes> So... can we all agree to the above? Any questions about that?
17:08:05 <Ravikumar_hp> we need to add those guidelenes
17:08:18 <Ravikumar_hp> so any new person cal adhere to that
17:08:32 <jaypipes> Ravikumar_hp: If we are in agreement, I will add them to the QA docs and to the email I send to the ML after this meeting
17:08:46 <jaypipes> So, if you agree, please #agreed
17:08:57 <Ravikumar_hp> #agreed
17:08:59 <dwalleck_nova> #agree
17:09:04 <dwalleck_nova> #agreed
17:09:30 <donaldngo_hp> #agreed
17:09:34 <jaypipes> OK, well that's good enough for now I suppose... I know a few folks are AFK right now
17:09:59 <jaypipes> #action jaypipes to write up guidelines for commit msgs to QA docs and ML email
17:10:07 <jaypipes> OK, next topic ...
17:10:32 <jaypipes> #topic Push for completing Compute API test coverage
17:10:42 <jaypipes> So... let me explain...
17:11:04 <jaypipes> I'd like this group to come up with a deadline for getting full coverage of the Compute 1.1 API done.
17:11:08 <jaypipes> However...
17:11:36 <jaypipes> There are 2 distinct groups among us: those working on Diablo-based systems and those working on Essex-based systems
17:11:47 <jaypipes> We need, of course, Tempest to run properly against both
17:11:50 <jaypipes> And so...
17:12:27 <jaypipes> I'm hoping that we can come together and push towards getting the Compute API coverage done *and tested* against BOTH Diablo and Essex environments
17:13:02 <jaypipes> One thing that has hindered us so far is that some individuals writing test cases have not been running Tempest against a real environment before pushing their changes
17:13:07 <jaypipes> We need to stop doing that :)
17:13:18 <dwalleck_nova> I know there are some minor differences, but I think we can modify the tests to be intelligent enough to handle it
17:13:29 <jaypipes> In order to stop doing that ASAP, it is important to get Tempest running against Diablo ASAP
17:13:37 <Ravikumar_hp> jaypipes: we do not have tests for API extensions. That some of us here working on
17:13:57 <jaypipes> Ravikumar_hp: could you explain a bit more?
17:14:20 <jaypipes> Ravikumar_hp: are you saying that you are writing the extension test cases but do not have an environment with those extensions installed?
17:14:29 <Ravikumar_hp> security groups , and key pairs - New tests are being added
17:14:55 <jaypipes> Ravikumar_hp: see my ? above ^^
17:15:01 <Ravikumar_hp> No . i think the environment is good enough to test extensions
17:15:35 <jaypipes> Ravikumar_hp: ok, I don't think I'm understanding you...
17:15:45 <donaldngo_hp> are all the extensions included in the devstack deploy?
17:15:50 <jaypipes> donaldngo_hp: yep
17:16:02 <jaypipes> donaldngo_hp: but I didn't think you all were testing against devstack?
17:16:19 <donaldngo_hp> ravi and others are
17:16:27 <jaypipes> ah, sorry, ok makes more sense now.
17:16:39 <donaldngo_hp> im trying to get tempest to run cleanly on our prod env
17:16:54 <jaypipes> BUT, that said, I don't think Ravi ran Tempest against a devstack for the most recent SecurityGroups tests ;)
17:17:05 <Ravikumar_hp> Jaypipes: my answer is to your question for  - compute API coverage" ,
17:17:08 <jaypipes> since there was a typo that caused an ImportErrort
17:17:49 <jaypipes> Ravikumar_hp: k. I just want to ensure that everyone who is writing test cases is running Tempest locally before pushing code to review.
17:18:07 <Ravikumar_hp> jaypipes: will enforce.
17:18:07 <jaypipes> Ravikumar_hp: that goes for all of us. It's absolutely essential to avoid issues like we had yesterday.
17:18:12 <jaypipes> Ravikumar_hp: coolio.
17:18:23 <Ravikumar_hp> Jaypipes: missed yesterday
17:18:30 <jaypipes> Ravikumar_hp: no worries
17:19:15 <jaypipes> alright, so looking at the list of Tempest bugs...
17:19:17 <jaypipes> #link https://bugs.launchpad.net/tempest/+bugs?field.searchtext=&orderby=-importance&field.status%3Alist=NEW&field.status%3Alist=CONFIRMED&field.status%3Alist=TRIAGED&field.status%3Alist=INPROGRESS&field.status%3Alist=INCOMPLETE_WITH_RESPONSE&field.status%3Alist=INCOMPLETE_WITHOUT_RESPONSE&assignee_option=any&field.assignee=&field.bug_reporter=&field.bug_commenter=&field.subscriber=&field.structural_subscriber=&fi
17:19:17 <jaypipes> eld.tag=&field.tags_combinator=ANY&field.has_cve.used=&field.omit_dupes.used=&field.omit_dupes=on&field.affects_me.used=&field.has_patch.used=&field.has_branches.used=&field.has_branches=on&field.has_no_branches.used=&field.has_no_branches=on&field.has_blueprints.used=&field.has_blueprints=on&field.has_no_blueprints.used=&field.has_no_blueprints=on&search=Search
17:19:24 <jaypipes> ay ya yai...
17:19:31 <dwalleck_nova> heh
17:19:34 <jaypipes> sorry about that guys
17:19:54 <jaypipes> #link http://bit.ly/w4i5td
17:19:59 <jaypipes> much better..
17:20:32 <jaypipes> So, here's the deal...
17:21:02 <jaypipes> we need to get all the unassigned bugs assigned.
17:21:26 <jaypipes> If you give me permission, I will assign bugs out to individual contributors evenly
17:22:00 <dwalleck_nova> That sounds fair
17:22:16 <Ravikumar_hp> jaypipes: i will look at it pick up some for my team in next hour
17:22:21 <jaypipes> By Friday, I'd like to be able to say to mtaylor and jeblair that we are near complete compute API coverage and that next week, we should be able to beta test gating Nova and Glance trunk against Tempestr runs.
17:22:42 <jaypipes> After all, the end goal is to have Tempest gating trunk
17:22:59 <dwalleck_nova> Absolutely
17:23:08 <jaypipes> alright then.
17:23:13 <Ravikumar_hp> jaypipes: we need to migrate Swift tests also
17:23:16 <Ravikumar_hp> from Kong
17:23:25 <dwalleck_nova> Jose? Carlos?
17:23:28 <jaypipes> Ravikumar_hp: yep, but Compute API is #1 priority rtight now.
17:23:39 <dwalleck_nova> I have a dynamic duo working on that :)
17:23:42 <Ravikumar_hp> jaypipes : i agree
17:24:14 <jaypipes> #action jaypipes to assign remaining test-needed bugs on Compute API and follow up with individual contributors on progress.
17:24:17 <dwalleck_nova> jaypipes: How many bugs do you think it will be per team?
17:24:24 <jaypipes> dwalleck_nova: 10-15
17:24:24 <dwalleck_nova> I just want to understand what the work commitment would be
17:24:44 <jaypipes> dwalleck_nova: new test case bugs only (test-needed tag)
17:24:55 <jaypipes> dwalleck_nova: estimate around 1 hour per bug
17:25:00 <dwalleck_nova> jaypipes: gotcha, understood
17:25:02 <jaypipes> dwalleck_nova: to get to code review
17:25:20 <Ravikumar_hp> jaypipes: keystone also in the list (bugs in LP) .
17:25:30 <jaypipes> Ravikumar_hp: yes, but after Compute
17:25:38 <jaypipes> Ravikumar_hp: I will focus on compute this week
17:26:41 <jaypipes> I will be assigning a few bugs (test-needed bugs) to myself, but my #1 priority task right now is getting Tempest running successfully against a Diablo environment
17:27:21 <jaypipes> OK, let's move on to Test Case style discussion, if that's ok with everyone?
17:27:30 <jaypipes> AntoniHP_: around?
17:27:51 <dwalleck_nova> sure
17:28:09 <Ravikumar_hp> Antoni is on vacation today
17:28:13 <jaypipes> ah, ok.
17:28:22 <jaypipes> Then we shall shelve that discussion to next week.
17:29:20 <jaypipes> dwalleck_nova: may we discuss this bug? https://bugs.launchpad.net/tempest/+bug/917973
17:29:21 <nati2> Hi folks. Sorry late
17:29:21 <uvirtbot> Launchpad bug 917973 in tempest "Refactor authentication out of rest client" [Medium,In progress]
17:29:28 <jaypipes> nati2: no probs
17:30:33 <dwalleck_nova> sure
17:31:07 <jaypipes> dwalleck_nova: I want to make sure I understand exactly what you are proposing there.
17:31:27 <dwalleck_nova> Sure, shoot and I'll tell you what I was thinking
17:32:52 <jaypipes> dwalleck_nova: so, my impression of the correct place to put the authentication process is in the base rest client, like is in novaclient: https://github.com/openstack/python-novaclient/blob/master/novaclient/client.py
17:33:33 <jaypipes> dwalleck_nova: because of the need to track the X-Auth-Token header value throughput the API call lifecycle, I feel the best place to put that tracking is in the base client.
17:33:56 <dwalleck_nova> jaypipes: Right, that was my initial thought as well. What this depends on is if we plan on using Keystone as the only auth method
17:34:24 <dwalleck_nova> I was thinking about handling auth in a more generic case if we wanted to support different auth systems
17:35:00 <dwalleck_nova> But if we only care about Keystone (Identity) and maybe Nova and Swift Auth, I could be convinced to keep things as is
17:35:26 <jaypipes> dwalleck_nova: well Nova and Swift Auth *is* the Keystone API, unless I'm mistaken?
17:36:13 <jaypipes> dwalleck_nova: although Glance's client supports pluggable auth "strategies". https://github.com/openstack/glance/blob/master/glance/common/client.py
17:36:34 <jaypipes> dwalleck_nova: perhaps you might be interested in using the Glance base client way of doing things.
17:37:00 <jaypipes> dwalleck_nova: that said, I'm wondering if this is something we want to work on right now?
17:37:11 <dwalleck_nova> jaypipes: Hmm...I thought there were specific auth capabilities built into both swift and Nova
17:37:23 <jaypipes> dwalleck_nova: I'm thinking this might be a task we could backburner until the compute API coverage is complete?
17:37:41 <dwalleck_nova> jaypipes: It can definitely be shelved while we work on completing coverage for Nova
17:37:53 <jaypipes> dwalleck_nova: OK, that's good to hear :)
17:38:10 <dwalleck_nova> I'm just been spinning around the thought of how I can make sure Tempest is flexible enough for anyone to use
17:38:18 <jaypipes> dwalleck_nova: underrstood
17:38:40 <jaypipes> dwalleck_nova: RAX public cloud is an Essex-based environment, correct?
17:38:51 <jaypipes> dwalleck_nova: at least, the beta huddle is, right?
17:40:04 <jaypipes> ok, we can leave that for later...
17:40:14 <dwalleck_nova> jaypipes: Sorry, yeah, it's essex
17:40:19 <jaypipes> ah, cool
17:40:21 <jaypipes> thx
17:40:51 <jaypipes> alright, then, I say we end the meeting now so I can get to assigning bugs ;) Does anyone have anything they would like to discuss today?
17:40:57 <jaypipes> #topic Open Discussion
17:41:12 <dwalleck_nova> Sorry, lots going on here :)
17:41:19 <jaypipes> dwalleck_nova: no worries at all!
17:41:59 <dwalleck_nova> So that's something else we have to worry about...for example, Essex uses a different URL structure for the Nova endpoint
17:42:12 <deshantm> jaypipes: just curious is there Xen testing going on with tempest at this point?
17:42:12 <dwalleck_nova> tentant-id instead of name
17:42:28 <jaypipes> deshantm: RAX is Xen, yes
17:42:32 <dwalleck_nova> I'm using Xen for all of my testing
17:42:40 <deshantm> ok good
17:43:18 <jaypipes> dwalleck_nova: re: the different endpoint structure, yes, that's what I'm currently dealing with in my local branch to get Tempest workign against Diablo
17:43:46 <jaypipes> dwalleck_nova: but a few simple changes to make the Tempest config a bit more flexible should do the trick
17:43:57 <dwalleck_nova> jaypipes: really? I hadn't updated the code to use the Essex version...maybe there was more than one change?
17:44:20 <jaypipes> dwalleck_nova: no... I mean a few simple changes that are in my local branch and not yet pushed to review ;)
17:44:30 <dwalleck_nova> Ahh :)
17:44:33 <jaypipes> :)
17:44:46 <dwalleck_nova> gotcha!
17:44:58 <jaypipes> any other discussion points before we wrap up?
17:45:05 <jaypipes> 5
17:45:07 <dwalleck_nova> And I do realize that there are some low priority issues I opened. I just wanted to start
17:45:08 <jaypipes> 4
17:45:10 <dwalleck_nova> me!
17:45:15 <jaypipes> go for it :)
17:45:21 <dwalleck_nova> bringing up concepts I'd like to add soon
17:45:25 <dwalleck_nova> Okay, now done :)
17:45:51 <jaypipes> dwalleck_nova: yep, absolutely. see my note about being able to run against multiple envs using the TEMPEST_CONFIG environ variable...
17:45:56 <jaypipes> OK, then, thank you guys! I'll write up an email to the ML shortly with a quick status update on Tempest
17:45:58 <jaypipes> Thanks!
17:46:01 <jaypipes> #endmeeting