21:01:41 <ttx> #startmeeting
21:01:42 <openstack> Meeting started Tue Jan 24 21:01:41 2012 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:43 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:01:49 <ttx> Today's agenda: http://wiki.openstack.org/Meetings/ProjectMeeting
21:01:50 <Vek> zns: OK, feel free to drop by any time.  I have the concept laid out as a graphic right now.
21:02:00 <ttx> #topic Actions from previous meeting
21:02:09 <ttx> * anotherjesse to sync up with zns on keystone-client blueprint status
21:02:17 <ttx> zns: did you get some updated status on that ?
21:02:43 <zns> ttx: erm… no, sorry.
21:03:09 <ttx> vishy: if anotherjesse is near you, could you ask him to join us on irc ?
21:03:32 <vishy> ttx: he is at castle
21:03:49 <vishy> (in meetings)
21:03:56 <ttx> arh.
21:04:08 <zns> ttx: I know there has been some work on keystone-client, and I contributed some, but not sure what status I would put on it...
21:04:25 <ttx> yes, I'm not sure what's the completion criteria on this one
21:04:31 <ttx> let's go over the rest of keystone status*
21:04:36 <ttx> #topic Keystone status
21:04:42 <ttx> #link https://launchpad.net/keystone/+milestone/essex-3
21:04:52 <zns> ttx: when does the gavel hit the gavel-thingy? When are we out of time for E3?
21:05:16 <ttx> ideally end of day today, so that I cut the branches tomorrow european morning
21:05:21 <ttx> there are 3 open blueprints left:
21:05:24 <zns> tx: ok
21:05:28 <ttx> * https://blueprints.launchpad.net/keystone/+spec/keystone-client (anotherjesse)
21:05:36 <ttx> * https://blueprints.launchpad.net/keystone/+spec/keystone-logging (heckj)
21:05:43 <ttx> * https://blueprints.launchpad.net/keystone/+spec/keystone-documentation (heckj)
21:05:54 <ttx> zns, heckj: status on the last two ?
21:06:00 <zns> Keystone status is good. I think we're closing off our last loose ends. The main items are ones assigned outside our team, but if we don't get them done tonight we slip to E4.
21:06:44 <ttx> zns: ok, so I can cut the milestone branch tomorrow with what's in today.
21:06:48 <zns> All the above three have enough progress on them to close them for E3. We can re-open new ones for E4 if there is more work. Except maybe keystone-client because it is well defined in a spec...
21:06:50 <heckj> zns: closing up the doc one now - it's where we needed it to be now
21:07:14 <zns> ttx: yes. We feel good with where we are today. We're cleaning up mainly until you cut.
21:07:24 <ttx> zns: you have 7 targeted bugs -- which ones are actually blocking E3 ?
21:07:34 <zns> ttx: none.
21:07:55 <zns> ttx: all the bugs we feel we HAD to get done are fix committed already
21:07:58 <ttx> so I will untarget the ones that are left tomorrow
21:08:06 <zns> yes.
21:08:06 <ttx> anotherjesse: yo
21:08:18 <anotherjesse> ttx: i'm in texas to meet with folks about keystone
21:08:18 <ttx> anotherjesse: status on https://blueprints.launchpad.net/keystone/+spec/keystone-client ?
21:08:35 <anotherjesse> ttx: that mostly works!
21:08:43 <ttx> anotherjesse: can we consider the bp completed ?
21:08:46 <anotherjesse> ttx: I think we have user/role/tenant/ec2 cli
21:08:53 <anotherjesse> ttx: we are working on tests as well
21:09:47 <heckj> anotherjesse: should we drop this back to E4, or wrap it up today?
21:09:52 <ttx> anotherjesse: here is my suggestion... lets' consider this one completed, and you can file extra blueprints for any work that needs to be done by E4
21:10:08 <anotherjesse> ttx: I think it is done - I just haven't verified that EVERY function is there
21:10:24 <anotherjesse> so I think closing it will be good and anythign we didn't hit is a bug
21:10:38 <ttx> anotherjesse: deal. Updating
21:10:52 <jakedahn> ttx: keystone client cli landed here: https://review.openstack.org/#change,3174 - does basic crud items
21:11:18 <ttx> zns: Looks good now. Anything else ?
21:11:31 <zns> Not right now! Thanks
21:11:36 <ttx> Questions for Keystone ?
21:11:46 <jakedahn> http://pastie.org/3245947
21:12:19 <zns> FYI: ayoung has been working on evebntlet IPv6 for us, but that applies to all OpenStack. Something to consider for Essex...
21:13:35 <ttx> #topic Swift status
21:13:40 <ttx> notmyname: o/
21:13:44 <notmyname> hi
21:13:48 <ttx> notmyname: Signs of 1.4.6 ?
21:14:17 <notmyname> yes, probably in about 3 weeks
21:15:06 <ttx> notmyname: should we set a tentative date, even if that may be modified ?
21:15:24 <ttx> or just keep it open-ended ?
21:15:32 <notmyname> I think we could tentatively set feb 13.
21:15:52 <ttx> I'll be skiing on that week, but I can find other people to replace me
21:15:58 <ttx> that could be an interesting exercise.
21:16:19 <notmyname> heh. I'll be travelling too
21:16:37 <notmyname> the 10th then?
21:16:37 <ttx> #action ttx to set Swift 1.4.6 tentative date to Feb 13.
21:17:02 <ttx> notmyname: release on the 10th means... freezing for your QA a bit earlier. Would that work ?
21:17:52 <notmyname> I'd expect to have our QA sign off by friday the 10th either way. it's just a matter of coordinating our different time zones (end of day here is awfully late for you)
21:18:47 <ttx> Let's put a tentative date on the 10th, and see what we can do to hit that. Worst case scenario someone else will release it early the next week
21:18:58 <notmyname> ok, sounds good to me
21:18:59 <ttx> #action ttx to set Swift 1.4.6 tentative date to Feb 10 (!)
21:19:06 <ttx> notmyname: Anything else ?
21:19:23 <notmyname> I'm almost done with object versions
21:19:38 <notmyname> I hope to have that in 1.4.6 (we'll see how code review goes)
21:19:57 <ttx> Questions on Swift ?
21:19:58 <notmyname> nothing else code related. just marketing stuff (conferences and meetups and stuff)
21:20:06 <notmyname> oh. the feb 2 bug fix day
21:20:19 <jaypipes> ++
21:20:27 * jaypipes will be in Austin
21:20:36 <notmyname> swift will be "officially unofficially" participating in the feb 2 bug squash day
21:20:39 <ttx> I'll be i nBrussels
21:20:47 <annegentle> there will be tacos
21:21:09 <jaypipes> notmyname: I like that :) officially unofficially
21:21:18 <ttx> notmyname: great.
21:21:29 <notmyname> in other words, we'll be around online (and we've already had one company ask to participate for swift), but we won't be actively promoting our own bug squash day at this time
21:21:52 <notmyname> I'm doing what I can to make sure that we have a rapid turn around on reviews on feb 2
21:21:56 <ttx> notmyname: no specific objective for the bug squashing day on your side ?
21:21:56 <notmyname> by core devs
21:22:00 <notmyname> correct
21:22:05 <ttx> ok.
21:22:09 <notmyname> well, less bugs is better ;-)
21:22:13 <jaypipes> :)
21:22:28 <ttx> #topic Glance status
21:22:34 <ttx> jaypipes: yo
21:22:37 <jaypipes> oy
21:22:39 <ttx> #link https://launchpad.net/glance/+milestone/essex-3
21:22:46 <ttx> Is interim-glance-authz-service complete ? Or more to come ?
21:22:59 <ttx> (convenience link: https://blueprints.launchpad.net/glance/+spec/interim-glance-authz-service)
21:23:05 <jaypipes> needed documentation. currently in review: https://review.openstack.org/3370
21:23:22 <jaypipes> ttx: that is the ONLY outstanding E3 item. other than that, we're ready to ship.
21:23:40 <bcwaldon> and that *will* be in today
21:23:45 <ttx> 5 targeted bugs -- none actually blocking E3 ?
21:23:56 <jaypipes> quoi?
21:24:04 <Vek> ttx: refresh?  I only see 2 bugs
21:24:09 <ttx> pff
21:24:16 <Vek> (all others fix-committed)
21:24:24 <jaypipes> ttx: you always fail to remember to refresh :P
21:24:39 <ttx> two incomplete bugs... what should I do with them ?
21:24:57 * ttx makes mental note not to fall into that refresh trap ever again
21:25:04 <jaypipes> ttx: meh... feel free to push to E4 for both. not a big deal..
21:25:22 <ttx> ok, will do if they are not fixed tonight.
21:25:29 <ttx> jaypipes: Anything else ?
21:25:30 <jaypipes> ttx: no, they won't be.
21:25:34 <jaypipes> ttx: feel free to move.
21:25:38 <ttx> so I move them
21:25:43 <jaypipes> ttx: nope, no other news from me.
21:25:57 <ttx> Questions on Glance ?
21:26:38 <ttx> #topic Nova status
21:26:42 <ttx> vishy: hey
21:26:43 <vishy> hi!
21:26:48 <ttx> #link https://launchpad.net/nova/+milestone/essex-3
21:26:52 <vishy> we're looking very good
21:26:59 <ttx> Let's review incomplete stuff:
21:27:06 <vishy> a few branches are being reviewed today
21:27:12 <ttx> Almost there:
21:27:15 <ttx> * https://blueprints.launchpad.net/nova/+spec/x509-cert-crud (vishy)
21:27:19 <ttx> * https://blueprints.launchpad.net/nova/+spec/apache-qpid-rpc (russellb)
21:27:32 <ttx> Could make it in:
21:27:37 <ttx> * https://blueprints.launchpad.net/nova/+spec/host-aggregates (armando)
21:27:47 <ttx> * https://blueprints.launchpad.net/nova/+spec/separate-nova-adminapi (bcwaldon)
21:27:56 <ttx> * https://blueprints.launchpad.net/nova/+spec/scaling-zones (comstud)
21:28:00 <ttx> * https://blueprints.launchpad.net/nova/+spec/public-and-private-dns (andrew)
21:28:11 <bcwaldon> ttx: marked separate-nova-adminapi complete
21:28:16 <russellb> apache-qpid-rpc is done and reviewed, should be in shortly
21:28:19 <vishy> https://blueprints.launchpad.net/nova/+spec/separate-nova-adminapi  and https://blueprints.launchpad.net/nova/+spec/public-and-private-dns  are done
21:28:19 <ttx> bcwaldon: cool.
21:28:22 <vishy> and marked
21:28:37 <ttx> host-aggregates and scaling-zones might fall a bit short
21:28:42 <vishy> scaling-zones is not going to make it
21:28:52 <vishy> host-aggregates might
21:29:00 <vishy> the others should make it
21:29:07 <ttx> and the remaining 7 clearly won't make it. Are you considering any for E4 ?
21:29:11 <vishy> yes
21:29:13 <armandomi> for host-aggregates, we got a bunch of reviews in the queue
21:29:16 <ewanmellor> Citrix has four host-aggregates reviews on Gerrit right now.  Would appreciate some reviews!
21:29:19 <ttx> vishy: which ones ?
21:29:23 <ewindisch> I'm still working on the 0mq stuff. Passes unit tests, doesn't pass smoketests yet... the patch would only create a new driver and service, it wouldn't touch any existing code and wouldn't be enabled by default.
21:29:23 <ewanmellor> Oh, hey Armando ;-)
21:29:25 <vishy> armandomi: I'm trying to get some reviewers
21:29:32 <vishy> there are 3 branches needed
21:29:33 <armandomi> we are nearly there, we still have some bits missing
21:29:38 <bcwaldon> vishy: I'll review shortly
21:29:55 <armandomi> but it'd be great if we could get at least the OSAPI extensions in
21:30:07 <armandomi> so that the rest could be filed as bug fixes
21:30:10 <vishy> I'm considering ff exceptions for zeromq and solidfire driver
21:30:19 <pvo> ewanmellor: we're lining up to review.
21:30:42 <ewanmellor> pvo: Thanks
21:30:43 <vishy> as neither one needs to touch core code
21:30:48 <ttx> vishy: any signs that those will be worked on ?
21:31:02 <armandomi> there is also bug #921087 that makes sense for host aggregates
21:31:03 <uvirtbot> Launchpad bug 921087 in nova "i18n-key and local-storage hard-coded in xenapi" [Undecided,Confirmed] https://launchpad.net/bugs/921087
21:31:12 <vishy> so volume type scheduler going to defer
21:31:18 <ttx> vishy: which one is solidfire ?
21:31:25 <vishy> also think an ffe for kvm-resize is useful
21:31:26 <armandomi> I have got a fix, file it later, tomorrow morning at latest
21:31:32 <ewanmellor> We also have a review outstanding for https://blueprints.launchpad.net/nova/+spec/xenapi-provider-firewall.  That's ready to go in if it can get reviewed in time.
21:31:40 <vishy> it just implements an unimplemented feature in libvirt driver
21:32:05 <ttx> vishy: no bp for that one yet, right ?
21:32:06 <vishy> ewanmellor: review link?  it isn't connected to the bp
21:32:07 <ewindisch> ttx: I'm committed to having the zeromq working and making good progress.
21:32:18 <vishy> ttx: which the kvm-resize?
21:32:22 <bcwaldon> vishy: is there a formal process for requesting feature-freeze exceptions?
21:32:27 <ewanmellor> vishy: https://review.openstack.org/#change,3207
21:32:51 <vishy> added to review list
21:33:04 <ttx> vishy: yes
21:33:19 <vishy> ttx: I think there is one
21:33:21 <ewanmellor> (Isn't Gerrit supposed to add those links automatically?  The blueprint name is in the title)
21:33:25 <vishy> ttx: maybe it didn't get targetted
21:33:43 <ttx> vishy: ideally you would mark "Deferred" the ones that go to F and target to E4 the ones that get a FFe
21:33:49 <vishy> ewanmellor: it needs to be in the form "blueprint xxxx"
21:33:56 <vishy> as opposed to bp/xxxx
21:34:01 <ewanmellor> vishy: Oh, bummer.
21:34:54 <ttx> vishy: so, unless you send me an IRC message or email, I'll cut milestone-proposed with what's in tonight
21:35:02 <vishy> ssl is fine in e4
21:35:05 <ttx> vishy: does that work for you ?
21:35:07 <vishy> as well as testing cleanup
21:35:09 <vishy> ttx: yes
21:35:13 <vishy> so i will move those
21:35:19 <ttx> On the bugs side, 5 targeted bugs...
21:35:29 <ttx> Bug 917397 needs some review love at https://review.openstack.org/#change,3245
21:35:30 <uvirtbot> Launchpad bug 917397 in nova "Quantum Manager configuration sanity checks" [Medium,In progress] https://launchpad.net/bugs/917397
21:35:44 <ttx> Those two that may already be solved:
21:35:45 <vishy> usnure about openvz and illumos
21:35:50 <ttx> * https://bugs.launchpad.net/nova/+bug/885265 (bhall)
21:35:52 <uvirtbot> Launchpad bug 885265 in nova "quantum 420 error leaves instance in BUILD state" [Medium,In progress]
21:35:55 <ttx> * https://bugs.launchpad.net/nova/+bug/917457 (sleepsonthefloor)
21:35:57 <uvirtbot> Launchpad bug 917457 in nova "Openstackx broken since nova api refactor" [High,Confirmed]
21:35:57 <vishy> i think we might just wait on those until f opens
21:36:04 <ttx> vishy: agreed
21:36:16 <ttx> Anything left to do on those two bugs ^^ ?
21:36:23 <bhall> ttx: we moved 885265 out
21:36:28 <ttx> it's a bit unclear from their status
21:36:40 <bhall> anyone else is welcome to grab it but I don't think we have time for it for this release
21:36:45 <ttx> bhall: out of... E3 ?
21:36:51 <bhall> ttx: yup
21:37:10 <ttx> ok, moving on nova side as well, then
21:37:18 <Vek> any word on how quick quantum will be refactored to nuke those non-standard responses?
21:37:20 <bhall> thank you
21:37:28 <ttx> what about bug 917457 ? Anything left to do on nova's side for this one ?
21:37:28 <uvirtbot> Launchpad bug 917457 in nova "Openstackx broken since nova api refactor" [High,Confirmed] https://launchpad.net/bugs/917457
21:37:31 <danwent> Vek: in review
21:37:41 <danwent> but will be only for API v1.1
21:37:42 <Vek> danwent: cool :)
21:37:46 <Vek> got it.
21:37:51 <danwent> since we don't want to change error codes and surprise clients
21:38:00 * Vek nods
21:38:04 <vishy> ttx: we are in process of removing openstackx
21:38:15 <vishy> i wil check status
21:38:21 <ttx> vishy: is this bug blocking E3 ?
21:39:38 <ttx> Finally, those last two don't have an assignee -- should we try to get them in as well:
21:39:44 <ttx> * https://bugs.launchpad.net/bugs/914418
21:39:44 <ttx> * https://bugs.launchpad.net/nova/+bug/917851
21:39:44 <uvirtbot> Launchpad bug 914418 in nova "Nova notifications now seem to be using the default rabbit exchange " [High,Confirmed]
21:39:46 <uvirtbot> Launchpad bug 917851 in nova "replace m2crypto with shelling to openssl" [Wishlist,Confirmed]
21:40:27 <dragondm> I've looked a bit into lp914418
21:40:49 <ttx> I think the M2Cryptoectomy can wait for post-E3
21:41:09 <vishy> ttx: I don't think so
21:41:28 <vishy> m2crypto can be e4
21:41:33 <ttx> ok
21:41:39 <vishy> the first one i haven't seen before
21:41:42 <russellb> dragondm: is it still broken?  looks right to me ...
21:42:11 <ttx> vishy: ok, let's keep those last two in E3 scope for the moment
21:42:11 <dragondm> I'm currently doing a workaround for a related system for the default exchange bug, so I haven't looked at the novaissue in a day or 2
21:42:22 <ttx> Anything missing from that list that should be blocking E3 ?
21:42:48 <ttx> dragondm: can we assign you to this bug for the time being ?
21:42:56 <dragondm> ya sure.
21:43:02 <ttx> dragondm: thx, keep us posted.
21:43:06 <dragondm> sure
21:43:34 <ttx> vishy: Anything else ?
21:43:56 <ttx> vishy: if you have other E3-critical bugs, be sure to add them to the E3 list
21:43:57 <vishy> ttx: nope.
21:44:02 <ttx> Questions on Nova ?
21:44:03 <vishy> good luck reviewing everyone
21:44:05 <oleg__> can I hope to target this to e-4: https://blueprints.launchpad.net/nova/+spec/nexenta-volume-driver ?
21:44:49 <oleg__> we have diablo version code, it is 2 week effort to update it for essex
21:44:53 <vishy> oleg__: I will consider Feature Freeze exceptions for drivers that don't touch the core code
21:45:02 <ttx> vishy: we could require a ML thread for every FFe request... so that we can have a public discussion on whether the benefit outweighs the risk
21:45:02 <vishy> but it needs to get in early in e4
21:45:10 <oleg__> vishy: good to hear
21:45:20 <vishy> or else you will have to ship it separately until F
21:45:20 <oleg__> what we have to do
21:45:21 <ttx> devcamcar: around now ?
21:45:30 <vishy> ttx: sounds good
21:45:32 <oleg__> to make it into e4 ?
21:45:35 <devcamcar> o/
21:45:41 <ttx> #topic Horizon status
21:45:54 <vishy> oleg__: please make a request to the mailing list so it can be discussed in public
21:46:04 <ttx> #link https://launchpad.net/horizon/+milestone/essex-3
21:46:06 <oleg__> fine, thank you
21:46:16 <ttx> Only one blueprint missing:
21:46:20 <ttx> https://blueprints.launchpad.net/horizon/+spec/novaclient-migration (sleepsonthefloor)
21:46:26 <ttx> devcamcar: What's the status on this one ?
21:46:38 <devcamcar> yea - and that is very very close to being done (jf not already)
21:46:42 <devcamcar> s/jf/if
21:46:48 <devcamcar> that will land today
21:46:51 <ttx> ok, so it should be done today.
21:46:54 <devcamcar> yes
21:47:05 <ttx> and we should be ready to cut.
21:47:08 <ttx> You also have 8 targeted bugs...
21:47:13 <ttx> Are they all blocking E3 ?
21:47:14 <devcamcar> yep! we are looking good
21:47:32 <devcamcar> there is only one critical bug at this time
21:47:35 <devcamcar> that should land today as well
21:47:48 <devcamcar> we have may to back port from trunk to milestone-proposed a few over the next few days
21:47:53 <devcamcar> er, well, tomorrow :)
21:47:57 <ttx> devcamcar: ideally after today you should refine the list so that it only contains candidates for milestone-proposed backporting
21:48:06 <devcamcar> ok
21:48:07 <devcamcar> will do
21:48:11 <ttx> thx
21:48:27 <devcamcar> i expect most of these to land today or tomorro
21:48:43 <ttx> (the idea being to use that as a dashboard of work left to do before E3 delivery)�
21:48:47 <ttx> devcamcar: Anything else ?
21:48:52 <devcamcar> that is all
21:49:01 <ttx> Questions for Horizon ?
21:49:40 <ttx> #topic Incubated projects and other Team reports
21:49:47 <ttx> danwent, troytoman: yo
21:49:50 <danwent> hello :)
21:49:52 <troytoman> 0/
21:49:54 <ttx> A quick reminder of how milestone-proposed works...
21:50:00 <ttx> Early tomorrow I'll cut a milestone-proposed branch off master
21:50:13 <ttx> That branch can still get urgent milestone-blocking bugfixes, but no more features or gratuitous changes
21:50:20 <danwent> yup
21:50:26 <troytoman> sounds good
21:50:27 <ttx> You have to push bugfixes to the master branch first, and propose a backport of the fix to milestone-proposed
21:50:35 <ttx> So, let's have a look at Quantum first
21:50:40 <ttx> https://launchpad.net/quantum/+milestone/essex-3
21:50:46 <ttx> danwent: Is the status accurate ?
21:50:48 <danwent> bit of a log-jam in reviewing
21:50:53 <danwent> yes
21:51:00 <danwent> one or more of the features won't make it
21:51:07 <ttx> Can I cut the milestone-proposed branch in 10 hours with what will be in there ?
21:51:08 * mtaylor is causing problems for quantum
21:51:10 <danwent> we're trying to get the repo split.  that should be done
21:51:18 <danwent> yes
21:51:19 <Vek> just do to the need for reviews?
21:51:33 <ttx> danwent: good.
21:51:40 <danwent> vek: an general stability
21:51:40 <ttx> danwent: anything else ?
21:51:44 <danwent> nope
21:51:53 <danwent> an -> and
21:51:57 <ttx> OK, Melange now...
21:52:02 <ttx> https://launchpad.net/melange/+milestone/essex-3
21:52:08 <troytoman> we've gotten the client separated out
21:52:22 <troytoman> primarily focused on vetting integration with nova/quantum
21:52:30 <troytoman> i think we're good for the milestone release
21:52:31 <ttx> troytoman: so that one can be marked completed ?
21:52:39 <ttx> *or both ?
21:52:45 <troytoman> i believe so
21:52:56 <troytoman> i'll double check that the reviews finished
21:53:01 <ttx> "improve scalability" is rather open-ended :)
21:53:19 <troytoman> sorry, will clarify that but it will push out to e4.
21:53:24 <ttx> troytoman: ok, will cut branch with what's in tomorrow, unless you tell me otherwise
21:53:32 <troytoman> i decided it was too disruptive to push in this window
21:53:44 <troytoman> sounds good.
21:53:51 <ttx> ok, so client split -> done, scalability -> e4 ?
21:54:08 <troytoman> ttx: yes. i'll update launchpad on scalability
21:54:16 <ttx> will mark client split done
21:54:20 <ttx> troytoman: other remarks ?
21:54:38 <troytoman> ttx: no
21:55:06 <ttx> Any other team lead with a status report ?
21:55:18 <ttx> annegentle:
21:55:26 <annegentle> yo
21:55:27 <ttx> mtaylor: ^ ?
21:55:56 <mtaylor> ttx: ?
21:55:59 <annegentle> The ginormous install guide is here: https://review.openstack.org/#change,3301
21:56:20 <mtaylor> ttx: code review auto-expiration went live last night
21:56:23 <annegentle> Also making headway on the API reference site.
21:56:36 <mtaylor> ttx: hoping to get some tox-based unittest stuff rolled out this week
21:56:38 <Vek> mtaylor: so I noticed :)
21:56:52 <mtaylor> ttx: python-quantumclient currently is using tox - so we've got a test case/example project
21:57:49 <mtaylor> also, LinuxJedi is going to solve all of our remaining problems this weekj
21:57:55 <ttx> mtaylor: python-quantumclient ? Do you have a tarball job for that ?
21:58:06 * ttx didn't plan to release quantumclient as part of E34
21:58:09 <ttx> E3*
21:58:32 <Vek> that would be quite a release cycle, if we were going all the way to E34
21:59:06 <LinuxJedi> lol! :)
21:59:14 <ttx> #topic Open discussion
21:59:17 <danwent> I think mtaylor is coding it up right now so he can say yes :)
21:59:30 <ttx> Anything else, anyone ?
22:00:04 <ttx> danwent: a bit late to include it in my process... We can make a quantumclient tarball release for E4 -- would that work ?
22:00:06 <mtaylor> ttx: working on the split - it'll be like keystoneclient/novaclient - part of quantum project
22:00:40 <danwent> mtaylor, ttx, let's chat after meeting
22:00:45 <mtaylor> danwent: ++
22:00:53 <zul> e3 is friday isnt it?
22:00:56 <ttx> danwent: if I'm still around :)
22:01:03 <ttx> zul: e3 is thursday.
22:01:18 <ttx> Rule #4 of release management is don't release on a Friday.
22:01:20 <danwent> ttx, i meant right now, but you can close main meeting first
22:01:26 <Vek> hehe :)
22:01:45 <ttx> danwent: sure
22:01:49 <ttx> #endmeeting