21:03:23 <ttx> #startmeeting
21:03:24 <openstack> Meeting started Tue Jan 31 21:03:23 2012 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:03:25 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:03:28 <mtaylor> see - we can get stuff done sometimes
21:03:34 <ttx> Today's agenda: http://wiki.openstack.org/Meetings/ProjectMeeting
21:03:41 <ttx> mtaylor: I never (EVER) doubted it.
21:03:54 <ttx> #topic Keystone status
21:04:00 <ttx> zns: o/
21:04:08 <ttx> #link https://launchpad.net/keystone/+milestone/essex-4
21:04:14 <zns> Keystone Light branch is in. It's called "redux"
21:04:25 <ttx> it's in ? or jus tproposed ?
21:04:33 <ttx> or just proposed ?
21:04:44 <zns> anotherjesse said "everybody is working on getting ksl ready for merge by next week"
21:05:09 <vishy> hi
21:05:15 <zns> ttx: it is a branch (https://github.com/openstack/keystone/tree/redux) and can be accessed through gerrit.
21:05:25 <ttx> oh, I see
21:05:31 <zns> So we should be looking at a merge soon.
21:05:43 <heckj> ola
21:05:44 <zns> Main items missing are:
21:05:45 <zns> Gaps:
21:05:45 <ttx> Would be good to have the rearchitecture appearing as a blueprint for essex-4
21:05:45 <zns> - Versioning
21:05:45 <zns> - Content-negotiation
21:05:45 <zns> - Extension negotiation
21:05:45 <zns> - Errors (with content sensitivity)
21:05:45 <zns> - URL normalization
21:05:46 <zns> - Pagination
21:05:46 <zns> - LDAP
21:05:47 <zns> Features:
21:05:48 <zns> - migration
21:05:48 <zns> - os: extension for Quantum and Melange
21:05:49 <zns> - OS-KSADM changes (support for password on user creation)
21:05:50 <zns> Bugs:
21:05:50 <zns> - ./keystone in bin, I get error
21:05:54 <ttx> that way we could track that
21:06:01 <heckj> ttx: will do
21:06:16 <ttx> heckj: cool, thanks. You can enumerate the gaps in the whiteboard
21:06:27 <zns> ttx: we also agreed to tag bugs/bps for ksl with "redux" in LaunchPad.
21:06:32 <heckj> ttx: will link it up to an etherpad that we're tracking
21:06:32 <ttx> I'll keep close attention to this
21:06:36 <gyee> will other extensions also be ported?
21:06:40 <ttx> heckj: perfect
21:06:51 <ttx> Do the other two blueprints (keystone-logging and keystone-test-refactor) still make sense in keystonelight context ?
21:07:15 <zns> keystone-logging, no. tests, somewhat, because we have to work on tests in ksl.
21:07:25 <heckj> ttx: most of the work I've been doing to keystone-logging has been applying it to the redux branch
21:07:50 <ttx> heckj: so they are interrelated a bit
21:07:51 <heckj> ttx: zns and team have bolstered logging in the current branch as well
21:07:59 <ttx> ok
21:08:38 <ttx> zns: Is keystone participating to the bug squashing day ?
21:08:39 <zns> ttx: IU want to confirm our position on new features. They should all be parked in local branches until folsom?
21:09:17 <zns> ttx: I believe so. I can't (was already booked out that day), but I think Dolph and joesavak will be.
21:09:20 <ttx> zns: until we do RCs, which is for keystone shortly after E4
21:09:55 <zns> ttx: and then we'll create the folsom branch? Need to know what tell folks (like gyee).
21:10:18 <ttx> then we create milestone-proposed to hold the release candidate, and trunk shifts to folsom
21:10:35 <zns> We're doing that in E4 for Keystone?
21:10:44 <zns> * sounds good - just confirmin *
21:11:00 <ttx> zns: yes, that's what we said at the last design summit
21:11:13 <ttx> RCs statr after E4, and Keystone should be one of the first to get finalized
21:11:23 <ttx> (and Horizon one of the last)
21:11:24 <zns> ttx: roger. On board with that.
21:11:34 <termie> which meeting is this that we are discussing keystone status in?
21:11:44 <ttx> Any specific bug squashing objective you'd like to mention on http://wiki.openstack.org/BugSquashingDay/20120202 ?
21:11:50 <ttx> termie: the keystone meeting, probably
21:11:52 <heckj> ttx: #link https://blueprints.launchpad.net/keystone/+spec/rearchitect-keystone
21:12:02 <ttx> heckj: thx
21:12:07 <heckj> termie - general meeting
21:12:13 <zns> termie: also http://wiki.openstack.org/Meetings/KeystoneMeeting
21:12:13 <termie> "project status meeting" okays
21:12:14 <ttx> zns: Anything else ?
21:12:21 <zns> ttx: nope.
21:12:49 <ttx> zns: for Keystone on bug squashing day it would be nice to review the list of bugs to see if they still make sense in KSL context.
21:13:17 <ttx> but maybe thats too early if the main branch hasn't been replaced
21:13:24 <zns> ttx: OK. I'll relay to joesavak.
21:13:31 <ttx> Questions for Keystone ?
21:13:32 <joesavak> \o got it
21:13:36 <deshantm> so just to be clear, ksl is default going forward only or is it also going to be in the essex release?
21:13:54 <ttx> going to be in essex, if it closes the identified gaps.
21:14:17 <anotherjesse1> deshantm: assuming community votes yes as well
21:14:36 <gyee> *all* existing extensions will be ported correct?
21:14:54 <termie> gyee: if the extension writers port them
21:15:02 <deshantm> ok thanks, just want to make sure where to focus QA efforts
21:15:07 <anotherjesse1> termie: we are working on porting them
21:15:09 <deshantm> we all want Essex to be solid
21:15:33 <ttx> More keystone / ksl questions ?
21:15:53 <ttx> #topic Swift status
21:15:59 <ttx> notmyname: o/
21:16:03 <notmyname> hi
21:16:05 <ttx> notmyname: Still expecting 1.4.6 on February 10 ?
21:16:12 <notmyname> no reason not to
21:16:20 <ttx> notmyname: When can we cut a milestone-proposed branch ? Tuesday next week ?
21:16:28 <ttx> or Wednesday maybe ?
21:16:29 <notmyname> probably on wednesday
21:16:53 <ttx> notmyname: Could you reference the features that are expected to be merged in this release at: https://launchpad.net/swift/+milestone/1.4.6 ?
21:17:05 <ttx> I know you've been working on object versioning...
21:17:10 <notmyname> yes, I've been asked to do that by others...
21:17:22 <ttx> would like to know (as the rest of the world) if that's going to hit :)
21:17:28 <notmyname> yeah, I've also been focusing on some rax stuff too. I'll get to it :-)
21:17:43 <ttx> notmyname: Any specific objective for Swift on the Bug Squashing day ?
21:18:06 <notmyname> no. but we'll have some of the core devs keeping an eye on the patches in order to give rapid feedback
21:18:16 <ttx> ok.
21:18:21 <ttx> notmyname: Anything else ?
21:18:24 <notmyname> so if patches are submitted, we hope to get them merged if possible that day
21:18:28 <notmyname> one more thing
21:18:37 <notmyname> ah. nm
21:18:53 <ttx> #action notmyname to link blueprints corresponding to 1.4.6 features on milestone page
21:19:05 <ttx> Questions on Swift ?
21:19:19 <ttx> #info &.4.6
21:19:22 <ttx> arh
21:19:42 <ttx> #info 1.4.6 milestone-proposed cut expected on Wed, Feb 8
21:19:56 <ttx> #topic Glance status
21:20:07 <ttx> bcwaldon: yo
21:20:16 <ttx> #link https://launchpad.net/glance/+milestone/essex-4
21:20:34 <ttx> Who will be working on glance-bittorrent-delivery ?
21:20:50 <ttx> bcwaldon: (if anyone)
21:21:23 <bcwaldon> no idea
21:21:49 <ttx> bcwaldon: Any specific objective for the Bug Squashing day ?
21:22:13 <ttx> #action jaypipes to assign or defer glance-bittorrent-delivery
21:22:16 <bcwaldon> The general idea of 'fix bugs' applies here
21:22:31 <bcwaldon> jaypipes is going to send out an email w.r.t. low-hanging-fruit in glance and tempest
21:22:44 <bcwaldon> no big news on the Glance front :)
21:22:46 <ttx> bcwaldon: fwiw I set some numbers as objectives for Nova, so that we can define "success"
21:22:57 <ttx> bcwaldon: feel free to do the same on the wiki page
21:23:10 <ttx> like "fall below N open bugs"
21:23:13 <bcwaldon> ok, we have nowhere near as many bugs (only ~20 available)
21:23:24 <bcwaldon> ...to be picked up
21:23:41 <ttx> bcwaldon: ok :)
21:23:43 <ttx> bcwaldon: Anything else ?
21:23:49 <bcwaldon> Negatory
21:23:57 <ttx> Questions on Glance ?
21:24:43 <ttx> #topic Nova status
21:24:49 <ttx> vishy: hey
21:24:59 <ttx> #link https://launchpad.net/nova/+milestone/essex-4
21:25:12 <ttx> Lots of stuff in there. Are all of those feature freeze exceptions ?
21:25:14 <vishy> hi
21:25:34 <ttx> or were some sneakily targeted ?
21:25:41 <vishy> most but not all
21:25:46 <vishy> some are just not really features
21:25:50 <ttx> netapp-volume-driver, essex-backup-for-ebs and nova-sweep do not have essex series goal set yet (or priority)
21:26:00 <ttx> does that mean those are not accepted yet ? ^
21:26:06 <vishy> https://blueprints.launchpad.net/nova/+spec/consolidate-testing-infrastructure
21:26:08 <vishy> for example
21:26:11 <ttx> right
21:26:34 <vishy> netapp seems to be supported on the ml so that one will probably be FFe
21:26:39 <vishy> the other two look new
21:26:54 <ttx> no need to review them now
21:27:10 <ttx> #action vishy to review essex-backup-for-ebs and nova-sweep and deny/grant FFe
21:27:19 <vishy> the scaling zones one is probably going to miss
21:27:35 <vishy> i'm going to talk to comstud tomorrow but it seems like it is too late to FFe it
21:27:39 <ttx> vishy: yes, this is a bit big.
21:27:55 <vishy> ttx: I think they will just do a branch and propose for F
21:28:06 <ttx> vishy: Anything else on the blueprints side ?
21:28:33 <vishy> i think not
21:28:34 <ttx> I'd like to quickly discuss dead wood... since the press makes their headlines on it
21:28:43 <vishy> most of the FFe stuff is in
21:28:43 <ttx> Do you agree with ajaxtermectomy and HyperVectomy ?
21:28:48 <vishy> yes
21:28:55 <ttx> Anything else we should get rid of while we still can ?
21:28:56 <vishy> ajaxterm definitely
21:29:17 <vishy> deprecated auth
21:29:27 <ttx> vishy: could you add tha tto the thread ?
21:29:31 <vishy> we need to fixup the migration script though
21:29:40 <vishy> m2crypto as well
21:29:46 <vishy> sure
21:29:50 <ttx> Do you want essex-4 blueprints to track their completion ?
21:30:06 <vishy> hmm, yeah that is probably a good idea
21:30:19 <ttx> I think it can't hurt. We had blueprints when we added the feature after all.
21:30:30 <vishy> although we have bugs for m2crypto and ajaxterm right?
21:30:40 <ttx> I'll add the ajaxterm and hyperV one. We'll link the bugs in
21:30:53 <ttx> ajaxterm has several bugs linked
21:31:04 <ttx> I'll propose the ajaxtermectomy. Anyone up to propose the HyperVectomy ?
21:31:14 <ttx> soren maybe ?
21:31:24 <berendt_> what about removing bin/nova-manage? i read some note in a change request that it should be removed during essex-4
21:31:30 <vishy> yes
21:31:38 <soren> ttx: Yeah, I was meaning to do that.
21:31:40 <vishy> berendt_: that is one of the hopes for focus for e4
21:31:53 <vishy> berendt_: we still need some of the functionality ported to admin extensions
21:32:03 <ttx> #action soren to create a blueprint about surgical removal of HyperV and target to e4
21:32:19 <ttx> #action ttx to create a blueprint about Ajaxtermectomy
21:32:22 <vishy> berendt_: my team was planning on focusing on that next (after the stuff in our current email is done)
21:32:26 <jog0> m2crypto bug: https://bugs.launchpad.net/nova/+bug/917851
21:32:27 <uvirtbot> Launchpad bug 917851 in openstack-ci "replace m2crypto with shelling to openssl" [High,In progress]
21:32:33 <vishy> berendt_: but help would be appreciated
21:32:44 <berendt_> vishy: are there existing bug reports?
21:32:48 <ttx> #action vishy to push deprectaedauth, m2crypto removal to ML and blueprints
21:33:01 <vishy> berendt_:  I don't know
21:33:13 <ttx> though M2crypto was already discussed, I think
21:33:14 <vishy> berendt_: there may be some, but i doubt it covers everything
21:33:17 <berendt_> should be added as action too...
21:33:20 <vishy> berendt_: live migration was moved
21:33:30 <vishy> berendt_: and networks as well i believe
21:33:46 <ttx> vishy: what replaces nova-manage ? plain nova + keystone CLI ?
21:33:53 <vishy> ttx: yes
21:34:01 <ttx> we still need db sync, I think
21:34:07 <rkukura> is there a blueprint for nova-manage-ectomy?
21:34:12 <ttx> rkukura: no
21:34:16 <vishy> ttx: any reason why we couldn't do that through an admin api?
21:34:31 <soren> Sorry, wait, what?
21:34:45 <ttx> vishy: sounds like the job of a specific helper.
21:34:49 <vishy> ttx: i guess we would have to make nova-api start without trying to load the models
21:34:50 <ttx> soren: what what ?
21:34:53 <soren> nova-manage is going away altogether or just for user management?
21:34:56 <devcamcar> nova-manage is going away?
21:35:01 <vishy> soren: hoping to remove nova-manage
21:35:06 <soren> Why?
21:35:09 <devcamcar> why?
21:35:11 <ttx> (that's news to me too, fwiw :)
21:35:23 <vishy> soren, devcamcar: because all of the stuff it does should be admin extensions
21:35:38 <devcamcar> but … it's not
21:35:41 <Daviey> The first i saw this mentioned was on the prettytable merge.
21:35:41 <devcamcar> so you can't remove it yet :)
21:35:44 <vishy> db could be a special case
21:35:54 <soren> vishy: This is for Folsom, right?
21:36:03 <vishy> devcamcar: hence the earlier comment: vishy: berendt_: that is one of the hopes for focus for e4
21:36:03 <vishy> [9:31pm] vishy: berendt_: we still need some of the functionality ported to admin extensions
21:36:13 <vishy> soren: if necessary
21:36:16 <devcamcar> sounds scary for essex
21:36:18 <soren> You cannot seriously be suggesting that we replace nova-manage for Essex?
21:36:22 <ttx> devcamcar: +1
21:36:38 <vishy> fair enough. If it must stay it must stay
21:36:46 <devcamcar> i'm all for it for folsom
21:36:49 <vishy> I still would like everything to become admin extensions
21:36:50 * ttx breathes again.
21:36:52 <vishy> asap
21:36:57 <devcamcar> its a good goal
21:37:09 * vishy hates nova-manage
21:37:21 <ttx> its a bit late to remove it. Even if we could do that in two weeks, it breaks a bit of docs.
21:37:27 <Daviey> Hmm
21:37:29 <Daviey> If nova-manage is going away next cycle, it makes stable/'s team harder :)
21:37:29 <vishy> and I wrote the first version so I'm allowed to
21:37:30 <soren> So how would you consume these admin extensions?
21:37:39 <soren> ....if not through nova-manage?
21:37:39 <ttx> Daviey: why ?
21:37:42 <vishy> soren: python-novaclient
21:37:54 <Daviey> ttx: harder^D impossible to cherry pick :)
21:38:25 <mtaylor> vishy: sorry, was away for a moment - LinuxJedi from my team was going to look at the M2Crypto removal bug if that's helpful
21:38:28 <ttx> if it's folsom work, let's discuss that around a beer in April.
21:38:34 <vishy> ok so how about this way: goal is to get everything into extensions so that you can successfully run without nova-manage
21:38:49 <vishy> mtaylor: cool i think bcwaldon was looking at it too, so you might have to fight him
21:38:53 <soren> My opinion: No.
21:39:00 <soren> Goal is: STable Essex.
21:39:02 <soren> That's number 1.
21:39:03 <vishy> we can leave nova-manage in
21:39:08 <mtaylor> vishy: if bcwaldon wants it, i'm sure LinuxJedi isn't going to argue :)
21:39:14 <soren> If we manage that, sure, knock yourself out. Write a million admin extensions.
21:39:16 <LinuxJedi> vishy: currently not my highest priority so happy for bcwaldon to play with it
21:39:42 <vishy> soren: goal hasn't changed there
21:39:57 <ttx> vishy: that's a Folsom goal, right ?
21:39:57 <soren> vishy: Well, if you're diverting a lot of attention to writing admin extensions..
21:39:57 <LinuxJedi> bcwaldon: feel free to re-assign https://bugs.launchpad.net/openstack-ci/+bug/917851 to you
21:39:59 <uvirtbot> Launchpad bug 917851 in openstack-ci "replace m2crypto with shelling to openssl" [High,In progress]
21:40:02 <vishy> OK, I'm being to ambitious
21:40:04 <soren> vishy: ...then I beg to differ.
21:40:05 <bcwaldon> LinuxJedi: kk
21:40:12 <vishy> * too ambitious
21:40:32 <Daviey> vishy: aim high, fall far :)
21:40:36 <vishy> fair enough.
21:40:47 <ttx> Folsom goal.deal.
21:40:52 <vishy> soren: stability isn't my only concern
21:40:53 <ttx> vishy: I set up basic objectives for Nova on http://wiki.openstack.org/BugSquashingDay/20120202 -- feel free to adapt/change.
21:40:56 <LinuxJedi> so that is why my wife always aims for the groin
21:40:58 <vishy> soren: i also want it to be operatable
21:41:25 <soren> vishy: All our admin docs explain how to do things with nova-manage.
21:41:35 <vishy> soren: yes, that is an excellent point
21:41:45 <soren> vishy: Things aren't going to automatically be more pleasant to work with because it gets APIified.
21:41:45 <Daviey> isn't that just a grep away?
21:41:50 <annegentle> we can prioritize it if needed though (the docs changes). Means some tough decisions though.
21:41:56 <vishy> soren: so I will push my nova-manage desires to folsom
21:42:03 <ewindisch> fyi, there have been suggestions of looking at encryption for the zeromq rpc driver. We might want m2crypto or similar when we get there.
21:42:03 <annegentle> Daviey: Ha. No.
21:42:07 <soren> Daviey: I sure hope vishy's hatred towards nova-manage goes further than just the name of the command.
21:42:09 <Daviey> annegentle: Sorry!
21:42:10 <ewindisch> that won't be essex, though
21:42:15 <annegentle> Daviey: :)
21:42:23 <ttx> vishy: Anything else ?
21:42:27 <ttx> we need to move on.
21:42:37 <vishy> soren: haha, the name of the command makes no difference to me. I just want it to be doing everything through the api
21:42:46 <vishy> ttx: nope, sounds like that one is settled
21:42:50 <ttx> Nova subteam leads: anything on your side ?
21:42:58 <soren> vishy: Right, so it's much more than just "a grep away" is my point.
21:43:03 <ttx> Other questions on Nova ?
21:43:41 <ttx> #topic Horizon status
21:43:47 <ttx> devcamcar: o/
21:43:51 <devcamcar> o/
21:43:54 <ttx> #link https://launchpad.net/horizon/+milestone/essex-4
21:43:59 <ttx> Lots of blueprints here, but that was kinda expected...
21:44:08 <devcamcar> i've already taken the first pass at removing a few of them and punting for folsom
21:44:25 <ttx> devcamcar: Having 3 Essential blueprints on the last milestone make me a bit nervous
21:44:31 <ttx> devcamcar: when do you expect those to hit ?
21:44:46 <ttx> "Essential" means "delay the release if not completed".
21:44:55 <ttx> So I'd rather see those completed yesterday.
21:45:00 <devcamcar> one is 80% done already, one has been tracking the overall work being done and we can close soon, the third i will downgrade to high
21:45:09 <ttx> devcamcar: cool.
21:45:19 <ttx> Who is assigned to ec2-credentials-download and image-upload ?
21:45:33 <ttx> oh, recent fix
21:45:34 <devcamcar> ec2 credentials is jake dahn
21:45:36 <ttx> nm
21:45:44 <devcamcar> image upload has not been started
21:46:17 <ttx> devcamcar: Do you have specific objectives for the Bug Squashing day ?
21:46:42 <devcamcar> tres and i will be triaging today and marking all the low hanging fruit items
21:47:00 <devcamcar> main objectives are adding unit tests and reducing bugs
21:47:16 <ohnoimdead> there's a lot of simple clean-up tasks new contributors can get their feet wet with
21:47:18 <devcamcar> lots of the remaining 50 bugs are low hanging fruit at this point, some as simple as moving padding
21:48:16 <ttx> devcamcar: ok, so "get all low-hanging-fruit addressed" or something
21:48:28 <devcamcar> indeed
21:48:32 <ttx> Feel free to mention on http://wiki.openstack.org/BugSquashingDay/20120202
21:48:52 <ttx> devcamcar: Anything else ?
21:48:58 <devcamcar> nope
21:49:45 <ttx> Questions for Horizon ?
21:50:08 <lloydde> fruit: nice
21:50:15 <ttx> fruit is indeed nice.
21:50:20 * mtaylor likes fruit
21:50:23 <ttx> #topic Incubated projects and other Team reports
21:50:30 <ttx> danwent, troytoman: yo
21:50:37 <danwent> got a couple of things.
21:50:45 <ttx> danwent: shoot
21:50:46 <danwent> Bug Squashing Day: focus is on getting some nova + quantum system integration tests written using devstack.
21:50:52 <danwent> in person quantum bug squashing hangout @ Nicira in Palo Alto 2pm on thursday.  presos will be done on webex, so people can attend remotely.  will also try to have a virtual g+ hangout for those remote.
21:51:05 <danwent> details on netstack list
21:51:11 <danwent> also: Quantum essex-3 tarball has a snafu if you install from source using 'setup.py install'.  New version of admin guide available with one-line work around: http://launchpad.net/quantum/essex/
21:51:27 <danwent> whoops, link got cut: http://launchpad.net/quantum/essex/essex-3/+download/quantum-admin-guide.pdf
21:51:35 <danwent> Since Quantum is not core, we do not have a full freeze for E-4, but we are moving the feature freeze to a week earlier than normal, so Feb 21
21:51:52 <danwent> working with horizon team to get quantum + horizon in shape as well
21:51:55 <ttx> danwent: ok.
21:51:56 <danwent> Finally, I don't think this will be a surprise, but we're planning to propose Quantum as a core project for Folsom at an upcoming PPB meeting.
21:52:02 <danwent> hooray for copy-paste :)
21:52:05 <danwent> that's all
21:52:11 * mtaylor is surprised
21:52:13 <mtaylor> wait
21:52:17 <mtaylor> the other thing
21:52:22 <danwent> which?
21:52:26 <ttx> danwent: the secret is to copy-paste slow enough that people think you're typing.
21:52:38 <danwent> ah, but meeting is almost out of time :)
21:52:47 <ttx> troytoman: around ?
21:52:55 <troytoman> not much to report on melange - we are focusing on some scale testing around quantum/melange/nova integration
21:53:14 <troytoman> so, we'll fix bugs as we find them
21:53:30 <troytoman> also try to lock down the melange API for a v1 final
21:53:42 <ttx> Any other team lead with a status report ? annegentle, mtaylor ?
21:53:55 <annegentle> I've been working on "release notes" for Essex at http://wiki.openstack.org/ReleaseNotes/Essex
21:54:06 <annegentle> next will be doc priorities based on what we know to be in
21:54:32 <annegentle> I'd like to learn more about KSL and the API
21:54:44 <annegentle> so that we can properly source the content for api.openstack.org
21:54:45 <mtaylor> various infrastructure things - moving some of the services around to new machines and whatnot
21:55:11 <mtaylor> most interesting is that we're starting to roll out multi-python version testing, and we're about to start doing some pre-approval testing
21:56:05 <ttx> ok
21:56:11 <ttx> #topic Open discussion
21:56:17 <vishy> I have a topic
21:56:22 <ttx> vishy: go for it
21:56:32 <vishy> this may be a summit discussion but i wanted to get people thinking
21:56:41 <vishy> we have way too many drivers and such in nova-core
21:57:01 <vishy> it would be really nice to have a way to package up drivers/schedulers/ and api extensions
21:57:12 <vishy> into a single package that could be shipped separately
21:57:22 <vishy> (perhaps with its own conf file)
21:57:31 <Daviey> vishy: what is the benefit?
21:57:35 <reed> any PPB member, please respond to the email I sent the board yesterday re: elections
21:57:41 <vishy> bonus for a 1-click installer via horizon
21:57:41 <ttx> We are at a netscape moment.
21:57:56 <vishy> Daviey: the problem is maintaining all of that code in core is silly
21:58:06 <vishy> example: solidfire has an optimization to their driver
21:58:14 <vishy> they have to propose it through core and wait for a release
21:58:19 <ttx> reed: I don't think I received it.
21:58:31 <vishy> if we made it really easy to ship and package it separately
21:58:36 <danwent> vishy: we have similar issues with Quantum manager
21:58:42 <reed> ttx, I used the emailaddress monty gave me ... I blame him :)
21:58:47 <vishy> we wouldn't have all of that overhead
21:58:52 <Daviey> vishy: wait, didn't we push more stuff into core to make it so trunk always worked?
21:58:59 <ttx> reed: PM
21:59:03 <danwent> our concern has been that if that code isn't in core, and interfaces change, no one will be running unit tests that catch the fact that they broke something in QuantumManager
21:59:10 <vishy> Daviey: sure, but we don't really test the drivers that much
21:59:15 <Daviey> python-novalcient was an example.
21:59:18 <danwent> but I agree with the goal
21:59:29 <vishy> Daviey: the packages could include tests
21:59:29 <berendt_> just as a side note: everything prepared for the FOSDEM?
21:59:31 <ttx> vishy: ok, time is running short tpo discuss rearchitecting components :)
21:59:32 <devcamcar> reed: confirmed, I didn't receive your message either
21:59:37 <ttx> Bug squashing day is Thursday !
21:59:38 <Daviey> vishy: if they want it in diablo, we have the stable/ process :/
21:59:43 <ttx> Join us on #openstack-bugsquash, follow progress on http://wiki.openstack.org/bugstats/
21:59:51 <ttx> berendt_: we'll have an OpenStack developers meeting at FOSDEM, Chavanne room, Saturday at 6pm.
21:59:57 <vishy> Daviey: and we could still include packages + testing
22:00:01 <reed> damnit
22:00:14 <berendt_> ttx: I now.. maybe someone forgot to prepare a talk ;)
22:00:30 <Daviey> vishy: well, it impacts you more than most.. but from my PoV it seems like a PITA.
22:00:32 <vishy> Daviey: but shipping them separately seems like it would get rid of a lot of overhead
22:00:43 <AndrewWeiss> hey guys, apologies for interrupting but I also wanted to bring up the latest research project on the Academic Initiative Group for those that are members and are interested
22:00:44 <vishy> Daviey: the current thing is a pain
22:00:55 <Daviey> vishy: it seems that it mostly will allow people to land code which breaks drivers, and /someone/ else has to fix it.
22:00:55 <Ryan_Lane> I agree with vishy. the current way of things is painful
22:01:05 <vishy> Daviey: we have a bunch of code that is unmaintained in core, then vendors update and try and ship it all at the last minute
22:01:09 <jdg> I think there are some benefits for everybody involved but we can pick up discussions later
22:01:21 <ttx> vishy: ML ?
22:01:24 <Ryan_Lane> I think we should go slightly further and have ways of directly extending core as well, though
22:01:27 <ttx> We need to clear the floor for netstack.
22:01:31 <vishy> ttx: ML sure,
22:01:37 <vishy> ttx: and discussion at the summit
22:01:39 <ttx> and probably summit as well :)
22:01:43 <vishy> have fun netstack!
22:01:43 <Daviey> summit
22:01:49 <danwent> :)
22:01:51 <ttx> #endmeeting