22:02:07 <danwent> #startmeeting
22:02:08 <openstack> Meeting started Tue Jan 31 22:02:07 2012 UTC.  The chair is danwent. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:02:10 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
22:02:24 <danwent> hello all, this is now the netstack meeting
22:02:39 <danwent> #info agenda: http://wiki.openstack.org/Network/Meetings
22:02:58 <danwent> everybody here?
22:03:03 <SumitNaiksatam> hi
22:03:06 <davlap> hi folks!
22:03:10 <mtaylor> o/
22:03:46 <salv-orlando_> hi there!
22:03:57 <danwent> Ok, let's get started
22:04:19 <danwent> #info bug-squashing day is this thursday, Feb 2nd.
22:04:38 <danwent> will will have an in-person meetup in Palo Alto at 2pm (email was to netstack list).
22:05:08 <danwent> debo + I will be presenting at the start, with a focus on people getting devstack setup and used to write more interesting system/integration tests.
22:05:34 <danwent> any questions, please contact me.  webex and g+ hangout will be available.
22:05:38 <danwent> if you are remote.
22:05:48 <salv-orlando_> great
22:06:02 <salv-orlando_> I'll be with you remotely for the first hours
22:06:11 <danwent> my goal is to end the day with some basic integration test / smoke test code that someone can check in and can be run on a devstack host.
22:06:30 <danwent> I will send webex info to the ML
22:06:43 <danwent> #TODO #danwent send bug squashing webex info to ML
22:07:09 <danwent> is debo here?
22:07:17 <danwent> anything to add?
22:07:33 <danwent> don't see him.
22:07:47 <danwent> Ok, one other topic that I just added to the agenda
22:08:02 <danwent> the deadline for applying to be a core project in Folsom is coming up very quickly
22:08:13 <danwent> mid-Feb, essentially.
22:08:48 <danwent> I think its been our goal to apply for core project status for Folsom, and plan to do that, but wanted to give people a chance to voice any opinions on the topic
22:09:03 <danwent> so, feel free to chime in
22:09:23 <danwent> i'll work with jbryce and others to put together application.
22:09:37 <danwent> are people excited?
22:09:45 <bhall> danwent: very
22:09:59 <salv-orlando_> what does the application process require?
22:10:19 <salv-orlando_> in human words, which are the requirements for becoming a core project?
22:10:20 <danwent> not much, in fact, its roughly equivalent to our incubation application, updated, I believe.
22:10:51 <salv-orlando_> ok
22:10:54 <danwent> I think the main criteria is that the openstack PPB sees value in the project and is willing to stand behind it.
22:11:16 <danwent> so their metrics will be around quality, team, docs, etc.
22:12:10 <danwent> I will also start a thread on the ML about this, but wanted to bring it up in the meeting as well.
22:12:26 <danwent> more important, do people have concerns around this?  If so, I'd like to start working to address them asap.
22:13:05 <salv-orlando_> my only concern is that we need to address much better documentation.
22:13:18 <danwent> salv-orlando: which type?  admin, dev?
22:14:04 <danwent> as a core project, you get the help of the openstack docs team, but obviously we still need to shoulder a lot of the load.
22:14:27 <salv-orlando_> both of them. People often resort to the mailing list because they cannot find information about installing quantum or developing for it. And also we keep a lot of obsolete stuff on the wiki, which creates confusion.
22:15:05 <danwent> I actually think the quantum admin guide is quite up to date… i think the emails to the ML are as much about people's tendency to not read documentation as they are about the docs being out of date.
22:15:17 <annegentle> salv-orlando_: I think you guys are in good shape, docs-wise.
22:15:20 <danwent> dev docs is definitely something we need to improve though.
22:15:21 <annegentle> danwent: yep, agreed
22:16:02 <annegentle> danwent: agreed on the tendency people have not to read docs :) Your dev docs sorta "have" to be on the wiki for now. Since there's no quantum.openstack.org.
22:16:03 <danwent> salv: are there particular wiki pages that are out of date and we need to clean up?  wikis indeed have a tendency of getting stale.
22:17:08 <danwent> annegentle:  that's a good point.  in fact, because quantum is not yet core, its fairly hard to find the docs on the openstack site, which might explain why there are so many questions to the ML.
22:17:34 <annegentle> danwent: yes, the search for incubated docs has bit us before...
22:18:09 <salv-orlando_> I know about the pages I've created... most of them contain information which are not fully valid. The incubation status might explain people having difficulties finding docs, actually. I did not think about that.
22:18:16 <annegentle> danwent: but this time around, the docs.openstack.org search box has included quantum admin docs
22:19:04 <ohnoimdead> danwent: sending you some email wrt quantum ui but basically: we should take a design pass at the ui based on the new QuantumManager model and then add some bugs in horizon for the implementation. given everything on horizon's plate right now for e4 though i'm worried about getting this done before folsom.
22:19:27 <danwent> ohnoimdead:  thx, happy to sync up via email
22:20:08 <danwent> annegentle:  that's good.  my guess is that people just go to docs.openstack.org and don't look a lot deeper.  but assuming quantum becomes core, that issue should go away
22:20:15 <ohnoimdead> danwent: cool
22:20:29 <danwent> annegentle: and by that I meant the landing page, and not much deeper
22:20:59 <danwent> Ok, anything else on this topic?
22:21:19 <danwent> I think everyone is asleep today :)
22:21:29 <danwent> Ok, one note about the Essex-3 tarball
22:22:00 <danwent> with the packaging changes, installing quantum from source using "python setup.py install" was broken with the E-3 tarball.
22:22:14 <danwent> I don't think many people use this, so we just documented a work-around in an updated version of the admin guide.
22:22:42 <danwent> we considered posting a new tarball, but that's a bit problematic with the official release process, so current thinking is that workaround is ok.
22:22:48 <danwent> any concerns?
22:23:07 <danwent> I believe this is fixed in master already (or at least in code review)
22:23:22 <mtaylor> in code review - it _should_ work
22:23:35 <mtaylor> although I'm _definitely_ in the market for feedback :)
22:23:42 <danwent> only time (or testing + time) will tell :)
22:23:57 <bhall> or just testing? :)
22:24:00 <cdub> what would a tarball be w/out special updated admin guide workaround? ;)
22:24:06 <danwent> bhall: yes, mainly testing
22:24:23 <danwent> cdub: sigh…
22:24:39 <danwent> Ok, anything else on E-3 before we start talking about E-4?
22:24:42 <edgarmagana> hi, sorry for joining late.. i was having some connection issues!!
22:24:55 <danwent> hi edgar :)
22:25:03 <bhall> edgarmagana: that's ok.. we just volunteered you to provide food at the bug squash
22:25:10 <danwent> :)
22:25:15 <bhall> edgarmagana: j/k
22:25:18 <edgarmagana> I will bring the beer!
22:25:23 <edgarmagana> forget about food!
22:25:25 <danwent> more beer can't hurt!
22:25:28 <danwent> great idea
22:25:33 <danwent> Ok, so Essex-4
22:25:52 <danwent> final release date is 3/1/2012
22:26:10 <salv-orlando_> Januray 3rd?
22:26:15 <bhall> no :)
22:26:17 <bhall> march
22:26:25 <danwent> salv-orlando:  so european :)
22:26:26 <salv-orlando_> oh... sorry I'm too european sometimes :)
22:26:37 <danwent> March 1st
22:27:37 <salv-orlando_> is March 1st GA date or release branch point date?
22:27:43 <danwent> plan is to avoid any large changes near to the end (as as the case with E-3) so we will code freeze a week ahead of usual, to make sure people have time to test sufficiently before the release:  feeze will be Feb 21st.
22:27:47 <danwent> freeze
22:28:01 <danwent> salv-orlando: GA
22:28:28 <danwent> so our freeze date for E-4 is a week ahead of the normal freeze date, which is usually two days before release.
22:29:10 <danwent> since a big focus of E-4 should be testing + bug fixes, having an early freeze point should be no problem, right?
22:29:39 <danwent> so let's take a look at features that we'll need to do before Feb 21st: https://launchpad.net/quantum/+milestone/essex-4
22:30:17 <danwent> debo: you're the main for system test?
22:30:31 <danwent> main -> main guy
22:31:03 <danwent> damn… he was here a few mins ago.  always seems to disappear when I need him
22:31:27 <salv-orlando_> it's an heisen-debo
22:31:38 <danwent> I will follow-up with debo specifically on that.  We're seeing a lot of issues due to nova + quantum integration, so this needs to be a key focus
22:31:44 <debo-os> Hi
22:31:46 <danwent> salv-orlando: oh, i like that nickname
22:31:50 <debo-os> Sorry I had to step out a bit
22:32:09 <danwent> debo-os:  just mentioning important of system test BP for e-4
22:32:14 <cdub> how about horizon integration?
22:32:32 <danwent> cdub: its on the agenda list, but not yet a BP.
22:32:46 <danwent> ohnoimdead and others will be creating bugs/BPs.
22:32:54 <cdub> ah, oops, jumping ahead (saw nova + qunatuum integration and made me think of it)
22:32:56 <danwent> there was also a thread on the email list.
22:32:57 <debo-os> I think it is .... and its going to be out soon ... was evaluating the different options ...
22:33:16 <danwent> debo-os:  "out soon"?
22:33:24 <debo-os> soon for sure ....
22:33:37 <danwent> you're talking about basic system test framework?
22:34:00 <debo-os> yes .... the basic test framework that we can use right awat
22:34:04 <danwent> great
22:34:20 <danwent> Ok, sumit, linux bridge plugin is ready for review already, correct?
22:34:37 <SumitNaiksatam> yeah...for more than a week now :-)
22:34:47 <SumitNaiksatam> already put 6 patches
22:35:28 <SumitNaiksatam> any takers??
22:35:30 <danwent> ok, great.
22:35:34 <danwent> I will definitely review this week
22:35:43 <SumitNaiksatam> ok great, thanks!
22:36:53 <danwent> I also want to talk with the Ryu controller team.   If they are planning on committing their plugin and creating a generic base class for ovs plugin and their plugin, I want that change in pretty early.
22:37:07 <danwent> #todo #danwent ping ryu controller team about plugin for E-4
22:37:31 <danwent> next item is updating the client (and CLI?) for API v1.1
22:37:37 <danwent> do this issue have an owner yet?
22:38:02 <danwent> we also need to update QuantumManager in nova to use v1.1, so it can take advantage of filters.
22:38:48 <danwent> Ok, I will shop around for an owner for the v1.1 client work.  Definitely want to make sure that the existing v1.1 work can be leveraged.
22:39:01 <danwent> (Nova + Horizon are obvious users)
22:39:10 <danwent> Salv-orlando:  what are plans for documenting v1.1?
22:39:31 <salv-orlando_> no owner for client at the moment. I would put it as highest priority. I'm willing to do it (client), but will have to defer some of the other work.
22:40:03 <salv-orlando_> For 1.1, I was thinking about doing the same thing I did for 1.0. And then there's the wadl. Some work was done, I need to check the current status.
22:40:24 <salv-orlando_> And unfortunately I do not remember who did the initial work on the WADL.
22:40:27 <danwent> salv-orlando:  great.  do you want to create an issue to track 1.1 docs?
22:40:33 <danwent> was it nachi?
22:40:44 <salv-orlando_> yeah nachi ueno!
22:40:44 <danwent> I think we can dig through email archives
22:41:03 <salv-orlando_> #action salv-orlando to file blueprint for API v1.1 documentation
22:41:12 <danwent> thx
22:41:24 <danwent> horizon integration was brough up earlier by cdub.
22:41:49 <danwent> some folks from the horizon team are on board for doing work here during e-4, as is mjfork
22:42:01 <danwent> cdub, anyone from your team able to pitch in?
22:42:40 <danwent> everyone's quite when we ask for something :)
22:42:44 <cdub> danwent: it's possible, we have bridge review/testing as first priority after e3 package is complete
22:42:52 <danwent> sounds good
22:43:27 <cdub> danwent: but, we can add to queue, i was actually not sure what the status was (hence the earlier question ;)
22:43:28 <danwent> Ok, anything big item is the Authz work.  Somik is traveling, so he can't check in, but I'm not sure how much progress has been made there.
22:44:14 <danwent> cdub:  i'm hoping for a lot of responses on the ML.  that discussion should flush out some more concrete issues that people can volunteer to tackle.  I'll make sure things get broken down into launchpad tasks
22:44:28 <cdub> danwent: perfect, thanks!
22:44:57 <danwent> finally, VPN.  based on comments from vishy during e-3, we think there may be new VPN capabilities in nova that will "just work" with quantum.
22:45:04 <danwent> but we should check.
22:45:21 <danwent> #todo #danwent contact vishy about VPN + quantum
22:45:32 <danwent> any items that already should be on our radar for E-4?
22:46:19 <danwent> ok, any other quantum issues?
22:46:32 <danwent> cdub, is everything in good shape for red hat/fedora packaging?
22:46:58 <cdub> danwent: rkukura pushed e-3 package today
22:47:00 <rkukura> danwent: initial F17 E3 package was pushed today
22:47:14 <danwent> rkukura: awesome, link?
22:47:20 <rkukura> still need to look at ovs agent, and a few other items
22:47:42 <danwent> can we download the packages manually to check them out?
22:48:19 <danwent> rkukura: let me know if there's any help you need packaging ovs agent.
22:49:18 <danwent> Ok, well, any open discussion?
22:49:22 <davlap> i have a quick announcement…
22:49:27 <davlap> i'll be giving a talk tomorrow night on quantum at the openstack boston meetup (6:30 pm in Harvard):  www.meetup.com/Openstack-Boston/
22:49:37 <davlap> if you're in the area would be great if you could make it!
22:49:38 <rkukura> F17 package is http://koji.fedoraproject.org/koji/buildinfo?buildID=296568
22:49:48 <danwent> davlap: spreading the word, great!
22:49:56 <davlap> should be a good crowd!
22:50:00 <rkukura> davlap: planning to drop in if possible
22:50:05 <davlap> great!
22:50:09 <davlap> look forward to meeting you!
22:50:25 <danwent> rkukura:  great, thanks.  do you all coordinate with stackops (they're fedora/rhel based, right?)
22:50:57 <rkukura> danwent: not sure of that - would need to ask markmc or someone
22:51:25 <danwent> ok, I was going to ping them about quantum packaging, but wanted to see if you were already working with them.
22:51:33 <danwent> Ok, last call for open items
22:52:07 <danwent> Ok, thanks folks.  Hopefully I will see/hear many of you at the bugsquashing event thursday!
22:52:12 <danwent> #endmeeting