21:04:39 <ttx> #startmeeting
21:04:40 <openstack> Meeting started Tue Feb 21 21:04:39 2012 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:04:41 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
21:05:02 <ttx> Today's agenda: http://wiki.openstack.org/Meetings/ProjectMeeting
21:05:27 <ttx> #topic Actions from previous meeting
21:05:34 <ttx> * anotherjesse to send post to ML after redux is merged into trunk explaining its impact
21:05:35 <jaypipes> ttx: o/
21:05:59 <ttx> Did I miss it ? Or is this convered in the redux thread posted last week ?
21:06:21 <anotherjesse> ttx: I think it was covered in the email (the bottom half was about the changes)
21:06:32 <anotherjesse> but we want to send another once xml & ldap lands
21:06:37 <anotherjesse> (both in review)
21:07:06 <anotherjesse> ttx: if you feel we should send another one now we can certain do so
21:07:17 <ttx> nah, it's ok
21:07:22 <ttx> #topic Keystone status
21:07:28 <ttx> zns: o/
21:07:32 <ttx> #link https://launchpad.net/keystone/+milestone/essex-4
21:07:38 <anotherjesse> heckj and others have been being vigilant at hanging out in irc to answer questions as they come up
21:07:45 <ttx> heckj: I marked rearchitect-keystone implemented as the branch was merged
21:08:24 <zns> Patches going in. Quiet on the email front after the merge, so not sure what else to report on.
21:08:46 <zns> Looking good so far. LDAP backend being implemented and I saw a few patches on migrations.
21:09:09 <anotherjesse> bcwaldon has got a patch to migrate from nova's deprecated auth to keystone as well
21:09:12 <heckj> ttx: thank you
21:09:24 <ttx> heckj: If there is any significant feature gap left, would be good to track it as a separate essex-4 blueprint
21:09:29 <heckj> XML and LDAP support are actively being reviewed right now
21:09:40 <jk0> anotherjesse: is that up on gerrit yet?
21:09:40 <ttx> heckj: like those ^
21:09:42 <zns> anotherjesse, termie, dolphm, heckj: anything note worthy?
21:09:58 <heckj> Other than that, we're working to lock things down to just fixing bugs and integration issues after Essex4 drop
21:10:05 <bcwaldon> jk0: yes, there's a nova and a keystone branch
21:10:17 <jk0> cool, thnx
21:10:37 <heckj> ttx: will be shifting back to blueprints to track that once I've had a chance to wrangle the current ones and asses their state
21:10:59 <ttx> On the bugs side, was the current list of 94 Keystone bugs reviewed to see if they still apply post-redux-merge ?
21:11:03 <heckj> ttx: it's been more functional short term to use bugs to track what should be in blueprints (because of tagging in the bugs) - we'll be shifting back away from that shortly
21:11:05 <anotherjesse> jk0: yes
21:11:05 <anotherjesse> https://review.openstack.org/#change,4304
21:11:05 <anotherjesse> https://review.openstack.org/#change,4334
21:11:11 <zns> * is pretty sure heckj meant to say 'assess' * :-)
21:11:18 <ttx> #action heckj to create BPs corresponding to major feature gaps
21:11:51 <heckj> ttx: yes - a few remain to be reviewed, and we discussed an ongoing triage process (I do it weekly, everyone yells at me) at the keystone meeting for the near term as well
21:12:26 <ttx> then it would be good to drop usage of the "redux" tag... and use essex-4 milestone targeting for selecting bugs instead.
21:13:19 <heckj> ttx: already in the works - that was an action item from today's keystone meeting as well
21:13:32 <ttx> Great.
21:13:34 <ttx> zns, heckj: anything else ?
21:13:39 <heckj> zns: and yeah, I'm a sloppy typist at speed
21:13:52 <zns> ttx: nothing else.
21:14:00 <anotherjesse> heckj - I hope you code slowly then
21:14:05 <heckj> ttx: We're trying to push basic RBAC (policy, etc) into the release prior to E4 - working with termie on the specifics
21:14:30 <heckj> ttx: will have a code for review hopefully this week, but need an keystone meeting to discuss some of the components to make sure we're all on the same page.
21:14:34 <termie> heckj, ttx: not providing a policy service, just making keystone do things the same way as nova
21:14:45 <heckj> what termie said:
21:14:48 <heckj> ^
21:14:57 <ttx> termie: sounds good. BP please so that we can track whether it lands in time
21:15:17 <ttx> remember that we cut milestone-proposed branch for E4 EOD next Tuesday
21:15:23 <ttx> that leaves little time
21:15:30 <ttx> Questions about Keystone ?
21:15:44 <heckj> ttx: I've got that
21:15:53 <gyee> will the fat keystone extensions be ported over by E4?
21:16:28 <anotherjesse> gyee: I think the major one is the cert verification
21:16:33 <gyee> same question for the middleware
21:16:47 <termie> gyee: we think ldap stuff will land, anything that large that isn't already in the patch queue sounds iffy
21:16:50 <gyee> what about HP-IDM-serviceID?
21:18:10 <termie> gyee: some extensions are also less applicable now, so not all make sense to port
21:18:33 <anotherjesse> gyee: we can discuss in more depth in the #dev channel if you have time
21:18:45 <ttx> right, we need to move on
21:18:45 <gyee> do we have a list of what will be ported?
21:18:48 <gyee> k
21:18:57 <ttx> #topic Swift status
21:19:02 <ttx> notmyname: o/
21:19:06 <notmyname> hi
21:19:13 <ttx> notmyname: Looks like there is time for one more release before inclusion into Essex final ?
21:19:18 <notmyname> I agree
21:19:22 <ttx> like sometimes mid-March ?
21:19:34 <notmyname> ya. when is the cutoff for essex?
21:20:11 <ttx> The release is April 5. Would be good to have your "release candidate" in one of the previous 4 weeks.
21:20:36 <anotherjesse> notmyname: if the cliauth blueprint change lands before your release we will have a single way for users to use an openstack cloud :)
21:20:45 <anotherjesse> thx for the help on that review!
21:20:51 <notmyname> ok. we'll shoot for middle/late middle march
21:21:00 <notmyname> anotherjesse: it will get in before the next release
21:21:39 <notmyname> lots of good swift news this week: wikipedia using it in prod, softlayer deploying it, swiftstack chosen for pycon startup row
21:23:31 <ttx> notmyname: can I put a tentative 1.4.7 on March 22 ?
21:23:41 <ttx> and we'll adjust the date if need be
21:24:18 <notmyname> ttx: 23rd (a friday) is generally better. although you know how I feel about setting dates so far in advance ;-)
21:24:29 <ttx> and you know how I feel about Fridays :)
21:24:39 <ttx> notmyname: Anything else ?
21:24:45 <notmyname> I don't have anything
21:24:50 <ttx> Questions on Swift ?
21:25:15 <ttx> #topic Glance status
21:25:20 <ttx> jaypipes: yo
21:25:29 <bcwaldon> second in command, here
21:25:29 <ttx> #link https://launchpad.net/glance/+milestone/essex-4
21:25:42 <ttx> bcwaldon: hi! Two blueprints left open: retrieve-image-from and progressbar-upload-image
21:25:50 <ttx> almost there ? Remember this needs to be merged before EOD Tuesday, next week.
21:26:25 <bcwaldon> looks like they will land
21:26:33 <bcwaldon> I'll review them today
21:27:01 <bcwaldon> I did want to thank eglynn__ for stepping up and fixing some bugs that have been around for a while
21:27:19 <bcwaldon> no major news here :)
21:27:23 <eglynn__> bcwaldon: np ;)
21:27:34 <ttx> bcwaldon:  Anything else ?
21:27:41 <bcwaldon> negative
21:27:44 <ttx> Questions on Glance ?
21:28:51 <ttx> #topic Nova status
21:28:54 <ttx> vishy: hey
21:28:57 <vishy> hi
21:28:58 <ttx> #link https://launchpad.net/nova/+milestone/essex-4
21:29:02 <ttx> I'd like to go through the remaining stuff, since most FFEs were given a deadline that is now past
21:29:12 <ttx> * https://blueprints.launchpad.net/nova/+spec/host-aggregates (Armando)
21:29:16 <ttx> marked implemented, but has reviews open... What's the story on that ?
21:29:31 <vishy> yeah
21:29:35 <vishy> i was going to mention that one
21:29:37 <vishy> https://review.openstack.org/#dashboard,748
21:29:58 <vishy> so it was marked implemented too soon
21:30:15 <vishy> the api etc was set with the first couple of reviews
21:30:21 <ttx> ok
21:30:28 <vishy> but there are various bugfixes/improvements to the underlying code
21:30:34 <vishy> so those really need some attention
21:30:45 <ttx> is it still on track ? and should be kept in Essex ?
21:31:18 <vishy> yes, most of those are ready to go in
21:31:35 <vishy> I'm going through them today, but they could use eyes from another core dev or 2
21:31:45 <ttx> * https://blueprints.launchpad.net/nova/+spec/keystone-export-rewrite (bcwaldon)
21:31:49 <ttx> should have been unblocked by redux merge... Status ?
21:32:13 <vishy> needs review here: https://review.openstack.org/#change,4334
21:32:20 <vishy> it wasn't linked to the blueprint properly
21:32:29 <bcwaldon> i pushed up a minute ago with a proper link
21:32:40 <vishy> the other blocked one i moved out of essex, since the migration plan depends on dep. auth
21:32:47 <vishy> so we can't pull it until folsom
21:33:56 <ttx> vishy: you mean, https://blueprints.launchpad.net/nova/+spec/remove-deprecated-auth ?
21:34:07 <vishy> yes
21:34:14 <ttx> ok
21:34:19 <ttx> * https://blueprints.launchpad.net/nova/+spec/scaling-zones (comstud)
21:34:22 <ttx> Are all the essex-4 tasks completed ?
21:34:31 <vishy> I think so.  I marked it implemented
21:34:58 <ttx> * https://blueprints.launchpad.net/nova/+spec/nexenta-volume-driver (Oleg)
21:35:01 <ttx> Looks like it's "almost there"... should we extend the FFe ?
21:35:44 <vishy> ttx: i haven't gotten a chance to look at it since getting back
21:35:48 <vishy> but it looked close
21:35:53 <vishy> when i left on thursday
21:36:00 <ttx> ok, let's keep it in scope
21:36:06 <ttx> * https://blueprints.launchpad.net/nova/+spec/zeromq-rpc-driver (ewindisch)
21:36:18 <ttx> Looks like it's still a bit far away, and the deadline is over. Extend or postpone ?
21:36:37 <russellb> I think it's ready for review, there were a lot of updates to it today
21:36:52 <devcamcar> given that that implementation is not intended for production use (yet) it wouldn't hurt to postpone it if its not ready
21:37:04 <vishy> russellb: is there any reason why it needs to hit in essex?
21:37:17 <vishy> I don't think anyone will reasonably be using it for production
21:37:27 <russellb> no, not IMO, anyway
21:37:53 <vishy> i don't really see the drawback of delaying it until folsom
21:37:59 <ttx> agreed
21:38:03 <ewindisch> between E4 bug fixes and stable backports, it can be made stable for production
21:38:25 <vishy> ewindisch: but is anyone planning on using it?
21:38:37 <vishy> ewindisch: it seems more like an experimental feature right now
21:38:46 <ttx> if it's experimental anyway, it can live in a specific branch
21:38:56 <anotherjesse> ewindisch: I assume you already have it in your product builds - having it land in F seems better from a support perspective
21:39:43 <ewindisch> my main problem is that it is becoming a hassle to maintain whenever RPC changes happen. I suppose that won't happen too much more in the Essex timeframe, though.
21:40:06 <ewindisch> just today, Russell proposed a change that would require changes to the zeromq driver.
21:40:29 <russellb> which one?
21:41:11 <ttx> vishy: I'm for postponing. Your call ?
21:41:14 <ewindisch> I0e5aff2e8a40ffd8390c0e19d89dd17e60a74130
21:41:26 <vishy> i'm leaning to postpone
21:41:44 <ttx> * https://blueprints.launchpad.net/nova/+spec/netapp-volume-driver (Robert Esker)
21:41:51 <ttx> This one was abandoned due to absence of activity. Folsom too ?
21:42:06 <vishy> they keep threatening to bring it back
21:42:13 <vishy> but it seems like it is taking too long
21:42:28 <vishy> i guess a branch for that one as well
21:42:32 <ttx> right
21:42:46 <ttx> On the bugs side, there are a few essex-4 targeted bugs that don't have clear assignee...
21:43:01 <ttx> See list at https://launchpad.net/nova/+milestone/essex-4
21:43:15 <ttx> #help assign yourself unassigned bugs on https://launchpad.net/nova/+milestone/essex-4
21:43:26 <ttx> vishy: Anything else ?
21:43:41 <vishy> nope
21:43:47 <vishy> don't forget to review!
21:43:49 <ttx> Nova subteam leads: anything on your side ?
21:43:55 <ttx> Questions on Nova ?
21:44:19 <anotherjesse> devstack has been getting lots of attention for XS/XCP support as well as some integration work towards supporting fedora
21:44:49 <anotherjesse> would be nice to work with the CI team to test XS/XCP (and LXC) deploys of openstack as well as KVM
21:45:38 <jog0> Also what is the status of getting an 'official' openstack chef recipes repo setup?
21:46:24 <anotherjesse> jog0: I think jaypipes might be able to speak to that
21:46:49 <jaypipes> jog0: you mean for diablo/stable?
21:47:02 <jog0> for both Essex and diablo/stable
21:47:07 <jaypipes> jog0: (since github.com/openstack/openstack-chef IS the official repo)
21:47:34 <ttx> ok, let's move on
21:47:34 <jaypipes> jog0: but that repo only has current development trunk, not stable/diablo
21:47:43 <ttx> #topic Horizon status
21:47:47 <ttx> devcamcar: o/
21:47:52 <ttx> #link https://launchpad.net/horizon/+milestone/essex-4
21:47:52 <jog0> thanks jaypipes
21:47:53 <devcamcar> o/
21:47:59 <ttx> 6 blueprints left, and one week left -- everything still on track ?
21:48:17 <devcamcar> so for the most part we are down to just bug fixes - most blueprints are trivial changes relating to django 1.4 dropping
21:48:29 <devcamcar> beta 1 just dropped so we are technically unblocked though we were hoping for an RC by now
21:48:40 <ttx> How far away is the essential ec2-credentials-download ? 7 days left to merge it.
21:48:42 <devcamcar> it'll be there before essex ships though so shouldn't be an issue
21:48:48 <devcamcar> its late in the review stage now
21:48:52 <devcamcar> should land any time now
21:49:09 <ttx> Your list of 30+ open E4-targeted bugs still looks a bit daunting. 9 days left for those:)
21:49:11 <devcamcar> we're also investing some resources into ensuring that django 1.4 lands in ubuntu 12.04
21:49:31 <ttx> devcamcar: hmm. It's post-FF there
21:49:35 <devcamcar> most bugs remaining are trivial and i expect we'll get through most of those
21:49:53 <devcamcar> i have a guy that is working with both the django and ubuntu community on it
21:50:02 <ttx> ok
21:50:02 <devcamcar> seems doable so far but we'll see
21:50:16 <ttx> devcamcar: Anything else ?
21:50:21 <devcamcar> question about process -
21:50:51 <devcamcar> the period between e4 landing and essex shipping - we currently have basically no work planned for that period
21:50:55 <devcamcar> which i'm assuming is a good thing
21:51:17 <devcamcar> if we have a bug that slips past e4 we can fix before what date?
21:51:33 <ttx> devcamcar: sure. the plan is to produce release candidates until one looks "good enough"
21:51:42 <devcamcar> great, we will be golden then
21:51:43 <ttx> at that point we cut a release branch
21:51:53 <ttx> and open Folsom
21:52:38 <devcamcar> sounds good
21:52:40 <ttx> ideally most projects would have their RC cut a few weeks before April 5, so that we are all set when we hit the deadline
21:53:01 <ttx> Questions for Horizon ?
21:53:39 <ttx> #topic Incubated projects and other Team reports
21:53:43 <ttx> danwent, troytoman: yo
21:53:51 <danwent> o/
21:54:23 <danwent> So for E-4, quantum is looking to get all features in and reviewed by today.
21:54:25 <danwent> https://launchpad.net/quantum/+milestone/essex-4
21:54:39 <danwent> we're good on having most things in, but still lots to review.
21:55:05 <danwent> two items not already in review are for devstack, so not really release issues.
21:55:33 <danwent> Also, not to bury the lead, but we got conditionally approved as a core project for Folsom by the PPB today.
21:55:39 <ttx> yay
21:56:00 <danwent> thanks to the PPB for a lot of great feedback on what will be needed for a successful transition from incubation to core
21:56:16 <danwent> and a call to the community to help us out once Essex is out the door :)
21:56:34 <annegentle> congrats to the Quantum team!
21:57:07 <danwent> thanks anne.  that's about all on my end.
21:57:34 <ttx> Any other team lead with a status report ? annegentle, mtaylor ?
21:57:50 <annegentle> Doc Day March 6th.
21:58:16 <annegentle> Need to work on Volume and Network replacements, maintenance of docs that exist as well as adding new.
21:58:32 <anotherjesse> ttx: mtaylor is sick - perhaps jeblair is around
21:59:20 <ttx> #topic Open discussion
21:59:24 <ttx> Two things I wanted to mention...
21:59:28 <ttx> First, we have elections coming up.
21:59:35 <ttx> #info For the PPB election, remember you need to register to vote, using the following website: http://ppbelectionsregistration.openstack.org/
21:59:43 <ttx> Second, the Folsom design summit.
21:59:50 <ttx> #info If you're an active OpenStack contributor, you should have received over the week-end a personal invitation to the Design Summit.
21:59:56 <ttx> You'll need that personal code to register for the summit.
22:00:03 <ttx> #info Summit is invite-only this time: if you're a contributor (or want to contribute to Folsom) but weren't invited, you should ask your PTL for a personal invitation code
22:00:15 <ttx> Anything else, anyone ?
22:01:57 <ttx> guess not
22:02:01 <ttx> #endmeeting