22:01:18 <danwent> #startmeeting
22:01:19 <openstack> Meeting started Tue Mar  6 22:01:18 2012 UTC.  The chair is danwent. Information about MeetBot at http://wiki.debian.org/MeetBot.
22:01:20 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
22:01:34 <danwent> shoudl be a quick meeting: http://wiki.openstack.org/Network/Meetings
22:01:45 <SumitNaiksatam> Hi All!
22:02:01 <danwent> main goal is to identify issues we need to have for RC1, and agree on target date for RC1.
22:02:20 <danwent> here is the current set of items on the table for RC1: https://bugs.launchpad.net/quantum/+milestone/essex-rc1
22:02:46 <danwent> if there are any issues you feel are critical for RC1 and aren't on this list, holler now.
22:03:22 <danwent> if you find something during the next few weeks of testing that you think is critical for essex, make sure it gets targeted for an rc release
22:03:42 <rkukura> hi!
22:03:43 <danwent> if no blocker bugs are found in an rc release, that exact code magically becomes the essex release.
22:03:50 <debo-os> sure
22:03:59 <danwent> ok, wanted to go through a couple of the key bugs
22:04:04 <edgarmagana> hi
22:04:05 <danwent> #944959
22:04:11 <danwent> bug #944959
22:04:12 <uvirtbot> Launchpad bug 944959 in quantum "API 1.1 Spec Update" [High,New] https://launchpad.net/bugs/944959
22:04:31 <danwent> salvatore, do you think you'll be able to update the spec, or should we try and find someone else to tackle this?
22:05:32 <danwent> salv-orlando: around?
22:05:50 <salv-orlando> Yep. Let me give you a final answer by tomorrow
22:05:56 <danwent> ok.
22:05:57 <danwent> thanks
22:06:02 <danwent> bug #948451
22:06:02 <uvirtbot> Launchpad bug 948451 in quantum "webob deprecated warning/error" [High,New] https://launchpad.net/bugs/948451
22:06:30 <danwent> this is someone new and is unassigned.  would be good if someone could grab it and explore.  reported via email by two people.
22:07:01 <danwent> bug #922356
22:07:02 <uvirtbot> Launchpad bug 922356 in quantum "QuantumManager does not invoke unplug on the linux_net driver" [Medium,New] https://launchpad.net/bugs/922356
22:07:15 <danwent> sumit, are you planning on tackling this for essex still?
22:07:33 <SumitNaiksatam> yes, I am
22:07:47 <SumitNaiksatam> I was looking at it, and then got distracted
22:07:56 <SumitNaiksatam> how much time do I have?
22:08:09 <SumitNaiksatam> most likely this going to be changes in the nova code
22:08:14 <SumitNaiksatam> not quantum
22:08:16 <danwent> ok, great.  you'll need to ping vish to make sure it gets targeted appropriately for nova
22:08:23 <danwent> yup, agreed
22:08:33 <danwent> bug #948467
22:08:34 <uvirtbot> Launchpad bug 948467 in quantum "agents should not need to run as root" [Undecided,New] https://launchpad.net/bugs/948467
22:08:59 <danwent> rkukura: you doing this on your own, or will you need help from the respective plugin owners?
22:09:18 <rkukura> either way works for me. owners?
22:09:39 <SumitNaiksatam> rkukura: anything special needed?
22:09:48 <danwent> i think preference would be for you to propose something, and the plugin owners can review.
22:09:53 <salv-orlando> on bug 948451: Seems a duplicate/regression of 925372
22:09:54 <uvirtbot> Launchpad bug 948451 in quantum "webob deprecated warning/error" [High,New] https://launchpad.net/bugs/948451
22:10:07 <rkukura> OK
22:10:09 <salv-orlando> bug 925372. There you go, virtbot :
22:10:10 <uvirtbot> Launchpad bug 925372 in quantum "Remove deprecated webob attributes in Quantum API" [Medium,Fix released] https://launchpad.net/bugs/925372
22:10:29 <danwent> but if you need extra info from plugin owners to make the changes, let us know
22:10:37 <rkukura> will do
22:11:33 <danwent> salv-orlando: interesting.  checking bug.
22:12:21 <danwent> let me check the people who emailed me, see what versions they were using.  hopefully its just a dup.  I will take that issue and assign it to me for now.  thanks.
22:12:54 <danwent> or looks like maru already took it, which is great :)
22:13:03 <danwent> maru, definitely reject if this was already fixed.
22:13:34 <danwent> so rkurkura mentioned that fedora has their testing day on thursday
22:13:49 <cdub> http://fedoraproject.org/wiki/Test_Day:2012-03-08_OpenStack_Test_Day <-- some details
22:14:08 <danwent> so we wanted to delay RC1 at least until we'd have a chance to react to any feedback
22:14:21 <rkukura> Yes
22:14:21 <danwent> my thinking was targeting March 15th, which is next thursday.
22:14:31 <danwent> does anyone know if ubuntu has an equivalent?
22:15:03 <danwent> #action #danwent to figure out if ubuntu has a testing day that we should consider in terms of RC1 target date.
22:15:21 <danwent> in general, are people good with 3-15 as an RC1 target?
22:15:32 <danwent> anyone think they need more time?  None of the existing bugs seem all that deep.
22:15:43 <rkukura> The Fedora test day is for F17, but we will also have a repo with F16 Essex packages.
22:15:52 <danwent> but if something big pops up, we can shift … 3-15 is just a target.
22:16:38 <danwent> rkukura:  can you add a link to the QuantumPackages wiki page?
22:16:56 <rkukura> I'll update what's there.
22:16:58 <danwent> i'm trying to keep info about all of the distributions and versions in one place
22:17:00 <danwent> thanks.
22:17:14 <danwent> ok, sounds like we'll stick with the 3/15 RC1 target, since I heard no concerns...
22:17:25 <danwent> anything else to discuss about RC1?
22:17:43 <danwent> #topic open discussion
22:17:51 <davlap> openstack boston and austin user groups will be having an install/test day this thursday
22:17:56 <davlap> Details at: https://github.com/dellcloudedge/crowbar/wiki/Install-Fest-Prep
22:18:21 <danwent> #info I added a new section to the starter bugs wiki page that outlines "community projects": http://wiki.openstack.org/QuantumStarterBugs
22:18:35 <danwent> these are projects that are general and for the good of the community
22:18:56 <danwent> with quantum becoming core we need to be able to focus more cycles on cleaning up some of these items.
22:19:05 <danwent> if you have ideas of other things, please add them to the page
22:19:09 <mnewby> I think it's good to maintain the projects on that page, but would suggest using 'LowHangingFruit' bug classification and link to a query for that instead of individual bugs that may not be available.
22:19:24 <danwent> if you're looking for something to bite off, feel free to grab a project (put your name on it).
22:19:56 <danwent> mnewby: yes, completely agree. that was mvoelkers suggestion.  do you want to update the bugs + wiki page for that?
22:19:56 <markvoelker> Quick note to everyone about time changes
22:20:07 <danwent> i've been meaning to, just slipped my mind.
22:20:11 <mnewby> danwent: will do
22:20:16 <danwent> markvoelker: yes!
22:20:33 <markvoelker> Per @ttx in previous meeting: "The big DST madness will hit us starting next week, with US adopting DST while Europe and others stay outside DST"
22:20:38 <danwent> thanks for mentioning that.
22:20:48 <markvoelker> "Meeting times stay the same in UTC...So for US people our meetings will start one hour later starting next week."
22:20:57 <danwent> at least this time change direction is less bad, as you show up early, rather than showing up late :)
22:21:28 <danwent> ok, anything else for open discussion?
22:21:43 <danwent> we have a handfull of reviews we need to close out
22:22:05 <danwent> please use the RC1 target to drive what reviews you prioritize
22:22:07 <debo-os> Thx to folks who reviewed the devstack script
22:22:20 <danwent> so we make sure we get those reviewed with highest priority
22:22:40 <danwent> debo-os: thanks for mentioning that.  what is status there?
22:22:49 <danwent> is it merged, or still in feedback?
22:23:27 <debo-os> merging the feedback stuff right now ... almost done
22:23:31 <danwent> great.
22:23:56 <danwent> ok, thanks folks.  keep up the testing!   Just over one week until essex RC1 target date!
22:24:03 <danwent> #endmeeting