20:04:17 <n0ano> #startmeeting
20:04:18 <openstack> Meeting started Thu Apr  5 20:04:17 2012 UTC.  The chair is n0ano. Information about MeetBot at http://wiki.debian.org/MeetBot.
20:04:19 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
20:04:48 <maoy> do we have any update on the summit session?
20:04:58 <n0ano> I believe sriram is working on the BP for the Orchestration session, do we have anything else to discuss today?
20:05:23 <maoy> is he here?
20:05:32 <n0ano> he hasn't chimed in yet
20:05:33 <mikeyp> I dont have anything specific
20:05:48 <mikeyp> waiting for more info on the SpiffWorkflow research
20:06:01 <maoy> right
20:06:32 <n0ano> I saw the emails on SpiffWorkflow, I am concerned that it might be overkill but let's wait for the detailed researc h
20:06:33 <maoy> i should look deeper in spiffworkflow. my first impression was it's more complicated than we need. but i could be wrong
20:07:24 <mikeyp> From my initial research, most of the others were _very_ limited
20:07:41 <sriramhere_> hello there
20:07:57 <n0ano> sriramhere, good to hear from you
20:07:59 <sriramhere_> my msgs were not going through, and logging in as sriramhere_
20:08:11 <n0ano> any news on the BP for the session?
20:08:25 <n0ano> #topic Orchestration session at the summit
20:08:42 <sriramhere_> I updated BP with the session topics as we discussed last week
20:08:50 <sriramhere_> session is still under review
20:09:36 <sriramhere_> also, you might have seen from the email threads, our submission is 'complete' for session proposal. but we can work on prototyping.
20:10:02 <sriramhere_> Ziad was mentionng abt abt using Zookeeper. is around?
20:10:39 <maoy> I saw it as "Unreviewed" in summit.openstack.org
20:10:52 <maoy> i mean I'm still seeing it as unreviewed right now
20:10:52 <sriramhere_> sorry, i meant 'Unreviewed'
20:10:56 <sriramhere_> not 'under review'
20:11:07 <n0ano> do we need to ping Vish about it?
20:11:42 <maoy> not sure if there is a deadline for that
20:12:14 <n0ano> yeah but it's getting close (less than 2 weeks away) I don't want to slip through the cracks
20:12:21 <sriramhere_> I can, but I am sure he is swamped with too many proposals. Let me send an email rt away
20:12:58 <sriramhere_> vishvananda@gmail.com is his eamil, er?
20:13:01 <sriramhere_> rt?
20:13:07 <n0ano> just a quick `did you see it, do you need anything else' should be sufficient
20:13:35 <n0ano> yep, that's the email I used last time I talked to him
20:13:55 <mikeyp> I think we will see movement now that Essex is out.
20:14:10 <sriramhere_> I agree.
20:14:43 <n0ano> #action sriramhere_ to ping Vish about the Orchestration session
20:15:19 <sriramhere_> done
20:15:54 <sriramhere_> i also started working on a branch; just got started
20:15:55 <n0ano> I think that pretty much covers the session for now, anything else we need to discuss?
20:16:12 <sriramhere_> if u have any pointers regarding the same, please shoot me an email offline
20:16:23 <sriramhere_> let us also wait for Ziad's updtes
20:16:35 <maoy> sriramhere_: what exactly are you coding towards?
20:18:01 <sriramhere_> trying to mimick aws workflow, per Sandy's suggestion.
20:18:30 <sriramhere_> having OS as a separate service.
20:18:52 <sriramhere_> i am currently thinking just be an observer of states.
20:19:51 <sriramhere_> still not very clear. playing around now. my intent is to show two things
20:20:09 <sriramhere_> 1) as a separate service how it tracks the states in a wf
20:20:53 <sriramhere_> 2) to see wat r the touch points with core, network
20:21:03 <sriramhere_> no real logic for now
20:23:04 <maoy> got it
20:23:28 <maoy> by aws workflow, you mean the SWF stuff?
20:23:46 <sriramhere_> yes
20:24:01 <maoy> perfect
20:24:17 * sandywalsh lurks :)
20:24:43 <sandywalsh> sriramhere_, you may want to look at stacktach/worker.py for how to monitor the notification queue
20:25:01 <sandywalsh> https://github.com/rackspace/stacktach/blob/master/worker.py
20:26:32 <sriramhere_> thanks Sandy
20:26:41 <sandywalsh> np
20:27:06 <sriramhere_> maoy - u had a point on zookeeper in the email thread. want to elaborate?
20:27:36 <maoy> which email? I already forget. :)
20:28:27 <sriramhere_> in response to Ziad's email on Zookeeper.
20:28:30 <maoy> zookeeper is a highly available service for distributed naming, synchronization, (configuration) state management, etc
20:28:46 <sriramhere_> ? I'm slightly concerned that  > SpiffWorkflow might be an overkill and bring unnecessary complexity  > into the game.
20:29:00 <sriramhere_> sorry tried pasting from your email
20:29:36 <maoy> sandywalsh mentioned "bitkeeper", is that a typo for zookeeper?
20:30:12 <n0ano> I hope so, bitkeeper is a git competetor, not what we're looking for.
20:30:28 <sandywalsh> maoy, yup, sorry
20:31:01 <maoy> great. now we are on the same page
20:31:51 <maoy> i'm curious about the same issue. but when I glanced through spiffworkflow, I didn't see any mentioning of where state is stored, etc
20:33:13 <sriramhere_> ok - so nobody seems to have concers abt zookeeper as of now, is that rt?
20:33:38 <sriramhere_> i will continue working on the branch and update as appropriately
20:33:54 <n0ano> well, I think we are all concerned that it might be overkill and we'd like to know more about it.
20:34:25 <maoy> i think there is always a concern when we introduce a new component. but the only workaround is to put the state in mysql
20:34:29 <n0ano> continuing on the branch seems like a great idea, let's see where that goes.
20:34:44 <sriramhere_> ok
20:34:46 <n0ano> and your problem with mysql is...
20:34:58 <maoy> :)
20:35:15 * n0ano thinks distributed databases do a pretty good job
20:35:37 <maoy> mysql doesn't have a watch function
20:35:48 <maoy> so the client side will have to periodically poll to check for state change
20:36:14 <n0ano> I'm not an expert on DBs (I have some stories about that) but mysql doesn't have triggers?
20:36:18 <maoy> functional-wise, that's the biggest difference i see
20:36:32 <maoy> triggers can only trigger db actions, not to outside component
20:36:38 <sriramhere_> triggers can compenseate lack of watches, rt?
20:37:38 <sriramhere_> which DB  has this kind of watch that can trigger a out-of-db action?
20:38:07 <n0ano> well, polling (with the right period) is not the worst solution possible but it does mean looking at something like zookeeper becomes more likely
20:38:49 <maoy> the other practical difference is that zookeeper is designed for HA. But because we rely on mysql on so many places, it doesn't make a huge gain by using zookeeper for just orchestration.
20:39:08 <sriramhere_> ok; appears that we are all looking towards Ziad's updates on zookeeper experiment. any other agenda items today?
20:39:45 <sriramhere_> maoy - r u proposing we move out mysql as persistence store for entire system?
20:40:06 <maoy> not really
20:40:22 <maoy> there are mysql addons to make mysql HA
20:40:59 <maoy> perhaps not as robust and easy to use as zookeeper but acceptable
20:41:27 <sriramhere_> ok
20:42:37 <maoy> my impression is that ziad is trying spiffworkflow, not zookeeper?
20:43:40 <sriramhere_> sorry again. lost track on email. Yes, Ziad is playing woth spiffwf.
20:43:55 <n0ano> so are we trying to decide between 3 options - 1)zookeeper, 2)spiffworkflow, 3)homegrown with mysql?
20:44:18 <mikeyp> don't think so.
20:44:34 <maoy> zookeeper and mysql are for state persistence
20:44:48 <mikeyp> the workflow engine (spiff or other) will need to store state
20:45:00 <maoy> spiffworkflow is extra workflow business logic on top.
20:45:42 <maoy> my take is that spiffworkflow is too big, lack of production users, so it may pay off just fine if we write our own specifically for nova
20:46:14 <n0ano> so there's 2 questions: 1) spiffworkflow or homegrown and then 2) store state in zookeeper or mysql?
20:46:43 <sriramhere_> and there are two efforts in progress now
20:46:46 <maoy> n0ano that's my take too.
20:46:47 <sriramhere_> 1) ziad's on spiff
20:47:09 <sriramhere_> and my mock on swf
20:47:40 <n0ano> I like competing projects, may the best man win
20:47:52 <sriramhere_> :)
20:47:55 <maoy> 3 efforts: I'm working on another one based on the BP here:http://wiki.openstack.org/TransactionalTaskManagement
20:48:47 <maoy> and i'm using mysql as persistent state for simplicity
20:49:08 <sriramhere_> maoy - do u want to include this for Folsom session proposal?
20:49:15 <maoy> hopefully the backend is plugable
20:49:22 <maoy> sure.
20:49:24 <n0ano> personally, simple is good (especially since mysql is already there).
20:49:49 <maoy> agreed
20:50:15 <maoy> sriramhere_: let me know what i need to do to get it into the session proposal. thanks.
20:50:39 <sriramhere_> maoy - i can update the proposal with link to your BP if its OK with you
20:50:52 <maoy> sounds good
20:51:02 <sriramhere_> any thing else?
20:51:08 <n0ano> anything else for today?  I would propose that we finalize the session proposal/agenda next week
20:51:22 <maoy> second that
20:51:27 <sriramhere_> +1
20:51:52 <n0ano> passed by unanimous consent (it is election season :-)
20:52:01 <n0ano> talk to everyone next week
20:52:13 <maoy> :)
20:52:42 <n0ano> #endmeeting