19:04:24 <LinuxJedi> #startmeeting
19:04:25 <openstack> Meeting started Tue Apr 24 19:04:24 2012 UTC.  The chair is LinuxJedi. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:04:26 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
19:04:29 <LinuxJedi> #topic CI meeting
19:04:47 <jeblair> I'll start talking...
19:04:51 <LinuxJedi> Hi guys, welcome to this week's CI meeting, really 2 weeks since we were all at the summit
19:04:56 * LinuxJedi hands over to jeblair
19:05:16 <jeblair> mtaylor has a list of work items for us collected from the summit
19:05:29 <jeblair> real soon now, he's going to make bugs from them, de-dup, etc.
19:06:15 <jeblair> i'm expecting to work on improving the gerrit trigger plugin
19:06:22 <jeblair> starting soon.
19:06:38 <jeblair> to add better support for matrix and triggered jobs.
19:06:45 <LinuxJedi> \o/
19:07:03 <soren> Cool beans.
19:07:05 <jeblair> that will help with some of the automatic job creation LinuxJedi is doing, as well as make things nicer for other CI systems that plug into us
19:07:31 <ttx> jeblair: I'd like us to brainstorm the "separate baking" while at UDS
19:08:02 <jeblair> (that's a couple steps away, but a better job structure would let us do things like run some tests immediately on uploads, so others can trigger their jobs on that)
19:08:08 <ttx> so it would be good if you could spend some time thinking about that in the next week
19:08:31 <jeblair> ttx: yes, that's at least one, maybe 2 or 3 of the items on the list.
19:08:45 <soren> Separate baking?
19:09:04 <ttx> soren: experimental branches to keep crap out of release branch
19:09:05 <soren> Topic branches?
19:09:12 * LinuxJedi assumes we can't bake the cookies and cakes at the same time
19:09:14 <ttx> not formally topic branches
19:09:15 <soren> Right. That. Cool.
19:09:20 <ttx> since the term is overloaded a bit
19:09:27 <ttx> and bleeds into implementation detail
19:10:11 <jeblair> i'm going to take next week off, so maybe we can regroup on that during UDS week?
19:10:22 <soren> Who will be at UDS?
19:10:24 <soren> o/
19:10:28 <jeblair> o/
19:10:34 * LinuxJedi can't make it unfortunately
19:10:34 <ttx> jeblair: sure thing
19:10:43 <LinuxJedi> plus they may hate the fact I run Fedora ;)
19:11:08 <soren> LinuxJedi: People have been thrown in the pool for less.
19:11:09 <jeblair> mtaylor hopefully will be.  everybody poke him and tell him it's important.
19:11:13 <soren> jk :)
19:11:23 <LinuxJedi> lol :)
19:11:44 <clarkb> remind me when he gets back
19:11:57 <jeblair> oh.  clarkb just started!
19:11:58 <LinuxJedi> oh so, everyone, say hi to clarkb.  A new member to the CI team
19:12:05 <soren> hi to clarkb
19:12:07 <clarkb> oh hi
19:12:12 <Shrews> hiya clarkb
19:12:49 <LinuxJedi> Shrews is also getting up to speed and we have some evil... I mean great things for him to cut his teeth into soon
19:13:10 <Shrews> yay! … i mean, booo
19:13:48 <LinuxJedi> jeblair: any other cool stuff on your side?
19:14:21 <jeblair> that's all i can think of right now
19:14:28 <LinuxJedi> ok, on my side:
19:15:03 <LinuxJedi> we have a big improvement to the puppetized automatic Jenkins job creator thing coming very soon.  This will help both Openstack and Stackforge
19:15:14 <LinuxJedi> we have parameters for more stuff
19:16:10 <LinuxJedi> jeblair and I (mostly jeblair) have been tweaking a few things in gerrit's source to make some subtle improvements to the look of it (hiding silly 'X's and background colour on outdated branches)
19:16:51 <LinuxJedi> I have everything ready to put meetbot into puppet.  So hopefully that will happen in the next week and will be much easier for us to manage
19:17:02 <jeblair> actually darraghb wrote the code to fix "X"
19:17:04 <LinuxJedi> we also have some improvements to meetbot lined up
19:17:26 <LinuxJedi> ah, awesome.  Ok, thanks to darraghb then ;)
19:17:30 <jeblair> I've just been writing the puppet commands to cause the servers to upgrade.  :)
19:17:50 <LinuxJedi> so many branches went through CI today I lost track of who owned what ;)
19:18:08 <jeblair> which is great, cause that's exactly the system we wanted.  it's now easier for us to take code contributions to gerrit and implement them in production.  :)
19:18:51 <LinuxJedi> in the next week I think I will be concentrating on improving Stackforge since there has been quite a lot of interest and it isn't quite as all automated to add projects as I would like yet
19:19:10 * LinuxJedi also has lots of new CI docs to write after everything we have been doing over the last couple of weeks
19:19:56 <jeblair> yes, sdake from the "Heat" project just popped into #openstack-infra and it sounds like they might be a good fit for stackforge
19:20:04 <jeblair> he's going to run it by the rest of the heat developers
19:20:05 <LinuxJedi> erm... I think that is all I have right now.  There was lots of things in the CI talk summit but those will appear as bugs later on
19:20:52 * LinuxJedi has a template for a stackforge website mostly baked but no content at the moment.  Something else to do this week
19:22:11 * LinuxJedi is sure mtaylor has lots to add to this meeting for those who weren't at the CI talk in the summit last week, but that may have to wait
19:22:53 <jeblair> http://openstack-ci.github.com/publications/ci-roadmap-folsom/index.html
19:22:55 <ttx> Could be good to track the biggest efforts (think I18N) as a blueprint rather than a bug ?
19:23:12 <jeblair> #link http://openstack-ci.github.com/publications/ci-roadmap-folsom/index.html
19:23:25 <jeblair> is the presentation with (nearly all of) the items we had identified during the summit
19:23:26 <LinuxJedi> jeblair: excellent point, I keep forgetting about the publications stuff
19:23:47 <jeblair> (as well as things we did during essex)
19:23:50 <LinuxJedi> ttx: yep, that one in particular will probably be one or more blueprints
19:24:09 <LinuxJedi> jeblair: it almost looks like we did work in the last 6 months
19:24:12 <ttx> whenever I'm back to 100% I'll check that nothing was forgotten there
19:24:30 <LinuxJedi> ttx: awesome, thanks :)
19:24:41 <ttx> jeblair: were you the one suggesting that we should outsource our mailman support ?
19:25:02 <jeblair> ttx: a little more nuanced than that...
19:25:03 <LinuxJedi> ttx: did I suggest it?  (I was thinking it at the time)
19:25:21 <jeblair> more like "it's great that launchpad runs our mailing lists right now so we don't have to"
19:25:42 <jeblair> and "it's a good deal of work to run mailing lists properly (spam, delivery problems, etc)"
19:25:49 <LinuxJedi> ++
19:25:50 <ttx> we actually have a mailman instance running
19:26:03 <ttx> (lists.openstack.org)
19:26:09 <LinuxJedi> ttx: who manages it?
19:26:18 <jeblair> yeah, and pretty much no one manages it.  which works fine until you start having bigger, more important lists that people care about
19:26:19 <soren> LinuxJedi: You do. Didn't you get the memo?
19:26:19 <ttx> some troll in a closet, afaik
19:26:34 * soren kids
19:26:39 <LinuxJedi> soren: lol, that wouldn't surprise me actually, I somehow owned a lot recently by accident ;)
19:27:09 <jeblair> so basically, i don't feel like it's something monty, andrew, and i can do in the margins, as it were... but...
19:27:20 <ttx> jeblair: would you have suggestions of where we could set it up instead ?
19:27:38 <LinuxJedi> if any company wants to invest time in it too maybe we could do something?
19:27:53 <jeblair> if there are more resources/people that want to contribute to it, we are _very_ happy to help do it within the server management infrastructure we've set up.
19:28:11 <jeblair> or, perhaps it's easier to subscribe to a service that will do it for us.  :)
19:28:29 <ttx> mmmmkay
19:29:10 * LinuxJedi suspects something that Rackspace may have resources for?
19:29:28 <LinuxJedi> at least for mail filtering/spam
19:29:28 <ttx> LinuxJedi: Rackspace runs the current one.
19:29:34 <LinuxJedi> ah!
19:29:58 <ttx> we just don't know how serious they actually are about it :)
19:30:22 <LinuxJedi> so, maybe something for us to investigate further
19:30:54 <ttx> I will probably have to look into it
19:31:16 <ttx> jeblair: is your "pretty much no one" the result of an analysis, or a gut feeling ?
19:31:23 <LinuxJedi> ttx: well, I'm sure someone in our team can look into the best solution
19:31:30 <jeblair> ttx: a talk with stef
19:31:38 <mtaylor> morning
19:31:46 <LinuxJedi> mtaylor: welcome!
19:31:49 <mtaylor> sorry I'm late - had trouble finding working internet - now solved
19:32:01 <ttx> mtaylor: you flew out of the US ?
19:32:09 <ttx> (to solve that issue ?)
19:32:46 <mtaylor> ttx: it's the usual solution
19:33:24 <LinuxJedi> mtaylor: I hand this meeting over to you (me and jeblair covered all our stuff)
19:34:12 <mtaylor> I'm mostly not even here today - so you guys feel free to keep up the good work
19:34:23 <LinuxJedi> oh, ok :)
19:34:35 <LinuxJedi> anyone have anything else to add today?
19:34:58 <LinuxJedi> #action research a mailing list solution
19:35:00 <jeblair> nope
19:35:05 <LinuxJedi> adding that as an action item ^
19:35:31 <ttx> LinuxJedi: will talk to you about features we might want in
19:35:40 <LinuxJedi> to find out more about the current mailman and a new one
19:35:50 * Shrews is working on tox changes to inject dependencies from jenkins runs without modifying tox.ini
19:36:01 <jeblair> Shrews: woot!
19:36:08 <Shrews> but having an issue with the tox test suite, so can't push upstream just yet.
19:36:27 <jeblair> hehe
19:36:31 <LinuxJedi> so, basically we want something that CI team can manage as far as infrastructure is concerned but not manage at the message/spam level
19:37:46 <LinuxJedi> multiple lists and maybe some review system like gerrit to add new lists
19:37:59 <LinuxJedi> which would be cool if CI puppet owned that part
19:38:19 <LinuxJedi> or just Launchpad but from the sound of it others aren't happy with that?
19:39:04 <jeblair> oh, so there was a requirement collected at the summit for lists that can have sub-topics
19:39:12 <jeblair> which is a mailman feature launchpad does not expose
19:39:30 <jeblair> (i wasn't at that session, i'm relaying second-hand)
19:39:35 <jeblair> ttx: is there an etherpad from that session?
19:39:40 <LinuxJedi> jeblair: none of us were unfortunately
19:39:59 <ttx> jeblair: there was, but it didn't capture 100% of the spirit
19:40:07 <jeblair> and also, mailing lists that aren't slower than molasses is an oft-requested feature.  :)
19:40:08 <ttx> due to Wifi Fail
19:40:09 <LinuxJedi> #link http://etherpad.openstack.org/FolsomCommunication
19:40:42 <LinuxJedi> ttx: requirement for the next summit: a wifi that can handle more than a couple of hundred users ;)
19:40:44 <ttx> jeblair: where is sub-topics documented ?
19:41:14 <ttx> jeblair: I searched and could not find such a feature
19:42:47 <jeblair> ttx: you mean in standard mailman?
19:43:23 <jeblair> ttx: http://web.mit.edu/lists/mailman/topics.html
19:43:29 <jeblair> there's also the umbrella list concept
19:43:51 <ttx> jeblair: looked at umbrealla and siblings, but they do not really do what we want them to
19:44:07 <jeblair> where you have multiple lists (like nova-volume) and nova is subscribed to it.
19:44:16 <jeblair> yeah.  similar, but different details.
19:44:39 <jeblair> honestly though
19:44:40 <ttx> what we want is enforce use of prefixes
19:44:52 <ttx> if that allows topic-specific subscription, why not
19:45:04 <jeblair> we should consider very carefully whether we want to use mailman topics.  they are _complicated_
19:45:25 <ttx> frankly, I think enforcing house rules on a single ML will do
19:45:45 <ttx> (single -dev ML, I mean)
19:45:55 <jeblair> it's worth a try, i think.
19:46:09 <ttx> not sure we should go through the hassle of a complex setup just to kinda enforec the setting of a prefix
19:46:41 <ttx> will look into topics.
19:47:40 <ttx> but they seem to be the other way around (allow topic-specific subscription, do not enforce a topic being set)
19:47:42 <jeblair> you might be able to enforce prefixes with sender filters (i doubt launchpad exposes that either)
19:49:14 * LinuxJedi personally doesn't like the fact that mailman signups and Launchpad signups will probably be disconnected
19:49:30 <ttx> jeblair: I think there is general consensus that we'll need more than Launchpad ML. If only to have fast discussions
19:49:55 * LinuxJedi agrees there
19:50:01 <ttx> LinuxJedi: so you need to find an ML provider that takes OpenID :)
19:50:14 <LinuxJedi> ++ :)
19:50:25 <LinuxJedi> bound to be one if we look around
19:50:52 <ttx> lists.openid.net being a mailman instance, they would know :)
19:51:20 <LinuxJedi> hehe, something we will look into :)
19:51:37 <LinuxJedi> I'd rather not own a mailman patch but that is also an option
19:52:27 <LinuxJedi> ok, so any more things before we sign-off?
19:53:52 <LinuxJedi> with that I shall end the meeting, see you all next week :)
19:53:56 <LinuxJedi> #endmeeting