18:02:16 <jgriffith> #startmeeting
18:02:17 <openstack> Meeting started Thu Apr 26 18:02:16 2012 UTC.  The chair is jgriffith. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:02:18 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:02:42 <jgriffith> Who do we have for volume/cinder folks?
18:02:52 <vladimir3p> here
18:02:53 <vladimir3p> hi
18:03:06 <rnirmal> hey
18:03:16 <jdurgin> howdy
18:03:26 <jgriffith> excellent...
18:03:34 <jgriffith> esker: you here?
18:03:42 <rnirmal> jgriffith: great job getting all the project setup kicked off
18:04:07 <jgriffith> rnirmal: thanks to you!!  I just followed your lead :)
18:04:30 <jgriffith> Ok... renuka is on vacation today so won't be here
18:04:35 <jgriffith> We should probably get started
18:04:59 <jgriffith> #topic cinder update
18:05:28 <jgriffith> So, as nirmal pointed out we now have an official project in the openstack ecosystem  :)
18:05:43 <rnirmal> https://launchpad.net/cinder
18:05:45 <vladimir3p> congrats!
18:05:56 <jgriffith> I've added everybody that "volunteered" at the summit to the core team
18:06:07 <rnirmal> and https://github.com/openstack/cinder
18:06:33 <jgriffith> rnirmal: Thanks, I forget not everybody has seen all of those yet probably
18:06:34 <rnirmal> https://launchpad.net/~cinder-core
18:06:44 <rnirmal> yeah that's why I'm pasting those links here
18:06:49 <jgriffith> :)
18:06:56 <rnirmal> so anybody looking at the mins will have it
18:07:13 <jgriffith> rnirmal: Excellent, THANKS!!
18:07:51 <jgriffith> So I believe as far as drivers team I'll have to figure out what we need to do there, elections etc
18:08:01 <jgriffith> Or something else, just don't know.
18:08:06 <jgriffith> But....
18:08:12 <jgriffith> In the meantime, we have a repo
18:08:26 <jgriffith> I don't know if anybody has had a chance to look at the break out I started:
18:08:37 <rnirmal> how abt cinder-bugs. should that be a moderated list?
18:08:39 <jgriffith> https://github.com/j-griffith/cinder
18:09:02 <rnirmal> sorry just wanted to complete that disucssion https://launchpad.net/~cinder-bugs
18:09:11 <jgriffith> rnirmal: NP..
18:09:35 <jgriffith> I believe that's typically moderated because of ranking/acceptance etc
18:09:49 <jgriffith> I'll double check on those sorts of details and get things set up correctly
18:09:49 <rnirmal> ah ok just making sure.
18:09:49 <vladimir3p> rnirmal: is there any reason to make it moderated
18:10:22 <vladimir3p> I'm fine with it either way
18:10:26 <rnirmal> not really for the bugs.. not sure if that's used for triaging etc.. but anyone should be able to do that
18:10:26 <jgriffith> rnirmal vladimir3p: Give me a chance to figure out how it's "supposed" to be done and we can go from there
18:10:43 <vladimir3p> good, seems like you have your 1st action item
18:10:59 <jgriffith> #action jgriffith figure out memeberships for various project pages
18:11:48 <jgriffith> So the next steps are getting some code going in the repo
18:12:16 <vladimir3p> I would suggest 1st to understand what modules we would like to put there
18:12:25 <vladimir3p> and how to re-use common parts
18:12:29 <vladimir3p> things like wsgi, etc.
18:12:46 <vladimir3p> unfortunately, there is no really nova-common today, correct?
18:12:48 <jgriffith> vladimir3p: yes... that's covered
18:12:58 <rnirmal> vladimir3p: there is a nova-common
18:13:04 <rnirmal> and some of the wsgi stuff is already in there
18:13:06 <jgriffith> vladimir3p: we're actually using openstack-common
18:13:12 <vladimir3p> link?
18:13:16 <rnirmal> sorry openstack-common
18:13:29 <rnirmal> https://github.com/openstack/openstack-common
18:13:42 <jgriffith> It's in the repo already, that's what's cool about jeblairs project setup
18:13:52 <jgriffith> We actually have a framework
18:14:10 <jgriffith> The code in my personal repo https://github.com/j-griffith/cinder followed the same process
18:14:23 <vladimir3p> very good
18:14:29 <jgriffith> I added more components to my config but don't know if they're all needed or not
18:14:42 <rnirmal> soren: jgriffith how are we going to move that code in the official repo
18:14:51 <jgriffith> So things like wsgi, some of the test infrastructure, utils etc we have
18:15:17 <jgriffith> rnirmal: So I'm planning to do a commit and submit for review... at least the framework
18:15:33 <rnirmal> great and we can slowly start moving in the pieces
18:15:45 <jgriffith> I've put together some "stripped down" versions of things together to get a foundation that can work and run tests
18:15:53 <jgriffith> rnirmal: exactly
18:16:23 <jgriffith> The only thing is I would like to get folks to at least take a brief look at what I have in my github before pushing to the official repo
18:16:43 <jgriffith> I'd like to avoid having to make MAJOR changes to the layout or anything after we've got it in Gerrit and such
18:17:18 <jgriffith> I probably need to take another turn on it this week but my goal is to have it up in the official repo this week-end
18:17:34 <jgriffith> Unless folks are anxious to start writing some code before then :)
18:17:40 <vladimir3p> ok, a quick question - seems like I'm missing scheduler part
18:18:18 <jgriffith> vladimir3p: in terms of what I have in my repo?  Yes, correct it's by NO means complete
18:18:36 <jgriffith> The idea was to get a minimal DB, Test infrastructure etc
18:18:37 <vladimir3p> yep, justa placeholder will be great
18:18:56 <vladimir3p> let's put there something like a simple or random scheduler
18:19:03 <jgriffith> What I'd really like is some feedback on what I did with the drivers directory versus plugins etc
18:19:14 <rnirmal> yeah lets start with basic stubs.. easier to get things rolling
18:19:26 <jgriffith> vladimir3p: random scheduler is fine with me.  Or even just an empty file
18:19:43 <jgriffith> #action add scheduler stub before pushing to official repo
18:20:33 <jgriffith> #idea I'll give folks a couple days to take a look at what's there, feel free to email suggestions, submit somehting of your own etc
18:20:44 <vladimir3p> agree
18:20:52 <vladimir3p> so, let's see what do we have and what we are missing ...
18:20:58 <jgriffith> Then I'll try to get our first submission pushed in this week-end
18:21:05 <jgriffith> Missing lots of stuff :)
18:21:16 <rnirmal> sounds good.. yeah don't worry about the missing stuff
18:21:16 <vladimir3p> I was thinking about cinder API (rest) level, volume APIs, DB, scheduler manager with drivers
18:21:25 <jgriffith> Some things I'd like to consider before talking about missing stuff
18:21:27 <rnirmal> as long as it has a basic api + service running
18:21:35 <vladimir3p> these seems to be main parts
18:21:35 <jgriffith> rnirmal: +1
18:21:39 <rnirmal> and the framework for running the tests
18:21:49 <jgriffith> rnirmal: +++++++++++1
18:21:53 <jgriffith> :)
18:21:56 <vladimir3p> :-)
18:22:17 <jgriffith> Ok, so something else we need to talk about is flushing out the endpoint definitions
18:22:30 <jgriffith> Or the api interface, however you want to look at it
18:22:37 <rnirmal> I think it would be great to get a blueprint out for the api
18:22:56 <rnirmal> and start by adding the existing definitions and refine on those
18:23:24 <jgriffith> rnirmal: Agree, also might be helpful to leverage the work Vish did on the python-cinder-client
18:23:29 <jgriffith> #link https://github.com/vishvananda/python-cinderclient.git
18:23:56 <jgriffith> We should keep in mind that our first goal is to offer a functional equivalent to the existing nova-volume api
18:24:13 <vladimir3p> jgriffith: what is the plan about plug-ins. How do you plan to use them?
18:25:18 <jgriffith> vladimir3p: The idea is this to behave sort of like what we do with extensions
18:25:31 <vladimir3p> so, those will be API extensions?
18:25:39 <jgriffith> I'm modeling more what quantum is doing here.
18:25:54 <jgriffith> Yes, with potential for other things in the future as well
18:25:56 <vladimir3p> sorry, not familiar with qunatum stuff
18:26:08 <rnirmal> this should be similar to the nova extensions too
18:26:31 <vladimir3p> because if we are talking about just API extensions (a-la nova), it would be great to reuse their code
18:26:36 <vladimir3p> (put it in common)
18:26:47 <rnirmal> there was a session on the extensions.. not sure what happened. there
18:27:24 <jgriffith> API extensions wouldn't be common though...
18:27:48 <rnirmal> I think common already has it
18:27:52 <jgriffith> rnirmal: Yeah, I didn't make that session but I can track down folks and get mor einfo
18:28:25 <rnirmal> https://github.com/openstack/openstack-common/blob/master/openstack/common/extensions.py ... we'll have to figure out what else is needed here.
18:28:34 <vladimir3p> ok, so the main comment on your branch - great stuff!!! If we could use openstack-common modules instead of what is there in common it will be even better
18:28:35 <rnirmal> I'll be able to help setup the extensions part.. we just did that for reddwarf
18:28:40 <rnirmal> using openstack-common
18:28:59 <vladimir3p> great!
18:29:04 <rnirmal> vladimir3p: part of it will also be actually getting stuff into common
18:29:04 <jgriffith> rnirmal: excellent
18:29:13 <vladimir3p> how about volume types?
18:29:25 <vladimir3p> if we are talking about volume separation - cut is pretty clear.
18:29:25 <jgriffith> #action rnirmal look at setting up extension framework in new codebase
18:29:34 <vladimir3p> nova knows only about volume uuid
18:29:50 <vladimir3p> but with volume types it is different ...
18:30:06 <rnirmal> wouldn't just cinder need to know about volume types?
18:30:16 <vladimir3p> for sure management of all volume types (+extra specs for types) should be within cinder
18:30:28 <vladimir3p> nova should also somehow be aware of them ...
18:30:56 <jgriffith> vladimir3p: Yes there's going to be work in both nova and cinder to get all of this coordinated
18:31:28 <jgriffith> It seems to me that maybe getting things somewhat structured in cinder then patching nova is the way to go about it
18:31:55 <vladimir3p> agree
18:32:16 <jgriffith> Anybody have any concerns/disagreements?
18:32:36 <jgriffith> Well, I'm sure we all have a few concerns  :)
18:32:51 <vladimir3p> no concerns, only working items :-)
18:33:08 <jgriffith> vladimir3p: So that brings me to the next point....
18:33:29 <jgriffith> Sounds like rnirmal is interested in looking at the extensions piece since he's already done a good bit of work there
18:33:43 <jgriffith> Anybody have interests in starting to dig in on any other specific pieces?
18:33:46 <rnirmal> jgriffith: if the api is not done... I'll pickup all the api pieces
18:33:57 <jgriffith> rnirmal: Excellet!
18:34:03 <rnirmal> moving over the existing stuff etc
18:34:08 <jgriffith> #action rnirmal start working on api pieces
18:34:33 <jgriffith> rnirmal: Perfect, yeah hopefully there can be alot of copy and paste at this stage
18:34:41 <vladimir3p> I can take scheduler, but nothing will be done in the next week or so..
18:35:21 <vladimir3p> it would be great if we could start with better separation between common and cinder part
18:35:30 <jgriffith> vladimir3p: Should be fine, we'll probably need a mox or something basic to test as we go but that should work
18:35:42 <jgriffith> vladimir3p: What do you mean exactly?
18:35:57 <rnirmal> there's still a lot of the pieces that are not in common
18:36:00 <rnirmal> rpc for example
18:36:19 <vladimir3p> to have clear dependency of openstack-common and remove all the code that is "common" from cinder
18:36:32 <vladimir3p> btw, why rpc will be different?
18:36:47 <rnirmal> it won't be.. just that it's not in openstack-common yet
18:37:21 <rnirmal> so we'll have to do copy pasta until it moves to common... or we take the effort to move it to common.. may be we don't need rpc at all?
18:37:30 <jgriffith> So I'm hoping that as we write code and put it in we are careful enough to not dup what's in common.  That should go without saying
18:37:55 <jgriffith> WRT rpc, that's a whole different topic. Can we get by with just rest endpoints?
18:38:03 <vladimir3p> yeah, instead of copying to cinder it will be better to copy to common
18:38:16 <vladimir3p> hmm... how?
18:38:29 <vladimir3p> we have API --> scheduler --> manager
18:38:38 <vladimir3p> somehow they must communicate
18:38:43 <jgriffith> vladimir3p: If we can contribute to common we surely should
18:39:09 <jgriffith> vladimir3p: Ahh, see what you're saying
18:39:52 <vladimir3p> if endpoint APIs will communicate directly with manager - it is s different story, but IMHO they must be different
18:40:00 <vladimir3p> and cinder must be a scalable solution
18:40:07 <rnirmal> yeah looks like we'll need it to start out. and I don't think we've had any proposals or ideas to do it differently
18:43:27 <rnirmal> do we have anything else for this week? I think there's enough work set out for this week
18:44:18 <jgriffith> I'm also trying to figure out if there's a clever way to have a somewhat "isolated" service
18:44:18 <jgriffith> Regardless, I'd like to tackle some of the lower hanging fruit first (api's, db etc)
18:44:18 <jgriffith> agreement?
18:44:18 <jgriffith> Anybody here still?
18:44:39 <vladimir3p> so, any volunteer to strip common code from john's repo?
18:44:49 <vladimir3p> by irc behaves weird
18:45:04 <vladimir3p> *my
18:45:48 <rnirmal> +1 on low hanging fruit first
18:46:38 <vladimir3p> ok, need to go now
18:46:44 <vladimir3p> +2 with everything what we've discussed
18:46:51 <vladimir3p> ;-)
18:46:52 <rnirmal> ok looks like jgriffith's network is down
18:47:13 <vladimir3p> yep
18:47:53 <vladimir3p> rnirmal: you mentioned that you already done the separation of common for reddwarf?
18:48:01 <vladimir3p> where can I take a look at repo?
18:48:22 <rnirmal> well not a complete separation
18:48:24 <rnirmal> https://github.com/hub-cap/reddwarf_lite
18:48:44 <rnirmal> but we atleast hit a few points where stuff needed to be in openstack-common but not there right now
18:49:00 <vladimir3p> yes, thanks
18:49:21 <vladimir3p> I suppose it will be way better to put as much as possible common code into openstack=common
18:49:34 <vladimir3p> and to avoid code replication
18:49:55 <rnirmal> yes totally agree and we can concentrate on the pieces that matter
18:50:06 <vladimir3p> great
18:50:53 <rnirmal> cool is there anything else? looks like jgriffith won't be able to make it back..
18:51:13 <vladimir3p> nope
18:51:20 <rnirmal> if that's all we can end the meeting. not sure if I can do that
18:51:21 <vladimir3p> any idea how to end the meeting?
18:51:26 <rnirmal> but going to give it a try
18:51:38 <rnirmal> #endmeeting
18:51:50 <vladimir3p> :_(
18:51:58 <rnirmal> nope looks like I don't have the permissions to do that... that should have ended the meeting with meeting notes etc
18:52:23 <vladimir3p> yeah, seems like only john can do it ...
18:52:28 <vladimir3p> but I might be wrong
18:52:44 <rnirmal> yeah I think it's configured.. I'll ask ttx if we can do it
18:54:10 <vladimir3p> #endmeeting
18:54:15 <vladimir3p> :-)
18:54:27 <rnirmal> ttx or vishy can one of you'll end this meeting? the moderator jgriffith got cut off.
18:55:24 <rnirmal> well looks like it's going to be dangling till someone else can come and end the meeting :)
18:55:47 <vladimir3p> ok
18:55:47 <rnirmal> anyways I gotta go. will meet up next week and hopefully have code in the official repo :)
18:55:54 <vladimir3p> great
18:55:57 <vladimir3p> bye
18:56:01 <rnirmal> bye
19:11:18 <vishy> #endmeeting
19:11:25 <vishy> nope :)
20:01:44 <maoy> n0ano: greetings
20:02:16 <n0ano> maoy, you survived the summit I see
20:02:30 <openstack> n0ano: Error: Can't start another meeting, one is in progress.
20:03:13 <maoy> n0ano, yeah.
20:03:22 <maoy> n0ano: how are you?
20:03:25 <n0ano> did someone hijack our meeting, I can't start it another one is in progess
20:03:34 <maoy> n0ano: i don't have much to say..
20:03:47 <n0ano> maoy, major jet lagged, I got home at 2AM last night :-)
20:03:50 <vishy> the last meeting was never ended
20:03:52 <maoy> n0ano: a lot of catching up after a week of absence
20:04:04 <n0ano> #endmeeting
20:04:34 <n0ano> hmm, I can't seem to end the last meeting, do we need an admin to do something?
20:05:00 <n0ano> maoy, I don't have anything either, I just got back to the office this morning
20:05:29 <n0ano> if sriram joins we can see if he has anything otherwise just meet up again next wee.
20:05:32 <n0ano> s/wee/seek
20:05:36 <maoy> sure.
20:05:38 <n0ano> s/seek/week
20:05:51 * n0ano needs to get his coordination back
20:06:06 <maoy> SandyWalsh told me how to send in a work-in-progress branch
20:06:17 <maoy> but i'm still unclear how to do feature branch
20:06:44 <n0ano> I don't know about those, are they maybe just the same thing by a different name?
20:07:02 <maoy> no idea..
20:07:18 <n0ano> sounds like you need to talk to sandy again
20:07:19 <maoy> vishy: is feature branch the same as work-in-progress branch in gerrit?
20:07:45 <vishy> there is no support for feature branches yet
20:07:53 <notmyname> jgriffith: needs to #endmeeting
20:07:55 <vishy> so WIP is the current method
20:08:06 <maoy> got it
20:09:16 <sriramhere> any nova-orchestration guys here?
20:09:21 <sriramhere> sorry i am late
20:09:52 <n0ano> sriramhere, yep, maoy & I are here but we don't have anything for today, do you?
20:11:21 <sriramhere> nope, just wanted to check for updates if any.
20:11:39 <sriramhere> and generally say HI and good job on the presentation last week entire team!
20:12:03 <n0ano> Indeed, tnx to both of you, you did the heavy lifting
20:12:08 <sriramhere> n0ano - to pick a bone with you that you didnt rig the raffle so that I can win :-)
20:12:44 <n0ano> well, it's only one SSD drive so you couldn't split it with, not point in my rigging things :-)
20:12:53 <sriramhere> :)
20:13:02 <maoy> lol
20:13:06 <sriramhere> thanks again guys, cya next week then...
20:13:29 <maoy> what's you guys launchpad accounts?
20:13:32 <maoy> before you go..
20:13:35 <n0ano> I think we're good then (fortunately since we can't start the meeting) so we'll talk again next week (hopefully with something to say then).
20:13:43 <n0ano> mines the same, n0ano
20:14:22 <maoy> noted
20:14:24 <sriramhere> sriramhere or sriram-x
20:14:47 <sriramhere> sriram-x
20:16:02 <maoy> ok
20:16:18 <maoy> c ya next week
20:29:32 <jgriffith> vishy: Did you manage to end the meeting?
20:29:41 <jgriffith> Or shall I try it now?
20:29:45 <vishy> go
20:29:53 <vishy> no one else can do it
20:30:09 <jgriffith> #endmeeting