18:00:53 <jgriff> #startmeeting
18:00:54 <openstack> Meeting started Thu May  3 18:00:53 2012 UTC.  The chair is jgriff. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:00:55 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:10 <DuncanT> Hi
18:01:13 <vladimir3p> Hi
18:01:46 <rnirmal> hey
18:01:54 <jgriff> Let's hope my internet connection doesn't die this week and lock up the channel :(
18:02:06 <rnirmal> :)
18:02:20 <jgriff> rnirmal: Sorry I didn't get your pull request last night before migration started back into gerrit
18:02:36 <rnirmal> np send the PR thru gerrit
18:02:44 <rnirmal> send/ will send
18:02:51 <jgriff> rnirmal: :)
18:03:18 <rnirmal> shall we start the meeting
18:03:23 <jgriff> Ok, so you've probably all noticed a flury of activity :)
18:03:35 <jgriff> Thanks especially to anotherjesse !!!
18:03:38 <rnirmal> jgriff: #startmeeting
18:03:47 <jgriff> I did
18:03:58 <rnirmal> oops my bad..
18:04:04 <jgriff> :>
18:04:20 <rnirmal> I think it just cleared off my screen.. n/m
18:04:24 <jgriff> Ahhh
18:04:39 <vladimir3p> so, there is an official openstack/cinder repo now
18:04:43 <anotherjesse> hi
18:04:58 <jgriff> vladimir3p: yes has been for about a week now
18:05:34 <rnirmal> #link https://github.com/openstack/cinder
18:05:53 <vladimir3p> yeah, just for some reason my git shows that it was created 15 min ago
18:06:03 <jgriff> so anyway... I'd suggest everybody take a look at the wiki page if you haven't: http://wiki.openstack.org/Cinder
18:06:09 <anotherjesse> vladimir3p: we just pushed a squash to it 15 minutes ago
18:06:22 <jgriff> Most importantly check out the etherpad
18:07:09 <jgriff> vladimir3p: Also I was convinced (fortunatley) that the way I was going about it wasn't so great so we did a reset
18:07:23 <jgriff> Instead we just pulled in all of nova and culled
18:07:49 <vladimir3p> ok, great
18:07:59 <anotherjesse> dtroyer is working on getting cinder support into devstack - https://review.openstack.org/#/c/7042/
18:08:23 <jgriff> and vishy is working on the first item in the decoupling section
18:08:39 <anotherjesse> we need to get vishy's python-cinderclient moved to official repo this week as well
18:09:05 <jgriff> anotherjesse: ahhh.. I'll hit up mtaylor about that, assuming keep it in it's current form
18:09:27 <anotherjesse> jgriff: that's ok, I think it bit rotted though
18:10:08 <jgriff> anotherjesse: still could use as a baseline yes?
18:10:08 <rnirmal> so is the cinder repo setup with gerrit now?
18:10:13 <mtaylor> yup
18:10:16 <jgriff> rnirmal: yep
18:10:20 <anotherjesse> jgriff: yeah
18:10:29 <rnirmal> cool thanks
18:10:29 <mtaylor> jgriff: let me know when it's there and I'll get cinderclient added
18:10:55 <jgriff> mtaylor: assuming just pull in vish's version
18:11:04 <mtaylor> yeah, prolly so
18:11:21 <jgriff> mtaylor: guess I'll need to do LP pages again
18:11:48 <mtaylor> we actually just use the cinder pages for cinderclient if we're following the model of the other projects
18:11:58 <jgriff> mtaylor: yes please
18:12:16 <jgriff> mtaylor: thanks, wasn't sure on that one
18:12:24 <jgriff> #topic next-steps
18:12:52 <jgriff> So I'd like to propose continuing the usage of the etherpad for starters
18:13:11 <jgriff> if anybody sees something inparticular they'd like to tackle it would be good to keep this record up to date
18:13:14 <anotherjesse> jgriff: it probably works for another week, but we will want to move to blueprints once we figure out what we don't know ;)
18:13:30 <rnirmal> I'd like to start opening up bugs/blueprints for anything new that's going to get merged in... easier to figure out what's getting worked on
18:14:07 <jgriff> rnirmal: fair
18:14:09 <anotherjesse> rnirmal: I think limiting to things we know need done - such as prototype http API extensions (#4 in decoupling work)
18:14:26 <jgriff> My proposal is this:
18:14:29 <anotherjesse> http://etherpad.openstack.org/cinder-worksheet
18:14:39 <jgriff> decoupling work, general structure etc is still in flux
18:14:46 <jgriff> use etherpad
18:14:57 <jgriff> building on top of what's there, features etc need bp
18:15:13 <vishy> jgriff: I started outlining the basic flow of attaching a volume in nova
18:15:27 <vishy> jgriff: in the etherpad, and how it 'should' work in the future
18:15:45 <vishy> jgriff: it is a little complex and weird right now
18:16:02 <jgriff> vishy: I saw that, was thinking that's where I should probably copy it into a bp once it's a bit settled
18:16:15 <jgriff> like anotherjess mentioned, maybe another week of etherpad
18:16:22 <jgriff> Maybe a little less
18:16:46 <jgriff> also I don't think that precludes anybody from submitting bp's
18:18:03 <rnirmal> it's probably worthwhile to hold off on new code submissions, till we get a base working copy with nova
18:18:24 <rnirmal> I mean new features
18:18:24 <anotherjesse> rnirmal: I actually don't know if getting it working with nova is #1 goal
18:18:31 <jgriff> rnirmal: I think I agree but it's "all" new code :)
18:18:35 <anotherjesse> I would like it to work on its own
18:18:41 <anotherjesse> and expose the APIs nova would need
18:18:59 <jgriff> So I believe we are all on the same page
18:19:00 <anotherjesse> but the code changes to nova will be more complicated, so lets not block on them
18:19:13 <jgriff> We agreed previously, get nova functionality working before anything else
18:19:15 <rnirmal> ok
18:19:24 <jgriff> in other words, existing nova-volume functionality
18:19:42 <anotherjesse> jgriff: define "nova functionality" - being able to do the functions or having nova actually using cinder?
18:20:03 <jgriff> I'd like to have nova actually use cinder before going into "new" features
18:20:10 <rnirmal> mimic nova-volumes in current functionality
18:20:28 <vladimir3p> jgriff: let's start with operating cinder without nova
18:20:32 <jgriff> yeah, granted it might not be perfect but focus efforts on just getting it usable
18:20:35 <vladimir3p> like with some externall app
18:20:41 <anotherjesse> cinder is a service, having cinder do the right thing and having nova integrate well with cinder are different problem sets
18:21:05 <anotherjesse> vladimir3p: yep!  we have python-cinderclient which we can make work with all the changes needed in the API to support volumes
18:21:12 <anotherjesse> (without a shared queue/db)
18:21:18 <vladimir3p> yeah, it will be the 1st step
18:21:29 <vladimir3p> nova tune-up will be a big step by itself
18:21:37 <jgriff> anotherjess: yeah, the nova side complicates
18:22:02 <anotherjesse> attach/detach first
18:22:07 <vladimir3p> if cinder could handle APIs properly and expose iSCSI devices - it is a good 1st milestone, IMHO
18:22:14 <anotherjesse> and then we can move into reserve/init connection if we want
18:22:20 <jgriff> I would like to try and get attach/detach working in F1 if possible
18:22:26 <anotherjesse> jgriff: agreed
18:23:21 <jgriff> so does anybody have time to dedicate/commit to some of these items?
18:24:26 <jgriff> hmm... ok, maybe that's to vague or commital
18:24:42 <jgriff> does everybody like what they see so far and agree with the direction still?
18:24:53 <anotherjesse> actually looks like initialize/terminate are more important
18:24:59 <anotherjesse> I just asked vishy what those where
18:25:08 <anotherjesse> that is how you actually get the iscsi connection information
18:25:26 <rnirmal> initialize/terminate is what provides the connection info
18:25:27 <jgriff> anotherjesse: guess you can't attach/detach without that
18:25:38 <anotherjesse> attach/detach is just metadata
18:25:39 <rnirmal> jgriff: yes
18:25:47 <rnirmal> no it's the other way round
18:25:54 <vladimir3p> jgriff: I like it :-) can't commit for next couple of weeks. I would prefer to see more stuff in common rather copy/pasting to cinder
18:26:02 <rnirmal> initialize/terminate is metadata that the volume service provides
18:26:19 <anotherjesse> vladimir3p: there should be a blueprint of blueprints to common-ize stuff
18:26:35 <vladimir3p> anotherjesse: ok
18:26:42 <DuncanT> I'm starting to look at cinder, but can't commit this week. Might get chance to make some progress
18:26:50 <jgriff> vladimir3p: I started using the approach but was educated by anotherjess and vishy
18:26:57 <vladimir3p> :-D
18:27:12 <jgriff> vladimir3p: I think it's a good idea to work on this after getting goals for F1 and F2
18:27:18 <anotherjesse> vladimir3p: we can move things towards common, but don't block on it landing in common
18:27:27 <jgriff> anotherjess: exactly
18:27:28 <rnirmal> yeah it's a nice to have at this point
18:27:39 <vladimir3p> anotherjesse: makes sense
18:27:52 <jgriff> I think nova will be striving for the same thing as well during Folsom
18:28:32 <jgriff> Does anybody see any glaring holes or things we didn't think of?
18:28:51 <anotherjesse> goal: (in a user story):  a user can use python-cinderclient to create a volume, and get the iscsi attach info, then manually attach to their system (this assumes networks are accessible), then store things, dettach, move it to another server and see the info written in the first server, then detach and delete
18:29:40 <rnirmal> +1
18:29:45 <jgriff> anotherjess: I plan to write something like that up and post on the wiki...
18:29:51 <jgriff> +1
18:29:57 <vladimir3p> +1
18:30:06 <jgriff> Also break it out and have stories per Folsom milestones
18:30:27 <jgriff> does that seem worthwhile/useful?
18:31:37 <vladimir3p> if I understand correctly this user story - the main functionality here is create/expose/delete.
18:31:38 <DuncanT> Definitely. Helps have everybody pulling in a similar direction
18:31:50 <vladimir3p> the entier attach/detach is kind of optional metadata update within cinder
18:31:51 <anotherjesse> vladimir3p: create / use outside nova / delete
18:32:15 <vladimir3p> anotherjesse: use outside nova == any host with iSCSI init
18:32:27 <anotherjesse> #action also to vladimir3p's point we should create a blueprint about openstack common - and start creating child blueprints for subcomponents - a blueprint for scheduler, a blueprint for service.py, ...
18:32:35 <anotherjesse> vladimir3p: yep
18:32:51 <rnirmal> anotherjesse: that should be in openstack-common right?
18:32:59 <rnirmal> the blueprints.. cos it pertains to nova too
18:33:21 <anotherjesse> we can move blueprints around, and they can point to things in other projects
18:33:27 <anotherjesse> the important thing is to start writing them ;)
18:34:02 <anotherjesse> given that we deleted ~100k lines in nova to make cinder, it might be easier for us to look at things in cinder repo and see what shouldn't be there.
18:34:02 <rnirmal> ok cool.. there's one for rpc already.. we'll just have to get the other ones out
18:34:31 <anotherjesse> rootwrap - https://github.com/openstack/cinder/tree/master/cinder/rootwrap
18:34:50 <anotherjesse> ...
18:35:46 <rnirmal> rpc, notifier, some more of the wsgi and extensions functionality, not sure how much of that is in common already
18:38:25 <jgriff> rnirmal: probably about half I believe
18:38:45 <rnirmal> k
18:39:04 <jgriff> alright, no reason to keep people hanging around for nothing....
18:39:29 <jgriff> rnirmal: I know you started working on some things, antyhing you want to go on record with right now?
18:39:42 <rnirmal> well I just have that one commit I need to make
18:40:04 <jgriff> ok
18:40:09 <rnirmal> that removes the compute/versions stuff from the api... added the missing pieces into the volume api code
18:40:50 <rnirmal> I'll just open a bug for it and submit it.. easier to do it that way for me
18:40:57 <jgriff> #action rnirmal submit his compute tear out and api work
18:41:51 <rnirmal> jgriff: do we have jenkins setup to run the unit tests to gate commits?
18:42:00 <jgriff> rnirmal: yes
18:42:49 <rnirmal> thanks to mtaylor for the infra setup
18:43:11 <jgriff> rnirmal: Yes, big thanks to mtaylor as well as jeblair !!!
18:43:44 <mtaylor> all thanks should really go to jeblair - I'm just here to sign his paycheck...
18:43:46 <mtaylor> :)
18:44:30 <jgriff> Ok, going forward:
18:44:45 <jgriff> Keep an eye on the etherpad for updates over the next few days
18:45:03 <jgriff> Keep an eye open for reviews needed in gerrit
18:45:25 <jgriff> Feel free to use email: [Openstack][Cinder] in the subject line
18:45:52 <jgriff> If you want to pick something up let folks know either IRC or ehterpad or both
18:46:03 <jgriff> (preferrably both)
18:46:11 <jgriff> Anybody have anything else?
18:47:52 <jgriff> alrighty.. thanks everyone, and HUGE thanks to anotherjesse vishy mtaylor and jeblair
18:47:55 <jgriff> #endmeeting