21:01:25 <ttx> #startmeeting
21:01:26 <openstack> Meeting started Tue May  8 21:01:25 2012 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:28 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:32 <ttx> Today's agenda: http://wiki.openstack.org/Meetings/ProjectMeeting
21:01:54 <ttx> #info We'll be mostly reviewing folsom-1/1.5.0 plans for each project
21:02:07 <ttx> #info Folsom-1 is May 24th, so the milestone branch should be cut on May 22nd
21:02:19 <ttx> That means we have two weeks left.
21:02:25 <ttx> But first...
21:02:33 <ttx> #topic Final Folsom release schedule
21:02:39 <ttx> #link http://wiki.openstack.org/FolsomReleaseSchedule
21:02:45 <ttx> This is the final proposal, which reflects the option we discussed last week.
21:03:01 <ttx> That makes final common "Folsom" release on September 27th.
21:03:17 <ttx> And for milestone-following projects, feature freeze on August 14 (two days before last milestone)
21:03:32 <ttx> And next Design summit on the week of October 15, with an extra week post-release to prepare.
21:03:43 <ttx> PTLs: Does that sound good to you ?
21:03:56 <heckj> ttx: yep
21:04:00 <notmyname> ttx: I think I'm free that week ;-)
21:04:06 <bcwaldon> yep yep
21:04:24 <ttx> notmyname: good!
21:04:48 <ttx> I tried to avoid Columbus Day week which apparently some people like to have off
21:05:12 <ttx> moving on then
21:05:15 <ttx> #topic Keystone status
21:05:26 <ttx> heckj: o/
21:05:29 <heckj> ola
21:05:30 <ttx> #link https://launchpad.net/keystone/+milestone/folsom-1
21:05:38 <ttx> Two blueprints targeted (both essential)...
21:05:55 <ttx> heckj: Is it a complete view of your folsom-1 plans ?
21:06:08 <heckj> yep. implementation in progress on both of them, slower than I'd like on the API drafting, but coming along
21:06:17 <ttx> stop-ids-in-uris: is marked beta available, so I guess it should be proposed for review soon ?
21:07:10 <heckj> ttx: Some of that code is in review now
21:07:20 <ttx> draft-v3-api: is the work on this started ? Is this really necessary by folsom-1 ? (if not, we can downgrade to "High")
21:07:52 <heckj> ttx: if we want to get it out, yes - it's essential. If we don't do it by F1, then we won't be doing a significant API upgrade this release at all.
21:08:02 <ttx> fair enough
21:08:16 <ttx> but work started on that, right ?
21:08:24 <heckj> ttx: yes
21:08:28 <ttx> ok, will update
21:08:34 <ttx> Looking at targeted bugs, there are three that are unassigned.
21:08:52 <ttx> Should probably be untargeted if nobody is working on them.
21:09:01 <heckj> will update individually
21:09:25 <ttx> thx
21:09:30 <ttx> heckj: anything else ?
21:09:38 <heckj> I'm good
21:09:40 <ttx> Questions about Keystone ?
21:10:04 <ttx> heckj: go grab lunch :)
21:10:09 <ttx> #topic Swift status
21:10:10 <heckj> FOOD!!!
21:10:15 <ttx> notmyname: o/
21:10:17 <notmyname> o/
21:10:21 <ttx> #link https://launchpad.net/swift/+milestone/1.5.0
21:10:33 <ttx> 4 blueprints, 2 completed already, looks good to me
21:10:42 <ttx> Any vague idea of the ETA for 1.5.0 yet ?
21:10:47 <notmyname> indeed. the important one there is https://blueprints.launchpad.net/swift/+spec/add-associated-projects-docs
21:11:00 * ttx looks
21:11:21 <notmyname> there is no timeframe for 1.5.0 yet (beyond the vague "in the next few weeks")
21:11:41 <notmyname> there is a lot of coordination to split out the pieces and make sure they are ready to go
21:11:44 <ttx> notmyname: sometime in May/early June ?
21:11:50 <notmyname> background: https://lists.launchpad.net/openstack/msg11237.html
21:12:13 <notmyname> ttx: I'd hope by the end of this month
21:12:28 <ttx> notmyname: you can use "priority" in the blueprint to convey how important each blueprint relatively is
21:12:36 <notmyname> this means that swift 1.5.0 will be somewhat larger than other releases
21:12:41 <ttx> ok
21:12:59 <ttx> notmyname: Anything else ?
21:13:10 <notmyname> by "larger" I mean it may take extra effor for deployers to upgrade since dependencies may have been added
21:13:45 <ttx> that way people will think they know why it's called 1.5.0 instead of 1.4.10 :)
21:13:54 <notmyname> indeed
21:14:00 <ttx> Questions on Swift ?
21:14:02 <notmyname> one more thing
21:14:15 <ttx> notmyname: go for it
21:14:42 <notmyname> swift now has http://swift.openstack.org/associated_projects.html and if someone has something they want aded, it can be added with a patch to the swift docs in the swift codebase (normal openstack conditions apply)
21:15:15 <ttx> ack
21:15:31 <ttx> no question on Swift ?
21:15:44 <ttx> #topic Glance status
21:15:50 <ttx> bcwaldon: yo
21:15:53 <bcwaldon> hey
21:16:00 <ttx> #link https://launchpad.net/glance/+milestone/folsom-1
21:16:09 <ttx> 5 blueprints, all essential...
21:16:15 <bcwaldon> that's how I roll
21:16:25 <ttx> almost all.
21:16:31 <ttx> Essential ones: all completed except one in review ?
21:16:37 <ttx> Looks almost done, which is good :)
21:16:48 <bcwaldon> Yep, I'm just pulling things in as they seem like they'll get done
21:16:58 <ttx> Is it a complete view of the Glance f1 targets ?
21:17:00 <bcwaldon> My target for the v2 API is Folsom, dont have a good milestone yet
21:17:04 <bcwaldon> ttx: I doubt it
21:17:12 <bcwaldon> ttx: probably adding more as the work gets done
21:17:26 <ttx> but all the others would not be blocking anything, so Med/Low prio
21:17:47 <bcwaldon> I guess i'm thinking about priority within the context of Folsom, not just F1
21:17:55 <ttx> hmm
21:18:01 <bcwaldon> so I have more Essential blueprints that arent targeted to F1
21:18:16 <ttx> sure
21:18:51 <bcwaldon> I have asked for some help with the v2 APi blueprints on the list, but I didn't get any response
21:19:04 <ttx> Next week we'll probably be looking at the whole folsom essential stuff and make sure the map to milestones is coherent
21:19:04 <bcwaldon> So if theres anybody thats interested in helping, I do have some work to be done
21:19:16 <bcwaldon> ttx: fine with me
21:19:29 <ttx> today I wanted to make sure folsmo-1 objectives were mostly making sense.
21:19:42 <ttx> #help <bcwaldon> I have asked for some help with the v2 APi blueprints on the list, but I didn't get any response
21:19:43 <bcwaldon> ttx: ok, as far as F1 is concerned, we're fine :)
21:19:49 <ttx> bcwaldon: Anything else you wanted to mention ?
21:20:06 <bcwaldon> ttx: Nope
21:20:09 <ttx> Questions on Glance ?
21:20:38 <ttx> #topic Quantum status
21:20:43 <ttx> danwent: hey
21:20:46 <danwent> hey
21:20:47 <ttx> #link https://launchpad.net/quantum/+milestone/folsom-1
21:20:48 <danwent> https://launchpad.net/quantum/+milestone/folsom-1
21:20:50 <danwent> :)
21:20:58 <ttx> :P
21:20:59 <ttx> 9 blueprints, all assigned
21:21:03 <danwent> so we've made good progress on everything but the two most important things.
21:21:21 <danwent> the new API with melange merged in
21:21:27 <danwent> and keystone integration.
21:21:31 <ttx> ok...
21:21:33 <ttx> Three are in unknown state:
21:21:41 <ttx> melange-integration: is that one started ?
21:21:59 <danwent> https://blueprints.launchpad.net/quantum/+spec/melange-integration
21:22:08 <danwent> refresh?
21:22:15 <ttx> arh
21:22:20 <danwent> yes, that is started and jkoelker_  has a design he's going to send out soon.
21:22:38 <danwent> but that's my main concern, as there are many dependencies for F-2 that require that work to be done by F-1
21:22:39 <ttx> yes, refreshed earlier today, you're good now
21:22:53 <danwent> sorry for the last minute tweaks
21:23:13 <ttx> danwent: should I just set the two "undefined" ones to "Low" prio ?
21:23:22 <danwent> i know heckj and troytoman-away have been talking about the keystone integration, but I'm less familiar with the current status.
21:23:27 <ttx> (database-common and man-support)
21:23:30 <danwent> ah, yes, I will do that.
21:24:08 <danwent> those are both in review already anyway, so I'm not worried about them at all.
21:24:19 <ttx> like you said, you look generally on track, but the essential/high stuff looks a bit behind
21:24:40 <danwent> yup, i think that's a good summary
21:24:51 <ttx> danwent: Anything else ?
21:24:54 <danwent> we have our quantum scrum meeting next.  hopefully jkoelker_ will be there to comment
21:24:59 <danwent> nope, that's it
21:25:04 <ttx> Questions on Quantum ?
21:25:33 <ttx> #topic Nova status
21:25:42 <vishy> hi
21:25:42 <ttx> vishy: hey
21:25:42 <jkoelker_> I'm here, i'm updating the blueprint with the etherpad links
21:25:49 <ttx> #link https://launchpad.net/nova/+milestone/folsom-1
21:26:23 <vishy> I haven't heard back from some of the blueprint assignees as to when they will be complete
21:26:28 <ttx> 15 blueprints - some in unknown state
21:26:33 <vishy> so there may be one or two more joining that list soon
21:26:59 <ttx> vishy: should I assume the "unknown" ones are "not started" ?
21:27:15 <ttx> or that you will hunt down the assignees to get some input from them ?
21:27:20 <russellb> formalized-message-structure sort of overlaps with versioned rpc apis .... so it's started
21:27:29 <russellb> i would just call it 'started'
21:27:34 <ttx> on it
21:27:48 <vishy> beat you
21:27:49 <vishy> :)
21:27:51 <ttx> arh
21:28:01 <ttx> I's easier when there is more lag between us
21:28:11 <vishy> they are all prioritized and have a status
21:28:28 <ttx> good!
21:28:35 <ttx> In general, this looks mostly on track. Any particular concern ?
21:29:11 <vishy> there are a bunch of important blueprints for folsom in general that have no assignees
21:29:31 <vishy> so no concerns about this milestone, but there is lots of work that needs to be done
21:29:44 <ttx> #help <vishy> there are a bunch of important blueprints for folsom in general that have no assignees
21:29:52 <vishy> #info https://blueprints.launchpad.net/nova/+spec/general-host-aggregates
21:30:00 <vishy> #info https://blueprints.launchpad.net/nova/+spec/config-drive-v2
21:30:01 <ttx> vishy: did you call for volunteers on the ML yet ?
21:30:04 <vishy> are two big ones
21:30:06 <vishy> i did
21:30:16 <vishy> i didn't call out specific blueprints though
21:30:19 <jog0> I can take https://blueprints.launchpad.net/nova/+spec/general-host-aggregates
21:30:34 <ttx> We could try to convince smoser to take config-drive-v2. He can be convinced with beer.
21:31:06 <oubiwann> hehe
21:31:17 <ttx> vishy: quick, grab jog0!
21:31:43 <vishy> jog0: oh you emailed me about that didn't you
21:31:47 <vishy> awesome will assign you
21:31:55 <jog0> vishy:  yup, thanks
21:32:15 <ttx> #action ttx and vishy to pour beer into smoser and get him to take config-drive-v2
21:32:19 <ttx> I'd like to talk briefly about Cinder...
21:32:28 <ttx> It will probably be "core" in Folsom as an existing core project split.
21:32:52 <ttx> We should have a recurrent Cinder topic at the weekly meeting
21:33:05 <ttx> There was a discussion at hte PPB meeting just before this one
21:33:11 <vishy> ttx: good idea, we might need to make sure jgriffith knows about it
21:33:32 <ttx> Where we decided that Cinder would be core if it can reach feature partity and release process conformity by folsom-2
21:33:39 <ttx> parity*
21:34:01 <ttx> #action ttx to invite jgriffith to a regular Cinder topic at the weekly meeting
21:34:11 <ttx> vishy: Anything else ?
21:34:45 <vishy> just a reminder about the email i sent regarding blueprints
21:35:00 <vishy> I'm going to obsolete all of the blueprints next week that are not targetted to folsom
21:35:10 <vishy> so if anyone knows of one that should stick around, let me know!
21:35:14 <ttx> I think that's ok to do, it's not as if you can't revert that move
21:35:34 <ttx> Questions on Nova ? on Cinder ?
21:36:13 <ttx> #topic Horizon status
21:36:17 <devcamcar> o/
21:36:19 <ttx> devcamcar: o/
21:36:24 <ttx> #link https://launchpad.net/horizon/+milestone/folsom-1
21:36:34 <devcamcar> i still have a few blueprints to create from the summit
21:36:45 <devcamcar> i retargeted a few for folsom-2 to keep the amount of work under check
21:36:57 <ttx> Status looks good to me...
21:37:11 <ttx> Progress looks a bit slow (2 "High" are "not started"), still on track from your point of view ?
21:37:12 <devcamcar> good progress on one of the bigger items: https://blueprints.launchpad.net/horizon/+spec/workflows
21:37:32 <devcamcar> ttx: yep, should still be good on the blueprints
21:37:39 <devcamcar> they are pretty narrow in scope
21:37:55 <ttx> devcamcar: Anything else ?
21:38:23 <devcamcar> no, other than to say folsom-1 is mostly preparing for folsom-2 changes which depend on workflows
21:38:39 <ttx> devcamcar: could you explain workflows in a few words ?
21:38:46 <devcamcar> yep
21:38:59 <devcamcar> we can currently swap out dashboards/panels and customize pretty extensively
21:39:10 <ttx> devcamcar: sounds important, but the blueprint is a bit dry :)
21:39:20 <ttx> ok...
21:39:22 <devcamcar> but we don't have a deeper integration between showing or hiding features
21:39:30 <devcamcar> for example, the launch instance workflow
21:39:42 <devcamcar> if quantum is enabled it needs to present different options to the end user
21:40:07 <devcamcar> and so the quantum within horizon has to be able to dynamically modify the workflow
21:40:23 <devcamcar> once we have this in place we can start having horizon pick and choose what to show in a much more elegant way
21:40:29 <ttx> devcamcar: so it's not really a user-facing feature, it's more on the developer/deployer/customizer side ?
21:40:35 <devcamcar> yes
21:40:42 <ttx> ok, thx
21:40:45 <devcamcar> user facing changes will mostly land as of folsom-2
21:40:50 <ttx> devcamcar: Anything else ?
21:40:53 <devcamcar> nope
21:40:57 <ttx> Questions for Horizon ?
21:41:22 <ttx> #topic Other Team reports
21:41:28 <ttx> annegentle, jaypipes, mtaylor: ?
21:42:00 <annegentle> I've created four blueprints for openstack-manuals and have identified resources for all but one - a "try-it-out" mechanism for TryStack.org.
21:42:29 <annegentle> I believe someone with big javascript chops could take it on, probably use https://github.com/ging/horizon-js.
21:42:54 <annegentle> #info Docs seeking javascript gurus to implement "try-it-out" for TryStack.org - https://blueprints.launchpad.net/openstack-manuals/+spec/api-try-it-out
21:42:59 <ttx> annegentle: I see 6 blueprints on https://blueprints.launchpad.net/openstack-manuals
21:43:19 <ttx> you should be able to set the series goal to folsom to further limit the view
21:43:46 <annegentle> ttx: ah, I need to follow up with lloydde about his.
21:43:49 <ttx> those are folsom-wide goals, right ?
21:44:04 <annegentle> ttx: yep.
21:44:29 <ttx> annegentle: anything else ?
21:44:44 <annegentle> ttx: that's all for this week. Next week we do have a Doc team meeting.
21:44:50 <ttx> On the I18N side, there is a thread going on the ML right now...
21:45:05 <ttx> I'd like the PTLs to chime in and say how much I18N they are ready to support
21:45:14 * ttx fetches link
21:45:50 <ttx> hrm
21:45:53 <devcamcar> ttx: horizon is fully prepared, as far as i know
21:46:32 <ttx> horizon is a bit of a special case, since it's very user-facing
21:46:56 <ttx> there are 3 optoins
21:47:12 <ttx> 1. Horizon being I18N as the user-friendly web interface to OpenStack
21:47:12 <ttx> 2. All API-user-facing messages should be fully I18N
21:47:12 <ttx> 3. Everything (including log messages) should be I18N, introduce error codes to enable cross-language searching
21:47:26 <ttx> all have horizon I18Ned :)
21:47:58 <annegentle> ttx: 3. includes some user docs?
21:48:09 <vishy> personally i think 3 is best based on feedback from eastern users
21:48:10 <ttx> Before someone decides we'll pursue (3) I'd like to make sure all the PTLs agree that they can support that level
21:48:27 <ttx> since I think "openstack" should be consistently I18Ned
21:48:43 <mtaylor> ttx: I put the folsom todo list up ...
21:48:55 <mtaylor> ttx: https://bugs.launchpad.net/openstack-ci/+milestone/folsom
21:49:03 <mtaylor> fwiw
21:49:17 <devcamcar> ttx: good thing it works in horizon then :)
21:49:17 <notmyname> I think we have "support" in swift, but it's in quotes because I don't think anyone has actually tried it
21:49:21 <ttx> so heckj, notmyname, bcwaldon, vishy, devcamcar, danwent: please comment on the "i18n of log message" thread
21:49:30 <devcamcar> ttx: will check it out
21:49:52 <ttx> if for some reason the list of options should be reduced, better know it soon
21:50:01 <ttx> before anyone gets too excited
21:50:21 <ttx> Any other team lead with a status report ?
21:50:42 <egallen> I've prepared the french translation for horizon web interface, I put it today on my github.
21:51:15 <ttx> vishy: about feedback from Eastern users, some of them voiced their support for option 1 (the China user group man did)
21:51:37 <ttx> vishy: so it's not necessarily a "Asia vs. the world" issue
21:52:09 <ttx> it's about reasonable expectations vs. effort involved, I think
21:52:17 <ttx> #topic Open discussion
21:52:47 <ttx> On the bug triaging front, we'll probably open up the bug triagers team. Currently those are restricted teams
21:53:08 <ttx> but I don't think the benefit outweighs the cost, so I'll propose something on the ML soon about it
21:53:27 <ttx> that's all I had
21:53:32 <ttx> Anything else, anyone ?
21:53:43 <ttx> oubiwann: how is the new dev ML coming up ?
21:54:10 <oubiwann> ttx: I need jeblair's help with exim as the next step
21:54:21 <oubiwann> now that he's back from vaca, we should be golden :-)
21:54:25 <ttx> oubiwann: are you set on the prefixes ?
21:54:50 <ttx> oubiwann: should we open the discussion on those a bit more publicly ?
21:55:05 <ttx> (I mean, it's an etherpad, but not everybody knows about it yet)
21:55:11 <oubiwann> yeah, there are some more than need to be added, but those are on the subteam page and I'll make sure I look at that and your etherpad notes before updating the mail list description
21:55:15 <oubiwann> right
21:55:22 <oubiwann> yeah, I can send out an email
21:55:32 <ttx> oubiwann: feel free to extend the discussion on those. I'd prefer them to be set in stone before we even open
21:55:40 <oubiwann> okay
21:55:52 <ttx> so that we can set the house rules quite clearly
21:56:26 <ttx> ok, so unless someone has something to add..
21:56:39 <oubiwann> to be clear for everyone else, ttx means "extend the discussions in a public forum" before we "open up the mail lists (put them live)"
21:56:53 <ttx> indeed
21:56:56 <oubiwann> :-)
21:56:57 <ttx> #endmeeting