19:59:51 <annegentle> #startmeeting
19:59:52 <openstack> Meeting started Mon May 14 19:59:51 2012 UTC.  The chair is annegentle. Information about MeetBot at http://wiki.debian.org/MeetBot.
19:59:53 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
20:00:20 <annegentle> #topic Action items from the last meeting
20:00:41 <annegentle> Anne to log bugs for CLI doc maw
20:00:50 <annegentle> done: https://bugs.launchpad.net/openstack-manuals/+bug/988902
20:00:53 <uvirtbot> Launchpad bug 988902 in openstack-manuals "Write documentation for python-novaclient (starter doc is available)" [High,In progress]
20:00:58 <annegentle> Karin working on it
20:01:16 <annegentle> Anne to create a note describing the extensions on api.openstack.org 'The following extensions ship with Nova, but are not required to be deployed for any openstack-compatibile cloud'
20:01:42 <annegentle> is this still needed?
20:02:04 <annegentle> Last action: Anne to investigate usability testing of Install/Deploy doc
20:02:22 <annegentle> great idea but didn't get to it!
20:02:42 <annegentle> #info Beth Cohen putting together training and will need to test the docs
20:03:41 <annegentle> we're getting a goodly amount of doc bugs in, so they're definitely being tested
20:04:18 <annegentle> #action Anne to send Beth draft "Learning OpenStack" document
20:04:22 <annegentle> #topic Essex release docs
20:04:47 <annegentle> #we now have a stable/essex branch for openstack-manuals
20:05:27 <annegentle> so propose to both when you have a fix for both
20:05:38 <annegentle> any Qs about essex branch?
20:05:47 <reed> #info <annegentle>  #we now have a stable/essex branch for openstack-manuals so propose to both when you have a fix for both
20:05:51 <lorin1> When will docs.openstack.org point to essex docs?
20:06:16 <annegentle> lorin1: so what I did is have a docs.openstack.org/essex and then kept the root pointing to trunk, is that ok?
20:06:37 <annegentle> not too much divergence yet, maybe in a month we stop doing that?
20:06:58 <lorin1> annegentle: Sounds good to me.
20:07:02 <annegentle> or since Essex is on LTS versions, should I switch root to /essex now?
20:07:39 <bfcohen> Need to clear that up and document it.
20:08:31 <annegentle> #info root of site pointing to /trunk documents, maybe switch to /essex sooner rather than later
20:08:39 <bfcohen> Essex has enough of a user base that we will need to keep it around for a while.
20:08:42 <lorin1> We could always wait until we get our first folsom-specific doc contribution. ;)
20:08:56 <annegentle> lorin1: I like it!
20:09:15 <annegentle> #agreed wait for divergence from essex to folsom to switch docs landing pages
20:09:25 <annegentle> # Blueprints status
20:09:48 <annegentle> I'm a bit new to blueprints...
20:09:53 <bfcohen> I am new to Blueprint as well.
20:10:03 <annegentle> thanks to joesavak for the blueprint tutorial
20:10:21 <joesavak> np. : ) Although i haven't followed up and created cdt bps yet
20:10:25 <annegentle> #link https://blueprints.launchpad.net/openstack-manuals
20:10:36 <annegentle> #topic Operations manual
20:10:44 <annegentle> #link https://blueprints.launchpad.net/openstack-manuals/+spec/openstack-operations-manual
20:10:47 <joesavak> #action joe to review bps and cdt product roadmap and update bps accordingly
20:11:02 <annegentle> targeted as f3
20:11:21 <annegentle> which is August 16th
20:11:38 <lorin1> Sorry, what's cdt?
20:12:02 <annegentle> #info some dependencies on Rackspace and TryStack for operations manual
20:12:12 <joesavak> cdt = cloud doc tools - the team that created and helps to maintain the cloud docs maven plugin
20:12:25 <bfcohen> FOr me it depned on the RS training project.  Should be begining of June and it will last 2-3 months.  Much of what I will need to do will be useable for the project.
20:14:15 <annegentle> Trystack does some of their admin doc in Google Docs, maybe keep updating that in the interim?
20:14:35 <bfcohen> I am most comfortable in Word and it is off-line so I can work on it anytime.  Then upload it to the repository.
20:14:58 <annegentle> #info work ongoing on the operations manual, in your own toolset
20:15:02 <lorin1> annegentle: Are the TryStack admin google docs public?
20:15:14 <annegentle> lorin1: no, they contain admin passwords and the like
20:15:22 <lorin1> annegentle: Ahh
20:16:40 <bfcohen> Realistically we will be spilling over into September because of vacations and general summer slowdown.
20:16:55 <annegentle> #info leaving the f3 target for the operations manual, knowing full well it'll go til Sept 27th (Folsom release date)
20:17:32 <annegentle> #topic Deployment template
20:18:07 <annegentle> #link http://etherpad.openstack.org/deployment-template
20:18:32 <annegentle> I tried to collect the questions as well as a list of configuration files
20:18:58 <annegentle> #info best first two candidates for collecting info are TryStack and Mediawiki
20:19:09 <lorin1> That's great, I didn't know it existed. I created the wiki page http://wiki.openstack.org/RealDeployments that seems to overlap this.
20:19:20 <annegentle> lorin1: yeah I found that too! Added it to the blueprint
20:19:42 <annegentle> #link https://blueprints.launchpad.net/openstack-manuals/+spec/deployment-template
20:19:58 <lorin1> When the Argonne guys finish their transition to essex, I think you'll be able to get details from them as well.
20:20:35 <annegentle> questions: how to sanitize data? How to gather it into one place, is the wiki page enough?
20:21:07 <lorin1> I think these should ultimately be turned into first-class standalone docs.
20:21:31 <annegentle> lorin1: ok, I like it - standalone title suggestions?
20:22:16 <lorin1> Maybe something like: "Case study: Mediawiki" or "Documented deployment: Mediawiki", … ?
20:23:19 <annegentle> lorin1: deep dive deployment: Mediawiki?
20:23:30 <lorin1> annegentle: Sounds good to me
20:23:37 <bfcohen> How about definitive Openstack Docs or Authoritative Openstack Docswiki
20:23:39 <annegentle> kinda corny :)
20:24:36 <annegentle> there are less detailed case studies called "User Stories" at http://openstack.org/user-stories/, these are different.
20:25:03 <annegentle> Reference Architecture: TryStack? Reference Architecture: MediaWiki?
20:25:42 <lorin1> I was thinking that "Reference Architecture" would be more of an idealized "This is how you should do it in a perfect world" example.
20:25:50 <lorin1> These are more: "What we actually did" examples.
20:26:18 <lorin1> I think we need reference architecture docs as well.
20:26:19 <annegentle> so I have "deployment-template" targeted for folsom-1, I'll check with MediaWiki and TryStack to see if that's crazytalk.
20:26:20 <annegentle> .
20:27:33 <annegentle> lorin1: can you talk a bit about what is required for a ref. arch? diagrams?
20:28:00 <bfcohen> Diagrams are great.
20:28:12 <lorin1> annegentle: I would include all example config files, network architecture diagrams, network configuration settings...
20:28:16 <bfcohen> Also metric criteria for the decision process
20:28:28 <annegentle> wowsa
20:29:35 <annegentle> examples: number of concurrent users, number of sessions, length of sessions
20:29:55 <annegentle> Ok, seems reasonable.
20:29:58 <bfcohen> FOr swift, profiles of object files
20:30:33 <lorin1> Maybe even some use case language: "e.g., multitenant IaaS provider"
20:30:45 <bfcohen> Nova: Images, types, service catalog
20:31:37 <annegentle> I'm going to leave it targeted as-is, adjust as needed - anyone else want to work on it besides me?
20:31:50 <bfcohen> I did much of this work for a client.
20:31:56 <annegentle> ok, good
20:32:18 <annegentle> ok, next blueprint
20:32:39 <annegentle> #topic API try-it-out
20:32:50 <annegentle> so I haven't found a taker for this one
20:32:56 <bfcohen> What is this?
20:33:05 <annegentle> #link https://blueprints.launchpad.net/openstack-manuals/+spec/api-try-it-out
20:33:16 <bfcohen> SInce I can't code in Jave, or much of anything, not me.
20:33:27 <lorin1> Is that even technically possible yet?
20:33:36 <annegentle> lorin1: for Trystack, I think so
20:33:45 <bfcohen> This iQA.  Canb this be scripted.
20:35:02 <dwcramer> https://en.wikipedia.org/wiki/Small_matter_of_programming
20:35:15 <joesavak> :-)
20:35:18 <annegentle> #info just a "small matter of programming" - if you know of someone who may want to pick it up, let 'em know its there
20:35:38 <annegentle> Could be a nice intern project.
20:35:48 <annegentle> any Qs?
20:36:12 <annegentle> #topic metadata in docs
20:36:13 <bfcohen> Get that Intern with Java skills.
20:36:34 <annegentle> #link https://blueprints.launchpad.net/openstack-manuals/+spec/doc-metadata
20:38:55 <annegentle> #info this blueprint is a good first step, next steps would be in CI team area
20:39:12 <annegentle> The CI team blueprint is tracked here: https://blueprints.launchpad.net/openstack-ci/+spec/ci-doc-automation
20:40:52 <bfcohen> This meta-data also tracks the revisions is that correct?
20:41:51 <annegentle> #info metadata we could include automatically would be git SHA, version of the plugin used to build the particular page, but there may be manual insertions as well.
20:43:24 <annegentle> We might need to come up with more info we want - such as what's the upper level filename for that section?
20:44:19 <bfcohen> How important is this for people.  That will determine how promident it is!
20:45:03 <annegentle> #action: put a list of pertinent metadata into the blueprint
20:46:21 <annegentle> #topic Getting Started documentation
20:46:45 <annegentle> It seemed like a lot of guides came in last week.
20:48:20 <annegentle> I definitely want to curate more, like http://wiki.openstack.org/BloggersTips.
20:48:53 <reed> i sometimes check it and add links to the weekly community newsletter from it
20:49:35 <annegentle> We haven't found a WordPress solution, really.
20:50:29 <annegentle> #idea canned search for curated sites
20:51:16 <annegentle> the search at the top of docs.openstack.org is a Google Custom Search Engine, could expand the scope to more sites, including blog posts
20:51:49 <reed> I like the idea, it's a good/simple solution
20:52:10 <annegentle> #action Anne to add individual blog posts to Google CSE
20:52:59 <reed> https://support.mozilla.org/
20:53:07 <annegentle> #link http://support.mozilla.org - custom-built knowledge base
20:53:41 <annegentle> it would be better to have one place for "Answers" rather than all the project sites
20:54:03 <bfcohen> System admins like to go to one place , not five.  Especially since some of their issues will be across the Openstack projects.
20:54:31 <annegentle> #info the Mozilla knowledge base engine is open source and available on github
20:55:28 <annegentle> #info also the Mozilla knowledge base engine enables multi-language
20:56:42 <annegentle> If you'd like to make this project a "real" project with high priority, contact reed.
20:56:47 <annegentle> #topic Doc tools update
20:57:12 <annegentle> joesavak: what's in the next CDT release that OpenStack wants to know about?
20:57:37 <annegentle> ok, dwcramer is explaining on Skype, I'll take notes. :)
20:57:38 <joesavak> removed ~200 lines of WADL from pom
20:57:45 <joesavak> (hi)
20:57:48 <annegentle> #info pom.xml much simpler for WADL pointers
20:59:15 <annegentle> #topic Open discussion
20:59:26 <bfcohen> I love the two track discussions!  Keep ity up
21:00:50 <annegentle> Ok, thanks all! Next one's next month!
21:01:00 <annegentle> #endmeeting