21:01:07 <ttx> #startmeeting
21:01:08 <openstack> Meeting started Tue May 15 21:01:07 2012 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:01:09 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:01:09 <devcamcar> o/
21:01:13 <notmyname> ttx: o/
21:01:17 <ttx> Today's agenda: http://wiki.openstack.org/Meetings/ProjectMeeting
21:01:18 <jgriffith> o/
21:01:27 <ttx> #info We have one week left before folsom-1 milestone-proposed cut
21:01:36 <ttx> so for affected projects we'll be reviewing progress against published milestone goals
21:01:49 <ttx> #info General release status page is back, available at:
21:01:53 <ttx> #link http://wiki.openstack.org/releasestatus/
21:02:16 <ttx> In other news, would be good if you could let me know what you think of:
21:02:28 <ttx> https://lists.launchpad.net/openstack/msg11678.html (the open bug triager thread)
21:02:42 <ttx> if you haven't cast your opinion yet, let me know what you think
21:03:02 <bcwaldon> ttx: that release status page is awesome
21:03:19 <ttx> It existed in previous releases as well :P
21:03:32 <ttx> #topic Nova status
21:03:38 <ttx> vishy: hey
21:03:44 <ttx> #link https://launchpad.net/nova/+milestone/folsom-1
21:04:00 <ttx> versioned-rpc-apis (russellb, needscodereview): was all code proposed for that ?
21:04:04 <ttx> or is there more to it ?
21:04:26 <vishy> I think that is all of it.  russellb ^^ ?
21:04:26 <russellb> that's all of it
21:04:36 <ttx> ok, cool
21:04:41 <ttx> finish-uuid-conversion (mikal, goodprogress): are we getting closer to code proposed ?
21:04:42 <russellb> well ... i haven't converted the network or volume rpc apis, actually.
21:05:33 <ttx> fwiw I need to work on more gerrit/LP integration to more accurately drive the status of blueprints from commit messages
21:05:44 <ttx> which would remove the need for most of those questions
21:05:55 <vishy> russellb: that is ok, I don't see any point in those
21:05:57 <russellb> volume because i didn't want to interfere with heavy cinder dev, and network because ... well i don't remember why.  i think i just figured that code isn't changing.
21:06:00 <russellb> ok cool
21:06:14 <russellb> then yes, that's all of it.
21:06:23 <vishy> ttx: there are only two tables left to convert
21:06:39 <ttx> ok, so looking on track
21:06:43 <ttx> volume-decoupling (vishy, goodprogress): same question ?
21:06:47 <vishy> not sure if mikal is here for status update
21:07:11 <vishy> ttx: there are a few items left, not sure that all of them will be done for folsom-1
21:07:35 <vishy> ttx: they depend on having a functioning cinderclient, so probably going to defer the later items to folsom-2
21:07:43 <ttx> ok. We'll talk about Cinder progress just after Nova
21:07:51 <ttx> Back to nova folsom-1: 2 targeted bugs
21:07:55 <ttx> https://bugs.launchpad.net/nova/+bug/990019 seems to need a new push to pass the gate
21:07:56 <uvirtbot> Launchpad bug 990019 in nova "Self links don't contain tenant id for server entity in images response" [Undecided,In progress]
21:08:15 <ttx> on https://review.openstack.org/#/c/6979/
21:08:30 <ttx> and https://bugs.launchpad.net/nova/+bug/966329 looks abandoned to me. jk0 ? bcwaldon ?
21:08:31 <uvirtbot> Launchpad bug 966329 in nova "RAX-specific auth in novaclient" [Low,In progress]
21:08:38 <vishy> yes if he doesn't rebase in the next couple days i will rebase
21:09:01 <bcwaldon> ttx: I'll follow up with westmaas on that
21:09:06 <ttx> bcwaldon: thx
21:09:30 <ttx> #action bcwaldon to follow up on bug 966329 status
21:09:31 <uvirtbot> Launchpad bug 966329 in nova "RAX-specific auth in novaclient" [Low,In progress] https://launchpad.net/bugs/966329
21:09:36 <ttx> A quick look at the general folsom plan at:
21:09:40 <ttx> #link https://blueprints.launchpad.net/nova/folsom
21:09:47 <ttx> vishy: Looks pretty complete to me. Should I set all the ones with undefined priorities to Low ?
21:10:28 <ttx> or will you adjust them more precisely ?
21:10:34 <vishy> ttx: I was going to go through them
21:10:42 <vishy> I haven't prioritized stuff after folsom-1 yet
21:10:56 <ttx> #action vishy to adjust 'undefined' folsom bp priorities
21:11:02 <ttx> 2 bps are targeted but without folsom series goal: instance-type-extra-specs-extension and per-user-quotas
21:11:20 <ttx> Want me to add them to folsom series goal ?
21:12:01 <vishy> i think those are new ones i havent looked at yet
21:12:39 <ttx> #action vishy to look at instance-type-extra-specs-extension and per-user-quotas for potential inclusion in folsom series goal
21:12:51 <ttx> Last remark: In general it would be good if assignees could set the milestone where they think their folsom-goal blueprints will land.
21:13:00 <vishy> ok looked, will approve them
21:13:00 <ttx> it's not really the PTL's job :)
21:13:16 <ttx> vishy: Anything else ?
21:13:44 <ttx> Questions on Nova ?
21:13:57 <vishy> yes
21:14:12 <vishy> So I announced last week that I'm going to clean house on blueprints
21:14:20 <vishy> Last chance before I obsolete them all!
21:14:30 <ttx> do it do it do it
21:14:37 <vishy> (This is reversible so if someone notices later it isn't too big of a deal)
21:14:46 <russellb> NO WAIT!
21:14:50 <russellb> jk.
21:14:58 * vishy beheads russelb
21:15:04 <ttx> jgriffith: could you give us a quick update on how Cinder is going so far ?
21:15:09 <russellb> eep
21:15:13 <jgriffith> ttx: yep
21:15:25 <jgriffith> Still working mostly on decoupling efforts
21:15:48 <ttx> jgriffith: should we make a proof-of-concept folsom-1 cut next week ? Or would that be totally useless ?
21:15:53 <jgriffith> Hopefully the last of the volume FK dependencies is removed with the bug I'm workign on now
21:15:58 <jgriffith> ttx: useless
21:16:07 <ttx> jgriffith: even on the client side ?
21:16:10 <jgriffith> ttx: I'm targetting F2 for functional
21:16:30 <jgriffith> ttx: I could be persuaded but I don't think it's realistic
21:16:33 * ttx is begging for more work
21:16:39 <jgriffith> ttx: :)
21:16:56 <ttx> jgriffith: ok then :)
21:16:57 <jgriffith> Currently it's me vish and jesse
21:17:06 <jgriffith> jesse has been out, but he's back in starting tomorrow
21:17:20 <jgriffith> Should see some good progress in the next week but not enough to stand up I don't think
21:17:39 <jgriffith> I'd like to see functional drop in by F2, that's been my goal all along
21:18:02 <ttx> jgriffith: I'll use folsom-1 to check if the CI stuff is up to snuff, but won't produce tarballs.
21:18:23 <ttx> jgriffith: anything more ?
21:18:30 <jgriffith> ttx: More than fair... good news is the CI stuff w/ exception of pythong-cinderclient should be good to go
21:18:42 <jgriffith> ttx: Nope, think that sums it up for now
21:18:47 <ttx> cool.
21:18:55 <ttx> Back to our regular schedule then.
21:19:03 <ttx> #topic Keystone status
21:19:03 <jgriffith> s/pythong/python/ :)
21:19:09 <ttx> heckj: o/
21:19:12 <ttx> #link https://launchpad.net/keystone/+milestone/folsom-1
21:19:37 <ttx> heckj: Both blueprints now in good progress ?
21:19:45 <heckj> good progress on the V3 keystone API draft - should have it up for public review this weekend.
21:20:09 <ttx> heckj: publication would complete this informational blueprint, right ?
21:20:13 <heckj> The tokenID/URI is in patches getting kicked back and forth between ayound and gyee, getting close to landing for a code review
21:20:27 <heckj> ttx: yes, publication will complete it
21:20:34 <ttx> ok
21:20:47 <ttx> 3 open targeted bugs... a few of them look stuck to me:
21:20:56 <ttx> https://bugs.launchpad.net/keystone/+bug/856887
21:20:57 <uvirtbot> Launchpad bug 856887 in keystone "Keystone cannot listen on IPv6" [Medium,In progress]
21:21:04 <ttx> This one should be turned into a blueprint and probably targeted to another milestone ?
21:21:52 <heckj> ttx: yeah, it probably should. DOn't know that it'll make a f1 milestone
21:22:05 <heckj> I'll do that
21:22:10 <ttx> https://bugs.launchpad.net/keystone/+bug/963098
21:22:11 <uvirtbot> Launchpad bug 963098 in keystone "Keystone isn't acting on consecutive failed logins" [High,Triaged]
21:22:21 <ttx> I think this one should be closed as FILED_AS_BLUEPRINT_NOW
21:22:54 <ttx> No need for duplicate pointers. I can do that for you.
21:23:03 <heckj> k
21:23:12 <ttx> Looking at the rest of the folsom plan at: https://blueprints.launchpad.net/keystone/folsom
21:23:24 <ttx> Does that plan fully reflect your folsom objectives ?
21:23:53 <heckj> at this time, yes. We might be able to bring some of PKI in earlier, depending on progress. Playing it by ear, will if we can.
21:24:14 <heckj> Announced the page and details to the list earlier today - it will mean new dependencies for the PKI related library to the project(s)
21:24:30 <ttx> heckj: could you set priorities so that we make sure essential stuff is properly tracked ?
21:24:46 <heckj> will do
21:24:53 <ttx> #action heckj to set priorities on https://blueprints.launchpad.net/keystone/folsom
21:24:59 <ttx> At first glance there seems to be a lot targeted to folsom-3 compared to folsom-{1,2}
21:25:03 <ttx> But based on the priorities you set it may or may not matter that much.
21:25:15 <ttx> heckj: anything else ?
21:25:27 <heckj> questions for Keystone?
21:26:27 <ttx> none apparently, switching to swift
21:26:30 <notmyname> o/
21:26:31 <ttx> #topic Swift status
21:26:37 <ttx> #link https://launchpad.net/swift/+milestone/1.5.0
21:26:46 <ttx> How are the splits into associated projects going so far ?
21:27:04 <notmyname> in progress. may have happened, but a few are still outstanding
21:27:07 <ttx> Oh. Two new blueprints since I last looked
21:27:13 <notmyname> :-)
21:27:20 <ttx> Is that task assigned to the whole core team, or to a specific individual ?
21:27:24 <notmyname> they are currently proposed patches
21:27:40 <notmyname> the associated projects split? that involves nearly everyone
21:27:52 <ttx> notmyname: ack
21:28:02 <ttx> Still on track for an end-of-May/start-of-June release ?
21:28:09 <notmyname> I still hope that 1.5.0 will be ready by the end of the month, but no promises yet
21:28:17 <notmyname> I'll have a better idea by next week
21:28:20 <ttx> works for me.
21:28:53 <ttx> So "expand swift recon support" and "proxy logging middleware" are already proposed changes ?
21:29:17 <notmyname> yes
21:29:18 <ttx> will mark them "good progress".
21:29:22 <ttx> notmyname: Anything else ?
21:29:29 <notmyname> not from me
21:29:34 <ttx> Questions on Swift ?
21:30:13 <ttx> #topic Glance status
21:30:17 <ttx> bcwaldon: yo
21:30:21 <ttx> #link https://launchpad.net/glance/+milestone/folsom-1
21:30:22 <bcwaldon> ttx: hey hey
21:30:38 <ttx> I suspect the status is accurate on your 7 targeted blueprints ?
21:30:48 <bcwaldon> Yep, making great progress on the v2 API
21:30:53 <ttx> Looks all on-track
21:31:08 <bcwaldon> Josh Harlow's blueprint has a patch waiting to go through jenkins
21:31:28 <bcwaldon> I'll add in more bp's as I get to them
21:32:00 <ttx> 4 open targeted bugs, mostly on track as well.
21:32:11 <ttx> https://bugs.launchpad.net/glance/+bug/994609
21:32:12 <uvirtbot> Launchpad bug 994609 in glance "wsgi.Server() starts but is broken on osx (test_multiprocessing never ends)" [Critical,In progress]
21:32:17 <ttx> I suspect there is more to this than just https://review.openstack.org/#/c/7172/
21:32:26 <ttx> Anyone working on completing it ? Or should the bug be split ?
21:32:28 <bcwaldon> ttx: commented on that this morning
21:32:37 <bcwaldon> ttx: I think Patrick will do it, he was waiting on me to answer
21:32:43 <bcwaldon> ttx: definitely my bad there
21:32:49 <ttx> ok
21:33:06 <ttx> https://bugs.launchpad.net/bugs/988099
21:33:07 <uvirtbot> Launchpad bug 988099 in glance "Monkey patch all the (eventlet) things" [Medium,In progress]
21:33:11 <ttx> Might need its change resubmitted.
21:33:26 <bcwaldon> maybe s1rp can follow up on that
21:33:27 <ttx> (was abandoned while we were looking the other way)
21:33:39 <ttx> https://review.openstack.org/#/c/6788/
21:34:03 <ttx> In the meantime, let's look at the rest of Folsom now:
21:34:24 <ttx> #link https://blueprints.launchpad.net/glance/folsom
21:34:35 <ttx> There are a number of undefined priorities there. Should those all be set to Low ?
21:34:59 <bcwaldon> the bottom 4 are not yet defined as a feature, so I'm not willing to prioritize them
21:35:06 <bcwaldon> the 5th from the bottom I will take care of now
21:35:39 <ttx> There are also a bit too much of "Essential" in there. Essential means "defer release if not here", which makes me nervous and annoying.
21:35:52 <ttx> So if you can downgrade a few of the Essential to "High" priority where it makes sense...
21:36:02 <bcwaldon> ttx: why's that?
21:36:13 <bcwaldon> ttx: to me, Essential means its gotta happen
21:36:24 <bcwaldon> ttx: High is I'd like to have it but we can ship without it
21:37:09 <ttx> You understand it well. It's just that when essential stuff is not completed by folsom-2 I tend to start knocking at your door.
21:37:26 <bcwaldon> ttx: everything Essential will be done by folsom-2, I promise
21:37:26 <ttx> but if that's what you really meant, it's ok. I guess :)
21:37:42 <ttx> #info <bcwaldon> ttx: everything Essential will be done by folsom-2, I promise
21:37:44 <ttx> amen
21:37:46 <bcwaldon> crap
21:37:50 <ttx> bcwaldon: Anything else you wanted to mention ?
21:38:00 <bcwaldon> negatory
21:38:07 <ttx> Questions on Glance ?
21:38:39 <ttx> #topic Quantum status
21:38:43 <ttx> danwent: hey
21:38:45 <danwent> o/
21:38:46 <ttx> #link https://launchpad.net/quantum/+milestone/folsom-1
21:38:59 <danwent> So we decided to bump the keystone stuff to F-2, just not going to happen.
21:39:15 <danwent> key focus in on v2.0 API
21:39:16 <ttx> which bp is that ?
21:39:34 <danwent> https://blueprints.launchpad.net/quantum/+spec/authorization-support-for-quantum
21:39:39 <ttx> ack
21:39:41 <danwent> ah sorry, that's the keystone one
21:39:46 <ttx> melange-integration (jkoelker, started): what's the status of this ? Any chance it will be completed before Tuesday next week ?
21:39:49 <danwent> wasn't sure what you were asking for.
21:40:06 <danwent> ttx: yes, I jkoelker and _cerberus_  are full speed on this one.
21:40:25 <ttx> database-common (garry kotton, needscodereview): is that completed by https://review.openstack.org/#/c/7169/ ? The commit message there was particularly unhelpful.
21:40:32 <danwent> its a lot of work, but its also the top prority for the project, so I expect everyone to chip in and help out
21:40:57 <ttx> https://blueprints.launchpad.net/quantum/+spec/database-common
21:41:00 <danwent> ttx: yes, please refresh
21:41:16 <ttx> argh.
21:41:24 <danwent> that one merged in, but missed the automated hooks
21:41:28 <ttx> exposed by caching
21:41:47 <ttx> man-support: in folsom-1 but not is folsom series goal, should I fix that for you ?
21:41:57 <danwent> sure
21:42:15 <ttx> Looking now at the more generic plan for folsom at:
21:42:19 <ttx> #link https://blueprints.launchpad.net/quantum/folsom
21:42:25 <ttx> There are a number of folsom-2 blueprints that are missing the series goal, let me know if I should set those for you:
21:42:32 <ttx> quantum-l3-fwd-nat, provider-networks, quantum-horizon, improved-nova-quantum-integration, new-cli, scalable-agent-comms
21:42:56 <danwent> sorry, will do that :)
21:43:06 <ttx> danwent: I can do it
21:43:17 <ttx> I actually have a script to catch the discrepencies.
21:43:22 <danwent> nice
21:43:44 <ttx> Does that folsom page represent all you had in store ? Or is there a lot more coming ?
21:43:55 <ttx> #action ttx to fix series goal for quantum/folsom bps
21:44:02 <danwent> ttx: we're putting everything critical in F-1 and F-2
21:44:20 <ttx> this is how I like it
21:44:22 <danwent> anything else if opportunistic for Folsom..
21:44:30 <ttx> danwent: Anything else ?
21:44:37 <danwent> dont' think so.
21:44:39 <ttx> Questions on Quantum ?
21:45:10 <ttx> #topic Horizon status
21:45:15 <ttx> devcamcar: o/
21:45:18 <devcamcar> o/
21:45:19 <ttx> #link https://launchpad.net/horizon/+milestone/folsom-1
21:45:24 <ttx> Status looks good to me on the blueprint side... no red flags ?
21:45:29 <devcamcar> no big updates since last week - folsom 1 is moving well
21:45:43 <devcamcar> i still owe blueprints for folsom 2
21:45:49 <ttx> I'm a bit more scared about the 20+ F1-targeted bugs
21:46:01 <ttx> I guess we'll refine that list before we hit the milestone-proposed cut Tuesday next week
21:46:05 <devcamcar> we're making steady progress on them
21:46:08 <devcamcar> sounds good
21:46:34 <ttx> Looking at folsom plan at: https://blueprints.launchpad.net/horizon/folsom
21:47:11 <ttx> does it represent your current Folsom goals ?
21:47:15 <devcamcar> still owe a blueprint for proper quantum integration
21:47:25 <devcamcar> and a few smaller ones, but yes this is pretty much accurate
21:47:34 <ttx> unfortunately, contrary to bugs, blueprints do not support multiple projects
21:47:40 <devcamcar> yea
21:48:06 <danwent> devcamcar:  i actually have "sister" bps in quantum
21:48:18 <devcamcar> once we have https://blueprints.launchpad.net/horizon/+spec/workflows that will enable a great quantum integration
21:48:18 <danwent> sharing them would be much nicer
21:48:37 <devcamcar> danwent: yea that would be nice. maybe some day :)
21:48:41 <ttx> the idea is to use those "Folsom" pages, togther with prioritization, to make sure the important stuff lands
21:48:48 <ttx> devcamcar: Anything else ?
21:49:00 <devcamcar> ttx: sounds good
21:49:04 <devcamcar> thats it for me
21:49:19 <ttx> thanks to gabrielhurley for championing our I18N effort, btw
21:49:28 <ttx> Questions for Horizon ?
21:49:54 <gabrielhurley> ttx: happy to :-)
21:50:07 <ttx> #topic Other Team reports
21:50:23 <gabrielhurley> ttx: I'll be working with heckj on keystone i18n coming up soon
21:50:26 <gabrielhurley> just fyi
21:50:34 <ttx> Anyone from docs team ?
21:51:05 <ttx> annegentle asked me to post the link to the Docs team meeting minutes
21:51:09 <ttx> #link http://eavesdrop.openstack.org/meetings/openstack-meeting/2012/openstack-meeting.2012-05-14-19.59.html
21:51:26 <ttx> the docs team had a meeting yesterday.
21:51:49 <ttx> mtaylor/jaypipes: anything from CI/QA land ?
21:52:10 <ttx> like an online tempest gate ?
21:53:06 <ttx> Note that in addition to a I18N advocacy team, we should soon have a Python 3 advocacy team
21:53:24 <ttx> formed after the meeting we had at the openstack design summit
21:53:42 <ttx> Any other team lead with a status report ?
21:54:14 <ttx> #topic Open discussion
21:54:19 <ttx> Anything else, anyone ?
21:56:15 <oubiwann2> ttx: who should we contact about the Python 3 advocacy team?
21:56:31 <ttx> oubiwann: Mike Pittaro should send an email about this soon
21:56:35 <oubiwann2> nice
21:56:45 <oubiwann2> I know dhellmann will be very interested in that :-)
21:56:52 <ttx> oubiwann: how is the ML setup going ?
21:57:20 <oubiwann2> jeblair: has some changes for puppet that should be landing soon
21:57:32 <oubiwann2> this will give us Exim configured for mailman
21:57:46 <oubiwann2> the next step is getting some DNS setup so we can start testing
21:58:03 <oubiwann2> *DNS set up, rather ;-)
21:58:10 <oubiwann2> (verb, not noun)
21:58:58 <ttx> ok then
21:59:05 <ttx> #endmeeting