18:01:12 <jgriffith> #startmeeting
18:01:13 <openstack> Meeting started Thu May 17 18:01:12 2012 UTC. The chair is jgriffith. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:01:14 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
18:01:28 <jgriffith> volume folks around today?
18:01:36 <rnirmal> I'm here
18:01:51 <jgriffith> rnirmal: howdy!
18:02:22 <rnirmal> hey jgriffith ... hope it's not another silent meeting :)
18:02:25 <jgriffith> rnimral: can you take a look at https://review.openstack.org/#/c/7537/ when you get a chance?
18:02:44 <jgriffith> rnirmal: me too
18:03:07 <jgriffith> Folks are typically a few minutes late, or jump in when they see their name mentioned :)
18:03:10 <rnirmal> jgriffith: I looked at it... and fell I'll have to run it to get a gauge, that's a lot of chagnes... great job putting it together
18:03:43 <jgriffith> rnirmal: Yeah, it's a big set, but the good thing is it's realy just a copy of novaclient
18:04:02 <rnirmal> jgriffith: that's good, yeah I'll look thru it.
18:04:06 <jgriffith> rnimral: anotherjesse made a bunch of changes to strip extras out and get it running on his cloud
18:04:11 <rnirmal> do you know if this will get merged in soon https://review.openstack.org/#/c/7406/
18:04:52 <jgriffith> rnirmal: Just waiting on an approve... changes to transfer to cinder I don't believe
18:05:06 <jgriffith> changes *don't* transfer to cinder
18:05:22 <rnirmal> jgriffith: ok just checking... atleast it affects us in nova right now
18:05:31 <rnirmal> and would like to get in soon
18:05:40 <jgriffith> rnirmal: Yeah, it's out of my hands now :)
18:05:50 <rnirmal> I'll ask vishy if it's pending other +1's
18:06:40 <rnirmal> jgriffith: do you just want to talk about cinder client and where we are with it. others can atleast look at the meeting mins.
18:07:02 <jgriffith> rnirmal: yep, I was going to run through cinder status updates real quick
18:07:25 <jgriffith> #topic cinder status
18:07:35 <DuncanT> oooops, hi all
18:07:39 <jgriffith> Yo
18:07:51 <jgriffith> So the big news right now is python-cinderclient
18:08:02 <jgriffith> It's working, unit tests passing etc
18:08:31 <jgriffith> anotherjesse tweaked an os setup yesterday and plugged it into horizon
18:08:41 <jgriffith> was able to test it against nova-volume
18:08:46 <jgriffith> create/delete etc
18:08:50 <jgriffith> Looks good
18:09:17 <jgriffith> dtroyer is working on devstack integration... he had one submittal for it already
18:09:45 <jgriffith> I tried it out this morning and hit a couple of issues, but there are some changes to what we're going to do and I believe he's working on them
18:10:01 <jgriffith> The idea is to be able to use cinderclient to do all of the nova-volume stuff
18:10:14 <jgriffith> This way we have something to test against
18:10:14 <rnirmal> cool... so is the plan to remove nova volume-* from novaclient. or keep it till the next release
18:10:38 <rnirmal> and switch to cinderclient for all volume purposes
18:10:49 <jgriffith> Depending on how things go I could see it out for Folsom and switched to cinder
18:11:01 <jgriffith> But we'll have to prove things out pretty well before that happens
18:11:20 <jgriffith> Or we may do like quantum and have both, don't know where those discussions ended but we'll have them again
18:11:32 <rnirmal> ok
18:12:03 <jgriffith> So we have a working client, we're getting things set up now for devstack to let us actually use cinder or nova-volume
18:12:50 <jgriffith> There are some new blueprints to look at: https://blueprints.launchpad.net/cinder
18:13:17 <jgriffith> If you pull up: #link https://blueprints.launchpad.net/cinder/+spec/python-cinder-client
18:13:42 <jgriffith> you cna see jesse put together a dependency graph that you can click on for the various pieces
18:14:20 <rnirmal> cool that looks good. we have a set of blueprints to move forward on
18:14:37 <rnirmal> are we going to start targeting them for milestones?
18:14:56 <jgriffith> Yes, I started that already I believe
18:15:01 <jgriffith> cinderclient is f1
18:15:23 <jgriffith> I believe extract-nova-volumes is f2
18:15:34 <jgriffith> or it "is"
18:16:09 <jgriffith> I think the others are sort of partials in f1 and targetted for f2
18:16:48 <jgriffith> I think that's the quick low down...
18:17:07 <jgriffith> anything people are wondering about specifically or might know that I missed?
18:17:47 <rnirmal> nothing that I can think of for the immediate short term
18:17:51 <jgriffith> The next thing I was going to start looking at was implementing the ability to specify cinder in nova
18:17:56 <jgriffith> ie alternate volume driver
18:18:09 <jgriffith> for a while we want to keep both obviously
18:18:29 <rnirmal> jgriffith: hmmm alternate volume manager or volume driver?
18:18:38 <jgriffith> sorry...neither
18:18:40 <jgriffith> API :)
18:18:55 <jgriffith> plugin like glane and quantum do...
18:19:15 <jgriffith> or "configurable" I guess is the right way to say it
18:19:33 <rnirmal> yeah... should be easy just switching endpoints
18:20:01 <jgriffith> rnirmal: famous last words
18:20:16 <rnirmal> :)
18:21:06 <jgriffith> don't think I have much else if there aren't any items other folks want to talk about?
18:21:14 <rnirmal> jgriffith: do you want to briefly discuss keeping things in sync between nova-volumes and cinder
18:21:23 <jgriffith> rnirmal: sure
18:21:28 <rnirmal> back porting or forward porting
18:21:40 <jgriffith> So we're comitted to staying in sync obviously
18:21:56 <jgriffith> I don't know of any big changes/bp's coming to worry about
18:22:10 <rnirmal> that's one thing I think we kinda decided upon
18:22:20 <rnirmal> no new features in nova-volumes.. they'll just go into cinder
18:22:20 <jgriffith> at the stage cinder is at right now it shouldn't be a major issue
18:22:28 <rnirmal> but it's mostly about bugs and minor enhancements
18:22:33 <jgriffith> rnirmal: ahhh... well....
18:22:47 <jgriffith> I tihnk if a feature is proposed it has to be addressed on a case by case
18:23:03 <jgriffith> cinder isn't in and core yet so nova-volume has to continue IMHO
18:23:30 <rnirmal> +1 on that. but how do we keep track of the changes
18:23:40 <jgriffith> In most cases it might mean it's implemented in both places like cpq16's work
18:23:45 <rnirmal> I guess we'll just have to follow and volume changes
18:23:48 <rnirmal> and/any
18:24:15 <rnirmal> yeah I asked cp16 to get it into both
18:24:19 <jgriffith> So I check gerrit constantly... also I would hope that nova core keeps transition in mind
18:24:26 <rnirmal> so looks like we'll just have to be on the lookout
18:24:59 <rnirmal> so there's one bug/enhancement I submitted to nova.. haven't done to cinder yet.. I'll do that soon
18:25:00 <jgriffith> also although it may be lame I'm doing diffs between cinder and nova-v every once in a while
18:25:12 <jgriffith> rnimral: which one?
18:25:45 <rnirmal> jgriffith: https://bugs.launchpad.net/nova/+bug/992729
18:25:47 <uvirtbot> Launchpad bug 992729 in nova "Add 'host' name to initialize/terminate volume connection" [Undecided,Fix committed]
18:26:26 <jgriffith> rnirmal: they can't just work off of the ip address?
18:26:53 <rnirmal> it's easier to for managing with hostnames.. they can work off ip address
18:27:07 <jgriffith> ok, thus enhancement versus bug :)
18:27:20 <rnirmal> yeah.. not all drivers have to use it
18:27:44 <jgriffith> Ya know I could solve this problem more easily for you..... ;)
18:28:08 <rnirmal> jgriffith: yeah I hear you
18:28:16 <jgriffith> LOL
18:28:35 <jgriffith> alrighty...
18:28:41 <rnirmal> so coming back to the point... how do we solve this... just make then as affecting both projects
18:28:48 <rnirmal> make/mark them
18:29:03 <jgriffith> Yeah, fill in the also affects project
18:29:11 <jgriffith> That's what I did at least
18:29:51 <jgriffith> Seems like the right way to go to me
18:30:08 <rnirmal> ok cool that works. just added that one.. so I'll do that for any volume changed in nova I come across
18:30:16 <jgriffith> excellent!
18:30:45 <jgriffith> #action jgriffith mention nova/cinder relationship for changes at next project meeting
18:31:16 <clayg> sorry I just joined, for cinder I'll look at the logs and try to be on time next week
18:31:16 <jgriffith> I'll bring this up again at next project meeting, maybe if everybody on nova core is aware that will help
18:31:28 <jgriffith> clayg: No worries...
18:31:52 <jgriffith> clayg: If you had anything specific though feel free...
18:31:59 <rnirmal> clayg: awesome...more participation is needed at this point
18:32:21 <clayg> jgriffith: nothing specific, just trying to be more present
18:32:42 <jgriffith> :)
18:33:17 <DuncanT> Craig Vyvial's notification changes are the only thing I've really looked at this week. Been trying to get an answer off our billing people about whether we've had to add anything that isn't currently provided by Craig's patch. No definite answer yet
18:33:52 <jgriffith> Yeah.. nice catch you and rnirmal on those reviews
18:34:27 <jgriffith> DucnanT: keep us all in the loop if there ends up being more to come
18:34:38 <jgriffith> again keeping nova-v and cinder in sync
18:34:38 <rnirmal> DuncanT: that's good would like to get more input on that
18:35:10 <rnirmal> we went with what we felt had the most info. but we would be missing some pieces in the notifications
18:35:15 <jgriffith> DuncanT: Also if you get a chance https://review.openstack.org/#/c/7537/
18:35:20 <jgriffith> :)
18:35:45 <jgriffith> I'd like to get that sucker pushed and close my personal repo ASAP
18:35:55 <DuncanT> jgriffith: I'll review that in the morning if not before
18:36:04 <jgriffith> thanks!
18:36:15 <jgriffith> Oh yeah... what time is it there?
18:36:16 <rnirmal> jgriffith: are you going to reset the openstack/python-cinderclient after that merge?
18:36:31 <jgriffith> rnirmal: yes, that was the plan
18:36:42 <jgriffith> or I'm going to ask mtaylor to do it
18:36:47 <DuncanT> 7:30 pm
18:37:18 <jgriffith> DuncanT: That reminds me, I think I promised you opening discussions on a differnt meeting time?
18:37:28 <DuncanT> I was going to ask if anybody minded making things an hour earlier, since most of us are on summer time now and the meeting stayed at the same time utc
18:38:43 <jgriffith> DucanT: QA meets in that slot but we could try before that maybe?
18:38:54 <rnirmal> I'm ok with 1 or 2 hrs earlier. need to make sure there's no other conflicting meetings
18:39:07 <DuncanT> Earlier is certainly better for me
18:39:15 <jgriffith> clayg: work for you?
18:40:13 <clayg> yup!
18:40:32 <jgriffith> Cool... I'll send an email out for the benefit of those that aren't here
18:40:42 <DuncanT> 5pm is metering, 6pm is QA, 7pm is our current slot, 9pm is orchestration
18:41:01 <jgriffith> Ahh...metering did grab that slot?
18:41:32 <DuncanT> According to the ICAL feed, yes
18:41:33 <jgriffith> Oh, Thu!! I searched on Thur
18:41:54 <jgriffith> hmph... that closes out Thursdays
18:43:30 <rnirmal> Wednesday seems to be open during that time
18:43:48 <DuncanT> I can do wednesdays
18:43:58 <clayg> yes, is fine
18:44:21 <jgriffith> ok... I'll send a note out
18:44:41 <jgriffith> anything else?
18:44:52 <jgriffith> anybody wanna write some cinder code?
18:44:53 <jgriffith> :)
18:45:45 <jgriffith> ok, well let me know via email or irc if something comes up or you have ideas/bandwidth
18:46:03 <jgriffith> If there's nothing else I'm going to go eat lunch :)
18:46:25 <DuncanT> Bit late for lunch for me, but the bar is open....
18:46:35 <jgriffith> DuncanT: that sounds better...
18:47:20 <jgriffith> #action jgriffith email proposal to switch meeting to Wed 2 hours earlier
18:47:29 <jgriffith> Alright, see ya guys
18:47:34 <jgriffith> #endmeeting