21:02:41 <ttx> #startmeeting
21:02:42 <openstack> Meeting started Tue May 22 21:02:41 2012 UTC.  The chair is ttx. Information about MeetBot at http://wiki.debian.org/MeetBot.
21:02:43 <openstack> Useful Commands: #action #agreed #help #info #idea #link #topic #startvote.
21:02:46 <heckj> o/
21:02:52 <ttx> Today's agenda: http://wiki.openstack.org/Meetings/ProjectMeeting
21:03:06 <ttx> nothing like bot boilerplate noise to attract heckj
21:03:13 <ttx> #info Last meeting before folsom-1. Will cut the milestone-proposed branch in ~10 hours
21:03:24 <ttx> #info So in this meeting we'll be updating F1-targeted features and bugfixes.
21:03:39 <ttx> #topic Actions from previous meeting
21:03:50 <ttx> * bcwaldon to follow up on bug 966329 status
21:03:53 <uvirtbot> Launchpad bug 966329 in nova "RAX-specific auth in novaclient" [Low,In progress] https://launchpad.net/bugs/966329
21:04:16 <bcwaldon> ttx: westmaas is on it
21:04:29 <ttx> bcwaldon: should we un-F1-target the bug ?
21:04:44 <westmaas> yes
21:04:51 <bcwaldon> ttx: yes, the bug itself is simple, but we want ot give affected parties time to regroup
21:04:55 <bcwaldon> or prepare
21:05:06 * ttx removes milestone
21:05:23 <ttx> * vishy to adjust 'undefined' folsom bp priorities: not done, pushing to next week
21:05:32 <ttx> #action vishy to adjust 'undefined' folsom bp priorities
21:05:37 <ttx> * ttx to fix series goal for quantum/folsom bps
21:05:50 <ttx> danwent: I did fix them, but there are two new ones there (F2-targeted):
21:05:58 <ttx> https://blueprints.launchpad.net/quantum/+spec/quantum-generic-firewall
21:06:02 <ttx> https://blueprints.launchpad.net/quantum/+spec/use-common-cfg (unassigned)
21:06:26 <danwent> ttx: k, I asked a few people to create bps this week, so perhaps those are new.  will fix
21:06:28 <ttx> danwent: You should look at them and set series goal = Folsom if those match your expectations... the second one definitely needs an assignee
21:06:54 <ttx> #topic Keystone status
21:07:02 <ttx> heckj: o/
21:07:07 <ttx> #link https://launchpad.net/keystone/+milestone/folsom-1
21:07:14 <heckj> Look - more bot noise!
21:07:20 * heckj runs up
21:07:22 <ttx> only one blueprint is left in F1: draft-v3-api (heckj)
21:07:31 <ttx> I think it should be considered completed now ?
21:07:35 <heckj> draft is published as of today - getting feedback now. Sec for a link.
21:07:43 <heckj> ttx:yep
21:07:50 <ttx> ok, marking complete
21:07:59 <oubiwann> heckj: btw, nice work on that api draft
21:08:03 <heckj> #link https://docs.google.com/document/d/1s9C4EMxIZ55kZr62CKEC9ip7He_Q4_g1KRfSk9hY-Sg/edit
21:08:17 <heckj> oubiwann: thanks, but I know we're not nearly complete here.
21:08:23 <ttx> heckj: On the bugs side, you still have 6 targeted bugs open
21:08:32 <ttx> heckj: since there is nothing critical/high in there, ok to defer to folsom-2 anything that is not merged today ?
21:08:40 <heckj> ttx: doing reviews for those today - any we can't get in, we'll defer
21:09:02 <ttx> OK. Then we'll use folsom-1 targeting to mean "must be backported to milestone-proposed in the day before F1 is published"
21:09:11 <ttx> i.e. milestone-critical bugs only.
21:09:20 <ttx> (if any)
21:09:35 <ttx> Quick glance at folsom-2: https://launchpad.net/keystone/+milestone/folsom-2
21:09:58 <ttx> heckj: Could you set the series goal to Folsom for https://blueprints.launchpad.net/keystone/+spec/keystone-ipv6-support if it has your support ?
21:10:31 <ttx> btw I'm working on a blueprint inconsistency detection tool that will help you detect oddities like this
21:11:08 <heckj> I think blueprints are, by convention, inconsistent
21:11:16 * ttx is gradually replacing himself with launchpadlib scripts
21:11:37 <ttx> heckj: On that F2 page: I suspect those "Unknown" status are actually "not started" ?
21:11:49 <ttx> If yes, I can adjust them
21:12:23 <heckj> Yes - but what's the difference?
21:12:41 <ttx> "Unknown" means "nobody knows"
21:12:57 <ttx> so it can be used to track blueprints where you've lost contact with the assignee
21:13:10 <heckj> then they're all "not started"
21:13:15 <ttx> ok, willfix
21:13:19 <ttx> heckj: anything else ?
21:13:26 <heckj> nothing form me
21:13:40 <ttx> Questions about Keystone ?
21:14:04 <ttx> #topic Swift status
21:14:07 <ttx> notmyname: o/
21:14:08 <notmyname> howdy
21:14:11 <ttx> #link https://launchpad.net/swift/+milestone/1.5.0
21:14:31 <ttx> So you have a tentative release date for it.. May 31
21:14:36 <notmyname> the "good progress" ones have pending patches
21:14:39 <notmyname> ya, 5/31
21:14:55 <notmyname> assuming we can get those merged this week (next week for testing)
21:15:08 <ttx> notmyname: when would be the QA cut date ? Friday ?
21:15:13 <notmyname> friday or monday
21:15:28 <ttx> OK, we'll cut milestone-proposed at the same time
21:15:39 <notmyname> I'll let you know
21:16:00 <ttx> hmm. Monday is actually a holiday around here
21:16:07 <notmyname> here too actually
21:16:19 <notmyname> so tuesday would probably give us enough time
21:16:33 <ttx> so I guess we could do Tuesday, yes. QA can start earlier
21:16:51 <notmyname> depends on what happens this week
21:16:57 <ttx> ok, keep me posted
21:17:00 <notmyname> will do
21:17:05 <ttx> notmyname: Anything else ?
21:17:06 <notmyname> ya
21:17:10 <notmyname> just a follow up
21:17:17 <notmyname> to something I said last week
21:17:44 <notmyname> most of the "to be removed in 1.5.0" pieces actually won't be removed (after much discussion among swift-core)
21:18:17 <notmyname> swift3 will come out, but the other pieces will stay in
21:18:28 <notmyname> makes more sense in swift (from a community perspective)
21:18:45 <ttx> notmyname: would you be interested in participating to a Bug triage day, as outlined on the ML ? If yes, we can push it back to first week of June to not interfere with 1.5.0
21:19:24 <ttx> #link https://lists.launchpad.net/openstack/msg12040.html
21:19:42 <notmyname> ttx: let me look in to it
21:19:55 <ttx> just let me know by answering the thread
21:20:04 <ttx> or we'll talk more about it at the end of the meeting
21:20:11 <ttx> so you can take your time :)
21:20:35 <ttx> Questions on Swift ?
21:20:50 <annegentle> ttx: what's the proposed date for a bug triage day? (a Tues. I guess?)
21:21:36 <ttx> annegentle: we'll discuss it in open discussion at the end of the meeting
21:21:42 <ttx> #topic Glance status
21:21:42 <annegentle> ttx: got it
21:21:46 <ttx> bcwaldon: yo
21:21:49 <ttx> #link https://launchpad.net/glance/+milestone/folsom-1
21:21:54 <bcwaldon> ttx: hey hey
21:22:07 <ttx> api-v2-image-tags & api-v2-user-properties are left -- will defer to F2 if it doesn't land in the next hours ?
21:22:30 <bcwaldon> ttx: yeah, its no biggie if they dont land in f1
21:22:37 <ttx> On the F1-targeted bugs side, 6 are still open
21:22:45 <ttx> https://bugs.launchpad.net/bugs/1001213 -- was wondering if that should be fixed
21:22:46 <uvirtbot> Launchpad bug 1001213 in glance "[folsom-1] Missing files in generated tarballs" [High,New]
21:23:02 <ttx> if yes, I can certainly push a fix before going to bed.
21:23:14 <bcwaldon> ttx: I'll comment on the bug for you
21:23:18 <ttx> ok
21:23:35 <ttx> feel free to invalidate if those files make no sense
21:23:42 <ttx> https://bugs.launchpad.net/bugs/994609 -- is that really critical ?
21:23:44 <uvirtbot> Launchpad bug 994609 in glance "wsgi.Server() starts but is broken on osx (test_multiprocessing never ends)" [Critical,In progress]
21:24:04 <bcwaldon> ttx: it has a partial fix in, so its not anymore
21:24:11 <bcwaldon> ttx: and it only affects certain osx environments
21:24:15 <bcwaldon> ttx: which dont happen to be mine
21:24:26 <ttx> bcwaldon: High and ->F2 ?
21:24:31 <bcwaldon> ttx: sounds good
21:24:43 <ttx> Do you agree to push back the medium ones to F2 if not landed when I cut milestone-proposed ?
21:24:52 <bcwaldon> ttx: yep
21:25:06 <ttx> Then, like Keystone, we'll use F1-targeting to mark bugs that should be backported to MP before F1 is finally published.
21:25:15 <bcwaldon> ttx: ok, sounds good to me
21:25:17 <ttx> Looking at F2... no blueprints were targeted there yet.
21:25:23 <ttx> Would you agree to target all the remaining "essential" stuff to F2, like promised last week ? ;)
21:25:40 <bcwaldon> yes, will do
21:25:41 <ttx> oh, you just added glance-client-v2
21:25:53 <ttx> One small inconsistency in priorities:
21:25:57 <ttx> api-2 (essential) depends on api-v2-anonymous-access (high)
21:26:15 <bcwaldon> ok, thats actually a bad dependency
21:26:21 <bcwaldon> will fix
21:26:24 <ttx> ack
21:26:28 <ttx> bcwaldon: Anything else you wanted to mention ?
21:26:36 <bcwaldon> I could use help with glance reviews
21:26:41 <bcwaldon> but thats a constant pain point
21:27:07 <ttx> bcwaldon: you should launch a recruitment campaign
21:27:17 <ttx> Become Glance Core, win a T-shirt
21:27:25 <bcwaldon> ttx: you're providing t-shirts?!
21:27:35 <ttx> bcwaldon: err.
21:27:53 <ttx> I thought *you* would to encourage *me* to join glance-core.
21:28:00 <bcwaldon> ohhhhhh
21:28:08 <ttx> bcwaldon: Anything else you wanted to mention ?
21:28:12 <bcwaldon> nope, glance is good to go
21:28:18 <ttx> Questions on Glance ?
21:29:04 <ttx> #topic Quantum status
21:29:07 <ttx> danwent: hey
21:29:11 <ttx> #link https://launchpad.net/quantum/+milestone/folsom-1
21:29:24 <ttx> 2 blueprints still in progress... anything you expect will land in the next hours ?
21:29:38 <danwent> yes, one is pretty close to end of review.
21:29:42 <danwent> not critical though.
21:29:51 <danwent> the other is tracking adding multi node setups to devstack
21:30:02 <ttx> danwent: OK if I defer anything that's not merged in ~10hours ?
21:30:02 <danwent> so not really something that will ship with quantum, but important for the project in general
21:30:06 <danwent> yup
21:30:34 <danwent> other than that, we've moved two very important items to F-2, which means that F-2 is PACKED
21:30:45 <ttx> That's how we like it
21:30:48 <ttx> 2 targeted bugs left: should they be deferred to F2 ? Or is there anything milestone-critical in there ?
21:30:56 <danwent> so I'm going to try and just get F-1 out without much drama, and have people start focusing on F-2 already
21:31:26 <danwent> i'm going to make sure at least bug #1000809 is fixed
21:31:32 <ttx> I should have said "can they be deferred to F2 if not complete tomorrow"
21:31:35 <uvirtbot> Launchpad bug 1000809 in quantum "unneeded import of ovs_models in OVS agent break 2.4 compat" [Medium,In progress] https://launchpad.net/bugs/1000809
21:31:41 <danwent> its a one liner and let's people run agent on xenserver (which requires 2.4)
21:31:47 <danwent> ttx: yes
21:31:55 <ttx> good!
21:32:00 <ttx> Quick peek at the folsom-2 plan at https://launchpad.net/quantum/+milestone/folsom-2
21:32:23 <danwent> just updated it.  good news is that almost all items have people working on them already, in some cases they've been working on it for a while.
21:32:25 <ttx> oo, lots of last-minute fixes in there :)
21:32:33 <danwent> :)
21:32:39 <ttx> Small inconsistency:
21:32:44 <danwent> which?
21:32:44 <ttx> quantum-system-functional-tests (implemented) is marked as depending on quantum-functional-test-environment (not complete)
21:33:01 <ttx> not in F2 but in the folsom general plan
21:33:15 <danwent> ok, that's an F-1 item.  I'll just break the dependency
21:33:23 <ttx> sounds good
21:33:55 <ttx> I checks deps to make sure we have the critical path for essential features in plain sight, so don't hesitate to carete them as needed
21:34:02 <ttx> create*
21:34:06 <ttx> danwent: Anything else ?
21:34:19 <danwent> ok, probably worth adding a few deps for F-2, as they definitely are some
21:34:32 <danwent> nope
21:34:37 <ttx> Questions on Quantum ?
21:35:11 <ttx> #topic Nova status
21:35:16 <ttx> bcwaldon: welcome back
21:35:22 <ttx> #link https://launchpad.net/nova/+milestone/folsom-1
21:35:29 <bcwaldon> ttx: hey hey
21:35:41 <devcamcar> ttx: i spent this morning reviewing fixed but untargeted bugs
21:35:56 <ttx> so vishy left us with 9 incomplete bps
21:35:56 <devcamcar> found about 100 that were fixed and in master but not tagged for folsom-1
21:36:06 <ttx> devananda: that's ok
21:36:11 <ttx> devcamcar: that's ok
21:36:36 <ttx> devcamcar: the release script sets the milestone when it does the FixCommitted->FixReleased transition
21:36:56 <russellb> eep, you were replaced by a small shell script ;(
21:37:13 <devcamcar> ttx: that's fine, except there were also a ton of fixes that had landed in stable/essex that were not updated
21:37:16 <devcamcar> i fixed those as well
21:37:17 <ttx> devcamcar: so all the FixCommitted should actually be folsom-1 fixes
21:37:34 <ttx> devcamcar: good
21:37:44 <devcamcar> ttx: i actually look at the milestone views though, so not having them targeted before release is … annoying at best
21:37:44 <ttx> bcwaldon: I guess I'll just move to F2 anything that's not completed in the next hours ?
21:37:52 <bcwaldon> ttx: yeah, I just moved the one assigned to me
21:37:58 <russellb> mine is done
21:38:06 <russellb> it was approved once, but i keep having to rebase because of conflicts
21:38:14 <ttx> devcamcar: I'll update the buglink magic so that it sets the "next milestone" when it sets FixCommitted
21:38:18 <bcwaldon> ttx: vishy didn't give me anything specific to share with the group, either
21:38:20 <russellb> half of it is in, other half needs to be approved again
21:38:45 <ttx> russellb: you have it under control ?
21:38:52 <devcamcar> ttx: if that script ran every day and updated untargeted committed fixes to current milestone, that would be far better imo
21:39:13 <ttx> russellb: just set to Implemented when complete
21:39:19 <ttx> russellb: or I'll defer it
21:39:23 <russellb> ttx: yeah, was just mentioning it in case someone felt like looking / approving ...
21:39:36 <ttx> devcamcar: or both. Would avoid too much bugnoise
21:39:53 <ttx> bcwaldon: 2 targeted bugs -- anything that should be kept as milestone-critical ?
21:40:09 <devcamcar> ttx: both what? sorry
21:40:21 <devcamcar> ttx: nm, i see
21:40:22 <ttx> Or i'll just defer to F2 if not fixed
21:40:26 <devcamcar> yea that would be nice
21:40:33 <bcwaldon> ttx: the bug assigned to Philip just needed a little more TLC in the review cycle, I'm pushing that through now
21:40:35 <ttx> bcwaldon: two F2-targeted bugs
21:40:44 <ttx> ok
21:41:05 <ttx> bcwaldon: I'll defer anything that's not completed in the next 10 hours
21:41:13 <bcwaldon> ttx: yep, sounds good
21:41:25 <ttx> bcwaldon: i won't annoy you with F2 plans
21:41:34 <bcwaldon> ttx: yeah, i dont have any answers for you anyways
21:41:35 <devcamcar> ttx: not to derail this too much, but i assume it's a known issue that backports and "fix committed" status aren't properly handled by jenkins/gerrit?
21:41:37 <ttx> only one inconsistency for Russell:
21:41:43 <ttx> russellb: no-db-compute (high) depends on no-db-messaging (low)
21:41:45 <devcamcar> they still require manual intervention
21:42:02 <russellb> ttx: no-db-messaging should be high then, i guess.
21:42:09 <ttx> devcamcar: yes. It should update the Essex task alright. On my list too.
21:42:18 <devcamcar> ttx: cool
21:42:22 <ttx> Might have the time to do it tomorrow after the MP cuts
21:42:33 <ttx> russellb: that's one way to fix it.
21:42:38 <ttx> bcwaldon: Anything else ?
21:42:49 <bcwaldon> ttx: negative
21:42:51 <russellb> no-db-compute was set to high very recently, i suspect the other was set long ago
21:42:54 <ttx> Questions on Nova ?
21:43:04 <ttx> russellb: certainly
21:43:17 <ttx> jgriffith: around ?how is Cinder going today ?
21:44:13 <ttx> let's do Horizon first, and go back to Cinder if John is around
21:44:18 <ttx> #topic Horizon status
21:44:25 <ttx> #link https://launchpad.net/horizon/+milestone/folsom-1
21:44:36 <devcamcar> both remaining blueprints will most likely land
21:44:43 <devcamcar> one is held up waiting for this review in devstack: https://review.openstack.org/#/c/7684/
21:44:48 <devcamcar> the other is being actively reviewed right now
21:44:49 <ttx> devcamcar: ok to defer if that's not the case for any reason ?
21:45:34 <devcamcar> ttx: https://blueprints.launchpad.net/horizon/+spec/workflows i could argue should be "essential" since a lot of future dev in f2 depends on it
21:45:48 <gabrielhurley> workflows *will* land today ;-)
21:45:49 <devcamcar> the other is fine to defer but workflows really needs to land
21:46:03 <ttx> devcamcar: ok, I'll wait for you in case shit happens
21:46:11 <devcamcar> however, if for some crazy reason workflows don't land i think we should slip a day
21:46:30 <devcamcar> rest of bugs in this milestone are not too terribly difficult
21:46:36 <ttx> we can cut milestone-proposed a bit late, and still hit the milestone day
21:46:41 <devcamcar> ttx: ok cool
21:46:43 <ttx> On the bugs side... 4 targeted bugs
21:46:49 <ttx> I'll cut the milestone-proposed branch in ~10 hours...
21:46:58 <ttx> ...and after that the remaining milestone-critical fixes should land in master and be backported to milestone-proposed
21:47:07 <devcamcar> ttx: sounds good
21:47:09 <ttx> To reduce the backporting pain, my suggestion would be for me tomorrow to only keep whatever you set to "Critical"
21:47:21 <devcamcar> ttx: agreed
21:47:22 <ttx> and defer the rest to F2 if incomplete. Would that work for you ?
21:47:25 <ttx> ok
21:47:34 <ttx> Quick look at F2 @ https://launchpad.net/horizon/+milestone/folsom-2
21:47:51 <ttx> Should the 2 unassigned blueprints be considered Nebula's ?
21:47:58 <devcamcar> yes
21:48:03 <ttx> willfix
21:48:06 <ttx> devcamcar: Anything else ?
21:48:10 <devcamcar> still need to create the quantum blueprint for f2, but it's pretty put together
21:48:12 <devcamcar> ttx: nope!
21:48:20 <ttx> Questions for Horizon ?
21:49:06 <ttx> #topic Other Team reports
21:49:12 <ttx> annegentle, jaypipes, mtaylor: ?
21:49:37 <ttx> jgriffith (Cinder) ?
21:49:51 <annegentle> o/
21:49:58 <ttx> and we have a winner !
21:50:07 <ttx> annegentle: go for it
21:50:12 <annegentle> ok
21:50:36 <annegentle> would love input on "Starter docs and articles" at http://www.openstack.org/blog/2012/05/starter-docs-and-articles/ or on the mailing list
21:51:13 <ttx> #help input needed on "Starter docs and articles" at http://www.openstack.org/blog/2012/05/starter-docs-and-articles/ or on the mailing list
21:51:19 <annegentle> also I just moved "deployment templates" blueprint to f2 for openstack-manuals… gathering more input from multiple people about "what do you want to know about other's deployments"
21:51:26 <ttx> #help Glance reviewers wanted
21:52:03 <ttx> annegentle: how did your F1 objectives go ?
21:52:05 <annegentle> Also starting to work with Javier Cervino to create a "try it out" javascript embed for TryStack.org on the api.openstack.org site… very early stages.
21:52:30 <annegentle> ttx: well by moving the deployment templates out to f2 we didn't have any other blueprints in f1
21:52:39 <ttx> good job :)
21:52:42 <annegentle> :)
21:52:51 <ttx> annegentle: anything else ?
21:52:58 <annegentle> and welcome Tom Fifield to doc-core!
21:53:00 <annegentle> that's it.
21:53:06 <ttx> yay!
21:53:08 <ttx> Any other team lead with a status report ?
21:53:25 <oubiwann> ttx: update from infrastructure
21:53:31 <ttx> oubiwann: shoot
21:53:32 <annegentle> #info Welcome Tom Fifield to openstack-doc-core
21:53:33 <oubiwann> openstack-dev list is created
21:53:46 <oubiwann> and I'm currently testing (and adding) topics
21:53:52 <oubiwann> and the associated regexs
21:54:06 <ttx> oubiwann: how does that work ?
21:54:07 <oubiwann> there are a handful of folks who have volunteered to help out with testing
21:54:37 <oubiwann> ttx: you create them in the admin interface for mailman, giving a description, name, and regex
21:55:04 <oubiwann> the in-coming emails are then parsed (subject and, optionally, first few lines of the body)
21:55:34 <oubiwann> if an email matches one or more of the topics (regexs), then only those people subscribed to those topics will receive it
21:55:34 <ttx> oubiwann: ok, no time to explain more, but will follow up
21:55:38 <oubiwann> otherwise, everyone gets it
21:55:41 <oubiwann> k
21:56:04 <ttx> oubiwann: any fuzzy ETA for GA ?
21:56:44 <oubiwann> I think at this point the only thing we're waiting on is reed decision of what to do with some of the sensitive mail lists from the old host
21:56:53 <oubiwann> could be as soon as thursday
21:56:56 <ttx> #topic Open discussion
21:56:57 <oubiwann> or as late as next wee
21:56:58 <oubiwann> k
21:57:10 <ttx> As explained in https://lists.launchpad.net/openstack/msg12040.html I'd like us to spend a day cleaning up our bug database
21:57:35 <ttx> This is mostly Nova and Swift, but I guess the exercise can't hurt the others as well
21:58:00 <ttx> heckj, notmyname, bcwaldon, devcamcar, danwent: thoughts ?
21:58:16 <ttx> maybe just follow-up on the thread if you think your project should participate
21:58:40 <danwent> ttx: seems like a good idea.  I did a quick scan for F-1 and saw a lot of stuff that likely can be cleaned up in Quantum, but needed a bit more investigation to confirm.
21:58:44 <ttx> annegentle: target would be a day in the week of June 4
21:59:15 <ttx> I'd say Thursday, at first glance
21:59:18 * heckj reads the link
21:59:28 <annegentle> yeah thursdays are nicer than Tuesdays. You can quote me on that.
21:59:31 <ttx> I prepared a number of wikipages:
21:59:41 <ttx> http://wiki.openstack.org/BugTriage
21:59:47 <ttx> http://wiki.openstack.org/BugTags
22:00:33 <ttx> Anything else, anyone ?
22:00:49 <ttx> Time to leave the room for the next meeting
22:01:10 <ttx> #endmeeting